Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

People can't connect to my server (Mac)

mac help server cant connect

  • Please log in to reply
8 replies to this topic

#1

pullmanator117

Posted 23 August 2012 - 08:47 PM

Okay, i have a macbook pro(version 10.6.8) and i'm trying to port forward on a Linksys WRT160Nv3 router and followed the instructions on how to do this whole process. When i try setting it up, it works when i do "localhost " or my internal ip address, and yes i did look up external ip. Now my friend tried it on his laptop (using Windows) and it works perfectly fine so now i know that its not the port forwarding but something on my mac that doesn't accept the port. does anyone know what i need to do? Thanks Posted Image
Stay Nurdy

-EN

Register or log in to remove.

#2

Zukaro
    Zukaro

    Redstone Miner

  • Members
  • 509 posts
  • Location: Canada
  • Minecraft: Zukaro

Posted 23 August 2012 - 09:09 PM

I don't know all that much about Mac's, but if they have a firewall you'll need to allow java through it (run your Minecraft server and then find the java process that runs when the server is running (on Windows it's javaw.exe, but I don't know what it'd be on a Mac)).

Also, make sure your IP address on the Mac is static and the ports are pointing towards the static IP.

Zukaro Travon

Robotic Fox

Posted Image


#3

pullmanator117

Posted 23 August 2012 - 09:56 PM

i'm sorry, i don't know what you mean by java process. i know that they are all .jars, or is it the parent process (which is Jar Launcher). and static IP isn't necessary i just change it when ever IP changes.
Stay Nurdy

-EN

#4

pullmanator117

Posted 23 August 2012 - 10:07 PM

Ok. i was looking through system preferences and i went into "sharing" and i was wondering if this wasn't working because the "internet sharing" tab was unchecked? or can it be due to the fact that i'm using airport. oh and when i tried hamachi it didn't work either.
Stay Nurdy

-EN

#5

Zukaro
    Zukaro

    Redstone Miner

  • Members
  • 509 posts
  • Location: Canada
  • Minecraft: Zukaro

Posted 24 August 2012 - 12:00 AM

View Postpullmanator117, on 23 August 2012 - 09:56 PM, said:

i'm sorry, i don't know what you mean by java process. i know that they are all .jars, or is it the parent process (which is Jar Launcher). and static IP isn't necessary i just change it when ever IP changes.

Basically the java process would be java running.  For example, in Windows Ctrl+Alt+Delete brings up the task manager which shows the running processes (as in, programs), there's also one for applications but the processes is what you're looking for as it runs in the background (with Linux you type "top" into a terminal and it does the same sorta thing).  I'm not sure of how to do that on a Mac though.

View Postpullmanator117, on 23 August 2012 - 10:07 PM, said:

Ok. i was looking through system preferences and i went into "sharing" and i was wondering if this wasn't working because the "internet sharing" tab was unchecked? or can it be due to the fact that i'm using airport. oh and when i tried hamachi it didn't work either.

You shouldn't need sharing to be checked as on (at least, I don't think you need that on).




Anyways; if Mac's have a firewall you'll need to allow the server through the firewall (I don't know if they have firewalls though).
I'm not sure what else the problem could be (I'm not very familiar with Mac's, sorry).

Zukaro Travon

Robotic Fox

Posted Image


#6

pullmanator117

Posted 24 August 2012 - 03:48 AM

its fine thanks for the help i'll try it out.
Stay Nurdy

-EN

#7

BL14N13
    BL14N13

    Tree Puncher

  • Members
  • 22 posts
  • Location: Adelaide Australia
  • Minecraft: BL14N

Posted 24 August 2012 - 12:50 PM

Ok I think I see what's wrong here it's that you haven't taken down the firewall for your server to do this look up on the Internet how to disable a firewall with terminal once you have found that enter it in terminal and bingo! If not then I would put :25565 after you ip :) sorry of I can't help though it try my best

#8

Tedster
    Tedster

    Blaze Extinguisher

  • Members
  • 4591 posts

Posted 24 August 2012 - 02:30 PM

View Postpullmanator117, on 23 August 2012 - 10:07 PM, said:

Ok. i was looking through system preferences and i went into "sharing" and i was wondering if this wasn't working because the "internet sharing" tab was unchecked? or can it be due to the fact that i'm using airport. oh and when i tried hamachi it didn't work either.
Hmm... Running on a Mac right now. Internet sharing is usually creating a second network with another computer that just allows the latter to connect to the internet through the former. I don't understand why it wouldn't work through Hamachi though. Sorry, but I can't help you here.
I used to be a Support Guru, but then ran out of time. I have more time now, but I'll only make the occasional helpful post.

#9

forrest4e2d

Posted 02 November 2012 - 11:13 PM

I have the exact same problem..=/
I turned my firewall off and it still wont let me connect.
I get a SocketExeception : Host is down when I try
I know that it works for alot of other people thou