Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Minecraft Open to LAN isn't working?

open to lan minecraft lan problems lan not working lan open to lan wont work

  • Please log in to reply
5 replies to this topic

#1

jordc1995
  • Location: Wales
  • Minecraft: jordc1995

Posted 04 August 2012 - 06:30 PM

I wanted to play on a LAN server with my brother earlier but somehow it doesn't work. I know it works because it worked the day before yesterday when I played with him.


He tries to connect but it says that the connection timed out or that it couldn't reach the server. He can find the server, but he cannot connect.


I'm using a wireless connection but he's using ethernet connection, I'm not sure if this makes a difference... I've tried rebooting the router and refreshing my internet settings but still no luck.

Has anybody else experienced this problem?

Also, is there a solution?

Your help and advice would be appreciated,

Thanks.



Register or log in to remove.

#2

king_scarecrow
  • Minecraft: king_scarecrow

Posted 04 August 2012 - 06:50 PM

This happened to me as well... We are Both using wireless so I don't think that makes a difference. :(

Posted Image


#3

riddle143

Posted 09 August 2012 - 03:13 AM

I'm assuming you're both using Windows PC's either Vista or later. If it's xp it's a different process. note: if the ip address (xxx.xxx.x.x:xxxxx (that many characters, but with numbers)) minecraft lists when you hit open to lan doesn't start with the same first six numbers on both computers this is a different problem that I'm having trouble fixing myself. Also if what you're trying to connect from is using an older version of minecraft that can cause this problem.

This sounds like it could be a firewall issue to me. Try going to your firewall settings (hit the windows key, or the start menu button (they're both the same symbol), type in windows firewall, click on the first option) and making a rule to allow incoming connections from minecraft on the port it opens the server on, normaly 192.168.x.x:xxxxx (where the bold underlined numbers are your port number) Minecraft will tell you this information when you open your world to LAN. To do this click on inbound rules (you may need to make an outbound rule as well, but it's unlikely) then look in the right pane for a button titled "New Rule...". You will have four options: Program, Port, Predefined, or Custom. Just making a rule for the program "minecraft.exe" may work, but to make it secure click Custom then click next. On the next page click the radio button "This program path:" and browse for your minecraft.exe file, normally [C:\Users\"Your User Name"\AppData\Roaming\.minecraft\minecraft.exe] then hit the next button. On the next page click first drop down list and select TCP. If you are the one hosting the server (that is the world that was opened to LAN was opened on your computer) then you need to open the port number you figured out earlier by selecting the "Specific Ports" option under the "Local Port" drop down list and typing in that number then hitting next. The next page allows for even more security and if you know what you're doing then you can specify IP addresses, but if you don't "Any IP address will do for both options, confirm this then hit next. Next you want to make sure the radio button saying "Allow the connection" (the first one) is selected and hit next. On the next page make sure all boxes are checked and click next. Finally simply give your rule a title (anything you want) and a description if you feel it's necessary and click "Finish". If it still doesn't work try the same process with the outbound rules. If it still didn't work that isn't your problem and it likely has something to do with your default network settings on minecraft, which is a problem I'm having with my linux computer. To date I haven't found a way to change what minecraft sees as default

#4

suzer
    suzer

    Newly Spawned

  • Members
  • 1 posts

Posted 10 August 2012 - 09:43 PM

Hey, me and my brother were having the same problem. I was wireless, he was ehernet, the 'connection failed/timed out' message, we played a few days ago and everything worked well but the next day I couldn't log into his lan server. Same situation basically.

Try having one of you log in and open the LAN server and examining the address that comes up (xxx.xxx.x.xxx:XXXXX)
Have the other person go to Muiltiplayer and click 'Direct Server'. Type in the address as is.

What we noticed was for some weird reason every time he logged into the LAN server, the last 5 digits of the address changed. It went from 49308 to 55499 and etc. So by clicking the saved LAN link from yesterday, we were logging into the wrong address.

This worked for us and I really hope it works for you. It was a frustrating problem and there was no answer in sight until he noticed the small difference in number and we pieced it together. Good luck!

#5

deltafive5

Posted 06 October 2012 - 10:40 PM

View Postriddle143, on 09 August 2012 - 03:13 AM, said:

I'm assuming you're both using Windows PC's either Vista or later. If it's xp it's a different process. note: if the ip address (xxx.xxx.x.x:xxxxx (that many characters, but with numbers)) minecraft lists when you hit open to lan doesn't start with the same first six numbers on both computers this is a different problem that I'm having trouble fixing myself. Also if what you're trying to connect from is using an older version of minecraft that can cause this problem.

This sounds like it could be a firewall issue to me. Try going to your firewall settings (hit the windows key, or the start menu button (they're both the same symbol), type in windows firewall, click on the first option) and making a rule to allow incoming connections from minecraft on the port it opens the server on, normaly 192.168.x.x:xxxxx (where the bold underlined numbers are your port number) Minecraft will tell you this information when you open your world to LAN. To do this click on inbound rules (you may need to make an outbound rule as well, but it's unlikely) then look in the right pane for a button titled "New Rule...". You will have four options: Program, Port, Predefined, or Custom. Just making a rule for the program "minecraft.exe" may work, but to make it secure click Custom then click next. On the next page click the radio button "This program path:" and browse for your minecraft.exe file, normally [C:\Users\"Your User Name"\AppData\Roaming\.minecraft\minecraft.exe] then hit the next button. On the next page click first drop down list and select TCP. If you are the one hosting the server (that is the world that was opened to LAN was opened on your computer) then you need to open the port number you figured out earlier by selecting the "Specific Ports" option under the "Local Port" drop down list and typing in that number then hitting next. The next page allows for even more security and if you know what you're doing then you can specify IP addresses, but if you don't "Any IP address will do for both options, confirm this then hit next. Next you want to make sure the radio button saying "Allow the connection" (the first one) is selected and hit next. On the next page make sure all boxes are checked and click next. Finally simply give your rule a title (anything you want) and a description if you feel it's necessary and click "Finish". If it still doesn't work try the same process with the outbound rules. If it still didn't work that isn't your problem and it likely has something to do with your default network settings on minecraft, which is a problem I'm having with my linux computer. To date I haven't found a way to change what minecraft sees as default
I am also having problems with Open LAN. I tried all of this information and it doesnt help me. I thought maybe it was an issue with my anti-virus firewall fighting my windows firewall, but no luck there. Anyone else have ideas or ways to fix this? Much appreciated.

#6

Timshark
    Timshark

    Newly Spawned

  • Members
  • 1 posts

Posted 20 October 2012 - 10:41 PM

I just wanted to inform you that I tried everything and found out that open to Lan didn't work with minecraft launcher.
But when I use the original launcher it works with the latest 1.4 pre-release