Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Help: My Server keeps saying "Connection Lost. End of Stream"


  • Please log in to reply
24 replies to this topic

#1

rekrowland

Posted 03 August 2012 - 10:39 PM

Whenever I start my server and try to run it, it says Connection Lost. End of Stream. My server used to work before this new patch. But since i downloaded the new patch, I get this stupid error message. :( please help!

Register or log in to remove.

#2

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8103 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 03 August 2012 - 10:40 PM

can you paste the server.log for when the server boots up and when the error happens please

#3

rekrowland

Posted 03 August 2012 - 10:44 PM

The server will say my ip address then then a random number, then lost connection. like this
"192.167.1.25:57476 lost connection"
And for the server.log.... idk how to open it... lol. im kinda a newb at this minecraft stuff. the server.log wont open with any of the programs i try to open it with. is there a certain one i must use?

#4

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8103 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 03 August 2012 - 10:46 PM

open the file with wordpad (not notepad) , i would reccommend you download notepad++ as it will make editing permissions and config files easier

#5

rekrowland

Posted 03 August 2012 - 10:51 PM

2012-07-22 21:37:12 [INFO] Starting minecraft server version 1.2.5
2012-07-22 21:37:12 [WARNING] To start the server with more ram, launch it as "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"
2012-07-22 21:37:12 [INFO] Loading properties
2012-07-22 21:37:12 [INFO] Starting Minecraft server on *:25565
2012-07-22 21:37:12 [WARNING] **** FAILED TO BIND TO PORT!
2012-07-22 21:37:12 [WARNING] The exception was: java.net.BindException: Address already in use: JVM_Bind
2012-07-22 21:37:12 [WARNING] Perhaps a server is already running on that port?
2012-07-22 21:37:41 [INFO] Stopping server

But isnt this from like... a few weeks ago? this is all the server.log has in it

#6

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8103 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 03 August 2012 - 11:11 PM

stop the server, delete the file called server.log, then start the server, that should create a new server.log file

#7

tregpala
    tregpala

    Out of the Water

  • Members
  • 2 posts

Posted 04 August 2012 - 01:14 AM

try stopping server or forward your port thats all i know

#8

QueenHallie
  • Location: United States

Posted 04 August 2012 - 03:32 AM

I am having the exact same problem. I start up my server, and it works normally, then I start up minecraft and try to multiplayer on the server and I get the 'End of Stream' message, when I look at my server log it says, [INFO] /127.0.0.1:52151 lost connection. I am new to this minecraft thing, honestly, i'm new to the whole PC gaming thing. Everything worked fine before the new update. I am so lost....all I know is that I just spent $$$ on a game that I can't play anymore....Can anyone help me?? and let me apologize upfront, I am not very good at the computer lingo, just saying...Help please!! Thanks!!!!

#9

Mr_Micro
    Mr_Micro

    Out of the Water

  • Members
  • 3 posts

Posted 07 August 2012 - 08:08 PM

The same thing happened to me and I tried deleting my server log, but that didn't work so I put it back.

#10

mreyno
    mreyno

    Tree Puncher

  • Members
  • 19 posts

Posted 07 August 2012 - 09:10 PM

i have the same problem
are you on 1.3.1 and when your server loads it says 1.2.5 server

#11

KingTretten

Posted 08 August 2012 - 05:13 PM

You must update your server. I´m on a mac, but i think it is the same for windows :)

go to http://www.minecraft.net/ and go to download

Under multiplayer you will find this:
Multiplayer Server

If you're running on Windows and just want to set up a server easily, download Minecraft_Server.exe (802 KB) and run it.

If you want to run the server on any other OS or without GUI it's a bit more involved (see this wiki article for a tutorial). First make sure you can use java from the command line. On Linux and Mac OS X this should already be set up but on Windows you might have to tinker with the PATH environment variable. Download and run minecraft_server.jar (621 KB) with java -Xmx1024M -Xms1024M -jar minecraft_server.jar nogui.



download the minecraft_server.jar file.

go to your server folder. delete the minecraft_server.jar file and replace with the one that you downloaded :P

I had the exact same problem as you when i downloaded the new update, but after you have done this, both the server and minecraft should run 1.3.1 :D Hope it worked for you! had the exact same problem :P


#12

Yazp23
    Yazp23

    Out of the Water

  • Members
  • 6 posts

Posted 23 September 2012 - 07:29 AM

Ehhh....Guys can someone help me:
When i open Minecraft server.jar it opens Command prompt and it flashes and its gone. I took a video then slo-moed it it said:
Error: Could not find or load Main class and its C;/ location bleh bleh...
Please help.....

#13

webrosc
    webrosc

    Kitty Moderator

  • Sectional Moderator
  • 8103 posts
  • Location: South West England
  • Minecraft: webrosc

Posted 23 September 2012 - 01:44 PM

View PostYazp23, on 23 September 2012 - 07:29 AM, said:

Ehhh....Guys can someone help me:
When i open Minecraft server.jar it opens Command prompt and it flashes and its gone. I took a video then slo-moed it it said:
Error: Could not find or load Main class and its C;/ location bleh bleh...
Please help.....
add a new line to the .bat file with just the word PAUSE  then run it again, this will make the window wait for a keypress before closing.
then tell us the exact error.

i'm guessing though it will mention java, so make sure its installed, and the path is correct, this may help http://www.minecraft....jar_version.29

#14

fancyfiddle

Posted 27 October 2012 - 02:43 AM

View Postwebrosc, on 23 September 2012 - 01:44 PM, said:

add a new line to the .bat file with just the word PAUSE  then run it again, this will make the window wait for a keypress before closing.
then tell us the exact error.

i'm guessing though it will mention java, so make sure its installed, and the path is correct, this may help http://www.minecraft....jar_version.29

this is my server what do i do?



2012-10-26 22:41:30 [INFO] Starting minecraft server version 1.4.2
2012-10-26 22:41:30 [INFO] Loading properties
2012-10-26 22:41:30 [INFO] Default game type: SURVIVAL
2012-10-26 22:41:30 [INFO] Generating keypair
2012-10-26 22:41:31 [INFO] Starting Minecraft server on 5.19.150.245:25565
2012-10-26 22:41:31 [INFO] Preparing level "world"
2012-10-26 22:41:31 [INFO] Preparing start region for level 0
2012-10-26 22:41:32 [INFO] Preparing spawn area: 61%
2012-10-26 22:41:32 [INFO] Done (1.570s)! For help, type "help" or "?"
2012-10-26 22:41:33 [INFO] Stopping server
2012-10-26 22:41:33 [INFO] Saving players
2012-10-26 22:41:33 [INFO] Saving worlds
2012-10-26 22:41:33 [INFO] Saving chunks for level 'world'/Overworld
2012-10-26 22:41:33 [INFO] Saving chunks for level 'world'/Nether
2012-10-26 22:41:33 [INFO] Saving chunks for level 'world'/The End
2012-10-26 22:41:34 [INFO] Stopping server
2012-10-26 22:41:34 [INFO] Saving players
2012-10-26 22:41:34 [INFO] Saving worlds
2012-10-26 22:41:34 [INFO] Saving chunks for level 'world'/Overworld
2012-10-26 22:41:34 [INFO] Saving chunks for level 'world'/Nether
2012-10-26 22:41:34 [INFO] Saving chunks for level 'world'/The End

#15

sononfabeach
  • Minecraft: sononfabeach

Posted 27 October 2012 - 11:12 AM

whenever i join a multiplayer server i get java crashed or end of stream any help?
Posted Image

#16

caspotronius

Posted 21 December 2012 - 01:37 PM

when i open up the server.log it is empty and i have the same problem does anyone know what to do?

#17

Ibster8668

Posted 16 May 2013 - 06:03 PM

SAME PROBLEM I GET THE MESSAGE : Connection Lost
   End Of Stream
WHY?!??!! AND HELP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
PL! PLZ PLZ !PLZ PL! PLZ! PLZ! PLZ!



I'm on Minecraft 1.5.2

#18

NoiseGenerator

Posted 16 June 2013 - 12:16 PM

View PostYazp23, on 23 September 2012 - 07:29 AM, said:

Ehhh....Guys can someone help me:
When i open Minecraft server.jar it opens Command prompt and it flashes and its gone. I took a video then slo-moed it it said:
Error: Could not find or load Main class and its C;/ location bleh bleh...
Please help.....
Put "pause" in your startserver.bat file without the quotes

Posted Image


#19

FireninjaDD

Posted 14 July 2013 - 12:18 PM

my console says this


Preparing level "world"
21:17:31 [INFO] Preparing start region for level 0 (Seed: -1399722656140218970)
21:17:32 [INFO] Preparing spawn area: 99%
21:17:32 [INFO] Preparing start region for level 1 (Seed: -1399722656140218970)
21:17:32 [INFO] ----- Bukkit Auto Updater -----
21:17:32 [INFO] It appears that you're running a Development Build, when you've specified in bukkit.yml that you prefer to run Recommended Builds.
21:17:32 [INFO] If you would like to be kept informed about new Development Build releases, it is recommended that you change 'preferred-channel' in your bukkit.yml to 'dev'.
21:17:32 [INFO] With that set, you will be told whenever a new version is available for download, so that you can always keep up to date and secure with the latest fixes.
21:17:32 [INFO] If you would like to disable this warning, simply set 'suggest-channels' to false in bukkit.yml.
21:17:32 [INFO] ----- ------------------- -----
21:17:32 [INFO] Preparing start region for level 2 (Seed: -1399722656140218970)
21:17:32 [INFO] Server permissions file permissions.yml is empty, ignoring it
21:17:32 [INFO] Done (2.010s)! For help, type "help" or "?"
21:17:40 [SEVERE] Reached end of stream for /192.168.1.12
21:17:41 [SEVERE] Reached end of stream for /192.168.1.12

#20

___ZSZ___
  • Location: Everywhere but nowhere
  • Minecraft: ___ZSZ___

Posted 15 July 2013 - 03:51 AM

Quote

21:17:40 [SEVERE] Reached end of stream for /192.168.1.12
21:17:41 [SEVERE] Reached end of stream for /192.168.1.12

That is the internal ip address for whoever tried to connect an that time, or a bug, it happens to me a lot but I think it was my friend trying to get on because i'm pretty sure that ever day he refreshes the multiplayer tab for a long time because before i can get on my own server he is already there. -
Posted Image