Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

How do I turn off PVP in LAN servers?

minecraft 1.3 lan pvp

  • Please log in to reply
15 replies to this topic

#1

Uigsyvigvusy
  • Location: USA
  • Minecraft: Lord_lucassen

Posted 02 August 2012 - 10:22 PM

Me and my friend did an LAN server yesterday with the new Minecraft update and noticed PVP was on. This was rather inconvenient since we were working together, as we did kill each other accidently many times. Any help on how to turn it off?
Posted Image

Register or log in to remove.

#2

rodabon
    rodabon

    End Dweller

  • Members
  • 7187 posts

Posted 02 August 2012 - 10:33 PM

I'm assuming there might be a server.properties file somewhere that you could modify.  Do a file search in the .minecraft folder for server.properties or config and see if you get any hits.

[edited]
Re: 3D Minecraft - Anyone tried it?
by c0yote  

I tried it with terrible results. I gave my wife my glasses for a second, a creeper showed up and now my wife is pregnant.
Stupid 3D..

#3

Nerevar
    Nerevar

    Creeper Destroyer

  • Members
  • 6104 posts

Posted 02 August 2012 - 10:35 PM

Since the subject is up, vanilla Minecraft really needs an OP command to turn on and off PvP.

-The Power to Destroy-


#4

pantsian
    pantsian

    Out of the Water

  • Members
  • 7 posts

Posted 01 January 2013 - 08:39 PM

Do you know any mods that do that? I really need one for an adventure map I made.

#5

StalePhish
  • Location: New England
  • Minecraft: StalePhish

Posted 02 January 2013 - 06:43 PM

There is a setting in the vanilla "server.properties" file called "pvp=true". Just change it to "pvp=false" and reload.

#6

MrPindabaas

Posted 03 January 2013 - 03:11 PM

Have you portforwarded yet? because I know a mod I use for LAN-Worlds wich allows you to turn PVP on/off.

#7

mullac5000

Posted 31 January 2013 - 08:12 PM

Sorry, I don't think you can without a mod. I really need to do this too, but config only has mods you've installed. There is an 'options' file, but it doesn't have anything about pvp. Howerver, if you have a server you can go to 'server' and turn pvp to false.

#8

Wanderer
  • Location: Washington, PA
  • Minecraft: DoctorDharok

Posted 01 February 2013 - 02:44 PM

Currently you must use a mod or set up a proper server. If you're playing locally on your LAN, you shouldn't need to set up port forwarding - it should work to simply turn on the server software and give your friend(s) your local IP on the network.
If you like my post, do me a favor and check out the topic for my Modded Survival Let's Play series!
<Thanks to all of my subscribers for the joy they bring me!

#9

Olavhippo

Posted 17 March 2013 - 07:34 AM

View Postpantsian, on 01 January 2013 - 08:39 PM, said:

Do you know any mods that do that? I really need one for an adventure map I made.
reallan mod does so that you can turn off pvp and do lots of stuff, it's basicly a server

#10

Olavhippo

Posted 17 March 2013 - 07:40 AM

View PostStalePhish, on 02 January 2013 - 06:43 PM, said:

There is a setting in the vanilla "server.properties" file called "pvp=true". Just change it to "pvp=false" and reload.
well yeah you know there is no way to get to the "server.properties"

#11

TheBlizzardMiner
  • Location: US
  • Minecraft: xMakerx

Posted 17 March 2013 - 07:43 AM

View PostOlavhippo, on 17 March 2013 - 07:40 AM, said:

well yeah you know there is no way to get to the "server.properties"

Yes there is. Follow these instructions:

Windows:
C:\Users\USERNAME\AppData\Roaming\.minecraft\server\server.properties

Change pvp=true to pvp=false.
Posted Image

#12

bergerbrat
  • Minecraft: bergerbrat

Posted 04 July 2013 - 07:59 PM

I found it out copy and paste these with CTRL + V

/scoreboard teams add team1

make sure every player on the server does this command : /scoreboard teams join team1

/scoreboard teams option team1 friendlyfire false

Your Welcome!
Posted Image

#13

gylalahun
  • Location: Hungary
  • Minecraft: GyLala

Posted 29 August 2013 - 07:51 PM

@bergerbrat thank you.

#14

Mistika2489

Posted 30 August 2013 - 07:10 AM

View Postgylalahun, on 29 August 2013 - 07:51 PM, said:

@bergerbrat thank you.
There's a 'Quote' button.
Logic? Logic is for idiots.

#15

Puredarkness

Posted 30 August 2013 - 10:32 PM

Put everyone on the server on the same scoreboard team and set doFriendlyFire (or something like that) to false in scoreboard options. Guaranteed to work on LAN. However it won't work on bukkit servers.
The Darkness will win one day, and light's time being the winner is nearing it's end. Because light is overrated.
People, the Modification Development section is for MODS, not Bukkit plugins. Do not be surpised if you don't get any help from there.
Spoiler: Random fact

#16

Skelator424

Posted 05 September 2013 - 07:44 PM

View PostPuredarkness, on 30 August 2013 - 10:32 PM, said:

Put everyone on the server on the same scoreboard team and set doFriendlyFire (or something like that) to false in scoreboard options. Guaranteed to work on LAN. However it won't work on bukkit servers.
If  you're running a bukkit server (or any server) just turn it off in the server properties file.
The only time it's a problem is if you're using the LAN option without actually running a server. In which case you can try the scoreboard, use a mod, wait for an update, or just be a little more careful.