Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

internal exception java.net.socketexception connection reset

read before posting server

  • Please log in to reply
32 replies to this topic

#1

Elystus
    Elystus

    .-.. .- -- .--. -- .. -.

  • Retired Staff
  • 1676 posts
  • Location: California
  • Minecraft: Elystus

Posted 01 August 2012 - 08:44 PM

If you are getting the error message, "internal exception java.net.socketexception connection reset" when trying to connect to server, then you will need to wait until that server updates to 1.3.1.  Please do not create threads asking about this as it clutters the support section.

If you wish to downgrade to 1.2.5 so that you can play on the servers, then you can use MCNostalgia to do so.

If you are having minecraft problems, make sure to check out the help site.


Posted Image


Register or log in to remove.

#2

Brandonforty2
  • Minecraft: Brandon111199

Posted 02 August 2012 - 02:49 AM

Or you could download it from the mojang website.  It is at the post about the pre-release of 1.2.5
Come check out my builds.
I usually get my information from google.

#3

Gretchen317

Posted 03 August 2012 - 04:29 PM

My huband is getting the java.net.socketexception connection reset error for our server but I am not.

My server moderator said they updated to 1.3.1 and it works for me after I updated.

Also, one other player on the server is getting this alternate error message:
Failed to login: java.net.UnknownHostException: session.minecraft.net.

Here are the fixes I tried on my husband's computer so far:
-Update Windows
-re-install minecraft
-try playing in online mode
-downgraded to Java 6 (32 and 64 bit)
-went back to Java 7, but tried 64 bit mode (since he runs in this mode)
-replaced the .jar file with my moderators .jar file

My husband has Windows 7 and I have XP; could this be the problem?

If it is server-sided, what should I tell my moderator to do since he has updated it to 1.3.1?

My husband has also removed the only mod he was running to see if that would fix it. It didn't.

#4

fred5656
    fred5656

    Tree Puncher

  • Members
  • 16 posts

Posted 03 August 2012 - 06:37 PM

This has happened to me on some servers to

#5

Gretchen317

Posted 03 August 2012 - 07:53 PM

Update:
My Server admin sent me the address to a friend's server to try. The two servers are identical except for where they are physically located in the US (Illinois and Texas). The new one worked on my husband's computer. My server admin said it is definitely an issue on the Multiplay end and put in a ticket.

#6

Brandonforty2
  • Minecraft: Brandon111199

Posted 03 August 2012 - 07:56 PM

For the java.net.socketexception connection reset, i think it is a problem with your firewall or network or 1.3.1.  For the java.net.UnknownHostException: session.minecraft.net, im not to sure.  I think it might be a problem with connecting to the mojang servers.
Every time you log onto a server, it checks with the mojang servers.  That is why cracked clients cant connect to servers.
Come check out my builds.
I usually get my information from google.

#7

HardStyle1000

Posted 03 August 2012 - 10:09 PM

so there is not fix for this? I play on three servers and each one has error codes like, Connection lost outdated server or End of stream and the all so famous Internal exception: Java.net.socketexception: Connection reset.. i have no clue how to fix this..

#8

Brandonforty2
  • Minecraft: Brandon111199

Posted 03 August 2012 - 10:48 PM

I guess you can ckeck your firewall settings.  BTW: I got this from google.  While number 2, I dont think theirs a fix for that.
Come check out my builds.
I usually get my information from google.

#9

Gretchen317

Posted 04 August 2012 - 03:03 AM

I apologize. My husband figured it out. When he re-downloaded the game, he had entered the i.p. address wrong. So, when he removed his mod and deleted everything out of the minecraft location on his computer and re-downloaded it, he had fixed it. He just didn't know it because of the typo. Thank you for all of your responses and suggestions.

#10

sabin666
    sabin666

    Newly Spawned

  • Curse Premium
  • Curse Premium
  • 1 posts

Posted 04 August 2012 - 07:43 AM

my friend has a server set up and when 1.3 came out we setp a new map and started playing with no problems.  Tonight when I tried to get on I started getting the following error.  

Failed to verify username! [internal error java.net.SocketException: Connection reset]

This error is happening to everyone that tries to connect to the server, all of us have paid for minecraft and as I said we were all playing earlier in the day with no problems. He has tried restarting his server several times and I have reinstalled Minecraft and I am using no mods or texture packs.

#11

DanSparrow
    DanSparrow

    Lapis Lazuli Collector

  • Members
  • 955 posts

Posted 04 August 2012 - 01:07 PM

I was playing on a server, now updated to 1.3.1, so I can't connect with older versions, but when I connect with 1.3.1, it gives me this error after a few seconds online. Awesome.

It seems to work in one server but it doesn't in others, so I'll have to check with them what system are they using because there's obviously something in server files causing problems with connections to some people.

#12

herobrine676
  • Location: Watching you
  • Minecraft: herobrineboo

Posted 04 August 2012 - 08:08 PM

I keep geting it on a 1.2.5 server i am going on a 1.2.5 on minecraft 1.2.5 but i keep geting it.
(The server is Realmcraft)

Posted Image
I got Ruby :)

#13

MrChris_CJ

Posted 04 August 2012 - 08:19 PM

go to

C:\Windows\System32\drivers\etc

(yes the folder is called etc)

open the "hosts" file in notepad

add the line, minus quotation marks to the bottom (for me there is a tab character between 40 and session though, not a space as it is formatted in the post)

"184.73.223.40 session.minecraft.net"

solved the issue for me, I didn't come up with the solution, but cannot for the life of me remember where I read it Posted Image

edit: you will probably have to change the security permissions inside the folder so that you are allowed to edit the file (whole run as admin rubbish that windows throws around), go into properties, security, then edit so that you can allow the needed write privileges to whatever user etc

#14

larlar9800

Posted 04 August 2012 - 08:52 PM

View PostMrChris_CJ, on 04 August 2012 - 08:19 PM, said:

go to

C:\Windows\System32\drivers\etc

(yes the folder is called etc)

open the "hosts" file in notepad

add the line, minus quotation marks to the bottom (for me there is a tab character between 40 and session though, not a space as it is formatted in the post)

"184.73.223.40 session.minecraft.net"

solved the issue for me, I didn't come up with the solution, but cannot for the life of me remember where I read it Posted Image
how do you save it? :unsure:

#15

MrChris_CJ

Posted 04 August 2012 - 09:43 PM

ah yes the pesky admin permissions

if I remember correctly I went into the folder properties and tweaked the security permissions so I had full permissions in that directory

even though I am an admin, Windows still likes to tell me I am not

#16

comette007

Posted 04 August 2012 - 11:19 PM

i put this "184.73.223.40 session.minecraft.net"
or i put the ip adress of the server

#17

MrChris_CJ

Posted 04 August 2012 - 11:22 PM

you put in

View Postcomette007, on 04 August 2012 - 11:19 PM, said:

184.73.223.40 session.minecraft.net


although as I said, between the "40" and "session" I have a tab character, so it will look more like

184.73.223.40 session.minecraft.net

not sure if that will make a difference as I don't know if Windows can get annoyed by using the wrong delimited format

#18

comette007

Posted 04 August 2012 - 11:30 PM

hum in etc i have some file
hosts
imhosts.sam
networks
protocol
services

#19

DanSparrow
    DanSparrow

    Lapis Lazuli Collector

  • Members
  • 955 posts

Posted 04 August 2012 - 11:40 PM

View Postcomette007, on 04 August 2012 - 11:30 PM, said:

hum in etc i have some file
hosts
imhosts.sam
networks
protocol
services
My advice: READ

Let me quote what he said: "open the "hosts" file in notepad"

#20

comette007

Posted 05 August 2012 - 12:12 AM

how do i save it say acces denied