Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Opening a 1.3 LAN server via Hamachi?

hamachi 1.3 open lan help

  • Please log in to reply
40 replies to this topic

#1

migueeel
    migueeel

    Zombie Killer

  • Members
  • 228 posts
  • Minecraft: Jack_red_creeper

Posted 28 July 2012 - 04:33 PM

Hi crafters!
I've been trying to make a server for me and a friend, but for the moment I'm using 2 computers (one that hosts the server, the other for playing), because of crappy computer (and other one's worse u.u).
Well, the thing is that I tried to make a LAN server with the 1.3 snapshots and I noticed that, when you open your game to LAN, it hosts the game in the computer's ip, instead of hamachi.

For example: My hamachi ip is 5.123.456.12 and my comp ip is 173.1.3.37. I press open to LAN and the game says "server hosted on 173.1.3.37".
Of course, because of wrong ip, my friend can't connect.

Any ways so I can change the hosting ip?

Register or log in to remove.

#2

Lord_Ralex
    Lord_Ralex

    Typoing Absolmin

  • Forum Admin
  • Curse Premium
  • 5808 posts
  • Location: Route 120
  • Minecraft: Lord_Ralex

Posted 28 July 2012 - 05:38 PM

Just curious, has he tried using the external IP or you try to port-forward instead of using Hamachi?

Not ran the snapshot myself so I cannot say whether or not what can be done to fix though.

MCF Admin for Servers and Mapping and Modding

Posted Image


#3

darthrevan43
  • Minecraft: darthrevan13

Posted 28 July 2012 - 07:30 PM

Seeing how this is the first result on google it is probably the best location to post the solution to this.
  • Start Run: Windows+R

  • Enter: ncpa.cpl

  • Right-click on Hamachi or your preferred network

  • Select Properties

  • In the Network tab select: Internet Protocol Version 4 (TCP/IPv4)

  • Click Properties

  • In the General tab click Advanced...

  • In the IP Settings tab uncheck the Automatic Metric option

  • In the box bellow write 1

  • Click OK and you're DONE
If you want to change your preferred network sometime then go back to the network that you changed the settings to and check the Automatic Metric option, after that you can set it 1 to the new network.

Happy Playing!
May the block be with you!

#4

jkell94
    jkell94

    Newly Spawned

  • Members
  • 1 posts

Posted 29 July 2012 - 06:17 AM

View Postdarthrevan43, on 28 July 2012 - 07:30 PM, said:

Seeing how this is the first result on google it is probably the best location to post the solution to this.
  • Start Run: Windows+R

  • Enter: ncpa.cpl

  • Right-click on Hamachi or your preferred network

  • Select Properties

  • In the Network tab select: Internet Protocol Version 4 (TCP/IPv4)

  • Click Properties

  • In the General tab click Advanced...

  • In the IP Settings tab  uncheck the Automatic Metric option

  • In the box bellow write 1

  • Click OK and your DONE
If you want to change your preferred  network sometime then go back to the netowrk that you change the settings to and check the Automatic Metric option and after that you can set it 1 to new network.

Happy Playing!
I can confirm that this works Thanks :D

#5

HawaiianLAWMAN
  • Location: Hawaii
  • Minecraft: Lawman

Posted 30 July 2012 - 12:37 AM

darthrevan43 thanks for the info, I tried your solution but have no players to really test it on...LOL
I'm not sure if this will work but I have a server hosted right now, here is the ip anyone can try it and see if it works if they want to help me test.

192.168.1.104:61025

or try it without the port 192.168.1.104
Christopher (Lawman) Law
Creator of True Minecraft

#6

lory
    lory

    Tree Puncher

  • Members
  • 15 posts

Posted 30 July 2012 - 09:03 AM

Does anyone know how to config the port on which the game is opened to lan?
It started on some 4000ish port for me for a while and my friends couldn't join, so I explicitly forwarded that port and the game then used some other port seemingly at random.
We seriously need some information on how this button works, Mojang. If It's already out there it's somewhere it shouldn't be, as I don't find it via Google. Posted Image

#7

lekrosa
    lekrosa

    Diamond Miner

  • Curse Premium
  • Curse Premium
  • 860 posts

Posted 30 July 2012 - 05:59 PM

View PostHawaiianLAWMAN, on 30 July 2012 - 12:37 AM, said:

darthrevan43 thanks for the info, I tried your solution but have no players to really test it on...LOL
I'm not sure if this will work but I have a server hosted right now, here is the ip anyone can try it and see if it works if they want to help me test.

192.168.1.104:61025

or try it without the port 192.168.1.104

Those are your internal IPs. Nobody can connect from that. You must portforward to open it up to your external IP.

Also, 61025 is not the default port, so you will have to enter it with the IP to connect.
Posted Image
Quote me to let me know you want a reply - Click the arrow if the post helped you in any way, or you just like it ->

#8

ZOMGbie
    ZOMGbie

    Stone Miner

  • Members
  • 79 posts
  • Location: Sailing on the cloud

Posted 31 July 2012 - 05:44 AM

now linux.... lol

#9

lekrosa
    lekrosa

    Diamond Miner

  • Curse Premium
  • Curse Premium
  • 860 posts

Posted 31 July 2012 - 05:11 PM

what about linux?
Posted Image
Quote me to let me know you want a reply - Click the arrow if the post helped you in any way, or you just like it ->

#10

ZOMGbie
    ZOMGbie

    Stone Miner

  • Members
  • 79 posts
  • Location: Sailing on the cloud

Posted 31 July 2012 - 09:01 PM

open a lan network with hamachi, but on ubuntu.  The above solution doesn't work for me.

#11

lekrosa
    lekrosa

    Diamond Miner

  • Curse Premium
  • Curse Premium
  • 860 posts

Posted 01 August 2012 - 12:15 AM

yes hamachi exists for ubuntu, but it is a bit hard to configure (I could not get it to work)
Posted Image
Quote me to let me know you want a reply - Click the arrow if the post helped you in any way, or you just like it ->

#12

migueeel
    migueeel

    Zombie Killer

  • Members
  • 228 posts
  • Minecraft: Jack_red_creeper

Posted 01 August 2012 - 12:46 PM

View Postdarthrevan43, on 28 July 2012 - 07:30 PM, said:

Seeing how this is the first result on google it is probably the best location to post the solution to this.
  • Start Run: Windows+R

  • Enter: ncpa.cpl

  • Right-click on Hamachi or your preferred network

  • Select Properties

  • In the Network tab select: Internet Protocol Version 4 (TCP/IPv4)

  • Click Properties

  • In the General tab click Advanced...

  • In the IP Settings tab uncheck the Automatic Metric option

  • In the box bellow write 1

  • Click OK and you're DONE
If you want to change your preferred network sometime then go back to the network that you changed the settings to and check the Automatic Metric option, after that you can set it 1 to the new network.

Happy Playing!

It works! many thanks :D

#13

coskungurel

Posted 01 August 2012 - 06:41 PM

View Postdarthrevan43, on 28 July 2012 - 07:30 PM, said:

Seeing how this is the first result on google it is probably the best location to post the solution to this.
  • Start Run: Windows+R

  • Enter: ncpa.cpl

  • Right-click on Hamachi or your preferred network

  • Select Properties

  • In the Network tab select: Internet Protocol Version 4 (TCP/IPv4)

  • Click Properties

  • In the General tab click Advanced...

  • In the IP Settings tab uncheck the Automatic Metric option

  • In the box bellow write 1

  • Click OK and you're DONE
If you want to change your preferred network sometime then go back to the network that you changed the settings to and check the Automatic Metric option, after that you can set it 1 to the new network.

Happy Playing!

It worked to some extent. I can see my friend's game but cannot joing. I get a timedout error. He doesn't even see my game in games list. Our ip adresses are shown correctly, though.

Any ideas on any fix?

#14

Guildy4
    Guildy4

    Out of the Water

  • Members
  • 2 posts

Posted 01 August 2012 - 07:09 PM

ok, using hamachi what ip do i need to use and what port ?
many thanks :)

#15

Atrelix
    Atrelix

    Tree Puncher

  • Members
  • 18 posts

Posted 01 August 2012 - 07:34 PM

Can anyone tell me where the server.props file for LAN is? Many thanks.

Click my signature for free Minecraft!

Posted Image


#16

jack5661
    jack5661

    Tree Puncher

  • Members
  • 15 posts

Posted 01 August 2012 - 08:18 PM

why does my server ip 192.168???

#17

nanocreation76

Posted 01 August 2012 - 08:40 PM

View Postdarthrevan43, on 28 July 2012 - 07:30 PM, said:

Seeing how this is the first result on google it is probably the best location to post the solution to this.
  • Start Run: Windows+R

  • Enter: ncpa.cpl

  • Right-click on Hamachi or your preferred network

  • Select Properties

  • In the Network tab select: Internet Protocol Version 4 (TCP/IPv4)

  • Click Properties

  • In the General tab click Advanced...

  • In the IP Settings tab uncheck the Automatic Metric option

  • In the box bellow write 1

  • Click OK and you're DONE
If you want to change your preferred network sometime then go back to the network that you changed the settings to and check the Automatic Metric option, after that you can set it 1 to the new network.

Happy Playing!
What about on a mac?

#18

GreenPurps

Posted 01 August 2012 - 08:58 PM

View Postdarthrevan43, on 28 July 2012 - 07:30 PM, said:

Seeing how this is the first result on google it is probably the best location to post the solution to this.
  • Start Run: Windows+R

  • Enter: ncpa.cpl

  • Right-click on Hamachi or your preferred network

  • Select Properties

  • In the Network tab select: Internet Protocol Version 4 (TCP/IPv4)

  • Click Properties

  • In the General tab click Advanced...

  • In the IP Settings tab uncheck the Automatic Metric option

  • In the box bellow write 1

  • Click OK and you're DONE
If you want to change your preferred network sometime then go back to the network that you changed the settings to and check the Automatic Metric option, after that you can set it 1 to the new network.

Happy Playing!
tryed this still having no luck. :< tryed my firewall maybe its my virus protection? idk any other suggestions would be nice

#19

Blahsadfeguie
  • Location: Taking a relaxing hot lava bath

Posted 01 August 2012 - 10:25 PM

darthrevan43's method works well enough, but whenever I do this I lose my internet connection and thus can't connect to Minecraft.net. I can get into the game and run a functional LAN server over Hamachi if I make the metric switch after logging in, but before starting the server; however, other players' skins do not load properly, and switching back after starting the server prevents anyone from joining.

Is there a way to keep Hamachi as the "default" network but have the computer access the internet through another network?
People are warned to shred the earth to get away from you before you have lost your marbles.

#20

Vathra
    Vathra

    Newly Spawned

  • Members
  • 1 posts

Posted 02 August 2012 - 03:58 AM

Ok here is a fix for the people with there internet cutting out after darthrevan43's method,
Goto Run: Windows+R
Goto CMD
Run this command every time you internet cuts out. (only have to do it maybe 1-3 times a month.

ROUTE DELETE 0.0.0.0 MASK 0.0.0.0 5.0.0.1