Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Problems With Magic Launcher, Optifine, and Minecraft Forge

minecraft problems with magic launcher optifine minecraft forge

  • Please log in to reply
80 replies to this topic

#1

krk064
    krk064

    Carpenter

  • Members
  • 62 posts
  • Minecraft: krk064

Posted 16 June 2012 - 01:49 PM

Alright, I have a problem with using Magic Launcher (I am using 0.9.8) to install Minecraft Forge and Optifine. (I am running Minecraft 1.2.5) First, when opening Magic Launcher and clicking "Setup", I clicked "add" and added Modloader. No problems. Then, I added Modloader MP, still without a problem. However, when I tried to add Minecraft Forge (minecraftforge-client-1.2.5) in red letters next to it, there was "not compatible". So, I removed this from the list (although I would really like to have minecraft forge, that is why i'm here), added all of my other mods (toomanyitems, elemental arrows, better enchanting, MC 1.2.5  -Player API client 1.0.zip, and MC 1.2.5 - Render Player API 1.3.zip), and added Optifine (OptiFine_1.2.5_HD_C2) and next to it there was "5 errors". According to some previous advice, I ignored the errors and clicked "test". When the window showed up, it remained a white screen. After removing OptiFine, I discovered that minecraft was working just fine. So, here's the challenge: Can anyone tell me a way to have both Minecraft Forge and OptiFine installed, using Magic Launcher, with everything running smoothly? Thanks!
Make sure to give my post an upvote if I helped you!Posted Image

Register or log in to remove.

#2

Planetguy
    Planetguy

    Coal Miner

  • Curse Premium
  • Curse Premium
  • 132 posts

Posted 16 June 2012 - 02:36 PM

Optifine needs to overwrite some Forge classes, make sure this is happening. Also, modloaderMP might not be compatible with Forge as of 1.2.5 so if Optifine overwriting Forge doesn't work, try removing modloaderMP.
Posted Image

#3

krk064
    krk064

    Carpenter

  • Members
  • 62 posts
  • Minecraft: krk064

Posted 16 June 2012 - 10:03 PM

View PostPlanetguy, on 16 June 2012 - 02:36 PM, said:

Optifine needs to overwrite some Forge classes, make sure this is happening. Also, modloaderMP might not be compatible with Forge as of 1.2.5 so if Optifine overwriting Forge doesn't work, try removing modloaderMP.
Please keep in mind that I am using magic launcher, so the overwriting would have to do with the order that I put the mods in. I have tried to do this before, and as I said before, optifine fails to work with or without Forge there. I will definitely try this, however, and thanks for your help.

EDIT: I removed Modloader MP, added Forge, and then added OptiFine. This time, OptiFine, in addition to forge, displayed the "not compatible" message in red letters. Again, keep in mind that I am using MAGIC LAUNCHER. Thanks again.
Make sure to give my post an upvote if I helped you!Posted Image

#4

Bob423
    Bob423

    Tree Puncher

  • Members
  • 28 posts
  • Minecraft: brs121094

Posted 17 June 2012 - 04:08 AM

im having the same problem. im not using modloader mp, and i have my mods in this order:

modloader, forge, optifine multicore
all are the latest version
this didnt work.

so i tried
modloader, optifine, forge
and i got the same thing as krk.
not compatible
in red letters. ive never gotten forge to work, even without magic launcher.
ive been trying different ways to arrange my mods, and nothing works. i've also learned that optifine is the only mod i have that is causing this, and i cant play minecraft without it, since its been REALLY laggy ever since the height limit of 256

without optifine, i still get "2 errors" next to forge. but again, i cant play minecraft without optifine

edit: TRY THIS: even tho it says not compatible with the "modloader, optifine, forge" arrangement, do it anyway. it worked for me :D (i had MC 1.2.5 - Player API client 1.1 between optfine and forge, so that might have something to do with it.) anywho, this just goes to show you. magic launcher isnt always right :P

#5

krk064
    krk064

    Carpenter

  • Members
  • 62 posts
  • Minecraft: krk064

Posted 17 June 2012 - 02:04 PM

View PostBob423, on 17 June 2012 - 04:08 AM, said:

im having the same problem. im not using modloader mp, and i have my mods in this order:

modloader, forge, optifine multicore
all are the latest version
this didnt work.

so i tried
modloader, optifine, forge
and i got the same thing as krk.
not compatible
in red letters. ive never gotten forge to work, even without magic launcher.
ive been trying different ways to arrange my mods, and nothing works. i've also learned that optifine is the only mod i have that is causing this, and i cant play minecraft without it, since its been REALLY laggy ever since the height limit of 256

without optifine, i still get "2 errors" next to forge. but again, i cant play minecraft without optifine

edit: TRY THIS: even tho it says not compatible with the "modloader, optifine, forge" arrangement, do it anyway. it worked for me Posted Image (i had MC 1.2.5 - Player API client 1.1 between optfine and forge, so that might have something to do with it.) anywho, this just goes to show you. magic launcher isnt always right Posted Image
Alright, I tried that order, modloader, optifine, player API 1.4 (I had the outdated 1.0) all of my other mods (elemental arrows, better enchanting, toomanyitems) and then added forge. Next to optifine there is still "5 errors" and next to forge there is still "not compatible". I ignored this, clicked test, and a window popped up saying "some mods are not complatible with minecraft.jar, do you want to continue?" I clicked yes, and a window with this showed up:
*** MagicMinecraftLauncher 0.9.8 ***
java.lang.IncompatibleClassChangeError: Implementing class
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(Unknown Source)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$000(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(Unknown Source)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$000(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.Class.getDeclaredMethods0(Native Method)
    at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
    at java.lang.Class.getMethod0(Unknown Source)
    at java.lang.Class.getMethod(Unknown Source)
    at magic.launcher.Launcher.main(Unknown Source)
so, problem not solved, still with no idea what is going on...... the most likely explanation would be that magic launcher simply isn't compatible, yet everyone else says that it works for them.... I doubt that this is the issue but I am running a Dell Inspiron 15R laptop with a 2nd gen i5 intel core, 6GBs of memory, 500GBs of hard drive, and 2.5 GHz.
Make sure to give my post an upvote if I helped you!Posted Image

#6

8BitAnimations
  • Location: World 4
  • Minecraft: zekerman99

Posted 17 June 2012 - 02:07 PM

Optifine and forge are incompatible with each other.
Posted Image

#7

Planetguy
    Planetguy

    Coal Miner

  • Curse Premium
  • Curse Premium
  • 132 posts

Posted 17 June 2012 - 02:45 PM

View Postsp614x said:

Compatibility with other mods
When installing OptiFine together with other mods always make sure to install OptiFine last. The only exception are mods which are designed to be installed after OptiFine and say so in their install instructions.

If you need ModLoader: Install OptiFine AFTER ModLoader.
If you need Forge: Install OptiFine AFTER Forge.


Magic Launcher will say that Optifine is incompatible with Forge, because generally mods that overwrite the same vanilla classes break each other, but Optifine actually includes the parts of Forge it overwrites.
Posted Image

#8

krk064
    krk064

    Carpenter

  • Members
  • 62 posts
  • Minecraft: krk064

Posted 18 June 2012 - 01:11 AM

View PostPlanetguy, on 17 June 2012 - 02:45 PM, said:

Magic Launcher will say that Optifine is incompatible with Forge, because generally mods that overwrite the same vanilla classes break each other, but Optifine actually includes the parts of Forge it overwrites.
I have told you, I put everything in the right order, tried the mods individually, tried different orders, none of it works. Please take the time to read my previous responses and posts before telling me something that I already know or suggesting something that I have already tried. Thanks for your help, but again, I know about and have tried all of this. I did say that it was a challenge.....
Make sure to give my post an upvote if I helped you!Posted Image

#9

Varelse4
    Varelse4

    Tree Puncher

  • Members
  • 39 posts
  • Location: Never-Never Land

Posted 18 June 2012 - 07:53 AM

Try them without using Magic Launcher, and if it does work, then post this on Magic Launcher's thread.
ALL YOUR KITTENS ARE BELONG TO ME

#10

Reagle606

Posted 18 June 2012 - 09:36 AM

Well i opened my mine craft.jar with he mod loader command (I'm on mac os 10.7) and then installed forge. the straight after that optifine and it says in game forge 1 mods loaded optifine. i have the multicore version so if this was any help good
Posted Image

#11

Lord_Time_Crafter
  • Location: I wonder...
  • Minecraft: The_Time_Crafter
  • Xbox:N/A

Posted 18 June 2012 - 10:02 AM

This is in the wrong section. This is more to do with mods.
Posted Image

#12

krk064
    krk064

    Carpenter

  • Members
  • 62 posts
  • Minecraft: krk064

Posted 19 June 2012 - 12:42 PM

View PostVarelse4, on 18 June 2012 - 07:53 AM, said:

Try them without using Magic Launcher, and if it does work, then post this on Magic Launcher's thread.
I have already tried to install just mod loader without magic launcher, and my minecraft crashed. Also, the challenge was to find a way to have optifine and forge work with Magic launcher, because I really don't want to mess with files in my minecraft.jar

View PostReagle606, on 18 June 2012 - 09:36 AM, said:

Well i opened my mine craft.jar with he mod loader command (I'm on mac os 10.7) and then installed forge. the straight after that optifine and it says in game forge 1 mods loaded optifine. i have the multicore version so if this was any help good
could you say that again? I think this might really help but I didn't understand it so could you post it with clearer wording?

View PostTime1, on 18 June 2012 - 10:02 AM, said:

This is in the wrong section. This is more to do with mods.
Magc launcher is actually a launcher so no, this is in the right section. I would appreciate solutions, though, and not criticism.

View Post8BitAnimations, on 17 June 2012 - 02:07 PM, said:

Optifine and forge are incompatible with each other.
I know this not to be true. I have read multiple forums, post and links, even watching several videos, all saying that they are indeed compatible.
Make sure to give my post an upvote if I helped you!Posted Image

#13

Fortifier41

Posted 19 June 2012 - 12:43 PM

Optifine and Forge work fine together.... Posted Image

ModLoaderMP & Forge are incompatible as of 1.2.5. There is a fix out for this called FML (ForgeModLoader).
Posted Image

#14

krk064
    krk064

    Carpenter

  • Members
  • 62 posts
  • Minecraft: krk064

Posted 19 June 2012 - 02:20 PM

Okay, I'm excited here. I have come across something new. I successfully installed both Forge and OptiFine in Magic Launcher. They no longer say "not compatible" but Forge has "9 errors" next to it and OptiFine has "4 errors" next to it. I ignored this, and hit "Test" at the bottom. The Minecraft title screen came up (the texture pack Dokucraft: The Saga Continues High has white lettering instead of the usual gold, which meant that it hadn't been patched, even though it had) and I even managed to get onto my world fine. After about 10 seconds of walking around, Minecraft crashed. I closed out the test window and clicked "Test" again. This time, the texture pack lettering was fine. However, when I clicked on my world, Minecraft crashed again. This is what came up:

1 mod loaded
Optifine OptiFine_1.2.5_HD_C2
Minecraft Forge 3.3.7.135
FML v2.2.48.135
Forge Mod Loader version 2.2.48.135 for Minecraft 1.2.5
mod_MinecraftForge : Available (minecraftforge-client-3.3.7.135.zip)


  Minecraft has crashed!   
  ----------------------   

Minecraft has stopped running because it encountered a problem.




--- BEGIN ERROR REPORT c86da1cd --------
Generated 6/19/12 9:10 AM

Minecraft: Minecraft 1.2.5
OS: Windows 7 (amd64) version 6.1
Java: 1.6.0_27, Sun Microsystems Inc.
VM: Java HotSpotâ„¢ 64-Bit Server VM (mixed mode), Sun Microsystems Inc.
LWJGL: 2.4.2
OpenGL: Intel® HD Graphics Family version 3.1.0 - Build 8.15.10.2361, Intel

java.lang.NullPointerException
at com.pclewis.mcpatcher.mod.Colorizer.colorizeBiome(Colorizer.java:134)
at ky.<init>(SourceFile:12)
at l.b(RenderGlobal.java:1881)
at l.a(RenderGlobal.java:1824)
at xd.a(World.java:1514)
at agv.b(SourceFile:218)
at xd.v(World.java:3671)
at net.minecraft.client.Minecraft.k(Minecraft.java:1880)
at net.minecraft.client.Minecraft.x(Minecraft.java:822)
at net.minecraft.client.Minecraft.run(Minecraft.java:750)
at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT 41ab9ab3 ----------
I did this by downloading Forge again, and for some reason the version was different. That is why it worked. Anyway, I removed all of my mods and the only mods on the list of Magic Launcher are Modloader, minecraftforge-client-3.3.7.135.zip, and OptiFine_1.2.5_HD_C2.zip. I am using the standard version of OptiFine. EXCITING! Posted Image

EDIT: On the Minecraft Title Screen in the Test window this was in the bottom left corner:
Minecraft 1.2.5
FMl v2.2.48.135
Optifine OptiFine_1.2.5_HD_C2
1 mod loaded
Also, if I try to get into any of my other worlds, Minecraft crashes and the same message as above shows up. STILL EXCITED! :)
Make sure to give my post an upvote if I helped you!Posted Image

#15

pickiniratmat
  • Location: in USA, Los Angeles
  • Minecraft: ratra1

Posted 20 June 2012 - 12:11 AM

forge never work -_-

My signature:

Posted Image

My server:

Posted Image


#16

stuffjunk
  • Location: right behind you >:D
  • Minecraft: stuffjunk

Posted 24 June 2012 - 04:22 AM

so question what do u do if u install a mod and it says no mods found for the satus???

so what do u do if u install a mod with ml and it tells u no mods found(pokemods for example)

#17

starlinvf
    starlinvf

    Glowstone Miner

  • Members
  • 3169 posts

Posted 24 June 2012 - 04:36 AM

View Poststuffjunk, on 24 June 2012 - 04:22 AM, said:

so question what do u do if u install a mod and it says no mods found for the satus???

so what do u do if u install a mod with ml and it tells u no mods found(pokemods for example)

Talk to the launcher and mod makers.  The way mods are injected into minecraft makes the process both error prone and difficult to resolve when you start mixing them.

#18

razorknight117

Posted 24 June 2012 - 09:48 PM

well for me it says "not compatible" but my game runs fine, well derp my first post

#19

Veerorith
  • Minecraft: VeeroRith

Posted 25 June 2012 - 10:02 PM

Same sort of errors for me, it seems like optifine, modloader, and forge just dont want to work together... I cant quite figure out how to fix this insanity...
I guess no battlegear then, does battlegear require forge, or just for spear??

#20

igotmilk2012

Posted 25 June 2012 - 10:50 PM

i had the same problem and fixed it today but i might be to late, u said u used a texture pack, do u use mc patcher? if so un patch and either run forge or optifine but not both. hope it works!