Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

How to reduce lag in Minecraft


  • Please log in to reply
43 replies to this topic

#1

314rft
    314rft

    Diamond Miner

  • Members
  • 842 posts
  • Location: planet Earth
  • Minecraft: 314rft

Posted 07 June 2012 - 12:37 AM

First thing, is this thread in the right place? I'm new to the forums and this is my first topic I started.


Here are some ways that i know reduce lag in Minecraft, some might work, some might not, but some are guaranteed to reduce lag.

I'll list some ways with an explanation on how to do them, starting with obvious going to non obvious.

1. Lower graphics - what you do is click esc then go into options then video settings and then lower your graphics. What to lower might vary, but definitely turn graphics to fast, rendering to normal or lower, smooth lighting off, and the rest may vary, but probably lower them anyway.

2. Set priority to high - this one doesn't work on me for some reason but it might work on you. What you do is push control-alt-delete, then click start task manager, then go to processes, then look for javaw.exe, if you can't find make sure minecraft is open first, if you STILL can't find it, then click "j" without quotes and javaw,exe will come up. What you do from there is right click on javaw.exe then go to set priority and click high. NOTE: you'll have to do this everytime you start up MC because it resets. You don't have to do this one though and you don't have to do it whenever you load up MC for MC to work,(I couldn't word that last sentence any differently without you getting confused).

3. Install optifine - this really helped me.

I'll add more later, but that's it for now.
Posted Image
The far lands generation was epic, why not re-add it?

Register or log in to remove.

#2

Craftiyan
  • Location: Lake Silencio, UT. April 22, 2010, 5:02 PM.
  • Minecraft: bdejean

Posted 07 June 2012 - 12:45 AM

Installing Optifine can't hurt, either.
Let’s play good guys against bad guys… Yes. Let’s play that. Are you ready? You’re the bad guy. And when you’re bad, you just run. That’s fine right? Well… Shall we play?

#3

CrazyCraft28

Posted 07 June 2012 - 01:20 AM

Well, I have a few ideas:

1.Set Graphics to "fast"

2.Set Particles to decreased

3.Turn smooth lighting off

4.turn clouds off

I hope this helped!

#4

Craftiyan
  • Location: Lake Silencio, UT. April 22, 2010, 5:02 PM.
  • Minecraft: bdejean

Posted 07 June 2012 - 01:22 AM

View PostCrazyCraft28, on 07 June 2012 - 01:20 AM, said:

Well, I have a few ideas:

1.Set Graphics to "fast"

2.Set Particles to decreased

3.Turn smooth lighting off

4.turn clouds off

I hope this helped!

Did you read the OP?
Let’s play good guys against bad guys… Yes. Let’s play that. Are you ready? You’re the bad guy. And when you’re bad, you just run. That’s fine right? Well… Shall we play?

#5

TurboVeggie
    TurboVeggie

    Lapis Lazuli Collector

  • Members
  • 1040 posts
  • Location: Oribiting Mars
  • Minecraft: Herobrine_Exodus

Posted 07 June 2012 - 01:23 AM

And, still, even setting everything to the minimum didn't help minecraft load 15,250ish entities of lit TNT.
Optifine time :U
First I'll delete 'em with MCEdit.
İndi Danışıq Azərbaycan alıram

#6

Kelts44
    Kelts44

    Tree Puncher

  • Members
  • 36 posts

Posted 29 July 2012 - 06:55 PM

I only get lag when loading massive mods like the Star Wars mod, but this is an EPIC idea for people who do their gaming on laptops:
  • Change your graphics drivers - there are two ways to do this, first of all, you can buy a better graphics card (Expensive and risky) or change to 64 bit colours in the control panel and install a 64 bit Java. You can also change the graphics software by un-installing it in your add or remove programs section and getting a better version.
  • Change render distance to 'tiny'. I usually have it on short or normal, but with mods like the 'Technic Pack' you are gonna need it (Unless you have a desktop PC, in which case why the heck are you reading this?). You can also turn the smooth lighting off (Yes, I know that was mentioned, smart-arse) and in extreme cases, turning the bobbing off. Basically, make sure your game looks absolutely crap and there will be NO LAG :) (Unless you are me and the world hates you because you have barely any money for a fancy f***ing desktop computer).
  • If you are STINKING RICH then you can just simply replace the core drivers and graphics drivers and then the lag shall disappear. Also, if you get paid £250,000 a week, then you can install new memory and that should help too :)
And that concludes why my life of gaming sucks.
Posted Image

#7

AlexanderValkyrie
  • Location: Minecraft, duh

Posted 29 July 2012 - 07:11 PM

I'm not entirely sure yet but I think playing in a smaller screen (playing without fullscreening Minecraft) helps it run a little faster.

I've also noticed that jungle biomes and snow biomes are laggier than other biomes so build your main base outside of those biomes.
http://www.minecraft...-the-villagers/
Click here if you support more interaction with the Villagers!

#8

CameronLateralus

Posted 30 July 2012 - 12:55 AM

View PostAlexanderValkyrie, on 29 July 2012 - 07:11 PM, said:

I'm not entirely sure yet but I think playing in a smaller screen (playing without fullscreening Minecraft) helps it run a little faster.
Playing the game at lower resolutions is a good way to improve performance.

- Stop all unnecessary processes with task manager, and close all other programs.
- Update your graphics card drivers
- If you have a 64 bit OS (On windows you can check by right-clicking Computer > Properties. It will tell you under System Type), make sure you are using 64 bit Java. Downloads here. This will make minecraft "large address aware", so it can use up to 4GB of RAM.
- Lowering your computer's screen resolution to 1024x768 (that is, if it is above this resolution) will help too.

#9

_Xiae
    _Xiae

    Void Walker

  • Retired Staff
  • 1575 posts
  • Location: Tasmania, AU
  • Minecraft: _Xiae

Posted 30 July 2012 - 03:21 AM

Just adding another method,
if you have a laptop with Intel GMA 945/950 graphics [Not many people have :P], you can get custom drivers for it. The performance increase isn't huge, but its certainly noticeable.

Sherry 945 drivers: Here.

Posted Image


#10

Arekku
    Arekku

    Tree Puncher

  • Members
  • 16 posts
  • Minecraft: iAlek

Posted 30 July 2012 - 03:23 AM

I have no problems running Minecraft Vanilla, but one time I decided to install the GLSL Shaders mod. That mod (as many already know, eats your resources completely). What I did was change the whole resolution of Minecraft to 640x480 and playing it on fullscreen.

To do it, rightclick your Minecraft.exe or Shortcut, go to compatibility and check the "Run in 640x480 mode" option. Then just launch your minecraft and go into fullscreen (F11 or force fullscreen in you options.txt). With the PC I have + Optifine and one of the Heaviest shader configs, I was running on 60 - 65 FPS happily, when in normal resolution I'd get around the 10 - 15 FPS. Huge improvement, but I only recommend it if you don't mind playing Minecraft with more pixels than it already involves.

#11

Cml42199
  • Minecraft: semper_fi_

Posted 30 July 2012 - 05:34 PM

View PostCrazyCraft28, on 07 June 2012 - 01:20 AM, said:

Well, I have a few ideas:

1.Set Graphics to "fast"

2.Set Particles to decreased

3.Turn smooth lighting off

4.turn clouds off

I hope this helped!
.  I'll try

View PostKelts44, on 29 July 2012 - 06:55 PM, said:

I only get lag when loading massive mods like the Star Wars mod, but this is an EPIC idea for people who do their gaming on laptops:
  • Change your graphics drivers - there are two ways to do this, first of all, you can buy a better graphics card (Expensive and risky) or change to 64 bit colours in the control panel and install a 64 bit Java. You can also change the graphics software by un-installing it in your add or remove programs section and getting a better version.
  • Change render distance to 'tiny'. I usually have it on short or normal, but with mods like the 'Technic Pack' you are gonna need it (Unless you have a desktop PC, in which case why the heck are you reading this?). You can also turn the smooth lighting off (Yes, I know that was mentioned, smart-arse) and in extreme cases, turning the bobbing off. Basically, make sure your game looks absolutely crap and there will be NO LAG :) (Unless you are me and the world hates you because you have barely any money for a fancy f***ing desktop computer).
  • If you are STINKING RICH then you can just simply replace the core drivers and graphics drivers and then the lag shall disappear. Also, if you get paid £250,000 a week, then you can install new memory and that should help too :)
And that concludes why my life of gaming sucks.

View PostCraftiyan, on 07 June 2012 - 12:45 AM, said:

Installing Optifine can't hurt, either.
what is that

View Post314rft, on 07 June 2012 - 12:37 AM, said:

First thing, is this thread in the right place? I'm new to the forums and this is my first topic I started.


Here are some ways that i know reduce lag in Minecraft, some might work, some might not, but some are guaranteed to reduce lag.

I'll list some ways with an explanation on how to do them, starting with obvious going to non obvious.

1. Lower graphics - what you do is click esc then go into options then video settings and then lower your graphics. What to lower might vary, but definitely turn graphics to fast, rendering to normal or lower, smooth lighting off, and the rest may vary, but probably lower them anyway.

2. Set priority to high - this one doesn't work on me for some reason but it might work on you. What you do is push control-alt-delete, then click start task manager, then go to processes, then look for javaw.exe, if you can't find make sure minecraft is open first, if you STILL can't find it, then click "j" without quotes and javaw,exe will come up. What you do from there is right click on javaw.exe then go to set priority and click high. NOTE: you'll have to do this everytime you start up MC because it resets. You don't have to do this one though and you don't have to do it whenever you load up MC for MC to work,(I couldn't word that last sentence any differently without you getting confused).

3. Install optifine - this really helped me.

I'll add more later, but that's it for now.
do you know how to make pocket edition not lag?

#12

TheRealDeletedUnit

Posted 31 July 2012 - 10:40 PM

View PostCml42199, on 30 July 2012 - 05:34 PM, said:

do you know how to make pocket edition not lag?
Have you tried killing your apps?

#13

Damagetype

Posted 05 August 2012 - 12:41 AM

I was trying to find all the methods to reduce lag in minecraft and many other games and i have decided to share my knowledge :  1) You can set low graphics in game as mentioned above.

2)Go to start and right-click on "Computer" and go to properties. On the left you will see "Advanced system settings" , click on it then you will see a window with system properties. Go to the "advanced" tab and click on settings right under performance, from there you can simply "adjust for best performance" and after you've done you can go to the advanced tab (again :) ), and click the change button under the "virtual memory" section . Now you can set how much of you're disk space you want to transform into RAM if you press "change" .

3)Install optifine

4)Right click the battery icon on your notification area and set power option to high performance.

5)Install a program called gamebooster . What it basically does is close all the unneccesary processes in the background http://www.iobit.com/gamebooster.html <- download link

6) I might add some methods later on :)

#14

dlminecr
    dlminecr

    Tree Puncher

  • Members
  • 30 posts
  • Minecraft: dlminecr

Posted 12 September 2012 - 09:35 AM

With OptiFine light I get 50-90 fps it really varies. I find that every time I enter my house it begins to lag a lot. I start to get 100-130 fps but every few seconds I lag to 0. I find it lags a lot when I go in my treehouse too.

#15

alxd133
    alxd133

    Out of the Water

  • Members
  • 3 posts

Posted 17 September 2012 - 05:56 PM

View PostArekku, on 30 July 2012 - 03:23 AM, said:

I have no problems running Minecraft Vanilla, but one time I decided to install the GLSL Shaders mod. That mod (as many already know, eats your resources completely). What I did was change the whole resolution of Minecraft to 640x480 and playing it on fullscreen.

To do it, rightclick your Minecraft.exe or Shortcut, go to compatibility and check the "Run in 640x480 mode" option. Then just launch your minecraft and go into fullscreen (F11 or force fullscreen in you options.txt). With the PC I have + Optifine and one of the Heaviest shader configs, I was running on 60 - 65 FPS happily, when in normal resolution I'd get around the 10 - 15 FPS. Huge improvement, but I only recommend it if you don't mind playing Minecraft with more pixels than it already involves.
Thank you so much my computer sucks so that helps alot. I still have to run in a window but it's a TON better. Thank you, alxd133

#16

314rft
    314rft

    Diamond Miner

  • Members
  • 842 posts
  • Location: planet Earth
  • Minecraft: 314rft

Posted 01 October 2012 - 10:52 PM

View PostCml42199, on 30 July 2012 - 05:34 PM, said:

.
do you know how to make pocket edition not lag?

I don't have the pocket edition.
Posted Image
The far lands generation was epic, why not re-add it?

#17

ramo486
    ramo486

    Iron Miner

  • Members
  • 306 posts
  • Location: New York
  • Minecraft: r10d10
  • Xbox:FTG Odyssey

Posted 01 October 2012 - 11:04 PM

New to the forums with 266 posts? Sketchy, but whatever. Also this is a very wrong sub-topic, and this thread already exists.
Posted Image

#18

IronicWedgie

Posted 14 October 2012 - 07:43 AM

Thanks to this my guy moved for the first time in ten minutes.

But somehow still lagging incredibly

#19

AJD2002
    AJD2002

    Zombie Killer

  • Members
  • 159 posts
  • Location: Hamilton, Ontario, Canada
  • Minecraft: AJD2002

Posted 24 October 2012 - 07:47 PM

View PostCrazyCraft28, on 07 June 2012 - 01:20 AM, said:

Well, I have a few ideas:

1.Set Graphics to "fast"

2.Set Particles to decreased

3.Turn smooth lighting off

4.turn clouds off

I hope this helped!

Also try going into video settings and turning off view bobbing.
www.youtube.com/user/ajd2002gaming

#20

TheProMiner25

Posted 07 December 2012 - 11:41 AM

View PostArekku, on 30 July 2012 - 03:23 AM, said:

I have no problems running Minecraft Vanilla, but one time I decided to install the GLSL Shaders mod. That mod (as many already know, eats your resources completely). What I did was change the whole resolution of Minecraft to 640x480 and playing it on fullscreen.

To do it, rightclick your Minecraft.exe or Shortcut, go to compatibility and check the "Run in 640x480 mode" option. Then just launch your minecraft and go into fullscreen (F11 or force fullscreen in you options.txt). With the PC I have + Optifine and one of the Heaviest shader configs, I was running on 60 - 65 FPS happily, when in normal resolution I'd get around the 10 - 15 FPS. Huge improvement, but I only recommend it if you don't mind playing Minecraft with more pixels than it already involves.
Thank you very much! This is an amazing way to increase FPS!!! However, the game ends up looking very odd and pixely as you said, but either way its awesome thanks alot!