Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

The '[WARNING] Can't keep up!....' problem


  • Please log in to reply
7 replies to this topic

#1

Tarn_Williamson1995

Posted 06 June 2012 - 01:38 PM

I host a server for me and my friends, when I am playing on the server the server maintains a good state, it is fast etc. However, if I leave my whole computer alone, after a while people get kicked, saying 'End of stream' and on the cmd it says 'can't keep up, did the time change.........'. I have changed my computer settings so it doesn't go onto sleep mode, however, the server continues to do this when the computer is left alone for around half an hour (the screen is still on and everything...). It's as if the computer is saving energy by going into a 'false' sleep mode which i am visually unaware of.
P.S I have chosen 3gb ram for the server (my computer has 8gb in total).
Thanks in advance :)

Register or log in to remove.

#2

Apollo_
    Apollo_

    Obsidian Miner

  • Members
  • 1327 posts
  • Location: Planet X (Yes, I get WiFi)
  • Minecraft: Rustayy

Posted 06 June 2012 - 04:13 PM

I would also like to know this.  My server has this problem every once in a while

Posted Image

Community Manager for SubZeroNetwork.com

Ex-Helper on Hypixel.net || Ex-Web Developer on Cylum.net


#3

Papalbator

Posted 07 June 2012 - 06:56 AM

Everybody encounter this problem.
But I managed to limit this event.
You just have to launch a Minecraft client on the computer that hosting your server.

If you're hosting on your own computer, just let your client running when you're away. No need to be in a game, but you need to be logged.
If your server is on another system, even a VM, you have to download the exe client on minecraft.net, then you just have to start the client on the same machine as the server and keep it running.

Personally I rent a VM through a special website and in addition to my server, I upload via FTP client Minecraft. I then asked the site administrator to start it and let it run at the same time as the server. Machine used in the load is relatively low if you do not leave it in full screen.

No more warning message since.
Hoping I helped you. bye.

#4

Mojokojo
    Mojokojo

    Lapis Lazuli Collector

  • Members
  • 911 posts
  • Location: Texas
  • Minecraft: Mojokojo

Posted 07 June 2012 - 07:26 AM

Remove all your plugins. If the problem persists its because you are lagging from too many resource intensive plugins. If this is not the problem right click on your clock in the right hand corner. Goto "Adjust date/time",  go to the "Internet Time" tab, and synchronize. Some times this error will appear if your server time is not matching your machine time. If none of these solutions work it's still a configuration error or your server is lagging.
Did I help? Click that green button!

Posted Image

#5

Papalbator

Posted 07 June 2012 - 10:42 AM

View PostMojokojo, on 07 June 2012 - 07:26 AM, said:

Remove all your plugins. If the problem persists its because you are lagging from too many resource intensive plugins. If this is not the problem right click on your clock in the right hand corner. Goto "Adjust date/time",  go to the "Internet Time" tab, and synchronize. Some times this error will appear if your server time is not matching your machine time. If none of these solutions work it's still a configuration error or your server is lagging.

I dont think this problem is caused by plugins or by the time protocol.
I made many tests about this, running my server on Windows, Linux (Ubuntu and Debian) and Mac OS X, and each time I synchronized my date/time on a NTP server. I kept the warning message onto all solutions.
I tried too with using no plugins, and even without using Bukkit.
The problem persist even like this.

I think the server encounter this problem because there's no client running on the same machine.
Maybe the client is the referent for the time. I dont know how ticks works in those programs.
But Im sure of this : Until Im running a minecraft exe client on the same machine than the server, I don't have anymore [WARNING]s.

To resolve this problem, That's the only solution I found.

But if anyone knows why this problem exists, I would be glad to know how to solve it.

#6

Catatonic27
  • Location: USA
  • Minecraft: Catatonic27

Posted 07 June 2012 - 03:26 PM

When I get this problem on my server, it's always because the CPU is pinged out at 100%. I often have two servers running on the same machine, so when I do something really intense on one server [i.e: generating 50,000+ blocks with WorldEdit or a large TNT detonation] I'll often get this error a few times in the other console until the server is done crunching those calculations.

Typically this problem fixes itself, but depending on what caused I somtimes have to stop the offending server in order to stop the lag from effecting the people in the other one.

Basically it's just your server whining about your processor being busy with other things. Make sure there's nothing else going on that would utilize CPU like internet browsers, audio players, etc.

Edit: In your bukkit.yml document there is a setting called 'warn-on-overload: true'. If you were to set this to false, I'm confindent that you would stop getting spammed in the console with this error.
As always my children, stay away from drugs, open flame, and normal people. They will all ruin your life.

#7

Papalbator

Posted 08 June 2012 - 06:53 AM

View PostCatatonic27, on 07 June 2012 - 03:26 PM, said:

Edit: In your bukkit.yml document there is a setting called 'warn-on-overload: true'. If you were to set this to false, I'm confindent that you would stop getting spammed in the console with this error.

That sounds right.
Im going to test this tonight and will give you a return.

But, if we just change this, we just turn off the alert, but the problem stays even there's no alert, no ?

#8

Catatonic27
  • Location: USA
  • Minecraft: Catatonic27

Posted 08 June 2012 - 12:54 PM

View PostPapalbator, on 08 June 2012 - 06:53 AM, said:

That sounds right.
Im going to test this tonight and will give you a return.

But, if we just change this, we just turn off the alert, but the problem stays even there's no alert, no ?

True. This will only stop the console spam, if your CPU truly can't handle what is being asked of it, it may be wise to fix the problem instead of ignoring it.
As always my children, stay away from drugs, open flame, and normal people. They will all ruin your life.