Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[1.6.2/1.5.2][Forge] denoflions Mods! (Threads condensed)

smp forestry

  • Please log in to reply
2401 replies to this topic

#941

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 23 December 2012 - 05:54 AM

Mod porting:

Done:
denLib
HDSAC
PfF2

Not Done:
Valve Pipe (and more!)
Custom Machine Recipes (CMR is no longer supported. I really have zero interest in it.)
Gate Copy
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

Register or log in to remove.

#942

harley9699

Posted 23 December 2012 - 06:34 AM

View Postdenoflions, on 23 December 2012 - 05:54 AM, said:

Mod porting:

Done:
denLib
HDSAC
PfF2

Not Done:
Valve Pipe (and more!)
Custom Machine Recipes (CMR is no longer supported. I really have zero interest in it.)
Gate Copy
Cool. Just starting a new 146 one, so will need pipes before gates anyway. Great job, man. (Obviously PfF2 before all)


Posted Image


#943

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 23 December 2012 - 06:47 AM

View Postharley9699, on 23 December 2012 - 06:34 AM, said:

Cool. Just starting a new 146 one, so will need pipes before gates anyway. Great job, man. (Obviously PfF2 before all)

I'm not sure of the fate of the Valve Pipe mod. Thermal Expansion and Rp2 remove most of the need for it honestly.
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

#944

harley9699

Posted 23 December 2012 - 06:55 AM

RP2's config is fried. Putting in PfF2 I get this:
Spoiler:

No RP2 involved...yet. I can't get it to work. Config's just mucked up.


Posted Image


#945

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 23 December 2012 - 07:00 AM

View Postharley9699, on 23 December 2012 - 06:55 AM, said:

RP2's config is fried. Putting in PfF2 I get this:
Spoiler:

No RP2 involved...yet. I can't get it to work. Config's just mucked up.

Relevant part of that log:
Slot 4095 is already occupied by ic2.core.block.BlockTex@3ca2b53e when adding forestry.core.gadgets.BlockSoil@2f7bb95a at amq <init>(Block.java:324)

Basically, an ID conflict made Forestry crap out, which then dominoes PfF down with it when it tries to ask Forestry for some item references.
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

#946

harley9699

Posted 23 December 2012 - 07:04 AM

View Postdenoflions, on 23 December 2012 - 07:00 AM, said:

Relevant part of that log:
Slot 4095 is already occupied by ic2.core.block.BlockTex@3ca2b53e when adding forestry.core.gadgets.BlockSoil@2f7bb95a at amq <init>(Block.java:324)

Basically, an ID conflict made Forestry crap out, which then dominoes PfF down with it when it tries to ask Forestry for some item references.
Geez. Sorry for bothering you. Late and with the flu---seeing kinda hazy.

Oh! You have any problems with RP2? Like, the 2nd time it's started after install?


Posted Image


#947

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 23 December 2012 - 07:06 AM

View Postharley9699, on 23 December 2012 - 07:04 AM, said:

Geez. Sorry for bothering you. Late and with the flu---seeing kinda hazy.

Oh! You have any problems with RP2? Like, the 2nd time it's started after install?

Don't worry about it. I'm not really doing anything but chatting in #ThermalExpansion anyway.
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

#948

harley9699

Posted 23 December 2012 - 07:09 AM

View Postdenoflions, on 23 December 2012 - 07:06 AM, said:

Don't worry about it. I'm not really doing anything but chatting in #ThermalExpansion anyway.
May have edited too late: have you had any RP2 problems? (like 2nd start config going crazy)


Posted Image


#949

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 23 December 2012 - 07:17 AM

View Postharley9699, on 23 December 2012 - 07:09 AM, said:

May have edited too late: have you had any RP2 problems? (like 2nd start config going crazy)

Rp2's auto assign is a little... stupid. Add onto that it doesn't report conflicts correctly, so when something conflicts you get a scary error like this:

Spoiler:

... instead of the normal conflict message.
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

#950

harley9699

Posted 23 December 2012 - 07:23 AM

View Postdenoflions, on 23 December 2012 - 07:17 AM, said:

Rp2's auto assign is a little... stupid. Add onto that it doesn't report conflicts correctly, so when something conflicts you get a scary error like this:

Spoiler:

... instead of the normal conflict message.
Yeah, but I didn't ever have the auto on, got multiple items with the same ID, resets on restart, etc. Massive oddness.


Posted Image


#951

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 23 December 2012 - 07:28 AM

View Postharley9699, on 23 December 2012 - 07:23 AM, said:

Yeah, but I didn't ever have the auto on, got multiple items with the same ID, resets on restart, etc. Massive oddness.

auto-assign turns itself on at least once when you first install Rp2. I'm actually watching my copy of Rp2 pick a fight with itself assigning every paint can to the same id. It is a bit... odd.
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

#952

harley9699

Posted 23 December 2012 - 07:31 AM

View Postdenoflions, on 23 December 2012 - 07:28 AM, said:

auto-assign turns itself on at least once when you first install Rp2. I'm actually watching my copy of Rp2 pick a fight with itself assigning every paint can to the same id. It is a bit... odd.
Mine too! PLEASE tell me how you resolve and fix it. Mine: once it's ready, it'll work fine. But then, after I shut down and restart MC, the numbers are messed up again.


Posted Image


#953

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 23 December 2012 - 07:37 AM

View Postharley9699, on 23 December 2012 - 07:31 AM, said:

Mine too! PLEASE tell me how you resolve and fix it. Mine: once it's ready, it'll work fine. But then, after I shut down and restart MC, the numbers are messed up again.

Will do. Feel free to join us in IRC in the meantime.
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

#954

harley9699

Posted 23 December 2012 - 07:46 AM

View Postdenoflions, on 23 December 2012 - 07:37 AM, said:

Will do. Feel free to join us in IRC in the meantime.
Lol! Thanks, but no. You guys would be way over my head. I can't even get this stupid RP2 to work. :)


Posted Image


#955

Khalamov

Posted 23 December 2012 - 07:52 AM

*sigh* Yeah, PluginsforForestry still not playing nice with GregTech, even with both mods ported to 1.4.6.

Same error, too:

2012-12-23 01:50:15 [INFO] [STDOUT] [LiquidRoundup]: Generating generic texture for .
2012-12-23 01:50:15 [INFO] [STDERR] Uncaught error fetching image:
2012-12-23 01:50:15 [INFO] [STDERR] java.lang.NullPointerException
2012-12-23 01:50:15 [INFO] [STDERR] at sun.awt.image.URLImageSource.getConnection(Unknown Source)
2012-12-23 01:50:15 [INFO] [STDERR] at sun.awt.image.URLImageSource.getDecoder(Unknown Source)
2012-12-23 01:50:15 [INFO] [STDERR] at sun.awt.image.InputStreamImageSource.doFetch(Unknown Source)
2012-12-23 01:50:15 [INFO] [STDERR] at sun.awt.image.ImageFetcher.fetchloop(Unknown Source)
2012-12-23 01:50:15 [INFO] [STDERR] at sun.awt.image.ImageFetcher.run(Unknown Source)

It hangs at this point, Minecraft never finished crashing, it just halts.

#956

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 23 December 2012 - 08:00 AM

View PostKhalamov, on 23 December 2012 - 07:52 AM, said:

*sigh* Yeah, PluginsforForestry still not playing nice with GregTech, even with both mods ported to 1.4.6.

Same error, too:

2012-12-23 01:50:15 [INFO] [STDOUT] [LiquidRoundup]: Generating generic texture for .
2012-12-23 01:50:15 [INFO] [STDERR] Uncaught error fetching image:
2012-12-23 01:50:15 [INFO] [STDERR] java.lang.NullPointerException
2012-12-23 01:50:15 [INFO] [STDERR] at sun.awt.image.URLImageSource.getConnection(Unknown Source)
2012-12-23 01:50:15 [INFO] [STDERR] at sun.awt.image.URLImageSource.getDecoder(Unknown Source)
2012-12-23 01:50:15 [INFO] [STDERR] at sun.awt.image.InputStreamImageSource.doFetch(Unknown Source)
2012-12-23 01:50:15 [INFO] [STDERR] at sun.awt.image.ImageFetcher.fetchloop(Unknown Source)
2012-12-23 01:50:15 [INFO] [STDERR] at sun.awt.image.ImageFetcher.run(Unknown Source)

It hangs at this point, Minecraft never finished crashing, it just halts.

I swear I fixed that error. How... annoying. That null name keeps slipping through in different places. Eventually it will run out of places to hide!
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

#957

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 23 December 2012 - 08:11 AM

@Khalamov: Give build 3 a try.
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

#958

harley9699

Posted 23 December 2012 - 08:15 AM

View Postdenoflions, on 23 December 2012 - 08:11 AM, said:

@Khalamov: Give build 3 a try.
That's odd. He must be running different mods than I am---I'm only up to 44 right now. Didn't get that error.


Posted Image


#959

Khalamov

Posted 23 December 2012 - 08:20 AM

View Postdenoflions, on 23 December 2012 - 08:00 AM, said:

I swear I fixed that error. How... annoying. That null name keeps slipping through in different places. Eventually it will run out of places to hide!

I was going to go back and edit my last post, but you beat me to it with an update, but with PfF installed and with GregTech removed, I still get a crash, although it's a different one.  I believe I have everything installed correctly, denLib in core mods and PfF in the mods folder.

Here's the crash report with the latest version you just posted (rev 3):

(with GregTech & PfF installed)  http://paste.ubuntu.com/1458947/

(with PfF installed, but not GregTEch) http://paste.ubuntu.com/1458943/

#960

sadris
    sadris

    Gold Miner

  • Members
  • 379 posts

Posted 23 December 2012 - 08:20 AM

Can you add a fuel based on gunpowder? It seems to be in great supply in late game and has no purpose.