Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[1.6.2/1.5.2][Forge] denoflions Mods! (Threads condensed)

smp forestry

  • Please log in to reply
2401 replies to this topic

#1001

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 25 December 2012 - 09:24 AM

View Postharley9699, on 25 December 2012 - 09:17 AM, said:

Thanks for renaming them with V number.

...and, no more out-of-date warnings as well.

The out-of-date warning got changed a bit. There is only one warning and one version number. All plugins have that number embedded in them at build time so they match up with the folder number on dropbox.
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

Register or log in to remove.

#1002

Lfty
    Lfty

    Diamond Miner

  • Members
  • 841 posts
  • Location: not here, not there, im everywhere :)
  • Minecraft: Lefty

Posted 25 December 2012 - 09:31 AM

I dont know if this is a bug or still unfinished, but when I change the value of bc stuff in Biogas (There should be a false/true by the way Posted Image)
it goes on the next restart back to normal values.

I mean this line:


buildcraft {
####################
# fuels
####################

fuels {
I:Fuel_BurnTime=80000
I:Fuel_MJt=6
}

}

EDIT: And this true/false:


forestry {
####################
# fuels
####################

fuels {
I:Biofuel_BurnTime=32000
I:Biofuel_MJt=5
}

####################
# enables
####################

enables {
B:Biofuel_InBiogas=true
}

}

EDIT2: Okay with 12 it works, but for buildcraft there should be a disable option :P

Beeeeeeeeeeep :P


#1003

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 25 December 2012 - 09:33 AM

View PostLfty, on 25 December 2012 - 09:31 AM, said:

I dont know if this is a bug or still unfinished, but when I change the value of bc stuff in Biogas (There should be a false/true by the way Posted Image)
it goes on the next restart back to normal values.

I mean this line:


buildcraft {
####################
# fuels
####################

fuels {
I:Fuel_BurnTime=80000
I:Fuel_MJt=6
}

}

EDIT: And this true/false:


forestry {
####################
# fuels
####################

fuels {
I:Biofuel_BurnTime=32000
I:Biofuel_MJt=5
}

####################
# enables
####################

enables {
B:Biofuel_InBiogas=true
}

}

Don't change the config file with the game open or that will happen. I'll add the missing boolean.
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

#1004

Lfty
    Lfty

    Diamond Miner

  • Members
  • 841 posts
  • Location: not here, not there, im everywhere :)
  • Minecraft: Lefty

Posted 25 December 2012 - 10:15 AM

I know that... but I though it was a bug, but I changed my minecraft client so, fail on my side :P

Beeeeeeeeeeep :P


#1005

MineWIZ
    MineWIZ

    Zombie Killer

  • Members
  • 161 posts

Posted 25 December 2012 - 10:21 AM

Do I have to install DenLib on server too to make Pff2 works?
[WIP]New windows Mod
Photos

#1006

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 25 December 2012 - 10:32 AM

View PostMineWIZ, on 25 December 2012 - 10:21 AM, said:

Do I have to install DenLib on server too to make Pff2 works?

Yes.
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

#1007

Darkblock306

Posted 25 December 2012 - 02:15 PM

Is there a complete changelog anywhere to see what each update does? Just wondering since the wiki was down.

Also I updated from build 10 to build 12 and got this error.
Spoiler:

Posted Image


#1008

Khalamov

Posted 25 December 2012 - 05:58 PM

View PostDarkblock306, on 25 December 2012 - 02:15 PM, said:

Is there a complete changelog anywhere to see what each update does? Just wondering since the wiki was down.

Also I updated from build 10 to build 12 and got this error.
Spoiler:

Interesting, I didn't have problems with upgrading from build 11 to build 12.
I wonder if it's a mod interaction problem.

#1009

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 25 December 2012 - 06:18 PM

View PostDarkblock306, on 25 December 2012 - 02:15 PM, said:

Is there a complete changelog anywhere to see what each update does? Just wondering since the wiki was down.

Also I updated from build 10 to build 12 and got this error.
Spoiler:

I'll look at this when I get back from doing xmas things.

You can follow the commit log on github for changes.
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

#1010

SvEgiiVEteR

Posted 25 December 2012 - 08:16 PM

how to get rid of the error? help please :(
PluginsforForestry2 beta 4
forestry-A-1.6.3.0
buildcraft-A3.2.2.7-Forge-1.4.5-6.4.1.408
Spoiler:

do not know much English.
Sorry for bad English :)

#1011

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 25 December 2012 - 09:29 PM

View PostSvEgiiVEteR, on 25 December 2012 - 08:16 PM, said:

how to get rid of the error? help please Posted Image
PluginsforForestry2 beta 4
forestry-A-1.6.3.0
buildcraft-A3.2.2.7-Forge-1.4.5-6.4.1.408
Spoiler:

That error has already been fixed.
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

#1012

SvEgiiVEteR

Posted 26 December 2012 - 05:04 AM

View Postdenoflions, on 25 December 2012 - 09:29 PM, said:

That error has already been fixed.
to 1.4.6? but I have 1.4.5. which version of "forg" or "Plugins for Forestry 2" we used to be 1.4.5 that the error did not? if you can do tell me :)
Sorry for bad english, thank you for your reply :)
do not know much English.
Sorry for bad English :)

#1013

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 26 December 2012 - 05:16 AM

View PostSvEgiiVEteR, on 26 December 2012 - 05:04 AM, said:

to 1.4.6? but I have 1.4.5. which version of "forg" or "Plugins for Forestry 2" we used to be 1.4.5 that the error did not? if you can do tell me Posted Image
Sorry for bad english, thank you for your reply Posted Image

That crash was fixed after the 1.4.6 port, so none of the 1.4.5 builds have the fix. Not backporting for 1.4.5, sorry.
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

#1014

SvEgiiVEteR

Posted 26 December 2012 - 05:37 AM

View Postdenoflions, on 26 December 2012 - 05:16 AM, said:

That crash was fixed after the 1.4.6 port, so none of the 1.4.5 builds have the fix. Not backporting for 1.4.5, sorry.
clear, or anything terrible, I know you do spend their own time on the mod. Now that is not a working version for 1.4.5? very quite? may be one of the four versions of Beto works? may be the wrong version of forg use .. I have to know what you have not written, and the version of the Forestry :(
do not know much English.
Sorry for bad English :)

#1015

Darkblock306

Posted 26 December 2012 - 06:07 AM

View Postdenoflions, on 25 December 2012 - 06:18 PM, said:

I'll look at this when I get back from doing xmas things.

You can follow the commit log on github for changes.
Ah thanks for the link, that helps. I eagerly await your assessment of the crashlog, thanks.

Posted Image


#1016

denoflions
    denoflions

    Obsidian Miner

  • Curse Premium
  • Curse Premium
  • 1468 posts

Posted 26 December 2012 - 06:15 AM

View PostDarkblock306, on 26 December 2012 - 06:07 AM, said:

Ah thanks for the link, that helps. I eagerly await your assessment of the crashlog, thanks.

I need more information. Pastebin me your ForgeModLoader-client-0.log.
Posted Image
Twitter | IRC: #PluginsforForestry on esper.net.

#1017

DeadStorage
  • Location: your trash can

Posted 26 December 2012 - 04:22 PM

have a go at this crash.

http://pastebin.com/0svzTCHk

it pointed to railcraft, so i deleted the railcraft folders in plugin for forestry and it didn't crash because of that, it started pointing at buildcraft next and so on.

any ideas what i might be screwing up
Posted Image

#1018

Darkblock306

Posted 26 December 2012 - 06:05 PM

View Postdenoflions, on 26 December 2012 - 06:15 AM, said:

I need more information. Pastebin me your ForgeModLoader-client-0.log.
I have no idea how this happened, but when I put the mods back in, it worked.

Posted Image


#1019

Khalamov

Posted 26 December 2012 - 10:14 PM

I started crashing after updating to Forge 486.  Had to update due to a bug with booster tracks and older versions of Forge.

full log: http://paste.ubuntu.com/1468241/

Two things to note, first there's a java.lang.reflect.InvocationTargetException  (lines 1507-1542) during the MC initialization, then when I try to create a world or load a world I get an Exception ticking world (lines 1941-1951) and a java.lang.NullPointerException (lines 1954-1963).

I'm using build 12 of PfF, denLib 2.1.2. Everything ran under Forge 480 without crashing.

EDIT: I'm trying to downgrade to verify if it really is Forge that's the problem, but files.minecraftforge.com has been up and down all day. They're having troubles with Dreamhost apparently. I'll update this post once I can downgrade and verify which version of Forge the problem starts in.

EDIT: OK, I've been able to determine that Forge 482 is the last one that seems to work. Forge 483+ crashes when loading/creating a world

Edited by Khalamov, 26 December 2012 - 11:13 PM.


#1020

Jay
    Jay

    Diamond Miner

  • Members
  • 866 posts
  • Minecraft: Jay

Posted 27 December 2012 - 12:13 AM

Likewise confirming the NPE with Forge 483+
Spoiler:

(If my posts seem hostile, read my "About me" page!)