Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

A server already running on that port?


  • Please log in to reply
5 replies to this topic

#1

Pandeh
    Pandeh

    Zombie Killer

  • Members
  • 150 posts
  • Location: In my chimney
  • Minecraft: Pandeh

Posted 09 May 2012 - 06:56 PM

I was trying to set up a Minecraft server, no bukkit or anything, so me and a friend could play together. I got most if not everything right, all done with no problems. Except for one, I'll paste what my server log says:


[WARNING] **** FAILED TO BIND TO PORT!
[WARNING] The exception was: java.net.BindException: Cannot assign requested address: JVM_Bind
[WARNING] Perhaps a server is already running on that port?

(port is 25565)

I remember having an old classic server with the same port, but it hasn't been up in maybe two years now. I don't think I even have the server files for it. Also, I tried switching the ports to close numbers such as 25566 or whatever but they gave me the same error.

Is there any more info I need to post? Is there a solution to this?

Register or log in to remove.

#2

arriej
    arriej

    Zombie Killer

  • Members
  • 156 posts
  • Location: The moon
  • Minecraft: arriej
  • Xbox:arriej

Posted 09 May 2012 - 06:58 PM

there is someting ( virus scanner) or an other program already using that ( and other close) ports try someting like 25586 or someting
Did I help you out on the forums don't forget to click the: Posted Image

#3

Pandeh
    Pandeh

    Zombie Killer

  • Members
  • 150 posts
  • Location: In my chimney
  • Minecraft: Pandeh

Posted 09 May 2012 - 07:04 PM

View Postarriej, on 09 May 2012 - 06:58 PM, said:

there is someting ( virus scanner) or an other program already using that ( and other close) ports try someting like 25586 or someting
I still get the same error as before..

#4

fccardiff
  • Minecraft: fccardiff

Posted 09 May 2012 - 09:08 PM

View PostPandeh, on 09 May 2012 - 07:04 PM, said:

I still get the same error as before..

Yep, this means you do have another server running on the port. Either restart the machine if possible and stop the creative server from running, or change the port to something else for the survival server and open that up.

#5

The0dark0shadow_
  • Location: Mc.buildcraftsmp.com?
  • Minecraft: the0dark0shadow

Posted 10 May 2012 - 12:55 AM

I have also incountered this error. There is a easy fix.
Go to task manager and look in the processes and delete cmd.
Then run the .bat and it should work.
If my post above helped you please press the (/\) button. Thanks!

#6

Rotenegg
  • Location: California
  • Minecraft: Rotenegg

Posted 10 May 2012 - 02:53 AM

you might want to try forwarding the port that you are using it should work, make sure you do not have another server program running in the background that uses the port that you have forwarded