Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

launch as java -Xmx1024M -Xms1024M -jar minecraft_server.jar


  • Please log in to reply
12 replies to this topic

#1

diegokilla

Posted 05 January 2011 - 05:23 PM

hi there i've got my server set up and it runs alright but i noticed i get this error when starting the server:

[INFO] Starting minecraft server version Beta 1.1_02
[WARNING] **** NOT ENOUGH RAM!
[WARNING] To start the server with more ram, launch it as "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"

i saw notch wrote a bit that i think has something to do with this on the downloads section of minecraft.net but it's quite confusing to me... anybody out there give me a hand and explain what it is i need to do and possibly how to do it?? i run win7 fyi

thanx in advance!

Register or log in to remove.

#2

Orcworm
    Orcworm

    Ghast Hunter

  • Members
  • 2731 posts
  • Location: Britain
  • Minecraft: Orcworm

Posted 05 January 2011 - 05:30 PM

Download this:
http://rapidshare.co...0963664/run.bat
Move it to your server directory, then run it. Make sure you have minecraft_server.jar in the directory too.

(The file is perfectly safe, you can check it via right click - edit)
Posted Image

#3

benphelps
  • Location: Muskogee, Oklahoma

Posted 05 January 2011 - 05:32 PM

Its telling you exactly what you need to do.

Open the .bat file that is packaged with the server software, you can use any text editor, notepad will work just fine.

Replace the contents with this.

@echo off
java -Xms1024M -Xmx1024M -cp minecraft-server.jar com.mojang.minecraft.server.MinecraftServer
pause

Should fix any memory problems.  Hope this helps.
Posted Image
Come join a great community, active players, creative and SMP servers available.
Professional Server Setup - Cheap Minecraft Servers - Great VPS Host - Dropbox

#4

diegokilla

Posted 05 January 2011 - 10:51 PM

.bat file? i went through all the files that came with the server and found no .bat file... i have .txt files and .log files... one of these??

#5

yan23
    yan23

    Tree Puncher

  • Members
  • 13 posts

Posted 15 April 2011 - 07:38 PM

Looks like you stumped him there diego :}

I got same prob ... opened the .jar file and there was lots of gobbledygook ... didn't wanna mess with it tho'

#6

Moondio
    Moondio

    Out of the Water

  • Members
  • 6 posts

Posted 20 November 2011 - 09:41 PM

View Postyan23, on 15 April 2011 - 07:38 PM, said:

Looks like you stumped him there diego :}

I got same prob ... opened the .jar file and there was lots of gobbledygook ... didn't wanna mess with it tho'

HA! So I see this thread died forever ago. Took me digging around a few other sites to find the easiest explination.
See here: http://infohub.me/sh...2#ixzz1eHg9HLR1

Basiclally, open a new notepad file.
Paste this in:

@echo off
java -Xmx1024M -Xms1024M -jar minecraft_server.jar
pause

and save as "run.bat" in the same folder you have your minecrafte server in.
If you have very limited RAM, like I do, put "nogui" (No GUI, aka Game User Interface) at the end of the second line and it should help.

Run your server and WOOT! It's fixed :)

Bye guys!

#7

Akrovbann

Posted 14 December 2011 - 01:42 AM

Ugh nothing worked for me i have a Mac OS X and i hope TextEdit works as what your talking to write down                    @echo off
java -Xmx1024M -Xms1024M -jar minecraft_server.jar
pause ya didnt work so if anyone can set a server up for me i will repay you in any way

#8

apple2
    apple2

    Out of the Water

  • Members
  • 7 posts
  • Minecraft: AppleII2, AppleII2_2

Posted 19 December 2011 - 11:44 PM

OK, so setting up a server on the Mac. I'm assuming you're using the default server, not Bukkit. Download the server.jar, and put it in its own folder called MCSERVER on your desktop. Open textedit and type


cd ~/Desktop/MCSERVER
java -Xms1024m -Xmx1024m -jar minecraft-server.jar

do SHIFT-COMMAND-T, and then save it to the MCSERVER folder. Then, change the extension from .txt to .command.
Then, download "Port Map" from http://www.codingmonkeys.de/portmap/. Set it up by clicking the plus button, then filling it out like this:
Local port:25565
Public Port:25565
Select tcp AND udp. For description, use MC Server or anything you want. Then, click add mapping. Launch the server and try connecting.

Hope this helps!

-A2

PS: For payment, I'd like a Lamborghini Reventon. Be careful what you say :P!

#9

lebsis1011

Posted 05 February 2012 - 07:21 AM

how do u get the ip adress

#10

Eoin@ClanSlots
  • Minecraft: cookednoodles

Posted 05 February 2012 - 08:39 AM

By the way, there is no real reason to set Xms, java will automatically allocate it.
Posted Image
I am a representative of ClanSlots (and an amazing one at that). Amazing game servers for intelligent and sexy people since 2009.

#11

Rogue
    Rogue

    Gambrinous

  • Forum Admin
  • Curse Premium
  • 8733 posts
  • Location: Rochester, NY
  • Minecraft: Rogue
  • Xbox:RogueMurder

Posted 05 February 2012 - 12:02 PM

>>>> This thread is a year old, please ignore it D: <<<<

Quote my post to make sure I see your reply - MCF Hosting CoordinatorPosted Image


#12

lukeskalwork

Posted 15 October 2012 - 12:54 AM

como eu baixo

#13

kainyabc
    kainyabc

    Newly Spawned

  • Members
  • 1 posts

Posted 13 May 2013 - 06:38 AM

lol

so hard to download minecraft server-jar