Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Tekkit Problem- Still not fixed!!!


  • Please log in to reply
9 replies to this topic

#1

KwickPhyre

Posted 14 April 2012 - 06:05 PM

When trying to launch the launcher.bat file for tekkit (for the first time) I always get these problems!
C:\Users\Our PC\Desktop\Things and Stuff\Things\Games\Survival\Minecraft\Server\
Tekkit Server>java -Xmx3G -Xms2G -jar Tekkit.jar nogui
Error occurred during initialization of VM
Could not reserve enough space for object heap
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
C:\Users\Our PC\Desktop\Things and Stuff\Things\Games\Survival\Minecraft\Server\
Tekkit Server>pause
Press any key to continue . . .


What do I need to do? What is going on?
Thanks, Kwickphyre.

Register or log in to remove.

#2

0strichGuy11
  • Location: My Ostrich Farm
  • Minecraft: mrostrichman
  • Xbox:lolconsole

Posted 14 April 2012 - 06:08 PM

Um, are you using the Technic Launcher? It does everything for u and comes with the yogbox, the tekkit and technic pack, and even the Voxel Modpack. If u arent I would use that instead.

#3

KwickPhyre

Posted 14 April 2012 - 06:13 PM

View Post0strichGuy11, on 14 April 2012 - 06:08 PM, said:

Um, are you using the Technic Launcher? It does everything for u and comes with the yogbox, the tekkit and technic pack, and even the Voxel Modpack. If u arent I would use that instead.

Have you ever had a tekkit server? The Technic Launcher doesn't run a server at the same time- you still need the server files. It's like in vanilla minecraft, you need the minecraft.exe as well as the server.jar.

#4

Aciada
    Aciada

    Out of the Water

  • Members
  • 5 posts

Posted 20 April 2012 - 10:13 PM

hey im having the same issue as the OP, origonally i had issues with the mods installing when i ran the .bat file from the tekkit server files, so i attempted a java reinstall. after reinstalling, restarting, deleting the old tekkit files then redownloading and extracting the package, and re running the .bat file, i get the same issue, and am also unable to find a solution to the problem.

i have both the tekkit launcher and the tekkit server files, and the launcher is still working just fine.

DOes anyone have any ideas what could be going wrong? :)

#5

Aciada
    Aciada

    Out of the Water

  • Members
  • 5 posts

Posted 20 April 2012 - 10:33 PM

ok i fixed this particular error by uninstalling java again, and reinstalling the 64 bit version of java, however i am now getting the slightly different error line when i run the .bat file: "java.lang.unsatisfiedlinkerror:" then my folder addresses and stuff. gonna do some more research ^^

#6

Aciada
    Aciada

    Out of the Water

  • Members
  • 5 posts

Posted 20 April 2012 - 10:55 PM

so i fixed all my problems by installing java 1.7 64 bit for my windows 7, and used the %programfiles%\java\jre7\bin\java.exe command in run, and au voila my bat worked perfectly. hope you can fix everything!

#7

Zeinh
    Zeinh

    Stone Miner

  • Members
  • 91 posts

Posted 01 June 2012 - 06:42 PM

Ur problem Solution : Go to ur console and edit it and ull see something like this-Xmx1024M -Xms1024M  Or The Numbers are Changed
The Thing Is That U have to Put It at the first and leave the last 1024 It Will show Like this:
-Xmx12288M -Xms1024M <---That is Mine

#8

Fufip_Hato

Posted 04 August 2012 - 04:47 PM

I have the solution!!! Right click in the launcher.bat and select Edit then in the Xmx do 1000M and in the Xms do 100M Posted Image Posted Image Posted Image Posted Image Posted Image Posted Image Posted Image

#9

Mindblasters

Posted 24 August 2012 - 06:36 PM

Remeber to also delete the word pause by right clicking the bach file!

#10

War_Eagle

Posted 12 December 2012 - 11:46 PM

that still wont work for me