Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

I can't install a MOD because I can't delete META-INF

meta-inf cant install delete delete meta-inf problem

  • Please log in to reply
17 replies to this topic

#1

Sandrituky

Posted 13 April 2012 - 02:58 PM

Hi! I'm having a problem deleting META-INF
I updated today my minecraft to 1.2.5 and the mods I had installed have gone...
So I'm installing them again, starting by mo'creatures and the mod requireds
(ModLoader, AudioMod, GUI Api, CustomMobSpawner)
And I must delete META-INF folder inside minecraft.jar

I think the problem could be Windows 7.... I installed W7 1 month ago, and before I could delete everything!
Those damn permissions of windows 7... -.- but I don't know
The guy of this video seems to have Windows 7 too and he COULD delete!!
Time:[1:55]

I'm sure that minecraft game wasn't opened, neither java... I reboot my computer for make sure... and still couldn't

I don't see neither the option "Run as administrator" that solved me some problems with other programs
Anyways... I think I'm the administrator... -.- I hate this of W7...


This is the error I get


Posted Image
Of course there are files! 3 files!

(I'm thinking this maybe happen because AppData is an invisible folder)
Let's check it's properties:
Posted Image
Well... I disable the only read, 30 seconds before it appears with no stick, then I press accept.
Then I go to AppData's properties again.... and it appears again with the stick!
Maybe that's the problem, can someone check if this appears to you with or without stick and can delete things?

(I've just tried to delete META-INF from my sister's PC, but it gets other error) -.-


Please, help me! D:

Register or log in to remove.

#2

MinecraftForumsGuide

Posted 13 April 2012 - 03:17 PM

Message me and I'll help you :)

#3

Willitox
    Willitox

    Newly Spawned

  • Members
  • 1 posts

Posted 10 May 2012 - 12:27 AM

View PostSandrituky, on 13 April 2012 - 02:58 PM, said:

Hi! I'm having a problem deleting META-INF
I updated today my minecraft to 1.2.5 and the mods I had installed have gone...
So I'm installing them again, starting by mo'creatures and the mod requireds
(ModLoader, AudioMod, GUI Api, CustomMobSpawner)
And I must delete META-INF folder inside minecraft.jar

I think the problem could be Windows 7.... I installed W7 1 month ago, and before I could delete everything!
Those damn permissions of windows 7... -.- but I don't know
The guy of this video seems to have Windows 7 too and he COULD delete!!
Time:[1:55]

I'm sure that minecraft game wasn't opened, neither java... I reboot my computer for make sure... and still couldn't

I don't see neither the option "Run as administrator" that solved me some problems with other programs
Anyways... I think I'm the administrator... -.- I hate this of W7...


This is the error I get


Posted Image
Of course there are files! 3 files!

(I'm thinking this maybe happen because AppData is an invisible folder)
Let's check it's properties:
Posted Image
Well... I disable the only read, 30 seconds before it appears with no stick, then I press accept.
Then I go to AppData's properties again.... and it appears again with the stick!
Maybe that's the problem, can someone check if this appears to you with or without stick and can delete things?

(I've just tried to delete META-INF from my sister's PC, but it gets other error) -.-


Please, help me! D:
Lo Solucionaste ??? podrias decir como si lo hiciste

#4

jwei44
    jwei44

    Zombie Killer

  • Members
  • 208 posts

Posted 10 May 2012 - 12:38 AM

As far as I'm aware, I've been skipping the META step. It still works [the mod] for me.

#5

StrawHatUra
  • Minecraft: HlywdUndead

Posted 10 May 2012 - 12:43 AM

do you have minecraft open when editing the files?
Posted Image
i5-4670k // Radeon HD 7950 // 2x4 DDR3 // ASRock Z87 PRO4 // 500W // 1TB HDD // Windows 8

#6

sethman50
  • Location: Tucson,AZ
  • Minecraft: sethman50

Posted 10 May 2012 - 01:09 AM

i need help with this and if it works because i get all the stuff to download and it doesn't work. I don't know how to make it work cause all the YouTube video dont help me and the sites don't help as much as i need it.

#7

laijka
    laijka

    Ghast Hunter

  • Members
  • 2970 posts
  • Location: Sweden

Posted 10 May 2012 - 07:40 AM

Try using MCPatcher
"It's easier to tolerate idiots if you do not consider them as stupid people, but exceptionally gifted monkeys."

#8

Seimiro
    Seimiro

    Gold Miner

  • Members
  • 369 posts

Posted 10 May 2012 - 08:10 AM

There might be 2 things that I can think of would cause this. One is that possibly, for some reason the javaw process is running. You'd have to terminate the process from the windows task manager manually. The other is that the roaming folder IS invisible, so you'd have to make a trip to the control panel to find the option and activate it.

#9

joshy020504

Posted 11 November 2012 - 02:15 AM

Have you solved the problem?

#10

SunMaster70

Posted 02 January 2013 - 02:49 AM

I am having the same problem I am on windows 8

#11

deefster10000
    deefster10000

    The Meaning of Life, the Universe, and Everything...

  • Members
  • 42 posts

Posted 02 January 2013 - 10:37 AM

Use the MCPatcher to install mods, it can be found here, but if you are going to install optifine, then you will want to untick the mods that come with the patcher, and the patcher installs mods starting with the top mod, and works its way down to the bottom, so any files that are in more than one mod will, minecraft will only get the files from the further down mods, AND MCPatcher only installs mods that need to go directly into the Jar, and also automatically deletes the META-INF. BUT if you want to install any mods that say you need to put them into the mods/coremods folder, that is how you install them, and NOT through the patcher.
Posted Image

#12

MeebaFan
    MeebaFan

    Tree Puncher

  • Members
  • 33 posts

Posted 17 January 2013 - 03:12 AM

You simpy Need to restart Your computer. Then Force  Update again delete you bin folder then start minecraft... then When It's done
loading just x out minecraft and the click the start button do %appdata% .minecraft bin Minecraft.jar/minecraft. ( The / means or) You can
delete meta-inf now trust me it works Posted Image

View PostWillitox, on 10 May 2012 - 12:27 AM, said:

Lo Solucionaste ??? podrias decir como si lo hiciste

View PostWillitox, on 10 May 2012 - 12:27 AM, said:

Lo Solucionaste ??? podrias decir como si lo hiciste
I Translated this dude's saying And He is right!

#13

Lolrogerr

Posted 05 February 2013 - 06:39 AM

Make sure u have ur minecraft off first of all force update then delete ur meta inf and boom ur done(:

#14

doyoulikdiamond

Posted 30 March 2013 - 02:12 AM

I am having thee same problem o am running on windows 8 and it says the disk is probably full

#15

SkyPirate

Posted 23 April 2013 - 10:08 PM

Hey Broyour not alone.... I had this Sh*tty problem to.
The way I fixed it is by going to my task manger
searched the Java

and clicked End process

When I clicked the end process
I went to my bin folder
and deleted the meta inf. I am sure this will solve your problem!


#16

iW3S1M
    iW3S1M

    Newly Spawned

  • Members
  • 1 posts
  • Location: In front of a computer.
  • Minecraft: _Wesim_

Posted 24 April 2013 - 01:56 AM

I honestly haven't seen this problem before. All I know is that you right click the minecraft.jar file (I think there could be another minecraft.jar except it is minecraft_1.2.5.jar or something) in the bin folder and do open with > winrar
Then I know that you should see META-INF, but I'm guessing that's what you did.

Posted Image


#17

jakefri
    jakefri

    Newly Spawned

  • Members
  • 1 posts

Posted 14 June 2013 - 10:20 PM

whenever i try to delete it, it says "The process cannot access this file because it is being used by another process."

#18

macbo11
    macbo11

    Tree Puncher

  • Members
  • 12 posts

Posted 15 June 2013 - 02:05 AM

That happened to me too!

I finally figured it out a month later.

Delete the bin folder, run minecraft, then go to minecraft.jar, and try again!