Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Minecraft "Quits Unexpectedly"


  • Please log in to reply
2 replies to this topic

#1

MarmaladeMatt

Posted 01 January 2011 - 09:04 PM

First off, I'm running Mac OS Snow Leopard and did a software update after this issue started so that my Java and such was up to date. Basically, while in game I get periods of excessive laggyness that last from anywhere from 1 to 5 seconds. During some of these (seemingly randomly) Minecraft will freeze, and then "Quit Unexpectedly". I reset the options to "fast" graphics and view distance "tiny" which fixed the lag bursts, however, the freezing didn't stop. After this the freezing still occurred at the seemingly random intervals and the game would quit once again.

This question had been asked before, and I searched through those threads, but none of the offered solutions worked. I tried reseting the options to optimize fps, which did nothing. I also deleted minecraft and reinstalled it, which didn't work. Then tried the software update and all which didn't work either.

I'm fairly certian doing a clean reinstall will fix this problem, I don't care about saving my game files, none of them matter to me. But even when I completely delete the associated files to minecraft (the one's in the "minecraft" folder created during install) there seems to be some cookie or other hidden file which keeps my saved games, and login information. So after I did the reinstall, my login information was still there, and so were my saved game files. If anyone knows what these files are named or where I can find them on my Mac it would be appreciated. I tried programs such as "AppDelete" but because of the type of file that Minecraft is when downloaded to Mac it isn't recognized as an "App (program)" nor does it appear in the "other" catagory. So a manual reinstall/delete is necessary.

If its important I use Safari as my  browser

Register or log in to remove.

#2

MarmaladeMatt

Posted 03 January 2011 - 06:27 AM

Bump

#3

MarmaladeMatt

Posted 03 January 2011 - 09:53 PM

Bump

Fixed the problem. I updated my Firmware and switched "Limit Framerate" from ON to OFF. Either one of these could have fixed the issue, I have no way to determine which did because I did both between the same sessions of Minecraft. Also, these could have done nothing and the problem may have sorted itself out during that time. Again I have no way to tell.

Whatever the case, this worked for me and hopefully can answer this problem for others in the future.