Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

1.6.4 - ExtrabiomesXL (3.15.7)

1.6.4 ssp smp universal biome biomes terrain generation

  • Please log in to reply
13667 replies to this topic

#10101

Aeraesoria
  • Minecraft: Elessar_Elanesse

Posted 12 December 2012 - 07:00 AM

View PostAnonTheMouse, on 12 December 2012 - 01:44 AM, said:

A wise(arse) man once said, "If life gives you saplings, make...charcoal."

meh charcoal I get plenty of that from smelting the logs... now turning those saplings into biomass that's a nice use for them Posted Image

also for those interested who use treecapitator

here's all the ID's for the logs and leaves blocks from Forestry, ExtrabiomesXL, Twilight Forest, IC2, and the newest magical mod out Thaumcraft 3.

Spoiler:

check the spoilers ppl Posted Image just copy and paste into the proper line in the treecapitator configs and your good to go to start clear cutting those nasty forests away in no time!
Posted Image

Register or log in to remove.

#10102

SecondHong

Posted 12 December 2012 - 07:30 AM

Hello,

I got a crash report when I am using ExtrabiomesXL 3.6.0

Hope that you can help mePosted Image

The crash report at this link:

http://pastebin.com/SNqC5kk0

#10103

Ashcrack
    Ashcrack

    Out of the Water

  • Members
  • 2 posts

Posted 12 December 2012 - 12:39 PM

Crashes on startup

http://pastebin.com/qWk34xLQ There's the forgemodloader log

http://pastebin.com/MytSMEEt Is the Crash Report

Any help would be greatly appreciated, cheers.


Seems I wasn't using the right version of forge, I dun goofed.

#10104

Undefinedmaster
  • Minecraft: Undefinedmaster

Posted 12 December 2012 - 12:43 PM

View PostScottKillen, on 12 December 2012 - 01:26 AM, said:

According to your log, several mods (Extrabiomes included) have been incorrectly installed into the minecraft jar. Ironically, some mod (one that is supposed to be installed in the jar) has altered the Block class and removed a method required by Minecraft Forge and forge mods.

Incorrectly installed? I may have put some in the jar that are supposed to be in the mods folder, but that worked out fine before 1.4.5

Did this post help? Rate my answer below.

13 Up 4 Down Posted Image


#10105

rsod
    rsod

    Iron Miner

  • Members
  • 268 posts

Posted 12 December 2012 - 02:07 PM

Will ores from another mods, such as IC2 and Forestry, spawn in EBXL biomes?

#10106

AkulaMak
    AkulaMak

    Diamond Miner

  • Members
  • 864 posts
  • Location: Just over the edge of sanity

Posted 12 December 2012 - 02:19 PM

View Postrsod, on 12 December 2012 - 02:07 PM, said:

Will ores from another mods, such as IC2 and Forestry, spawn in EBXL biomes?
Absolutely

#10107

wideload
    wideload

    Obsidian Miner

  • Members
  • 1333 posts
  • Location: Stalking the poster above.

Posted 12 December 2012 - 02:46 PM

View PostUndefinedmaster, on 12 December 2012 - 12:43 PM, said:

Incorrectly installed? I may have put some in the jar that are supposed to be in the mods folder, but that worked out fine before 1.4.5
If you put some mods in a place they weren't supposed to be then yes, they are incorrectly installed. It doesn't matter if it worked before with previous MC versions - they are in the wrong place now. You can't just mix and match where mods go, the instructions are there for a reason.
Try again with everything in it's correct place. Check the instructions for all your mods and double check whether they are installed in the jar, coremods or mods folder (or a combination). Hopefully that will get you somewhere.
Posted Image

#10108

ScottKillen
  • Location: A virtual rocker on my cyber porch
  • Minecraft: sdkillen

Posted 12 December 2012 - 02:47 PM

View PostSecondHong, on 12 December 2012 - 07:30 AM, said:

Hello,

I got a crash report when I am using ExtrabiomesXL 3.6.0

Hope that you can help mePosted Image

The crash report at this link:

http://pastebin.com/SNqC5kk0
According to the log, the problem is some kind of network issue.  Vanilla code is crashing.

Veteran Minecraft Modder / Grumpy Old Man


Posted Image


#10109

ScottKillen
  • Location: A virtual rocker on my cyber porch
  • Minecraft: sdkillen

Posted 12 December 2012 - 02:53 PM

View PostUndefinedmaster, on 12 December 2012 - 12:43 PM, said:

Incorrectly installed? I may have put some in the jar that are supposed to be in the mods folder, but that worked out fine before 1.4.5

No doubt, but when you do something other than what is described in the instructions, it makes it difficult for us to support. In similar circumstances, I revert to the instructions before asking for help.

In any case, the cause of your issue is that one of the mods that must be installed in the jar is not compatible with Forge and overwrite a class that is changed by Forge.

Veteran Minecraft Modder / Grumpy Old Man


Posted Image


#10110

Keybounce

Posted 12 December 2012 - 05:44 PM

Scott, what do you look for in the logs to tell where a mod is installed (in the jar or in the mods folder)?
My channel with Mystcraft, and general Minecraft Let's Plays: http://www.youtube.com/user/Keybounce
** NEW: FtB "Magic Farm", performance testing and java flags.
My main world: http://www.minecraft...ts-play-series/
"Wait, an update?! Geez, I didn't know we skipped Easter and went straight to Christmas."

#10111

ScottKillen
  • Location: A virtual rocker on my cyber porch
  • Minecraft: sdkillen

Posted 12 December 2012 - 05:58 PM

View PostKeybounce, on 12 December 2012 - 05:44 PM, said:

Scott, what do you look for in the logs to tell where a mod is installed (in the jar or in the mods folder)?

It is boring reading...but:

2012-12-11 19:40:49 [FINE] [ForgeModLoader] Examining file minecraft.jar for potential mods
...
...
...
2012-12-11 19:40:50 [FINE] [ForgeModLoader] Identified an FMLMod type mod extrabiomes.Extrabiomes
...
...
...

As opposed to:



2012-12-11 23:58:20 [INFO] [ForgeModLoader] Searching C:\Users\My Games\Minecraft Stuff\minecraft\mods for mods
...
...
...
2012-12-11 23:58:21 [FINE] [ForgeModLoader] Examining file TF2_Teleporter_1.4.5c.zip for potential mods
2012-12-11 23:58:21 [FINER] [ForgeModLoader] Located mcmod.info file in file TF2_Teleporter_1.4.5c.zip

Veteran Minecraft Modder / Grumpy Old Man


Posted Image


#10112

EdvinKosenkov

Posted 12 December 2012 - 06:29 PM

my Minecraft crashes becouse of ExtraBiomesXL , but i realy wanna use it , any help? :)
here is my crash report: ---- Minecraft Crash Report ----
// I just don't know what went wrong :(

Time: 12.12.2 15.33
Description: There was a severe problem during mod loading that has caused the game to fail

cpw.mods.fml.common.LoaderException: java.lang.NoClassDefFoundError: net/minecraftforge/common/ConfigCategory
    at cpw.mods.fml.common.LoadController.transition(LoadController.java:117)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:481)
    at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:151)
    at net.minecraft.client.Minecraft.a(Minecraft.java:424)
    at net.minecraft.client.Minecraft.run(Minecraft.java:756)
    at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NoClassDefFoundError: net/minecraftforge/common/ConfigCategory
    at buildcraft.core.BuildCraftConfiguration.save(BuildCraftConfiguration.java:27)
    at buildcraft.BuildCraftCore.loadConfiguration(BuildCraftCore.java:233)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at cpw.mods.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:440)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:69)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:317)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:300)
    at com.google.common.eventbus.EventBus.post(EventBus.java:268)
    at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:140)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:69)
    at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:317)
    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:300)
    at com.google.common.eventbus.EventBus.post(EventBus.java:268)
    at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:83)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:480)
    ... 4 more
Caused by: java.lang.ClassNotFoundException: net.minecraftforge.common.ConfigCategory
    at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:141)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 32 more
Caused by: java.lang.NullPointerException
    at org.objectweb.asm.ClassReader.<init>(Unknown Source)
    at net.minecraftforge.transformers.EventTransformer.transform(EventTransformer.java:29)
    at cpw.mods.fml.relauncher.RelaunchClassLoader.runTransformers(RelaunchClassLoader.java:178)
    at cpw.mods.fml.relauncher.RelaunchClassLoader.findClass(RelaunchClassLoader.java:133)
    ... 34 more


A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- System Details --
Details:
    Minecraft Version: 1.4.5
    Operating System: Windows 7 (amd64) version 6.1
    Java Version: 1.7.0_07, Oracle Corporation
    Java VM Version: Java HotSpot™ 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 444726432 bytes (424 MB) / 514523136 bytes (490 MB) up to 954466304 bytes (910 MB)
    JVM Flags: 2 total; -Xms512m -Xmx1024m
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Suspicious classes: FML and Forge are installed
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP v7.23 FML v4.5.14.455 Minecraft Forge 6.4.0.393 9 mods loaded, 9 mods active
    mcp [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized
    FML [Forge Mod Loader] (coremods) Unloaded->Constructed->Pre-initialized
    Forge [Minecraft Forge] (coremods) Unloaded->Constructed->Pre-initialized
    BuildCraft|Core [BuildCraft] (buildcraft-A-3.2.1.jar) Unloaded->Constructed->Errored
    BuildCraft|Builders [BC Builders] (buildcraft-A-3.2.1.jar) Unloaded->Constructed->Errored
    BuildCraft|Energy [BC Energy] (buildcraft-A-3.2.1.jar) Unloaded->Constructed->Errored
    BuildCraft|Factory [BC Factory] (buildcraft-A-3.2.1.jar) Unloaded->Constructed->Errored
    BuildCraft|Transport [BC Transport] (buildcraft-A-3.2.1.jar) Unloaded->Constructed->Errored
    BuildCraft|Silicon [BC Silicon] (buildcraft-A-3.2.1.jar) Unloaded->Constructed->Errored

#10113

Annysia
    Annysia

    Void Walker

  • Curse Premium
  • Curse Premium
  • 1986 posts
  • Location: Missouri

Posted 12 December 2012 - 06:37 PM

View PostEdvinKosenkov, on 12 December 2012 - 06:29 PM, said:

my Minecraft crashes becouse of ExtraBiomesXL , but i realy wanna use it , any help? Posted Image
Spoiler:

Please use spoilers when posting an error log.  Also, per the OP:   You should post your complete log (ForgeModLoader-0.log -or- ForgeModLoader-client-0.log) on pastebin.com and then post a link to it here on the forum.

Just looking at it though you have an older version of forge...and if you are using our 3.6.0 version of EBXL, also per the OP:  Requires Forge 6.4.1.411 and higher, which can be found here.
Posted Image

#10114

stfun00b
    stfun00b

    Zombie Killer

  • Members
  • 189 posts
  • Minecraft: X3N0PH083

Posted 12 December 2012 - 08:00 PM

I'm using this mod in a modded minecraft_server.jar, for use with Minecraft Land Generator. However on running, I get this error:
Spoiler:

I'm not certain, but I think its an issue with ExtrabiomesXL rather than MLG. Can anyone shed some light?

From what I gather, MLG is hanging because of an issue finding/using some of the trees in EBXL. My .jar works fine in my normal server.
Ingame: X3N0PH083

#10115

Craftiyan
  • Location: Lake Silencio, UT. April 22, 2010, 5:02 PM.
  • Minecraft: bdejean

Posted 12 December 2012 - 08:14 PM

View PostUndefinedmaster, on 12 December 2012 - 12:43 PM, said:

Incorrectly installed? I may have put some in the jar that are supposed to be in the mods folder, but that worked out fine before 1.4.5

Actually, I can definitely say that some mods, like SimpleOres, didn't work if installed in the jar as early as 1.2.5.  Make sure to read the install instructions and put your mods where the instructions say to put them.


View Postrsod, on 12 December 2012 - 02:07 PM, said:

Will ores from another mods, such as IC2 and Forestry, spawn in EBXL biomes?

Start up Feed the Beast.  Look for ores.
Let’s play good guys against bad guys… Yes. Let’s play that. Are you ready? You’re the bad guy. And when you’re bad, you just run. That’s fine right? Well… Shall we play?

#10116

Annysia
    Annysia

    Void Walker

  • Curse Premium
  • Curse Premium
  • 1986 posts
  • Location: Missouri

Posted 12 December 2012 - 08:25 PM

View Poststfun00b, on 12 December 2012 - 08:00 PM, said:

I'm using this mod in a modded minecraft_server.jar, for use with Minecraft Land Generator. However on running, I get this error:
Spoiler:

I'm not certain, but I think its an issue with ExtrabiomesXL rather than MLG. Can anyone shed some light?

From what I gather, MLG is hanging because of an issue finding/using some of the trees in EBXL. My .jar works fine in my normal server.

Please see the post directly above yours regarding the type of log we need to be able to provide support.  You also might want to update your EBXL to the 3.6.0 version since you are using the latest version of forge.
Posted Image

#10117

ScottKillen
  • Location: A virtual rocker on my cyber porch
  • Minecraft: sdkillen

Posted 12 December 2012 - 09:01 PM

View PostEdvinKosenkov, on 12 December 2012 - 06:29 PM, said:

my Minecraft crashes becouse of ExtraBiomesXL , but i realy wanna use it , any help? Posted Image  

Spoiler:

Funny, your log says it is caused by Buildcraft:

Quote

Caused by: java.lang.NoClassDefFoundError: net/minecraftforge/common/ConfigCategory
at buildcraft.core.BuildCraftConfiguration.save(BuildCraftConfiguration.java:27)
at buildcraft.BuildCraftCore.loadConfiguration(BuildCraftCore.java:233)

Veteran Minecraft Modder / Grumpy Old Man


Posted Image


#10118

ScottKillen
  • Location: A virtual rocker on my cyber porch
  • Minecraft: sdkillen

Posted 12 December 2012 - 09:12 PM

View Poststfun00b, on 12 December 2012 - 08:00 PM, said:

I'm using this mod in a modded minecraft_server.jar, for use with Minecraft Land Generator. However on running, I get this error:
Spoiler:

I'm not certain, but I think its an issue with ExtrabiomesXL rather than MLG. Can anyone shed some light?

From what I gather, MLG is hanging because of an issue finding/using some of the trees in EBXL. My .jar works fine in my normal server.

According to your log, the game is getting a server tick error while trying to generate vanilla trees.
  • This is vanilla code crashing, not modded code...so nothing to do with Extrabiomes.
  • Tick errors are normally caused when the system is so overtaxed that is cannot keep up with the game.
Given the way that the Land Generator works, it is pretty obvious that it is overtaxing your system.

Veteran Minecraft Modder / Grumpy Old Man


Posted Image


#10119

Undefinedmaster
  • Minecraft: Undefinedmaster

Posted 12 December 2012 - 09:14 PM

I installed everything correctly  (quite a few things were wrong), but still get a crash whenever I try to break a tree. As it turns out, it only happens on EXBL trees. I can break normal trees and any wood block I place. Here is the full report

Did this post help? Rate my answer below.

13 Up 4 Down Posted Image


#10120

stfun00b
    stfun00b

    Zombie Killer

  • Members
  • 189 posts
  • Minecraft: X3N0PH083

Posted 12 December 2012 - 09:17 PM

Thats strange, I've used vanilla MLG before for a 10,000x10,000 map before and its been fine. I have a 2.7Ghz quadcore i5 and 4Gb DDR3 Ram. Is it possible I havent assigned enough RAM to it? I think MLG is only set at 1Gb br default.
Ingame: X3N0PH083