Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

disconnect.genericReason


  • Please log in to reply
28 replies to this topic

#1

KuroiGetsuga

Posted 23 December 2010 - 07:56 AM

I tried to create a server with the latest build, Beta 1.1_01, however I cannot connect, nor can anyone else. The following is displayed in the server dialogue:

Quote

[INFO] KuroiGetsuga [/192.168.1.1] logged in with entity id 100
[INFO] Inuki [/80.0.151.76] logged in with entity id 211
[INFO] KuroiGetsuga lost connection: disconnect.genericReason
[INFO] Inuki lost connection: disconnect.genericReason
The clients say "logging in" and sit there for about a minute before eventually timing  out with: Connection Lost, Timed out. The server notes the loss of connection before the client does.



The server properties are:

Quote

#Minecraft server properties
#Thu Dec 23 07:25:08 GMT 2010
level-name=world
hellworld=false
spawn-monsters=true
online-mode=true
spawn-animals=true
max-players=20
server-ip=
pvp=true
server-port=27902




The clients are reaching the server, this is not a port forwarding or firewall issue. They begin to log in and then time out.

Register or log in to remove.

#2

zajacmp3
    zajacmp3

    Tree Puncher

  • Members
  • 27 posts

Posted 23 December 2010 - 08:08 AM

I have the same. Not in a minute of playing though. In 90% what I checked in console when I have java error the server instantly kicks me. No known by me solution to this issue. Probably will get fixed in newer versions of the game. For now just hold tight.

#3

Aarown
    Aarown

    Newly Spawned

  • Members
  • 1 posts

Posted 23 December 2010 - 08:14 AM

The exact same thing is happening to me. I can connect to my own server using my LAN ip, but I can't connect using my external WAN ip, and neither can anyone else. When I connect to the server using my LAN ip and someone else tries to join, they float at the spawn point for maybe 1 minute before disconnecting. The person attempting to connect only saw "logging in..." before a connection timeout on their client. Anyone else have any ideas on what's up?

edit: So for some reason using MCAdmin has allowed me to connect to my own server with my external ip. I'm still waiting to here from my friend if he can connect, but it's looking promising. I would still like to know why the default server files aren't working though...

#4

jmcneely
  • Location: US
  • Minecraft: jmcneely

Posted 23 December 2010 - 08:03 PM

Does anybody know exactly what disconnect.genericReason means? Its not much of a big problem for me but a lot of people in my server get this error message a lot.

#5

Pxl_Buzzard

Posted 24 December 2010 - 01:17 AM

My friend is trying to connect to my server and he keeps getting this error, but I have another friend who can play just fine, so it's a very selective thing as far as I can tell.

#6

Mega64
    Mega64

    Tree Puncher

  • Members
  • 11 posts

Posted 24 December 2010 - 04:07 PM

My friend is having the same issue, hope they fix it sooner rather than later.

#7

M1guli
    M1guli

    Newly Spawned

  • Members
  • 1 posts

Posted 24 December 2010 - 08:33 PM

I'm having the same problem with my friend ;o Need help really bad :x

#8

Maligore
    Maligore

    Tree Puncher

  • Members
  • 11 posts

Posted 24 December 2010 - 09:15 PM

Having the same problem Anyone got an answer.

#9

randomprey

Posted 25 December 2010 - 05:46 AM

Maligore said:

Having the same problem Anyone got an answer.

me too :iapprove:

#10

Xankrieg
    Xankrieg

    Out of the Water

  • Members
  • 4 posts

Posted 30 December 2010 - 05:38 PM

Hello fellow minecraftians.

I too have this problem and am running windows 7 64bit and also have an atheros network adapter.

I have been trying to fix the problem and have found that it has nothing to do with port forwarding or firewall settings.
I have checked  my network adapter and tested all the option on it and it did not have any effect on the server, so it is definitely not that.
I have reinstalled and installed many different versions of java if it be 32bit or 64bit, and this has not helped either.
I am currently out of ideas on what i could do the solve this.

Atm My computer is the only one that can connect to the server. not even others on my network can join so i think it is a problem with the computer its self rather than any router settings.

P.S. The Genericreason is only a cover for the actualy error.
If you run the server in the "More RAM" way you will see on the comand prompt that you actualy recieve 2 errors
1 being SocketWriteError.
the other being Recv Failed.
Both seems to be associated with java but i have not found java to be the cause.

#11

minerdave
    minerdave

    minecraftserverhost.net

  • Members
  • 2113 posts

Posted 30 December 2010 - 06:06 PM

Sounds like it could be another beta bug:

http://getsatisfacti... ... ericreason
Trusted and Established Minecraft Server Hosting since Alpha in 2010.
Minecraft Server Host: www.minecraftserverhost.net
Test Servers: test.minecraft.ms | la.minecraft.ms | nyc.minecraft.ms | va.minecraft.ms
I am a representative of Minecraftserverhost.net

#12

Jonez69
    Jonez69

    Newly Spawned

  • Members
  • 1 posts

Posted 09 January 2011 - 04:28 PM

Hi,

I created a server for me and my friend to play, and we both started suffering from BSOD.
It happens randomly, about 5-15 minutes range, and it always shows "disconnect.genericReason" at the server log.
I have found rumours that it might be OpenGL-related problem or something, but I only get this when I play multiplayer, single works absolutely fine.
BUT we noticed something:
As we were at  :opblock:-height, it did not crash once when we were there (40+mins). No idea why, though.

edit: Forgot to mention; that instant we came back to surface, it happened again... for both of us...  :SSSS:

#13

Chuar
    Chuar

    Out of the Water

  • Members
  • 2 posts

Posted 19 March 2011 - 05:53 PM

Hey, so I've found a simply solution, A generic reason fault means simply that the server is too full and that he can't generate the whole map when you move fast. most of the time you get kicked when you play like 1 minute, that's because you move too fast too an another side of the map(the map generates in pieces) so what you have to do is. you simply press the F button, press it 3 times, now the distance and your view will get shorter. but you won't get kicked any more. you will get a little bit lagg when you move too new pieces is the map, but that's not a big problem. Have fun with playing minecraft :D

Greeting,

Chuar :)

#14

Chuar
    Chuar

    Out of the Water

  • Members
  • 2 posts

Posted 19 March 2011 - 06:01 PM

@jonez69
''As we were at -height, it did not crash once when we were there (40+mins). No idea why, though.''

The server has problems with big and long views, so when your underground you haven't any far sights, that's why you won't get kicked when your underground :Diamond:

Greeting,

Chuar :DBlock:

#15

Odium
    Odium

    Tree Puncher

  • Members
  • 16 posts

Posted 19 March 2011 - 06:41 PM

yeh i have the same issue.

#16

The Mom Of Notch

Posted 24 March 2011 - 02:55 PM

Chuar said:

Hey, so I've found a simply solution, A generic reason fault means simply that the server is too full and that he can't generate the whole map when you move fast. most of the time you get kicked when you play like 1 minute, that's because you move too fast too an another side of the map(the map generates in pieces) so what you have to do is. you simply press the F button, press it 3 times, now the distance and your view will get shorter. but you won't get kicked any more. you will get a little bit lagg when you move too new pieces is the map, but that's not a big problem. Have fun with playing minecraft :Diamond:

Greeting,

Chuar :tnt:
That is not a solution. No one can even connect to it when it's empty. I just hope 1.4 server comes out soon.

#17

Undozed
    Undozed

    Newly Spawned

  • Members
  • 1 posts

Posted 11 April 2011 - 02:33 AM

somebody has solved this problem?

Panic  :SSSS:

#18

EpicVapnar

Posted 20 April 2011 - 01:48 PM

I have the same problem.
At first everything works out perfectly fine, so I'm just jumping around, exploring my new multiplayer world and sometimes I destroy a block. Everything is still working as it should. BUT as soon as i place a block, everything freezes and a few seconds later the game crashes.
Then when I try to connect again it wont let me, and I get an error message.

Does anyone know how to solve this problem?

#19

Equim
    Equim

    Out of the Water

  • Members
  • 7 posts

Posted 21 April 2011 - 07:21 PM

Has anyone found a fix for this yet? I get the same problem on my server, both with the normal server client and bukkit, same thing happends.
You start to break a random block and everything freezes, the game crashes and "X lost connection: disconnect.genericReason"

#20

endofzero

Posted 21 April 2011 - 11:26 PM

Equim said:

Has anyone found a fix for this yet? I get the same problem on my server, both with the normal server client and bukkit, same thing happends.
You start to break a random block and everything freezes, the game crashes and "X lost connection: disconnect.genericReason"

genericReason is the code that is returned when the server doesn't receive one of expected return codes. The server will get this error if you just close Minecraft without going to disconnect first. With that being said, this is unfortunately a very generic error and, from my experience, mostly an issue with the client, not the server.
MC Sheller - Automated Shell Script git - MC Log Parser - Hub

Lulz

MoonBeans said:

As far as I've heard, Sk89q is a virus. Not sure though!