Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

1285: Out of memory


  • Please log in to reply
14 replies to this topic

#1

Gisst
    Gisst

    Tree Puncher

  • Members
  • 17 posts

Posted 22 December 2010 - 09:40 PM

Hi,

i've searched this forum and only found 1 thread about this but it doesn't help me much, because it's about windows 64bit. The fact that there is only 1 thread indicates that this may not a specific minecraft problem.

I'm playing minecraft for some weeks now without any (technical) problems. I'm still playing with version 1.2.6 and haven't changed anything (e.g. mods) for a few days.

Since yesterday evening i'm getting this error after a few minutes ingame:
########## GL ERROR ##########
@ Post render
1285: Out of memory

I was tired mining and building so i startet exploring. My save before exploring was about 9MB and now it's 16MB and it crashes all the time :Sheep:

I watched the MC process with Process Explorer and noticed that the virtual size grows massively even when i pause MC. When it reaches 2GB (!) it crashes.

Any ideas?

My comp is running XP 32bit with 3,5GB RAM and GeForce 8800GT. Open GL Version 3.2.

Thanks in advance ;)

Register or log in to remove.

#2

MagickSid

Posted 22 December 2010 - 09:53 PM

I have found that deleting my /bin directory (located in the .minecraft folder) and running the Minecraft.exe launcher to re-download the files fixes many odd errors like this.

#3

Fooby
    Fooby

    Obsidian Miner

  • Members
  • 1481 posts
  • Location: Gotham City (Chicago)

Posted 22 December 2010 - 10:32 PM

That or force the program to use less memory, many people using laptops with Intel GPU's have to do this to even get the program to run.

#4

MagickSid

Posted 22 December 2010 - 11:57 PM

Side note, upgrade to win64 -- you have 5 gigs ram -- it will be better utilized

#5

fle1schregen

Posted 27 December 2010 - 04:34 PM

Deleting the bin folder did not solve the problem for me. My World is about 10MB and now always crashes after about two minutes. Is updating windows to 64bit the only chance to fix the problem?

#6

Gisst
    Gisst

    Tree Puncher

  • Members
  • 17 posts

Posted 29 December 2010 - 06:10 PM

Hi,

sorry for the late response but i wasn't able to play because of the christmas stress  :SSSS: but i observed the forum a bit and realised that this is a problem to a lot of people though not much are mentioning the 1285 error code.

Downloading the files wasn't a option because i wanted to stay with 1.2.6 until the heavenly wild grass mod is updated :) but i startet fresh with a clean 1.2.6 jar with no luck.

Foobys advice has the solved the problem for me. At least MC is running for 1 hour now without any crashes and the vsize remains steady.

fle1schregen said:

Deleting the bin folder did not solve the problem for me. My World is about 10MB and now always crashes after about two minutes. Is updating windows to 64bit the only chance to fix the problem?

Have you tried starting MC via Batchfile?
http://getsatisfacti...window_of_death

You may can alter the xmx and xms values depending on your hardware. There are several threads in the support section that are recommending the same.
When you are using Windows keep in mind that you have to download the Linux minecraft.jar from http://minecraft.net/download.jsp to do this.
Hope that helps.

Thanks again for the help!

#7

Azazavr
    Azazavr

    Tree Puncher

  • Members
  • 32 posts

Posted 08 August 2011 - 08:40 PM

Today I've update my videocard to GTX570, new PSU 750W, 8 GB of selected RAM, new CPU i7 2600K...and I got out of memory error!! <_<
Before - no such errors was found...
(Sorry 4 my English)

#8

miksutrikku
  • Location: Finland
  • Minecraft: miksutrikku

Posted 03 September 2011 - 04:42 PM

I think this is happening to all people on this topic and more. Would someone tell me how to

Quote

force the program to use less memory

Posted Image

#9

Squall_Le0nhart

Posted 07 September 2011 - 10:01 AM

View Postmiksutrikku, on 03 September 2011 - 04:42 PM, said:

I think this is happening to all people on this topic and more. Would someone tell me how to

Java tends to overallocate memory, by around 480MB and as you traverse further in MC this grows further. Many sites are incorrectly telling users that they need to allocate more when in fact the problem is that too much is allocated; especially on the 32bit java.

Minecraft allocates Xmx1024M and Xms512M itself, which translates to 1490MB Virtual Allocated, and around 690 Private allocation (This is the Commit / Paged size).

The problem is the Virtual allocated. Java RE x86 is not large address aware, which means when the default settings get close to 1980MB, the VM will crash out and you end up with either blocks turning invisible or the Out of Memory error.

On 32bit windows, this is even lower, you can usually only get to around 1.75GB of virtual allocated before the app crashes.

Once you get into a world, Virtual allocation increases to 1800MB.

Java x64 will take on the allocation limit of the OS, which is 64GB(theoretically it could be much less given we are only using 48bit for the memory addressing on current cpu's).

Minecraft on this version of JRE will allocate and use as much ram as is available, up to the point where you start eating into the non paged Kernel Memory area.

The real fix is to preallocate as little as possible, so that Java only allocates new blocks as required by memory growth. the XMx and XMs settings are not limits, they are preallocation blocks. What also helps is enabling Java Garbage collection.

I use the following batch to set my gamedata location and optimise the allocation blocks

@echo off
Title Minecraft Launcher
set APPDATA=%CD%\
"c:\Program Files\Java\jre7\bin\javaw.exe" -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:ParallelGCThreads=5 -XX:+CMSIncrementalPacing -XX:+UseAdaptiveGCBoundary -XX:SurvivorRatio=16 -Xmn1M -Xmx2M -Xms2M -jar minecraft.exe

you can also use

@echo off
Title Minecraft Launcher
set APPDATA=%CD%\
start javaw.exe -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:ParallelGCThreads=5 -XX:+CMSIncrementalPacing -XX:+UseAdaptiveGCBoundary -XX:SurvivorRatio=16 -Xmn1M -Xmx2M -Xms2M -jar minecraft.exe

with this, Jave goes from this (I'm not listing Working set, since its roughly 95% of the commit most of the time).
Start - 630MB Private(Commit), 1478MB Virtual
Menu - 820MB Private(Commit), 1724MB Virtual
In Game - 1,102MB Private(Commit), 2095MB Virtual (Hangs near instantly)

to
Start - 48MB Private(Commit), 1325MB Virtual
Menu - 298MB Private(Commit), 1623MB Virtual
In Game - 704MB Private(Commit), 1979MB Virtual (Hangs near instantly)

this will probably still be too much on x86 copies of windows, so the the normal view distance should be used to drop this further.

#10

RubyTore
    RubyTore

    Out of the Water

  • Members
  • 5 posts

Posted 25 September 2011 - 01:28 PM

I've been playing MC for just under a year. I just got this error message today and saw this post. I'm not all that computer savvy and don't know a thing about programming and so this last post, which might be exactly what I need, is Greek to me. Someone, if you can, dumb it down for those of us that play games, but don't program. :D Thank you in advance.

#11

Gokuuk
    Gokuuk

    Newly Spawned

  • Members
  • 1 posts

Posted 25 September 2011 - 03:06 PM

View PostRubyTore, on 25 September 2011 - 01:28 PM, said:

I've been playing MC for just under a year. I just got this error message today and saw this post. I'm not all that computer savvy and don't know a thing about programming and so this last post, which might be exactly what I need, is Greek to me. Someone, if you can, dumb it down for those of us that play games, but don't program. :D Thank you in advance.


Hey there:

Just right-click on your desktop or minecraft folder space, and make a new Notepad file. Paste in what Squall wrote, and then say "Save As". Pull the drop down menu to select "all files", give it whatever name you feel, and finish with ".bat".
Then you can merely drop it in your minecraft folder and load it from there, and/or make a shortcut to your desktop for ease of access :).

Hope that helps!

#12

JMC17
    JMC17

    Coal Miner

  • Members
  • 126 posts

Posted 25 September 2011 - 03:38 PM

If the above post didnt work for you, read http://www.minecraft...emory-problems/

#13

Topast
    Topast

    Tree Puncher

  • Members
  • 10 posts

Posted 25 September 2011 - 03:43 PM

View PostMagickSid, on 22 December 2010 - 11:57 PM, said:

Side note, upgrade to win64 -- you have 5 gigs ram -- it will be better utilized

10/10!

he is right

Upgrade to 4/5GB RAM...

#14

kaimaxmunte
  • Location: Dutch

Posted 03 October 2011 - 02:47 PM

forum link!
it lets you chose how much ram you want and increase fps works with all sytems



#15

Aed3
    Aed3

    Out of the Water

  • Members
  • 3 posts

Posted 04 October 2011 - 07:37 AM

I had this problem. Could only run Minecraft for 30 seconds before "Out of Memory" error. Solution below.

The ONLY thing that worked was installing 64 bit Java runtime client for Windows 7. http://java.com/en/download/manual.jsp

intel i7 2600k
geforce gtx 570
windows 7 64 bit
8 gb ram