Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

Perhaps a server is already running on that port?


  • Please log in to reply
3 replies to this topic

#1

trevorsutton

Posted 22 December 2010 - 08:16 AM

Someone may have already posted it, but couldnt find a legitimate answer.

I'm a linux noob, but I made a minecraft server on my ubuntu computer, and when I start the server it opens, and runs fine. But if for whatever reason I have to stop the server, when I try to restart it I get "Perhaps a server is already running on that port?"

I have tried restarting the computer, and I have tried resetting the port on the router, but the only way that I have been able to start the server back up is to completely delete minecraft_server.jar.

It's probably something really simple...lol, but for the life of me I can't figure it out.

Register or log in to remove.

#2

rch
    rch

    Minecraft.cm

  • Members
  • 4104 posts
  • Location: Florida
  • Minecraft: rch

Posted 22 December 2010 - 09:24 AM

This question would be best posted in the Server Administration forum.

Also, are you starting your server within a screen? From console? What commands are you using to start/stop? Can you provide any more details?

Try this, in console type "screen -r" and if your servers console shows up, hold CONTROL and hit C or type 'stop' to kill the server.

#3

trevorsutton

Posted 23 December 2010 - 01:36 AM

Yeah wasn't sure where the best place to post it was, but for more info.

I'm running it on ubuntu desktop edition, im using the same console command to start it that it says to directly below the minecraft.jar download, or:

java -Xmx1024M -Xms1024M -jar minecraft_server.jar nogui

I played with it a bit more, and its definitely not the server.jar thats causing the problem, if I delete that nothing happens, but if I delete EVERYTHING in the server folder, then it will start back up like new...well it is new, but thats not the point. Something remains blocking the port, or it believes that the port is still blocked regardless of what I do to the current server. Currently I am just using stop to stop the server, if there is a better way then by all means let me know.

Also I would like to point out that resetting the router has no affect on the message saying something is running on that port, changing the port in server.properties has no affect, closing the terminal minecraft was previously running in has no affect, changing the servers ip on my router has no affect, renaming the folder the minecraft_server.jar is in has no affect, and as I said before restarting the entire server has no affect. Not to mention the fact that running a server on my windows 7 laptop has no problems, it binds to the port even when ubuntu says it can't, and closing it and restarting it is not an issue. There has to be something simple im missing, but having to delete all my world data everytime minecraft updates is not my favorite solution.

#4

grosskum
    grosskum

    Out of the Water

  • Members
  • 5 posts

Posted 24 March 2012 - 02:34 AM

I got the same problem, i did a full wipe and fresh install and im still getting it, I have no idea what is wrong. it worked fine about a week ago?