Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[MineCraft Forge] Error, '


  • Please log in to reply
4 replies to this topic

#1

Rainbow_Pancakes
  • Location: Never Never Land
  • Minecraft: Rainbow_Pancakes

Posted 20 February 2012 - 04:52 PM

Hello fellow Modders, I have recently transferred my mod to Minecraft Forge but I have ONE SMALL error...

I know what the error is but I can't find where it is...

this is the error:

Spoiler:

Again, I know what the problem is it says "Caused by: java.lang.RuntimeException: unknown character '"

I just don't know where it is in the code...

mod_Quicksand.java:

Spoiler:

Thanks to anyone that helps :)
Posted Image

Register or log in to remove.

#2

crueltyinc
  • Location: SoCal
  • Minecraft: alisalover

Posted 20 February 2012 - 05:32 PM

My guess is you need to change "Block'o'mud" to "Block\'o\'Mud". I'd test it myself if I could, but that's the only place I see a ' character.
No current project! Have any coding problems? PM me and I'll help in any way I can.

#3

Rainbow_Pancakes
  • Location: Never Never Land
  • Minecraft: Rainbow_Pancakes

Posted 20 February 2012 - 05:37 PM

View Postcrueltyinc, on 20 February 2012 - 05:32 PM, said:

My guess is you need to change "Block'o'mud" to "Block\'o\'Mud". I'd test it myself if I could, but that's the only place I see a ' character.

Okay, I got rid of that and made it Mud Block instead but I still get the error...
Posted Image

#4

crueltyinc
  • Location: SoCal
  • Minecraft: alisalover

Posted 20 February 2012 - 05:53 PM

View PostRainbow_Pancakes, on 20 February 2012 - 05:37 PM, said:

Okay, I got rid of that and made it Mud Block instead but I still get the error...

Curious, I just looked at line 54 (the one referenced in the error) and it's
configuration.load();
Look for any ' in your configuration file and change them accordingly.
No current project! Have any coding problems? PM me and I'll help in any way I can.

#5

Rainbow_Pancakes
  • Location: Never Never Land
  • Minecraft: Rainbow_Pancakes

Posted 20 February 2012 - 06:26 PM

View Postcrueltyinc, on 20 February 2012 - 05:53 PM, said:

Curious, I just looked at line 54 (the one referenced in the error) and it's
configuration.load();
Look for any ' in your configuration file and change them accordingly.

I found it! Thanks a lot! :) +1
Posted Image