Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

BUG? Mobs spawning too close to lights & players


  • Please log in to reply
3 replies to this topic

#1

burundilapp

Posted 17 December 2010 - 04:37 PM

Something isn't quite right in the current server build with mobs.

This is where the spider spawned, note the proximity to the light and myself.

Posted Image

I am about 5 blocks from the spawn level of the spider which is sea level.

Client is v1.2.6, server is 0.2.8 and we are running the following addins:
DatDeleterv1
HMod v131
Multiplay Admin 0.8
Stairfixer 22/10/2010 06:41

Is this a known issue, I thought mobs were supposed to spawn away from lit areas and quite a way from an active player.  it would explain why some players are having difficulty mob proofing their homes.

Thanks
B.

Register or log in to remove.

#2

Agnate
    Agnate

    Carpenter

  • Members
  • 61 posts

Posted 17 December 2010 - 04:45 PM

Yeah, we were constantly having spiders (and only spiders, no other mob types) spawning in our fortress.  I had to add lights partway between the ceilings.

My only guess was that it was spawning a 1-block high monster in the air between the light source and the ceiling.  Adding more lights seemed to stop the random spawning, though.

#3

MelancholyFae

Posted 18 December 2010 - 03:05 AM

The first day or two that we turned on mobs, we got EVERYTHING spawnining inside our cities - even the city that had no grass just smoothstone/etc.  we were... pardon the pun.. mobbed by these things.
Later though, not only did they dissappear, but our animals did too.

Now we get some, once in awhile.. they seem to not spawn near lights anymore at least (we went CRAZY putting up lights everywhere in our city btw), but its rather few or none in many areas, and the animals are still fewer. (No chickens for days - I've seen a pig and a cow once thugh)

Any ideas about this one as well?

me - "I feel like being evil today."
friend - "Don't do it! Crime doesn't pay!"
me - "So? I'm not doing it for the money."


#4

Agnate
    Agnate

    Carpenter

  • Members
  • 61 posts

Posted 20 December 2010 - 01:21 PM

That's odd...

I've been landscaping a city for the last two days on our server, and the number of sheep, cows, and chickens is incomprehensible (as well as monsters outside of the city walls).  Must be a setting on your server, or one of the files is messed up.  Maybe re-extract/build the server files (saving your worlds, of course)?

Otherwise, I have no idea.  We run vanilla, though, so maybe it's one of the mods you have that's acting up.