Jump to content

  • Curse Sites
Become a Premium Member! Help
Latest News Article

[1.5.2] Little Maid Mob Mod [Sound Fix]


  • Please log in to reply
27 replies to this topic

#1

talespinner1965

Posted 07 February 2012 - 02:13 AM

Welcome to...

Posted Image


Well, as the title suggests, this is the place where you can get the better sounds for your very own, Little Maid! You'll never have to deal with that obnoxious Ghast following close behind. Now, you will have the charming little "Hai Hai" behind you wherever you go!

Now, of course this entire post is useless unless you have the actual mod. So here, go here for the Japanese Forums original link Click Me!. If you prefer English, this is a new post to visit that gives you the basic breakdown of the mod Click Me!. Be sure to check out MMM's other mods (try getting the FN5728Guns and the Zabuton mods for some added quirks to your Little Maids). Go to the "Any questions?" if you have any questions. Also, if you want to know anything about this fix, you may wish read this post. Just a suggestion.

Download:
Spoiler:


Installation:
Spoiler:

Changelog:
Spoiler:

Snapshots and Videos:
Spoiler:

In the ~FUTURE~
Spoiler:


Credits:
Spoiler:
Banners:

Spoiler:

Any questions?:
Spoiler:

Donate:
Spoiler:


Source:
Spoiler:

Other Information:
Spoiler:

Please note:
-I have a VERY busy life. Please don't be insulted if I don't respond to a question you have right away. Thank you! God Bless.


Posted Image


Register or log in to remove.

#2

ItalianHydra

Posted 14 February 2012 - 03:25 AM

Thank you sir :)

#3

KaptinKraftinator
  • Minecraft: myakami

Posted 17 February 2012 - 09:01 PM

Oh THANKS YOU!!! :D
I've been stressing myself out for hours trying to get the updated sounds to work!
When I heard her cute little "HiHi!" I Cheered and throw my arms into the air! xD Like scoreing a goal. And I don't even like football. lol

You get a good dose of rep from me! :D

#4

talespinner1965

Posted 12 March 2012 - 12:43 AM

Well, guess what! The sound fix is COMPLETELY compatable with Minecraft 1.2.3 AND can be installed in the same...exact....manner!
I hope this helps!
-Talespinner1965


Posted Image


#5

Retro-Juz
  • Location: Australia

Posted 19 April 2012 - 04:05 PM

Can anyone tell me does this fix work for Little Maids 1.2.5?
My maids have no sound in 1.2.5, did I balls it up?

Posted Image


#6

BrainSlugs83
  • Location: WA
  • Minecraft: BrainSlugs83
  • Xbox:Teariz

Posted 16 May 2012 - 09:23 PM

First off, thanks for getting these sounds together.

Some suggestions though:
  • I would recommend only installing one copy of the .ogg sound files -- in the correct -- littleMaid mob folder, you need to alter your .cfg file though -- instead of littleMaid.[SoundFileName] you have to put littleMaidMob.[SoundFileName] folder.
  • Move all the se_[sound effect name]= lines into the sounds config only, and not in the main directory config -- also just rearrange the order of the main config so that it makes more sense.  (I can supply an example of all this if you need).
Finally, I'd like to note that there are some issues with the sounds in 1.2.5 (I don't know if these issues existed before, I've only used little Maid Mob with 1.2.5):

The sounds cut-off at about 1 second into them, for instance "Hai Hai" works fine, but like "itadakimasu" (cookfinish.ogg) for example cuts off abruptly part way through (even scratching the whole thing and reinstalling following your exact instructions, I get the same behavior -- it's not just this sound, but it's an easy one to see it -- also other sounds like goodnight "oyasumi nasai" get cut off -- which is a real shame since they're so damn cute!)

Does anybody know a fix?

I'm guessing that the mod is hard coded to play the sounds in a loop or something for exactly 1 second (since it was all weird/creepy animal noises before), and that this issue is not unique to 1.2.5 -- if nobody knows how to fix this, I'll probably try to decompile this when I get some free time and see if I can find where the issues lies.

Edit:
Ahh, it looks like I'm not the only one experiencing this, and it also looks like it's not just in version 1.2.5:


Edit 2:
Figured it out, there is an issue, with the .ogg files, I'm not sure if it's specific to these files or what, but on decompiling, I followed the trace all the way deep into the bowels of the sound system, and it breaks in there somewhere.  Though, happily for us, if you just convert the .ogg files to .wav files they will no longer be cut off (yes this means more than renaming them -- and yes you have to delete your .ogg files, or move them somewhere else, as the loader just looks for the first file with the correct name, and doesn't consider the extension as far as I can tell.)

I just converted all my .ogg to .wav via http://media.io -- you just select "wav" and then hit "choose file" and hit convert, and a few seconds later you'll be on a page giving you the option to download them.  I know it's a pain to do it one at a time, but it worked for me, and the files were still pretty small.  AND THEY DON'T CUT OFF ANYMORE!  HELL YES!!! \o/

#7

talespinner1965

Posted 10 July 2012 - 06:07 PM

Well, I can honestly say that Audiomod seems to be one of the best (mabey the only, not sure though) mod sound loader out there. I was able to use BrainSlugs83's advise to take and compile and entire new set of files that is MUCH less complicated and works out very well. If anyone has any further suggestions or comments feel to ask! Thanks for inquiring!Posted Image
-Talespinner1965


Posted Image


#8

Kakujo
    Kakujo

    Carpenter

  • Members
  • 50 posts
  • Location: Bortland
  • Minecraft: Kakujo

Posted 18 July 2012 - 12:07 PM

View Posttalespinner1965, on 10 July 2012 - 06:07 PM, said:

Well, I can honestly say that Audiomod seems to be one of the best (mabey the only, not sure though) mod sound loader out there. I was able to use BrainSlugs83's advise to take and compile and entire new set of files that is MUCH less complicated and works out very well. If anyone has any further suggestions or comments feel to ask! Thanks for inquiring!Posted Image
-Talespinner1965

Thanks so much! This worked great for me in 1.2.5. Can the same process be used for the other download (pre 1.2.5)? I use Yogbox in another game and have to use LMM 1.2.3 and still have the cut-off issue, it seems.
Hello, Everyone! I have a comic at KakuJomics and a daily let's plays at KakuJomics Gaming!

#9

talespinner1965

Posted 27 July 2012 - 08:38 PM

View PostKakujo, on 18 July 2012 - 12:07 PM, said:

Thanks so much! This worked great for me in 1.2.5. Can the same process be used for the other download (pre 1.2.5)? I use Yogbox in another game and have to use LMM 1.2.3 and still have the cut-off issue, it seems.
Well, as long as Audiomod is installed (along with Little Maid Mod's other requirements) the non-1.2.5 download should work, according to my post about it working for 1.2.3 (I'll be honest, it has been AGES since I've played Minecraft v1.2.3!). If the fix doesn't work, I'll see what i find to fix it.
  -Talespinner1965Posted Image

(There seems to be an interesting new list of Emoticons!?!)


Posted Image


#10

GodzillaRulz
  • Location: Stuck in a cave, fighting off Zubats. Darn Zubats... they're everywhere!
  • Minecraft: GodzillaRulz

Posted 29 July 2012 - 07:17 PM

View PostKapinSebby, on 17 February 2012 - 09:01 PM, said:

When I heard her cute little "HiHi!" I Cheered and throw my arms into the air! xD Like scoreing a goal. And I don't even like football. lol
They aren't saying "Hi hi!" they are saying "はい はい" aka which is "Yes" in Japanese. The word sounds similar to the English word "Height"
Sorry... my sister uses Japanese words... a lot...
In America!
Posted Image

#11

DubzDean
    DubzDean

    Out of the Water

  • Members
  • 4 posts

Posted 04 August 2012 - 11:23 PM

Is this available in Minecraft 1.3.1 Version?!

#12

talespinner1965

Posted 05 August 2012 - 03:11 PM

View PostDubzDean, on 04 August 2012 - 11:23 PM, said:

Is this available in Minecraft 1.3.1 Version?!

I'm not quite sure as to what you mean by Minecraft 1.3.1 version, but I'd be happy to help you if let me know what you mean by this version.
   -Talespinner1965 ~~~~Posted Image ~~~~

EDIT: My bad, I didn't see that Minecraft had updated to 1.3.1 (It's only been out for 4 days). I will update this ONLY when the actual mod updates (Otherwise, how would I know what to do to make sure the sounds work if it's not updated!).

  Thanks for informing me of this!


Posted Image


#13

DubzDean
    DubzDean

    Out of the Water

  • Members
  • 4 posts

Posted 06 August 2012 - 06:44 AM

View Posttalespinner1965, on 05 August 2012 - 03:11 PM, said:

I'm not quite sure as to what you mean by Minecraft 1.3.1 version, but I'd be happy to help you if let me know what you mean by this version.
   -Talespinner1965 ~~~~Posted Image ~~~~

EDIT: My bad, I didn't see that Minecraft had updated to 1.3.1 (It's only been out for 4 days). I will update this ONLY when the actual mod updates (Otherwise, how would I know what to do to make sure the sounds work if it's not updated!).

  Thanks for informing me of this!
Thnx! Post back to me when u find out! Posted Image

#14

talespinner1965

Posted 20 August 2012 - 07:01 PM

Well, Minecraft has updated to 1.3.2 and the mod is not updated yet, however I may have one idea as to why the sound fix was failing in the Technic Modpack...

View PostKakujo, on 18 July 2012 - 12:07 PM, said:

Thanks so much! This worked great for me in 1.2.5. Can the same process be used for the other download (pre 1.2.5)? I use Yogbox in another game and have to use LMM 1.2.3 and still have the cut-off issue, it seems.
...and I think it has to do with the way Forge API and the setup of the modpack work (with the extra "modpack.jar", and the mods with their sounds inside the ".minecraft\mods\~Mod~" folder). The directories that the sounds usually come from are redirected to a different path (Observed when one looks at the ".minecraft\resources\mod\sound" folder and finds nothing inside). Therefore, I'll have to look into a pathing (whether it be through the configuration or otherwise) to make this work for Technic.

   -Talespinner1965
P.S. I realize that your errors are cut-off issues. I had just tried the sound fix in my 1.2.5 Technic and it failed to sound off anything but ghast noises. (and yes, Audiomod is already included).


Posted Image


#15

YurkaMaku

Posted 04 November 2012 - 12:51 AM

Ive tried everything, the audio doesnt work in technic at all, has anyone else come up with a solution? or should i just abandon this mod and every mod involved with it, and move on with my life.

#16

talespinner1965

Posted 22 March 2013 - 01:59 AM

View PostYurkaMaku, on 04 November 2012 - 12:51 AM, said:

Ive tried everything, the audio doesnt work in technic at all, has anyone else come up with a solution? or should i just abandon this mod and every mod involved with it, and move on with my life.

Try the Technic fix where you extract your "Technicssp" or whatever folder you prefer from the Technic folder to your "C:\Documents and Settings\<username>\Application Data" and rename it to ".minecraft". Then, go to your "bin" folder and user an archiver such as 7-zip or WinRAR  to open both the "modpack.jar" and the "minecraft.jar". Send ALL files in the "modpack.jar" into the "minecraft.jar" and be sure that you delete any folders that say "META-INF" to prevent black-screening. Also, make sure to delete the "modpack.jar" from your "bin" folder. Once you have that, you may close the windows and run Minecraft. This should allow the sounds to operate on Minecraft's Vanilla level rather than Technic's advanced pathing.

Hope this solves your problem!

P.S. Doing this strategy actually makes your (Technic, Tekkit, etc.) Minecraft not lag so much! So enjoy the sounds and reduced lag!


Posted Image


#17

talespinner1965

Posted 22 March 2013 - 02:12 AM

So, I guess the solution for those of you who have Technic and the other packs, you may want to try my suggestion to YurkaMaku. It will fix the issue.

Pro Tip: Be careful with these Little Maids on these mod packs. I've unfortunately encountered the problem with assigning them tools that derive from these other mods. Some will not work, such as the R.E.P (It was a funny idea, giving her a dangerous tool, but it ended abruptly her throwing one and getting the much loathed, "Saving Chunks" error). Recommendation: Create a test world, assign her some tools with a book, and spawn some creatures.

Cheers!
  Tales~


Posted Image


#18

Monitomen

Posted 18 April 2013 - 06:29 AM

i have the technic launcher as well, i added the mods to the vanilla minecraft fallowed the steps given n still doesn't  work with the sounds, the default sounds are driving me crazy and if i cant find a way to fix this im taking the mod out, its just annoying hearing this cute things making ghast noises

#19

Nicholas_Biddle
  • Location: Fighting Pirates with Muskets (Somewhere)

Posted 20 April 2013 - 10:43 AM

I have installed this mod in 1.5.1 and it works, however but the mod uses ghast sound even after i placed the soundpack in resources folder, and also i have installed ModLoader+Audiomod+Forge.
What should i do?
!エロゲは最高です!
!アニメは最高です!

#20

talespinner1965

Posted 20 April 2013 - 11:50 PM

View PostNicholas_Biddle, on 20 April 2013 - 10:43 AM, said:

I have installed this mod in 1.5.1 and it works, however but the mod uses ghast sound even after i placed the soundpack in resources folder, and also i have installed ModLoader+Audiomod+Forge.
What should i do?

This is simply fixed. Install Modloader + Audiomod -or- Forge. Doing both will counteract each other and (from my experience  it causes cut-offs). Also, be sure that you installed it correctly:

1. Download and Install Risugami's Modloader and Audiomod -or- Minecraft Forge, then run Minecraft.
2. Download and Install MMMLib and Little Maid Mod, then run Minecraft. (EN or JP) [Can't read Japanese? Use Google's Automatic Translator!]
3. Go to (run / %appdata% / .minecraft / resources / mod / sound) and delete the current "littleMaidMob" folder.
4. Insert the included "littleMaidMob" folder into the place where you deleted the previous one.
5. Run Minecraft!

*If you are having trouble with opening the zip or you want to change parts of the config., refer:

Open zips: 7-zip
Open Configs and many other text-based files: Notepad++ [I recommend that you stick to the "Installer" download. It's a lot easier!]

By the way, thanks for informing me that it is 1.5+ compatible. I've tested it out, corrected a typo and there is now a new release.


Posted Image