All users will need to merge their Minecraft Forum account with a new or existing Twitch account starting October 23rd. You can merge your accounts by clicking here. Have questions? Learn more here.
Dismiss
  • 0

    posted a message on [1.2.5] MyCraft / MyCraft+ Beta - All your mods in one place! [V2.4.4]
    I'm away from home for the next little while, and it turns out I left some of the things I need to work on MyCraft at home, so there probably won't be an update for a while longer. There's still some stuff I can do, but can't update the in-game menu or flying until I get back =(

    I'm sorry this update is taking so long, but the whole deal with moving over to the beta wasn't planned very well...

    Quote from Adnarel

    So... if I understand correctly, only people who pay will be able to enjoy this mod?


    There will be a free version and a pay version.
    The new free version will actually have more features than the current one, so you don't have to worry.
    Posted in: Minecraft Tools
  • 0

    posted a message on [1.2.5] MyCraft / MyCraft+ Beta - All your mods in one place! [V2.4.4]
    Quote from CooroDragon

    Soooo can we hope to have an updated mycraft in the near future? i simply love this mod launch client thingy once i started using it i couldnt use anything else :P

    Yes, there should be an update to MyCraft Beta very soon. I decided I won't be updating the original MyCraft, and instead will be working on adding all the features into the Beta. The in-game menu will be out in the next update, and flying in the update after that.

    Quote from lordroy

    I really was planning on donating to this mod, as I have been using it since it came out, however...

    The lack of support for 1.3.1 (neither Mycraft nor Mycraft+ beta work for me), the lack of updates on the website (Mycraft Updated: March 4th, 2012... Mycraft+ Beta Updated: April 27th, 2012), and the overall lack of work on this makes me hesitant to donate anything.

    I really do miss using Mycraft, but if it is not going to be updated in a timely matter, I can not rely on it.

    -=R=-

    If you don't plan on donating, that's fine with me.
    But just to let you know how I've been doing updates:
    The only way I've really bothered to update is by posting on this topic. The way it's worked out is that, I have a certain amount of time to work on MyCraft, and during that time I can either update forum topics and webpages to say MyCraft isn't working, there's been an update etc.. Or I could work on actually getting an update out that will fix a bunch of problems.

    There is an automatic system to show when I've last made a release, and you can see that here (It's only for the beta)
    http://mycraft.frustra.org/builds
    This isn't tied in with the last updated section on the website, so I haven't always changed the date on the website to match.

    Recently I've been working quite hard on getting MyCraft fixed up. Usually updates are almost instant for MyCraft, except now that minecraft single player is now a mini multiplayer server, it's broken almost everything. That's why this update is taking so long.

    Quote from SuperDogBoo

    I am on a mac. I once had it working fine. Then the update for 1.3 for minecraft released. Since then it has not worked. But I also downloaded mods since then. I tried deleting every glimpse of mods I can find and even reinstalled minecraft. MyCraft still says there are some conflicting mods. Can someone please help me?


    If you're not using the beta, then you're getting the "Mod conflicts" message because it's not working with 1.3
    You can try the beta out, since it is working with 1.3, but you won't have the in-game menu or flying until I finish those updates.
    Posted in: Minecraft Tools
  • 0

    posted a message on [1.2.5] MyCraft / MyCraft+ Beta - All your mods in one place! [V2.4.4]
    Quote from Hairymexican69

    when i log in with the beta and i hit V to fly, nothing happens. Am i doing something wrong? I love the V Feature.


    The flying and in-game menu haven't been added to the beta yet. I've been working pretty steadily to get these finished. I won't say when these will be done, since I don't really know myself, but I have been making progress. I'll be posting here once I have any updates available.
    Posted in: Minecraft Tools
  • 0

    posted a message on [1.2.5] MyCraft / MyCraft+ Beta - All your mods in one place! [V2.4.4]
    Quote from gabessdsp

    Ahhh okay thanks



    Ugh...now I get this error in the log:
    *log here*


    I'm trying to figure out exactly what's happening with your game, I think I've made a fix, but I'm not entirely sure. We'll see once I get the next update out.

    Quote from Snagglebeast

    I just updated my MyCraft to + Beta and I am having a render issue when I run texture packs. I am using MC Patcher's latest version. Both the mods and texture packs work seperately, but when I run them together the images of items I hold are messed up. Any assistance provided is greatly appreciated.


    I'll see if I can figure our why that's happening. In the mean time, it'd be useful if you could post a log file from when you're getting render issues.

    Quote from triple_negative

    I am unable to access the in game menu in Mycraft+ Beta Please help


    The in-game menu hasn't been added to the MyCraft Beta yet, it will be added in the next update (I'm working on it right now)
    Posted in: Minecraft Tools
  • 0

    posted a message on [1.2.5] MyCraft / MyCraft+ Beta - All your mods in one place! [V2.4.4]
    Quote from gabessdsp

    Okay...so I download the beta...and I just overwrite the jar file then with the new one?

    EDIT: When I download the beta the only thing I get is a mods folder and a MyCraft.jar. So I overwrote the existing jar(also I did delete the .minecraft folder before this) and I still get the same error. Did I do something wrong?


    You'll want to delete the exe, the beta doesn't come with an exe right now, so you need to run the jar instead. It should work to just double click on it.
    Posted in: Minecraft Tools
  • 0

    posted a message on [1.2.5] MyCraft / MyCraft+ Beta - All your mods in one place! [V2.4.4]
    Quote from gabessdsp

    So I deleted my .minecraft folder again to start from scratch. Then I downloaded the regular version of MyCraft and it still give me the same exact error in the log :/


    Sorry about that, that was a typo. You need the MyCraft+ Beta if you're on Minecraft 1.3.1
    The non-beta will be updated to 1.3.1 very soon. (Working on it right now)
    Posted in: Minecraft Tools
  • 0

    posted a message on [1.2.5] MyCraft / MyCraft+ Beta - All your mods in one place! [V2.4.4]
    Quote from gabessdsp

    Hey I want to have MyCraft+ but I can't find anywhere to purchase it :(

    So how do I get it? :D

    So I deleted my .minecraft folder, and then I downlaoded a brand new MyCraft, and brand new minecraft. I still get a mod conflict error. I don;t even have anything in the mods folder.

    http://pastie.org/4434580


    Right now only the beta is working with Minecraft 1.3.1
    There isn't actually anything for sale yet. The MyCraft Beta is available under the MyCraft+ page:
    http://www.frustra.org/mycraft-plus
    Posted in: Minecraft Tools
  • 0

    posted a message on [1.2.5] MyCraft / MyCraft+ Beta - All your mods in one place! [V2.4.4]
    The MyCraft Beta is now updated and working with 1.3.1! I didn't end up having much time over the weekend after all, but I've freed up some time to work on MyCraft during the week. I've decided I won't be updating the non-beta, but I will be working as fast as possible to add in all the old MyCraft features, like flying and the in-game menu. Most of it's done, it's just a matter of getting it out there.



    Wow what happend? So your idea is to discontinue the normal Mycraft updates ( It errors when used in 1.3) and provide a newer Mycraft+ that has features the original should have but also comes with a price tag, when there are other programs such as modloader that does the same thing as Mycraft but is free.

    Needless to say im off to go download modloader, which is cost free.


    That's not really the case. The current MyCraft Beta is completely rewritten to be faster and make modding easier. Once I am finished with the beta, it will contain all the features of the original along with a couple more, replacing the current standard MyCraft. This will be completely free. MyCraft+ is being built off the Beta as well, and will include a couple extra features as mentioned in the OP. The reason I am going to charge for MyCraft+ is because the amount of time I have and will be putting into it is just not worth it otherwise. Not only that, but I have a server to keep running. I realize not that many people have money to spend freely on the internet. The standard MyCraft will always be free.

    I'm sorry if the info I've posted before was a little unclear.
    Posted in: Minecraft Tools
  • 0

    posted a message on [1.2.5] MyCraft / MyCraft+ Beta - All your mods in one place! [V2.4.4]
    Hi guys, sorry that I haven't been around to give support / make updates.
    I've been really busy with work and school recently. I can't make any long-term commitments, but I should be able to make an update this weekend (long weekend for me).

    In the mean time, the MyCraft+ Beta should still be working with 1.3. It doesn't come with flying, but you can install a different mod into it like Single Player Commands that contains flying.

    @Superted64
    Since MyCraft doesn't have a settings interface yet, you have to edit the config file to turn on the proxy.
    in MyCraft/myc/ create a text file called settings.txt, and add proxify=on into it. Then rename it to remove the .txt, and you should have proxy turned on the next time you run MyCraft.

    -xthexder
    Posted in: Minecraft Tools
  • 0

    posted a message on [1.2.5] MyCraft / MyCraft+ Beta - All your mods in one place! [V2.4.4]
    Quote from SkyAxis


    thx
    sorry it took so long, my computer is a bit slow XD


    It took you a year to install a DLL? Good job =)
    Posted in: Minecraft Tools
  • 0

    posted a message on [1.2.5] MyCraft / MyCraft+ Beta - All your mods in one place! [V2.4.4]
    Quote from Akari

    Oh, I forgot to add that its been doing this since about 1.2 release, rendering it unplayable.


    You can always try the MyCraft Beta, it's a bit better for this kind of thing.
    Do make sure all your mods are for 1.2.5, and check your Modloader folder for any mods that got left there.
    Posted in: Minecraft Tools
  • 0

    posted a message on [1.2.5] MyCraft / MyCraft+ Beta - All your mods in one place! [V2.4.4]
    Quote from Akari

    Okay, I need help. I cannot for the life of me get this to work anymore. Its constantly saying that Modloader is out of date, even though i have the most recent version of modloader. No clue what is causing this. Heres the log from the first time this happened a while back.

    Log:


    Available x64 JREs:
    C:\Program Files\Java\jdk1.6.0_27\jre\bin\java.exe
    C:\Program Files\Java\jre6\bin\java.exe
    Running with JVM: C:\Program Files\Java\jre6\bin\java.exe
    Using launch options:
    -Xmx1024m
    -Xms1024m
    Running with custom launch options
    MyCraft Launcher 6.0
    MyCraft V2.4.4
    Running from folder: C:\Users\Megan\AppData\Roaming\.minecraft\bin\mycraft
    Lib file: minecraft.jar

    Init: net.minecraft.GameUpdater
    Injecting ModLoader
    java.lang.VerifyError: (class: alj, method: c signature: (Lxd;IIILjava/util/Random;)V) Incompatible argument to function
    at pb.<clinit>(SourceFile:138)
    at qa.<init>(SourceFile:14)
    at net.minecraft.client.Minecraft.<init>(SourceFile:173)
    at n.<init>(SourceFile:33)
    at net.minecraft.client.MinecraftApplet.init(SourceFile:33)
    at org.frustra.mycraft.modding.advanced.InjectUtil.postInit(InjectUtil.java:233)
    at net.minecraft.Launcher.replace(Launcher.java:141)
    at net.minecraft.Launcher$1.run(Launcher.java:87)


    Try doing a force update to your jar, it may be that there's something else in your jar that is conflicting with modloader.

    Quote from Xthinker

    I'm trying to install Pam's HarvestCraft. To do this you need Modloader AND Forge. For somereason MyCraft says they are conflicting mods. The only thing I'm not sure about is whether to unzip the mods (I didn't).


    If you're using the beta then you don't have to extract the zips, but for the original you should.
    To fix the conflict between modloader and forge, delete the file from modloader that it says is conflicting.
    Posted in: Minecraft Tools
  • 0

    posted a message on [1.2.5] MyCraft / MyCraft+ Beta - All your mods in one place! [V2.4.4]
    Quote from Jak2012

    Help please?When i try to download MyCraft,it's loading for some time,and then says the website is offline.


    Well, it seems php has gone and failed on us. Everything is back up, but the problem isn't completely fixed, so I'll see what I can do to make sure it doesn't happen again.
    Posted in: Minecraft Tools
  • 0

    posted a message on [1.2.5] MyCraft / MyCraft+ Beta - All your mods in one place! [V2.4.4]
    The frustra blog has been being updated regularly now. You guys should check out the latest posts.

    http://www.frustra.org/blog
    Posted in: Minecraft Tools
  • 0

    posted a message on The KaiserCorp HQ v2 [WIP]
    That's quite an amazing album you've got there!

    I like the designs on your roof.
    Posted in: Screenshots
  • To post a comment, please or register a new account.