All users will need to merge their Minecraft Forum account with a new or existing Twitch account starting October 23rd. You can merge your accounts by clicking here. Have questions? Learn more here.
Dismiss
  • 2

    posted a message on Mine Little Pony v1.6.4.1
    I'm still here and I'm still planning on releasing an official update to this soon. I started work on it last weekend, but it will take another week or so for me to find time to get it done.

    I hadn't been following MCP twitter so I only found out that there was a release candidate that would produce obfuscated code when someone told me last week (there's still no official release). I started working on the update when I found out.

    I haven't looked at any unofficial updates to this mod made by other people and I'm not going to make any comment on them. I know I'm not an easy person to contact sometimes so it doesn't bother me too much, but I can't vouch for them and I'm not going to test them.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mine Little Pony v1.6.4.1
    I updated this for Minecraft 1.6.4. Get it here:

    http://www.minelittlepony.com/wiki/Download

    and don't forget you'll need the 1.6.4 version of LiteLoader too.
    Posted in: Minecraft Mods
  • 1

    posted a message on Mine Little Pony v1.6.4.1
    Quote from Ziero1986
    I am pretty sure this mod and the RenderPlayerAPI conflict in some way.
    Yes, they do. Sorry about that.

    I've made changes in the past so that they don't actively crash Minecraft when they are run together, but they don't work properly together.

    The reason is we both want to change the same stuff (player rendering). I think if I wanted to be compatible I would have to use RenderPlayerAPI for Mine Little Pony, and I don't want to do that for several reasons.

    First, I'm generally against having third-party dependencies. Second, I already have my own compatibility layer for compatibility with custom player rendering in VoxelPlayer (which was tricky enough as it is!). I think our compatibility layers probably work in very similar ways to each other, but I haven't looked at RenderPlayerAPI source to confirm that. Third, I really know very little about RenderPlayerAPI and have no idea if I could do what I need with it (Mine Little Pony really wants to be responsible for all player rendering, so it seems pointless to be compatible with other mods that want to also be responsible for all player rendering). Fourth, I have too much to do to have given this the time it would need to be able to make an informed comment, so I'm going with the easy option of ignoring the problem...
    Posted in: Minecraft Mods
  • 0

    posted a message on Mine Little Pony v1.6.4.1
    Quote from CarriePika

    Hi there!

    I'm getting an item error when trying to use MLP on my private server.


    Thank you for the report. This was caused by the workaround I made to make buckets behave better in single-player. I've just released Mine Little Pony 1.6.2.5 which adds an option to disable that workaround. You can read about it here:

    http://www.minelittl...c.php?f=3&t=529

    or download it here:

    http://www.minelittl...m/wiki/Download

    Quote from Sto3IV

    my friend has a bug: when I create a LAN server, and my friend joins and kicked from server, then it has "internal server error. we have included all of the options except Equestria Girls (humans)


    This is probably resolved by Mine Little Pony 1.6.2.5, please let me know if you still have these problems when using this version.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mine Little Pony v1.6.4.1
    Quote from CarriePika

    2013-09-18 10:44:02 [INFO] [fml.ItemTracker] The mod Minecraft is overwriting existing item at 325 (net.minecraft.item.ItemBucket from Minecraft) with com.minelittlepony.minelp.ItemPonyBucket
    2013-09-18 10:44:02 [INFO] [fml.ItemTracker] The mod Minecraft is overwriting existing item at 326 (net.minecraft.item.ItemBucket from Minecraft) with com.minelittlepony.minelp.ItemPonyBucket
    2013-09-18 10:44:02 [INFO] [fml.ItemTracker] The mod Minecraft is overwriting existing item at 327 (net.minecraft.item.ItemBucket from Minecraft) with com.minelittlepony.minelp.ItemPonyBucket

    That's annoying, this is a complaint about the fix for buckets. That only works in singleplayer anyway, so I'll add an option to disable that.

    Teleporting issues and compatibility issues with Zombe's fly mod are forcing me to rewrite Pony's Eye View again too, so I'll release another update soon which contains this and the option to disable buckets. And 1.6.3 :)
    Posted in: Minecraft Mods
  • 0

    posted a message on Mine Little Pony v1.6.4.1
    Quote from Artem76

    I have a error when i join my friend's LAN server
    We are using same configs and mods.
    Version of the mod 1.6.2.4. Without this mod i can join easily and without any errors

    I'm going to need some information to be able to help you.

    Lets start withg a list of the other mods you are using please.

    Then I need your client error log. LiteLoader should have made a file called output-client.log in your .minecraft directory. Stick it on mediafire and let me take a look please. Or if you're using Forge, ForgeModLoader-client-0.log is fine too.

    Quote from Sto3IV

    my friend has a bug: when I create a LAN server, and my friend joins and kicked from server, then it has "internal server error. we have included all of the options except Equestria Girls (humans)

    Mlp skins version: 1.6.2.4
    Forge version: 9.10.0.804
    Lite Loader version: 1.6.2_04
    (cascaded tweaks enabled : minecraft Forge)


    Same to you. It would be useful to see the server log too, if either of you can provide that please.

    I updated my page on how to report bugs to make this easier for you folks in future:

    http://www.minelittlepony.com/wiki/Report_a_bug
    Posted in: Minecraft Mods
  • 0

    posted a message on Mine Little Pony v1.6.4.1

    Thank you very much. From the log I can see you are using a rather old version of Forge. Mine Little Pony depends on a function that was added to the Forge source on July 24th 2013 for full compatibility, and you're running a build of Forge from July 9th. Please update Forge, most of your Mine Little Pony problems will probably be solved.

    If not, please give me another log to look at :)
    Posted in: Minecraft Mods
  • 0

    posted a message on Mine Little Pony v1.6.4.1
    Quote from darknessninja77

    the invisible armor/item in hoof is still there

    I can't duplicate this, can I please see the file .Minecraft/ForgeModLoader-client-0.log? It's huge so you'll need to put it on pastebin or something.

    Quote from darknessninja77
    and the tping is also still there but it looks like the only trigger is using the filly skin and riding a horse

    Ah I didn't know that was a way to trigger it, thanks, I'll take a look.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mine Little Pony v1.6.4.1
    Quote from _Genni_Isralker_

    Do I really NEED liteloader for this?

    Yes.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mine Little Pony v1.6.4.1
    Mine Little Pony 1.6.2.4 is out now!

    It fixes a bunch more bugs, including the rubber-banding some of you experienced with Pony's Eye View in multiplayer. And it adds a surprise new feature... :)

    Read about it here:

    http://www.minelittl...c.php?f=3&t=512

    Or just download it here:

    http://www.minelittl...m/wiki/Download

    I've also uploaded an updated skin pack. Thanks to AlphaSpaceWombat for putting the pack together, Stephanoodle for her help with this, and all the people who submitted skins on the Mine Little Pony forums! Get the new skin pack here:

    http://www.minelittl...nload_the_skins
    Posted in: Minecraft Mods
  • 0

    posted a message on Mine Little Pony v1.6.4.1
    Quote from darknessninja77

    i'm having issue where, when ever i put on armor it turns invisible as well as the items i'm holding until i take off the armor

    That's a new one on me. What other mods are you using? It might be fixed by the changes I made to armor handling in my current build, but I'd like to test if you can identify which other mod is causing your issue.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mine Little Pony v1.6.4.1
    Quote from ShayminKeldeo421

    Also, I found a new bug! All leather armor shows up White!

    Yeah, that's a real bug, my next release will fix it :)
    Posted in: Minecraft Mods
  • 0

    posted a message on Mine Little Pony v1.6.4.1
    Quote from SpaceKGreen

    Welp. No, I didn't have any other voxel box mods, nor did I have two copies of the mod.

    However, I did solve the problem, as far as I can tell. I had left RenderPlayerAPI in my mod folder from a mod I was using before this updated. I deleted it on a whim, and my character model was a pony, and the config regenerated. Apparently there's a code conflict with RenderPlayerAPI in MLP 1.6.2.3 that wasn't in MLP 1.6.2.2.

    That's good information, thanks.

    I've never tried to support RenderPlayerAPI nor tested with it, so it probably doesn't work correctly with Mine Little Pony (especially if you use VoxelPlayer too). But I don't want to be explicitly incompatible either. So I've renamed some methods to avoid this particular issue. The fix will be in my next release.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mine Little Pony v1.6.4.1
    The link for 1.6 goes to a .litemod. That's what you need to use. Maybe you clicked the download for Minecraft older than 1.6? I'll just remove the link for Minecraft before 1.6 to eliminate any possibility of people getting that in future.
    Posted in: Minecraft Mods
  • 0

    posted a message on Mine Little Pony v1.6.4.1
    Quote from ShayminKeldeo421

    Oh... The download for the minelittlepony.com is broke, then. I'll try the .litemod

    Please show me the link on minelittlepony.com that gaves you a jar or a zip for 1.6. It's my site, I can fix it, and I'd hate to think I am distributing bad files.
    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.