• 0

    posted a message on Schematica
    Quote from Xcom6000»

    Thank you for the reply


    Regarding the material listing showing feedback. It's more for redstone and slime block contraptions with a lot of blocks where even a single misplaced block can cause issues. The material list provides very useful info to give reliable feedback of the finished build. The main issue is just that there could be rogue blocks in wrong places or other unforeseeable issues during the placement that can cause havoc. It would be really nice getting some feedback in the material list to know if there is some misplaced blocks somewhere. Specially when the builds are large enough for errors to be concealed behind other blocks. That is when you really rely on the material tab, just that the material tab wont give you the rogue blocks and sometimes in redstone give you false negatives.


    The problem is, how would I incorporate that into the material list. Say that there is a few redstone dusts in the wrong state somewhere in the build. How should that be displayed, do you have anything on your mind, any examples?



    Quote from MilesOMeat»

    Howdy all - Long time creeper, first time poster.


    I'd like to say to the creator that this mod is by far the most used mod in my repertoire. Thank you for the amazing concept and great execution! Now that the brown nosing is thoroughly completed, I was wondering if anyone has an idea on how I could modify the printer function to only pull resources from my hotbar?


    I'm a little OCD at times and when I am leaving my little hut I load up with X materials for the projects in front of me but at times I will flick on the printer and would use more supplies than I prepared for (I know, my fault!), leaving me high and dry on the other items I was planning on.


    Weird request for a weird reason, I know.


    So I looked through the config and didn't see anything that I could do to limit the printer to only using what was in my hotbar and figured I would reach out to this crowd to see if it is something I missed or if this is not something that can be done from my end.


    Thanks!


    The only way to disable this is to remove all swap slots from the configuration. That should prevent the printer from swapping materials automatically to the hotbar.

    Quote from panter411»

    Is there a way to check all the blocks i need to make it? like can i get a list with the amounts of blocks i need or would it just be easier to do that in MCedit?


    Btw, ****ing epic mod ma dude.


    It's in the operation GUI, under material list.


    Quote from AdamjonByte»

    Hello,
    I have a problem that hinder me a lot. When I turn on the schematica, it flicker strongly and uncorrectly displays the blocks that are already built and which haven`t been built yet. What could be the problem?
    Thank you.
    P.S. Sorry for my English, I don`t know this language wery well.


    No need for big letters. How does it flicker? Can you supply some screenshots or videos that show what exactly the issue is?



    When will Schematica be updated for 1.12? It seems awesome and I would really like to use it.




    Quote from AWesomer»

    Hey there! Any plans for a 1.12 update? Thanks!



    Quote from xromen»

    When 1.12?



    When it's done.
    Posted in: Minecraft Mods
  • 0

    posted a message on Schematica
    Quote from Xcom6000»

    Hi,


    Should start off by thanking the developer of this mod. Does wonders and so useful.


    Just had a feature request or possible bug. When you rotate the structure the rail data don't get rotated, if the structure is rotated 90 deg then the build indicates that the rails are rotated the wrong way. The only way to fix it is to save the structure facing the correct direction.


    Another small request would be to indicate somewhere on the material list the number of miss placed blocks or blocks that aren't supposed to be there. Basically all the orange, red and purple indicators displayed as data for troubleshooting larger builds.


    Great thanks

    Xcom


    I'll have to check what exactly is wrong with rails.

    Does having that information even provide any sort of useful feedback if you're building a large build? You'd be spending a lot of time looking for misplaced blocks anyway.

    Quote from legodude567»

    I am coming across a problem where when using the printer while riding a minecart it constantly kicks me out of the cart. Do you know why this happens? Is there an easy fix to the problem?


    There is not. The printer uses shift+right click to place blocks, which is most likely why you're getting kicked out.
    Quote from claydog12312»

    When I am on a multiplayer server my schematics dont load.


    The server most likely disabled Schematica if it works fine in SP.
    Posted in: Minecraft Mods
  • 0

    posted a message on Schematica
    Quote from MeWoodster»

    I don't mean "I don't care" as in make a public release for it, I just want to know if it's possible for me. Is there anything I can do to make it printer water in the 1.8 version without completely rewriting the code :)?.


    My friend did it using Eclipse, by editing one of the classes rather than one of the configuration files you are talking about.


    My suggestion then is to ask your friend to modify the source to add the use of buckets to the printer.
    Posted in: Minecraft Mods
  • 0

    posted a message on Schematica
    Quote from AnrDaemon»

    If that's the only problem, can it show but not place liquids? Would help solve the problem gracefully.


    It should show the liquids like any other block? Last time when I checked liquids worked fine.
    Quote from MeWoodster»

    That part is not a problem for me. All I need it to do is place water and lava where I want it to. I don't care if it's placed too early, I just want it done. A friend of mine said he got it to place water by adjusting a few things in the files some time ago, but he deleted the working version. Any idea what to edit to make it printer water?


    You don't care, but most of the other people would care. In addition to accidental liquid spills this opens up even more "tools" to server griefers. I don't have the time nor will to deal with the potential uproar that might happen because of that.

    It may have been possible in the versions before 1.7 (before block states were introduced), when every single block was "hardcoded" into a few configuration files.

    You can't edit the files in the latest version.
    Posted in: Minecraft Mods
  • 0

    posted a message on Schematica
    Quote from MeWoodster»

    Why not, if I may ask?


    Placing lava/water too early anywhere could result in really bad scenarios (redstone build, wooden builds etc).
    Posted in: Minecraft Mods
  • 0

    posted a message on Schematica
    Quote from MeWoodster»

    Just trying to find a workaround to printer water, mr. Grumpy.


    There won't be any kind of support for liquids for the foreseeable future.
    Posted in: Minecraft Mods
  • 0

    posted a message on Schematica
    Quote from winwinner»

    help you know the double stone slab with the seamless tag it places the ones with the seems and it destroys it afterwards can you fix it so either you make it so that it places seamless or it doesn't at all?


    It shouldn't be ignoring the seamless tag. Are you sure that it's picking and placing the wrong block type? Also what's the Minecraft / Forge / Schematica version?
    Quote from RepoDraghon»

    Oh, hey, I have a small bug/issue/could be fixed on my end, with anything that operates like a door... if I make a building then place a door and NOT close it when I go through then copy the design, the printer freaks out and places and deleted the door a billion times...


    It's a known issue and there is no easy way to fix it other than disabling block breaking in creative mode. The same thing will happen with any other block that can have multiple states, like repeaters, redstone, trapdoors etc.
    Posted in: Minecraft Mods
  • 0

    posted a message on Schematica
    Quote from Calrissian»

    Hi there. I think something is not working as it should. I have saved bigger schematics (like 10*10 chunks area, but also smaller ones) with Schematica on a server. but the shematics are missing some chunks that is suposed to be filled with blocks when I sooner paste it in with the mod or with MCEdit.


    Do you know why not all chunks I have marked does not save? (it says succyfully saved when I press the SAVE-button though)

    Is there a limit only for servers how many chunks you can save? Because it seems to work fine in Singleplayer.


    There is no way to get blocks outside the chunk render distance on servers. Entire chunks are missing from the final schematic.
    Posted in: Minecraft Mods
  • 0

    posted a message on Schematica
    Quote from Kyezif»

    Is it possible to have this mod downloaded without Forge, because I have seen others use this mod while only using Optifine. Is that even possible.



    I'm afraid that forge or optifine may affect the game mechanics (Optifine lowers mob spawns, unload spawn chunks, etc.)




    SO is there any actually way to download this in a vanilla world. (Singleplayer)



    Thanks


    Forge is required, it provides the necessary hooks for the mod.
    Posted in: Minecraft Mods
  • 1

    posted a message on Schematica
    Quote from Sticky_»

    Hello, thanks for the mod it is great!

    I have a question about the replace command.

    Is it possible to use item id numbers to identify the blocks as I am having issues with mobbed blocks that have the same name tag i guess you would say.

    For example i want to replace gravel with some cyan concrete road from chisel but the way the blocks identified is the same as several other blocks.


    chisel:concrete_cyan1

    this covers a few different blocks and when you use that it picks the first one in the list with 0 meta data i assume.

    this happens with tconstrct:brownstone too as there are several different ones of those too as well as many other modded blocks.


    This may be easy and I just dont know how to use item id's already :D


    I felt like i should add this question in as well just in case the rest didn't make sense

    How do i find out the properties of a block or whats possible such as minecraft:glass

    how do i find out what different properties there are for different blocks


    But just incase and to be clear what im asking is it possible to do something like

    /schematicaReplace 7495:3 3436:2

    using item id and meta data


    again thanks for the mod great work


    Using IDs no longer works. You should use the block state properties instead, you can find them on the debug overlay (F3) menu, on the right side.
    Quote from RepoDraghon»

    Has anyone tried this with Chisel & Bits? Does it save properly?


    It worked when C&B was first released, if the API hasn't changed a lot it should still work (except for the printer).
    Posted in: Minecraft Mods
  • 0

    posted a message on Schematica
    Quote from WolfGangSen»


    I don't think he wants a bypass.

    What I think he means is a feature I have kind of wished for myself.

    Instead of working on all blocks in range, just check what block the user is looking at, and its face, to work out which block they would be placing, and if that is a block in the blueprint , place it.

    This much more accuratly simulates regular minecraft play. And isn't bypassing any "security / anti-cheat" it is just obeying their rules.


    The printer as it is right now doesn't support for such a thing anyway (without hardcoding even more stuff). I barely have the time to keep the mod up to date and I don't really feel like investing time into such a workaround when I could spend my time on things that need more attention.
    Posted in: Minecraft Mods
  • 0

    posted a message on Schematica

    So as of a couple days ago, no schematics will load. I'm not getting any form of error, no crashing, nothing. I open schematica, like I've done a hundred times, on the same server I've always been on, andall of a sudden the Schematica mod wont work right.I open the schematic list, open the schematic I want, and then press the load button, but it literally does nothing. No schematic pops up, nothing happens at all.


    Is there a video setting that got messed up on my laptop? What could possibly cause schematica to literally do nothing? The mod works like it always did, I can open the Schematic List, I can open the Schematic Editor part, where you can change the xyz coords, but the Editor part is completely blacked out like it is when NO schematic is loaded. Anyideas?


    Test in singleplayer. The server owner might have disabled the mod.
    Posted in: Minecraft Mods
  • 0

    posted a message on Schematica
    Quote from 8ZAvemanXD»

    I've recently had an issue while viewing materials needed for a blaze grinder. Here is what I got:

    The game crashed whilst rendering screen
    Error: java.lang.NullPointerException: Rendering screen


    I've found the issue. The build had saved a spawner and when I went to look at the materials, it crashed as one of the materials was a spawner.


    Can you post the entire crash log?
    Posted in: Minecraft Mods
  • 0

    posted a message on Schematica
    Quote from MY_DOOD»

    schematic its not targeting the blocks I am looking, therefore, by targeting the blocks I am not looking at, the anti-cheat stops the placement, and it messes with both (2) lines of carpets, and making the mod useless, adding a "trigger bot" option for placement would be great, as long as it did got stopped by the anti-cheat as often


    There's little benefit to adding a bypass for security/anti-cheat plugins. Even though Schematica is not intended for cheating it may be seen as such by some server owners.
    Quote from 8ZAvemanXD»

    Yeah, I copy pasted some stuff over into it with world edit. Besides that the only mods I'm using with forge are yours, world edit, and optifine.


    Did you use the new structural void block by any chance? That block is considered as air.
    Posted in: Minecraft Mods
  • 0

    posted a message on Schematica
    Quote from 8ZAvemanXD»

    I had an issue when reviewing the materials it populated a list of 'Air' with 0/1 and that has never happened to me before. The only thing I could think of that could have affected it is that it was a build I had copy-pasted with world edit. Are there any fixes for this?


    Was it a modded world?
    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.