All users will need to merge their Minecraft Forum account with a new or existing Twitch account starting October 23rd. You can merge your accounts by clicking here. Have questions? Learn more here.
Dismiss
  • 0

    posted a message on |URGENT| Eclipse Modding Returns java.lang.RuntimeException upon Client Startup

    Hello! I have been working on a mod for some time now, and I had just finished the code for a custom Creative Tab for my mod when the client started to crash. Reverting back to the old code had no effect, something else must have happened. If someone could debug this log I would be very grateful.


    ---- Minecraft Crash Report ----
    // On the bright side, I bought you a teddy bear!

    Time: 8/28/17 3:36 PM
    Description: There was a severe problem during mod loading that has caused the game to fail

    net.minecraftforge.fml.common.LoaderExceptionModCrash: Caught exception from null (mwab)
    Caused by: java.lang.RuntimeException
    at net.minecraftforge.fml.common.LoadController.buildModObjectList(LoadController.java:289)
    at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:225)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:91)
    at com.google.common.eventbus.Subscriber$SynchronizedSubscriber.invokeSubscriberMethod(Subscriber.java:150)
    at com.google.common.eventbus.Subscriber$1.run(Subscriber.java:76)
    at com.google.common.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:399)
    at com.google.common.eventbus.Subscriber.dispatchEvent(Subscriber.java:71)
    at com.google.common.eventbus.Dispatcher$PerThreadQueuedDispatcher.dispatch(Dispatcher.java:116)
    at com.google.common.eventbus.EventBus.post(EventBus.java:217)
    at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:148)
    at net.minecraftforge.fml.common.Loader.preinitializeMods(Loader.java:604)
    at net.minecraftforge.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:266)
    at net.minecraft.client.Minecraft.init(Minecraft.java:508)
    at net.minecraft.client.Minecraft.run(Minecraft.java:416)
    at net.minecraft.client.main.Main.main(Main.java:118)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97)
    at GradleStart.main(GradleStart.java:26)


    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------

    -- System Details --
    Details:
    Minecraft Version: 1.12.1
    Operating System: Windows 10 (amd64) version 10.0
    Java Version: 1.8.0_144, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 792071296 bytes (755 MB) / 1037959168 bytes (989 MB) up to 1037959168 bytes (989 MB)
    JVM Flags: 3 total; -Xincgc -Xmx1024M -Xms1024M
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    FML: MCP 9.41 Powered by Forge 14.22.0.2463 5 mods loaded, 5 mods active
    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored

    | State | ID | Version | Source | Signature |
    |:----- |:--------- |:------------- |:-------------------------------- |:--------- |
    | U | minecraft | 1.12.1 | minecraft.jar | None |
    | U | mcp | 9.19 | minecraft.jar | None |
    | U | FML | 8.0.99.99 | forgeSrc-1.12.1-14.22.0.2463.jar | None |
    | U | forge | 14.22.0.2463 | forgeSrc-1.12.1-14.22.0.2463.jar | None |
    | U | mwab | 0.1 - MC 1.12 | bin | None |

    Loaded coremods (and transformers):
    GL info: ' Vendor: 'NVIDIA Corporation' Version: '4.5.0 NVIDIA 385.41' Renderer: 'GeForce GTX 750 Ti/PCIe/SSE2'

    I an so very lost as to why this isn't working, because I followed the modding tutorials to the letter! Anyways, thanks in advance for any help!

    -LordOfTheBlocks_

    Posted in: Modification Development
  • 0

    posted a message on Singleplayer Crash when tessellating Thaumcraft Mana Pods

    Hello, all!

    I have a user who is playing my modpack on Curse, and his game crashes whenever he loads/creates a singleplayer world. It seems his game can't handle tessellating a Thaumcraft Mana Pod, as seen on his crash report (Crash Report).

    I told him to remove all Mana Pods in MC Edit, and that worked.... But when he generated new chunks, the same thing happened.

    I don't understand why this is occurring for him, because we had a server with the same modpack, and it worked just fine—I even played singleplayer, no problem.

    Anyways, if anyone has an answer, I'd be grateful, I wanna help this guy out. :)

    Thanks!

    -LordOfTheBlocks_

    Posted in: Modded Client Support
  • 0

    posted a message on TARDIS Mod [Updated to v0.994 on 25/12/2015]

    Ok, so can anyone tell me if they are getting this problem? Usually, the TARDIS behaves fine, but it seems that whenever I try to dye the walls or make any custom changes, the whole singleplayer world corrupts. For instance, I colored my TARDIS interior to look like the 11th's 2nd TARDIS, and it looked cool, but then I couldn't do anything on the console—couldn't pull levers or push buttons—and I couldn't get out of the TARIDS. Also, when I try to exit the singleplayer world, it just says "Shutting down internal server...." forever—I left it for half an hour and it still said the same thing. I am currently running version 0.995, on my modpack ACEMC Infinity.

    If anyone is having these issues and knows a fix, I'd be very grateful.

    Thanks!

    Posted in: Minecraft Mods
  • 0

    posted a message on Minecraft Curse Client will not start packs
    Quote from DragonLevain»

    It is the same problem caused by Nvidia version 378.49
    Have you installed the previous version 376.33?


    That could also be the problem. I know when I updated to the latest NVidia graphics driver, it broke my game, so I rolledback one version and it works fine.
    Also, if you have an "!" in the profile name, that breaks java---found that out the hard way. ;)
    Posted in: Modded Client Support
  • 0

    posted a message on Curse Client crashes upon launch.
    Quote from youngtomlin»

    If it works fine, they crack on playing. Have any problems, then a mod list would be great.

    Actually, I am a genius. For SOME WEIRD REASON, when I took the exclamation mark off of the end of the profile name, it ALL WORKS. IDK why having an exclamation mark would mess up the launcher, but it did, and it WORKS, so thanks for your time! :D
    Posted in: Modded Client Support
  • 0

    posted a message on Curse Client crashes upon launch.
    Quote from youngtomlin»

    Post your mods list please.


    Ok, so I copied the mods to a new profile and it boots just fine... Any thoughts? Should I still sent a mod list?
    Posted in: Modded Client Support
  • 0

    posted a message on Curse Client crashes upon launch.

    \/

    Posted in: Modded Client Support
  • 0

    posted a message on Minecraft shut down inappropriately. Won't launch.

    Is there a log or crash report? If so, post it to gist.github or something similar. Also, are you running the regular old Minecraft launcher, or are you using a launcher like Technic or Curse?

    Posted in: Modded Client Support
  • 0

    posted a message on Minecraft Curse Client will not start packs

    Are you hosting your Minecraft files on OneDrive? There's a lot of code, but your directory was in the OneDrive folder. Try hosting your files directly on your computer (eg. C/Users/YOU/Documents/Curse/Minecraft/blahblahblah). I'm no expert at debugging, but see if that works. :)

    Trust me, I've been fighting the same thing for 2 days, but my errors are different than yours.

    Posted in: Modded Client Support
  • 0

    posted a message on Curse Client crashes upon launch.

    Hello!

    I am playing on the Curse client, and I uploaded a modpack, which was approved, and when I downloaded the modpack and tried to play it, the game wouldn't even start. No crash reports... Blank logs.... Here's what the launcher returned: Game Output

    Anyone have any ideas? I can see that something is wrong with CodeChickenCore, but nothing I do fixes it.

    Also, all of my mods are for 1.7.10; I've checked the folder many times to make sure.

    Any help would be appreciated, thanks!


    Here's a link to the modpack if you want to try it yourself: ACEMC Infinity

    Posted in: Modded Client Support
  • 0

    posted a message on Reocurring Crashes with no apparent cause.

    Wow, that worked, thanks!!!!

    Posted in: Modded Client Support
  • 0

    posted a message on Reocurring Crashes with no apparent cause.

    Hello! I've had a SICKENING that's S-I-C-K-E-N-I-N-G amount of crashes in the last day, but at the end of the error log, it usually gives hints as to what mod is erroring. (FYI, the game loads fine, but crashes whenever I try to load/create a singleplayer world) Can anyone debug this crash report??

    Semi-Obvious crash report --- Crash report I can't figure out

    If anyone can figure this out, I'd be very grateful. Also, sorry if this is in the wrong section, I wasn't sure where to put it.

    Thanks!!

    Posted in: Modded Client Support
  • 0

    posted a message on TARDIS Mod [Updated to v0.994 on 25/12/2015]

    Ok, thanks! I'll try it ASAP! ;)

    Posted in: Minecraft Mods
  • 0

    posted a message on Reoccurring crashes that I can't diagnose

    Unfortunately no. Also, I'm sorry, I wasn't sure where to put it.

    Posted in: Modded Client Support
  • 0

    posted a message on TARDIS Mod [Updated to v0.994 on 25/12/2015]

    If you go to the lower level of the console room, one of the sides has a panel with a slot for the sonic. Put the sonic into the slot and press the button. You can change between the tenth, eleventh, or fourth Doctor's screwdrivers in this way (simply remove the sonic when it is the design you want).

    Enjoy!


    Thank you! I had actually figured this out after I posted the comment, but was too lazy to edit the post. XD
    By the way, do you know how to change consoles? I looked around on the bottom, but didn't see anything that worked.

    Posted in: Minecraft Mods
  • To post a comment, please or register a new account.