• 0

    posted a message on Having a LAN Server
    Bump, i have the same problem
    http://www.minecraft.net/play.jsp?ip=17 ... rride=true
    and
    http://www.minecraft.net/play.jsp?ip=17 ... port=25560

    Gives me login failed
    Do i need to forward or edit a host somewhere so i can login from 172.19.3.3 on 172.19.3.4.
    I see my self popup in the logs but somehow my login fails.
    Posted in: Classic - Creative Mode
  • 0

    posted a message on [Software] ZenCraft - Optimized Bukkit Without Java [1.3_01]
    Quote from QQCucumber »
    Quote from Anoniempje »
    Quote from QQCucumber »
    Okay, with help from SynMonger, I was able to get it working. The only problem is, all the plugins I'm using that use SQLite databases started throwing errors (LWC, iConomy, Persistence). Everything else seemed to work fine though. Is there any way around this issue?

    Here's one of the errors:
    2011-03-15 04:57:16 [SEVERE] A type load exception has occurred. loading iConomy v4.4 (Is it up to date?)
    System.TypeLoadException: A type load exception has occurred.
      at java.sql.DriverManager.getConnection (System.String , java.util.Properties , java.lang.ClassLoader ) [0x00000] in <filename unknown>:0 
      at java.sql.DriverManager.getConnection (System.String url, ikvm.internal.CallerID ) [0x00000] in <filename unknown>:0 
      at com.nijiko.coelho.iConomy.net.iDatabase..ctor () [0x00000] in <filename unknown>:0 
      at com.nijiko.coelho.iConomy.iConomy.onEnable () [0x00000] in <filename unknown>:0 
    	at java.sql.DriverManager.getConnection(DriverManager.java:591)
    	at java.sql.DriverManager.getConnection(DriverManager.java:220)
    	at com.nijiko.coelho.iConomy.net.iDatabase.<init>(iDatabase.java:15)
    	at com.nijiko.coelho.iConomy.iConomy.onEnable(iConomy.java:71)
    	at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:76)
    	at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:55)
    	at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:201)
    	at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:143)
    	at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:73)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    	at java.lang.Thread.threadProc(Thread.java:2297)
    	at java.lang.Thread$1.Invoke(Thread.java:796)
    	at cli.System.Threading.Thread.StartUnsafe(Unknown Source)


    Again, anything not using SQLite is working fine.

    Odd, LWC is running fine here, had my 493 server running overnight. hardly noticalbe.
    Did you try fresh or over an old server?

    I did not start fresh. What OS are you using? I'm using Linux so there may be some discrepancy there.

    W7 64 bit
    Posted in: Server Administration
  • 0

    posted a message on [Software] ZenCraft - Optimized Bukkit Without Java [1.3_01]
    Quote from QQCucumber »
    Okay, with help from SynMonger, I was able to get it working. The only problem is, all the plugins I'm using that use SQLite databases started throwing errors (LWC, iConomy, Persistence). Everything else seemed to work fine though. Is there any way around this issue?

    Here's one of the errors:
    2011-03-15 04:57:16 [SEVERE] A type load exception has occurred. loading iConomy v4.4 (Is it up to date?)
    System.TypeLoadException: A type load exception has occurred.
      at java.sql.DriverManager.getConnection (System.String , java.util.Properties , java.lang.ClassLoader ) [0x00000] in <filename unknown>:0 
      at java.sql.DriverManager.getConnection (System.String url, ikvm.internal.CallerID ) [0x00000] in <filename unknown>:0 
      at com.nijiko.coelho.iConomy.net.iDatabase..ctor () [0x00000] in <filename unknown>:0 
      at com.nijiko.coelho.iConomy.iConomy.onEnable () [0x00000] in <filename unknown>:0 
    	at java.sql.DriverManager.getConnection(DriverManager.java:591)
    	at java.sql.DriverManager.getConnection(DriverManager.java:220)
    	at com.nijiko.coelho.iConomy.net.iDatabase.<init>(iDatabase.java:15)
    	at com.nijiko.coelho.iConomy.iConomy.onEnable(iConomy.java:71)
    	at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:76)
    	at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:55)
    	at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:201)
    	at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:143)
    	at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:73)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    	at java.lang.Thread.threadProc(Thread.java:2297)
    	at java.lang.Thread$1.Invoke(Thread.java:796)
    	at cli.System.Threading.Thread.StartUnsafe(Unknown Source)


    Again, anything not using SQLite is working fine.

    Odd, LWC is running fine here, had my 493 server running overnight. hardly noticalbe.
    Did you try fresh or over an old server?
    Posted in: Server Administration
  • 0

    posted a message on [Software] ZenCraft - Optimized Bukkit Without Java [1.3_01]
    Quote from iamjagman »
    When I open the zip file it makes a cpkg file that makes a zip file that makes a cpkg and it just keeps going.

    WTF? What am I supposed to do?

    Try making your own :smile.gif:
    i just did because there wasnt a 493 version.

    Also, suprisingly easy
    Go to http://ikvm.net/
    Download.
    Once extracted the BIn and the bin_XXX files in one dir
    Download the craftbukkit.jar of choice
    then open a command screen.
    ikvmc craftbukkit.jar

    Creats a craftbukkit.exe you can use like a real jar file

    I did run in some problems with the plugins but once i moved to groupmanager i chat stopped working and when i updated that, it all worked rather well. Ran it over night, no problems. see how well it fares today to see if i might keep on using it.
    Posted in: Server Administration
  • 0

    posted a message on [Software] ZenCraft - Optimized Bukkit Without Java [1.3_01]
    Quote from QQCucumber »
    I'm a Linux newbie running my server on a VPS hosting service using CentOS, so I'd appreciate if anyone could tell me how to install the dependencies this needs to work. Thanks.


    Click the notch :wink.gif:
    :iapprove:
    Posted in: Server Administration
  • 0

    posted a message on [Software] ZenCraft - Optimized Bukkit Without Java [1.3_01]
    I have WIndows 7 and 64 bit system
    I made a new folder and extracted the ZIP in the OP there.
    I ran it and it gave me the error
    I checked out the site in the OP and found a download with several files
    I noticed that there was a map named bin_x64 and wondered if the 32bit/64bit was an issue; Since phonic asked about it. I took a shot and extracted that bin_x64 folder and saw that two files there were the same as the two files in the zip.
    I copied the two dll files from the bin_x64 folder to the Zencraft folder and overwrote the old ones.

    Then I double clicked craftbukkit.exe. Noticed it started a clean 513 server with errors that it could not find lists and settings. Made sense since that happens with a clean install. I stopped the server, made my self op, changed the port. and started again. No errors. I connected, it was a pretty world, nice and flat, would make a great spawn.
    Sucks that there are some plugins that I need, that don't work with 513. So that is where my quest ended.

    I came here to ask for a 493 version and saw your question. I hope i answered it.

    Plus hereby my request for a 493 version.
    Posted in: Server Administration
  • 0

    posted a message on [Software] ZenCraft - Optimized Bukkit Without Java [1.3_01]


    Fixed it :smile.gif:
    Quite easy,
    I downloaded http://www.ikvm.net/download.html and then grabbed the dll files from the bin_x64 dir and used them to replace the files that came in the zip. It runs now.

    Phonic, how did you get those pretty graphs?
    Posted in: Server Administration
  • 0

    posted a message on [Software] ZenCraft - Optimized Bukkit Without Java [1.3_01]
    Quote from PhonicUK »
    Anoniempje, Do you have a 32 or 64-bit machine + OS?

    64 w7
    Posted in: Server Administration
  • 0

    posted a message on [REQ] Grab paintings from URL
    Hi, I would like to have a mod that will download and replace the current kz.png in the many different texture packs my players have from an external source every so often/login.

    That way as an admin i can keep players updated with the latest banners and server map in paintings. Also update ads and player of the month :smile.gif:

    Instead of having to download the kz.png and packing them in their own texture pack I'd like to cut out a few steps and have the file update itself. Which talent can pull this off?
    Posted in: Mods Discussion
  • 0

    posted a message on [1.3.1] GLSL Shaders (DoF, Bump Mapping, Waving Wheat, Dynamic Shadows, and More!)
    Damn you ati powered laptop!
    Posted in: Minecraft Mods
  • 0

    posted a message on [Server] MCLawl! Not crappy anymore!
    Bump to first page for request acknowledgement :smile.gif:
    Posted in: Server Administration
  • 0

    posted a message on [Server] MCLawl! Not crappy anymore!
    I have disabled restart on error. but it still restarts :sad.gif:
    Can you update the dont restart on error to work with the new restart on error?


    ----19-11-2010 20:37:12 ----
    Type: InvalidOperationException
    Source: mscorlib
    Message: Collection was modified; enumeration operation may not execute.
    Target: ThrowInvalidOperationException
    Trace: at System.ThrowHelper.ThrowInvalidOperationException(ExceptionResource resource)
    at MCLawl.Server.<Start>b__9()
    at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
    at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
    at System.Threading.ThreadHelper.ThreadStart()

    -------------------------
    the others are in use port errors because the crashing does not close the ports. Worst case, a full computer reboot to close the ports any way.
    Posted in: Server Administration
  • 0

    posted a message on InvCheck - Check your players inventories - Updated: 1st Nov
    Love it :smile.gif:

    I caught a few cheaters :smile.gif:
    Warned them
    They got scared and threw the items in lava.
    THe fact that i have this makes it so that i hardly have to use it :smile.gif:
    its like logblock the act of having it makes it useless to have it.
    Posted in: Alpha - Survival Multiplayer Discussion
  • 0

    posted a message on Lock this thread (hMod thread)
    I just renamed the existing world, let it make a new one and place a sign that said:
    I know, stfu
    be patient
    -Ano

    As the first thing they see :smile.gif:
    Posted in: Server Administration
  • To post a comment, please or register a new account.