accelerated OpenGL mode

  • #21
    Ok, this is REALLY PISSING ME OFF.

    I had the same issue as the OP. I tried to update my drivers, but all the auto-update programs failed when trying to scan my device. I tried both of the CMD -jar run things, both just caused the Command Prompt to flash. I tried finding a slider to adjust my settings, but my computer says
    Your current display driver does not allow changes to be made to hardware acceleration settings


    In short, I cannot play mincraft alpha, and I'm quite angry that I paid for something that does not work.

    I have a Toshiba satellite A105-s2236, running windows Vista 32-bit, with an "ATI Radon Xpress 200m series" video card.
  • #22
    I have the similar problem, and I'm using the family laptop at the moment. I don't want to start playing with the minecraft executeable because I'm running the program off of an external hard drive at the moment and don't want to mess it up for my other computer.

    I went through the settings and checked that hardware acceleration is set to full, so that's not the problem. I don't have much else to contribute except this isn't the first problem I've had with laptop graphic cards and their drivers. They seem to be like some sort of entirely different animals and their drivers are horribly limited. With my personal laptop [which can start Minecraft with 5 year old drivers] there ARE no more updates. Manufacturer simply says they won't update it anymore.


    EDIT: Got the game to run in browser for some odd reason. Runs perfectly fine [except for unholy lag because this computer can't handle it.] Well, so much for that escape from "family movie night".
    Why can't things be simple?
  • #23
    i am confused in laptop works in computer not and i try al of your sujestons some not i need t playyy i want craft :Flint: :GP: :GoldBar: :Iron: 29 :Diamond: for the person who helps me (and work) and some :--+: and a :chestfront: and a secret
  • #24
    Quote from luckyseth »
    HELP ME TOO I HAVE NO IDEA ON WHAT TO DO ARRGH I WAS ABLE TO PLAY IT FOR ABOUT A WEEK THEN I HAD TO GET A NEW HARD DRIVE (CORRUPT) AND NOW IT DOESN'T WORK! (IM GONNA CRY) NOT EVEN CLASSIC! RAAAAAAAAAAAAAAAAAAAAAAAAAAGE!!!!!!! :VV: :VV: :VV: :VV: :VV:

    rarararrarara you are funny :iapprove:
  • #25
    Quote from naisanza »
    Quote from TheGuardian001 »

    That was the non-tech savvy version. Just type the command (java -Xmx800M -jar "LOCATION_OF_MINECRAFT_HERE") into cmd (start->run->cmd).


    THANK YOU SO MUCH. THIS HELPED. I can now show my girlfriend the world I created. Now she knows what I've been doing all winter break long.

    I do this and apear Unercognnizaded opition-jarC:/Documents
    Could not create the Java virtual machine wat i do if works i will tell you my secret
  • #26
    ok... I am frustrated beyond beliefe... several people have said this already and no one is offering any solutions... just posting the same thing over and over. I have tried renaming and moving the Mincraft.exe file as Mincraft.jar and I put it in the cmd prompt several different ways (just to make sure I wasnt putting it in wrong) but each time it says "Unable to access jarfile 'blah blah blah'" I would like to hear from someone who works directly with those behind the programming or running of minecraft, however, I suppose thats not really an option around here. Again, I already tried renaming and moving the file, it simply didnt work. are there any other ideas? I am really believing that Minecraft is simply not compatible with intel... however, different from before, I used to be able to play minecraft just fine in browser, then I downloaded the new update and it stopped working. I am kind of pissed that I paid for something that doesnt work... that requires so much hassle, and that didnt bother to mention that it was nearly incompatible with intel products.
  • #27
    I have tried literally all of these fixes, one of them flat out does not work for me, one just flashes a cmd prompt then closes very quickly, changing the acceleration did nothing as well, i have a dell demnsion 3000, intel intergrated graphocs controller 82865g, i was playing just a few days ago and it sprung this on me
  • #28
    I figured out the flashing command from the file, you labeled Minecraft.jar as the name of the game, but when I changed it it changed to Minecraft.jar.exe

    When I changed the name to imput into cmd from Minecraft.jar to Minecraft.jar.exe, the command accepted it, and the whole thing flickered lines passed, and the game opened, but I still got the same message :'(

    *edit: so if it does flash for a split second, you messed up somewhere in the path. It could be the path to the game, such as C:\Users\Yourname\Desktop\.. or the name of the game ..Minecraft.jar.exe as explained above.
  • #29
    Quote from deadbOlt »
    There is a very simple fix that worked for me without needing to type anything in a command line.

    1. Right click on your desktop, somewhere empty

    2. Click on 'Properties' (or just navigate to your Display Properties window in Control Panel)

    3. Click 'Settings'

    4. At the bottom right of the window that pops up is a tab titled 'Advanced' <---- click this tab

    5. One of the tab options at the top of the window will be 'Troubleshoot' <---- click this tab

    6. Now you will see 'Hardware acceleration and a slider bar that says 'None' on the left and 'Full' on the right.

    7. You need to move the slider bar to just about the middle spot. For me it was the point just left of the middle that allowed it to work for me.

    8. Click 'Apply'

    9. Now go play Minecraft.


    My laptop had this issue and I was able to get it running (pretty low fps) with this method. My laptop has an integrated Intel GMA950 graphics chipset.

    Hope this helps.



    I have been playing Minecraft for a couple months through the browser because I couldn't get my computer to work right, but THANK YOU for finding a solution! I thought my graphics card was just to poor to play it (even though I could play through Chrome) but your method works beautifully!

    Thanks! :Diamond: :Diamond:
  • #30
    Quote from im_bad_at_n »
    I figured out the flashing command from the file, you labeled Minecraft.jar as the name of the game, but when I changed it it changed to Minecraft.jar.exe

    When I changed the name to imput into cmd from Minecraft.jar to Minecraft.jar.exe, the command accepted it, and the whole thing flickered lines passed, and the game opened, but I still got the same message :'(

    *edit: so if it does flash for a split second, you messed up somewhere in the path. It could be the path to the game, such as C:\Users\Yourname\Desktop\.. or the name of the game ..Minecraft.jar.exe as explained above.



    I've got some tips for you guys who are renaming .exe files to look like .jar files. .exe is a Windows application (program etc) that you can run directly by double clicking on it. If you download the "Windows" version of Minecraft, this is what you should be getting.

    So what, you may ask, 1.) what is a .jar file, and 2.) why should you rename your .exe file to be .jar?

    Well, a .jar file is a java application which does not run on your windows machine (your pc), but it does run on a java machine. You happen to be in luck, because in order to play minecraft, you must already have the java virtual machine (a software program which can read and understand .jar files) installed on your pc, which means your pc can also run .jar files as if they are .exe files. This is a FIRST point of failure for some of you. Make totally certain that you have the JRE (java runtime environment) installed, before you complain. If you don't, it wont hurt to "google" Java Runtime. Odds are, your properly working Minecraft installer will make sure Java works on its own (if you downloaded the .exe).

    The reason you were misinformed into renaming your .exe file into a .jar file is that there IS a minecraft.jar file that you can use in place of the .exe file, and some previous poster probably had the poor misfortune of not knowing how to correctly RUN a .jar file with the Java Runtime Environment, so they then renamed the .jar file to .exe hoping it would run like all of their normal Windows applications. Days of smashing their head against the wall later, this same person renamed it back, but this time managed to get it to run as a Java application through the JRE. That is likely how people would get the idea that .jar and .exe can be renamed to eachother. Nothing can ever be more ridiculous. If you are interested in what can be renamed, sometimes a .jar gets downloaded incorrectly as a .zip, and can then be renamed to .jar and be run with the JRE. But that's neither here nor there.

    Well, since you can't rename your .jar to .exe, and your original and true Minecraft.exe that was never renamed still opens but doesn't work properly, the tip I have for you is that even the .exe file is really just some windows code that runs the .jar file behind your back. This is useful to know because Minecraft has memory allocation issues that cause it to crash with a black screen when the Java memory manage doesn't give Minecraft the memory it wants, when it wants it. Maybe I'm way off base here, but I've "fixed" my Minecraft many times by increasing the memory Java was willing to give Minecraft, and that can be done on the commandline (like in cmd, a shortcut or batch script), but probably only if you have the true Java version of minecraft, without the silly .exe code wrapped around it. To get that, redownload the linux version of minecraft ONTO YOUR WINDOWS MACHINE, despite that it isn't for WINDOWS. The reason this will help you is that Java programs on Windows are the same exact thing as Java programs on Linux, cause neither Windows nor Linux can run Java programs and instead, both rely on their resctive JREs to do that for them! Once your Linux version of Minecraft.jar is downloaded, you can do what andubadea or TheGuardian001 or adiktuz said to do and make a .bat file that contains the following text, and put it RIGHT NEXT TO the MINECRAFT.JAR file : java -Xmx800M -Xms2046M -jar Minecraft.jar

    Another thing you can do is make a shortcut to the Minecraft.jar, rightclick it, go to Properties, click inside the Target text box in the shortcut properties and scroll all the way to the end of the shortcut and add a space followed by -Xmx2046M -Xms2046M and then click apply and OK and open the shortcut. If this doesn't work, perhaps try different numbers after the Xmx and Xms. I have a modern PC so I want it to use LOTS of memory, so I use Xmx2046. I'm not sure what you can get away with on your PC, but the number better be less than your memory capacity and more than Minecraft needs, and if you use Texture Packs Minecraft can end up using gigs of ram, sadly.

    Lastly, for Leonardo7852, "do this and apear Unercognnizaded opition-jarC:/Documents
    Could not create the Java virtual machine wat i do if works i will tell you my secret" seems to mean that you made some typographic errors in your Java -XmxNUMBER -XmsNUMBER -jar Minecraft.jar script. First mistake is that minecraft.jar is being kept somewhere in Documents and Settings. This path has spaces, which means your have more problems. You can solve these problems by wrapping the path to the .jar file in quotation marks, like so: -jar "C:\Documents and Settings\Leonardo\AppData\.minecraft\minecraft.jar". Another error is you forgot the space between -jar and C:\.

    I'm sure I've made lots of mistakes of my own in this question answer session, but the questions were going unanswered so I figured I would give it a shot. They've actually been answered less verbosely, several times, but in the end a good answer isn't enough for the lowest common denominator, so a I added more. Good luck with one of the world's least tech supported game, with the most bugs and the best glitches. Gameplay in this game is actually governed by glitches. People use glitches as weapons, defenses, and base their strategy around them. WHen a glitch gets fixed, entire worlds need to be redesigned to no longer leverage the power of that beneficial glitch. In a game like this, a few black screens are to be expected. Also try hitting F11 and alt Tab if your PC gets swallowed in a Black Screen of Minecraft.
  • #31
    I typoed. It should have said -Xmx800M -Xms800M, where the numbers for Xmx and Xms match. You can make them different but Xms should be lower, as it's the lower limit of memory that java will give Minecraft, where as Xmx is the upper limit. I'm sure the original tip to just use -Xmx800M would have worked in some cases for some MC configurations due to giving MC more ram.
  • #32
    Keyosuke, thank you for your guide on how to give minecraft more RAM, I dont explicitly need it, but it helps the framerate. I'm also glad you cleared up the .exe/.jar confusion, I was wondering how the two could possibly be interchangeable.

    I was able to fix my black screen and error message by changing the hardware acceleration, try that if you haven't already and are still having problems.
  • #33
    If you have an ATI card and you're getting this error. Please use the Catalyst 9.12 drivers as can be found here.

    http://www.guru3d.com/news/ati-catalyst ... -released/

    I was forced to use a Radeon 1900gt & X800xl for a while and couldn't run Minecraft because of the 'pixel format not accelerated' error. I searched for a couple days and could not find any information on it anywhere that was of use. I finally found out that the Catalyst 10.2 drivers (which are the latest ones) only support opengl 1.1. If you un-install them and install the 9.12's you should be good to go assuming there are no other issues.

    Those goes for all the following ATI cards which use the legacy driver:

    ATI Radeon 9500 Series
    ATI Radeon 9550 Series
    ATI Radeon 9600 Series
    ATI Radeon 9700 Series
    ATI Radeon 9800 Series
    ATI Radeon X300 Series
    ATI Radeon X550 Series
    ATI Radeon X600 Series
    ATI Radeon X700 Series
    ATI Radeon X800 Series
    ATI Radeon X850 Series
    ATI Radeon X1050 Series
    ATI Radeon X1300 Series
    ATI Radeon X1550 Series
    ATI Radeon X1600 Series
    ATI Radeon X1650 Series
    ATI Radeon X1800 Series
    ATI Radeon X1900 Series
    ATI Radeon X1950 Series
    ATI Radeon Xpress Series
    ATI Radeon X1200 Series
    ATI Radeon X1250 Series
    ATI Radeon X2100 Series
  • #34
    =(
    I cant fix this! i need help!

    Mobile Intel 915GM/GMS, 910GML Express Chipset Family


    Bad video card drivers!
    -----------------------

    Minecraft was unable to start because it failed to find an accelerated OpenGL mode.
    This can usually be fixed by updating the video card drivers.



    --- BEGIN ERROR REPORT 7fe0271 --------
    Generated 5/1/11 10:52 AM

    Minecraft: Minecraft Beta 1.5_01
    OS: Windows XP (x86) version 5.1
    Java: 1.6.0_25, Sun Microsystems Inc.
    VM: Java HotSpot(TM) Client VM (mixed mode), Sun Microsystems Inc.
    LWJGL: 2.4.2
    [failed to get system properties (java.lang.NullPointerException)]

    org.lwjgl.LWJGLException: Pixel format not accelerated
    at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
    at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
    at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:185)
    at org.lwjgl.opengl.Display.createWindow(Display.java:311)
    at org.lwjgl.opengl.Display.create(Display.java:856)
    at org.lwjgl.opengl.Display.create(Display.java:784)
    at org.lwjgl.opengl.Display.create(Display.java:765)
    at net.minecraft.client.Minecraft.a(SourceFile:272)
    at net.minecraft.client.Minecraft.run(SourceFile:658)
    at java.lang.Thread.run(Unknown Source)
    --- END ERROR REPORT c1b6fd81 ----------
  • #35
    Quote from deadbOlt »
    There is a very simple fix that worked for me without needing to type anything in a command line.

    1. Right click on your desktop, somewhere empty

    2. Click on 'Properties' (or just navigate to your Display Properties window in Control Panel)

    3. Click 'Settings'

    4. At the bottom right of the window that pops up is a tab titled 'Advanced' <---- click this tab

    5. One of the tab options at the top of the window will be 'Troubleshoot' <---- click this tab

    6. Now you will see 'Hardware acceleration and a slider bar that says 'None' on the left and 'Full' on the right.

    7. You need to move the slider bar to just about the middle spot. For me it was the point just left of the middle that allowed it to work for me.

    8. Click 'Apply'

    9. Now go play Minecraft.


    My laptop had this issue and I was able to get it running (pretty low fps) with this method. My laptop has an integrated Intel GMA950 graphics chipset.

    Hope this helps.


    I LOVE YOU IT WORKS SO WELL!!! <3

    Anyone using a dell with a 915 or whatever card, THIS WILL WORK FOR YOU. (I'm using a dell inspiron 1300, if you're not... Well, it's worth a try anyway! :3 )
  • #36
    Quote from deadbOlt

    There is a very simple fix that worked for me without needing to type anything in a command line.

    1. Right click on your desktop, somewhere empty

    2. Click on 'Properties' (or just navigate to your Display Properties window in Control Panel)

    3. Click 'Settings'

    4. At the bottom right of the window that pops up is a tab titled 'Advanced' <---- click this tab

    5. One of the tab options at the top of the window will be 'Troubleshoot' <---- click this tab

    6. Now you will see 'Hardware acceleration and a slider bar that says 'None' on the left and 'Full' on the right.

    7. You need to move the slider bar to just about the middle spot. For me it was the point just left of the middle that allowed it to work for me.

    8. Click 'Apply'

    9. Now go play Minecraft.


    My laptop had this issue and I was able to get it running (pretty low fps) with this method. My laptop has an integrated Intel GMA950 graphics chipset.

    Hope this helps.

    Thankyou so much!
    This worked perfectly :smile.gif:
    My minecraft still a bit crappy because of my fail ass computer!
    This driver problem made me go you know what ...im saving for a laptop!:L
    Im still going to get one but THANKYOU SO MUCH!
    Im sure many more people will be thanking you :smile.gif:
  • #37
    Sorry, but I tryed all ideas of this topic, and none work for my computer.
    I have an hp EliteBook 6930p.
    My video card drivers, two Mobile Intel(R) 4 Series Express Chipset Family
    are in right.
    I've try the deadbOlt's proposition, but it just flashes.
    Can you help me?
    Thanks!
    Sorry for all the english mistakes I could do cause I'm french and I don't all understand (I don't speak enough good english).
  • #38
    Try to uninstall and reinstall your Minecraft.
  • #39
    Already done.
    Sorry for all the english mistakes I could do cause I'm french and I don't all understand (I don't speak enough good english).
  • #40
    Update your video card drivers
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes