[14w11b / 1.7.10 / 1.7.2 / 1.6.4 and earlier][update 6/27] MCPatcher HD fix 4.3.2_03

  • #1910
    As far as I can tell, the whiskers are gone now with the test version. Haven't found any other issues, Kahr. Thanks btw.
  • #1911
    Whichever pack I use, the custom water/lava doesnt work. It was fine with v2.0.1 but with this one the water and lava 'animations' just stand still.. I deleted .minecraft, patched it again and it just doesnt work. What's the problem?
  • #1912
    Kahr
    How start test patcher 2.1.0_01 ? .... Make please a .exe file
    Thanks
    Last edited by Desanto: 5/28/2011 11:22:38 AM
    Im Russian. I bad know English :(
    Я РУССКИЙ. Я плохо знаю английский, если тут есть русско-язычные помогите с проблемой.
  • #1913
    Quote from Kahr

    Thanks! OP updated again.

    Would a few people try a test version of the patcher and let me know your results? There are fixes for the items-with-whiskers bug and the missing custom items from ModLoader. I'm especially interested if you are having the problem below:


    I have just tried your beta1 patch with 1.6.4 and modloader and it does fix this problem:
    java.lang.NoSuchMethodException: no suitable constructor found
            at com.pclewis.mcpatcher.mod.TextureUtils.newTextureFX(TextureUtils.java:124)
            at com.pclewis.mcpatcher.mod.TextureUtils.registerTextureFX(TextureUtils.java:131)
            at jf.a(SourceFile:373)
            at ModLoader.RegisterAllTextureOverrides(ModLoader.java:1211)
            at ModLoader.OnTick(ModLoader.java:967)
            at EntityRendererProxy.b(EntityRendererProxy.java:15)
            at net.minecraft.client.Minecraft.run(SourceFile:745)
            at java.lang.Thread.run(Unknown Source)


    I'm not sure about the other problem though as I have not seen it here.
  • #1914
    Kahr,

    I'm not sure if it was the 1.6.5 patch or the test version of the patcher, but I got a significant performance hit now. Will test more to see if non-patched has same issues.
  • #1915
    Give me pls patch :sad.gif:
    Im Russian. I bad know English :(
    Я РУССКИЙ. Я плохо знаю английский, если тут есть русско-язычные помогите с проблемой.
  • #1916
    Quote from Desanto

    Give me pls patch :sad.gif:


    The test patcher is up and working. All you have to do is double click it......
    Last edited by Adriorn: 5/28/2011 11:59:44 AM
  • #1917
    Quote from Kahr

    Thanks! OP updated again.

    Would a few people try a test version of the patcher and let me know your results? There are fixes for the items-with-whiskers bug and the missing custom items from ModLoader. I'm especially interested if you are having the problem below:


    I can't check on the white boxes but I can tell you that the "item-with-whiskers" bug seems to be gone now.

    EDIT: Looks like it may be causing issues with the MPMenu extension now.

    java.lang.NullPointerException
    	at mod_MPMenu.OnTickInGame(Unknown Source)
    	at ModLoader.OnTick(ModLoader.java:994)
    	at EntityRendererProxy.b(EntityRendererProxy.java:15)
    	at net.minecraft.client.Minecraft.run(SourceFile:745)
    	at java.lang.Thread.run(Unknown Source)
    Stopping!
    Last edited by shinji257: 5/28/2011 12:34:04 PM
  • #1918
    Quote from Kahr

    Thanks! OP updated again.

    Would a few people try a test version of the patcher and let me know your results? There are fixes for the items-with-whiskers bug and the missing custom items from ModLoader. I'm especially interested if you are having the problem below:


    I can't open LB Photo Realism texturepack after patching with MCPatcher 2.1.0 and 2.1.0_01 beta 1 (I tested both).
    Minecraft runned out of memory!

    Kahr, can you please fix this bug? Even patching Minecraft Beta 1.6.4 doesn't worked for me (Misa's texturepack worked on 1.6.4 but LB Photo Realism doesn't worked :sad.gif:)

    Edit: I used LB Photo Realsim x128 and x256! The x64-Version works after patching. So it has to be a problem with MCPatcher and no with the texturepack devoloper!
    Last edited by ElectroJungle: 5/28/2011 12:40:05 PM
  • #1919
    my LB photrealism pack isnt working in the same manner it usually doesnt work right after a game patch. when switching to the pack in the mods and packs section of the game menu i get a black screen freeze. or if i "test minecraft" via the MCPatcher ill get the following error:





    Minecraft has crashed!
    ----------------------

    Minecraft has stopped running because it encountered a problem.

    If you wish to report this, please copy this entire text and email it to [email protected]
    Please include a description of what you did when the error occured.



    --- BEGIN ERROR REPORT a1dce528 --------
    Generated 5/28/11 1:47 PM

    Minecraft: Minecraft Beta 1.6.5
    OS: Windows Vista (amd64) version 6.0
    Java: 1.6.0_24, Sun Microsystems Inc.
    VM: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Sun Microsystems Inc.
    LWJGL: 2.4.2
    OpenGL: GeForce GTX 470/PCI/SSE2 version 4.0.0, NVIDIA Corporation

    java.nio.BufferOverflowException
    at java.nio.DirectByteBuffer.put(Unknown Source)
    at java.nio.ByteBuffer.put(Unknown Source)
    at jf.a(SourceFile:233)
    at jf.b(SourceFile:139)
    at ka.a(SourceFile:43)
    at cy.a(SourceFile:32)
    at fs.a(SourceFile:142)
    at pt.b(SourceFile:549)
    at net.minecraft.client.Minecraft.run(SourceFile:743)
    at java.lang.Thread.run(Unknown Source)
    --- END ERROR REPORT 752633f2 ----------






    not sure if this is an issue with the MCPatcher or the texture pack. the same thing happened when minecraft 1.6.4 went in but everything was fine after downloading MCPatcher with 1.6.4 compatibility. however, the newest version of the patcher doesnt seem to have the same results for minecraft 1.6.5



    any thoughts?
  • #1920
    Quote from taukarrie

    my LB photrealism pack isnt working in the same manner it usually doesnt work right after a game patch. when switching to the pack in the mods and packs section of the game menu i get a black screen freeze. or if i "test minecraft" via the MCPatcher ill get the following error:





    Minecraft has crashed!
    ----------------------

    Minecraft has stopped running because it encountered a problem.

    If you wish to report this, please copy this entire text and email it to [email protected]
    Please include a description of what you did when the error occured.



    --- BEGIN ERROR REPORT a1dce528 --------
    Generated 5/28/11 1:47 PM

    Minecraft: Minecraft Beta 1.6.5
    OS: Windows Vista (amd64) version 6.0
    Java: 1.6.0_24, Sun Microsystems Inc.
    VM: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Sun Microsystems Inc.
    LWJGL: 2.4.2
    OpenGL: GeForce GTX 470/PCI/SSE2 version 4.0.0, NVIDIA Corporation

    java.nio.BufferOverflowException
    at java.nio.DirectByteBuffer.put(Unknown Source)
    at java.nio.ByteBuffer.put(Unknown Source)
    at jf.a(SourceFile:233)
    at jf.b(SourceFile:139)
    at ka.a(SourceFile:43)
    at cy.a(SourceFile:32)
    at fs.a(SourceFile:142)
    at pt.b(SourceFile:549)
    at net.minecraft.client.Minecraft.run(SourceFile:743)
    at java.lang.Thread.run(Unknown Source)
    --- END ERROR REPORT 752633f2 ----------






    not sure if this is an issue with the MCPatcher or the texture pack. the same thing happened when minecraft 1.6.4 went in but everything was fine after downloading MCPatcher with 1.6.4 compatibility. however, the newest version of the patcher doesnt seem to have the same results for minecraft 1.6.5



    any thoughts?






    apparently if i change the MCPatcher's java heap size to 3072 i seem to be able to run this texture pack jsut fine. must be a memory issue
  • #1921
    Probably a ram allocation issue. I use 64-bit Java and set Minecraft to use 2GB of ram (rather than the default 1GB) and have not had any issues with the x128 and x256 texture packs

    2GB of video ram in the system as well

    I would suspect that high texture sizes would need large amounts of video ram.
    Last edited by shinji257: 5/28/2011 1:12:53 PM
  • #1922
    the test works fine for me with 1gb allocated on 8gb of ram.
    Running a very high end computer and i never had any issues other than the wisker issue while holding items in hand. Wisker issue is now fixed. Thanks!
    Radeon 6950 latest driver (not hotfix though).

    Runing lb realism x256 texture pack fine on 1gb. but i do have 2gb of video memory so i think that is helping a lot.
  • #1923
    Quote from Kahr

    Thanks! OP updated again.

    Would a few people try a test version of the patcher and let me know your results? There are fixes for the items-with-whiskers bug and the missing custom items from ModLoader. I'm especially interested if you are having the problem below:


    So I downloaded and ran the beta patcher after a clean minecraft install, and when I'm not getting the MC out of memory error(which is more often than not) I load my save and still have the white blocks and i read through the output of the patcher and no obvious errors occurred so idk whats happening

    but keep working hard all of us here appreciate your efforts to help us :smile.gif:
    Last edited by CursedFrozenSkull: 5/28/2011 2:02:36 PM
  • #1924
    Quote from shinji257

    Probably a ram allocation issue. I use 64-bit Java and set Minecraft to use 2GB of ram (rather than the default 1GB) and have not had any issues with the x128 and x256 texture packs

    2GB of video ram in the system as well

    I would suspect that high texture sizes would need large amounts of video ram.


    forgive me for my ignorance but how did you do that?
  • #1925

    forgive me for my ignorance but how did you do that?

    "%programfiles%\Java\jre6\bin\javaw.exe" -Xms512m -Xmx2048m -jar "%userprofile%\Desktop\Minecraft.exe"


    -Xms defines the smallest allocation of ram
    -Xmx defines the maximum allocation of ram
    -jar defines the path location to your Minecraft.exe file.

    Usually defined in #m for reference sake here. If you are like me and leave Minecraft.exe on your desktop then the above will do fine. You must have 64-bit java to allocate 2GB to Minecraft.
    Last edited by shinji257: 5/28/2011 2:13:52 PM
  • #1926
    Quote from shinji257

    "%programfiles%\Java\jre6\bin\javaw.exe" -Xms512m -Xmx2048m -jar "%userprofile%\Desktop\Minecraft.exe"


    -Xms defines the smallest allocation of ram
    -Xmx defines the maximum allocation of ram
    -jar defines the path location to your Minecraft.exe file.

    Usually defined in #m for reference sake here. If you are like me and leave Minecraft.exe on your desktop then the above will do fine. You must have 64-bit java to allocate 2GB to Minecraft.


    can i use 64-bit java on my 32-bit machine?
  • #1927

    can i use 64-bit java on my 32-bit machine?


    No. 64-bit code will not run on a 32-bit operating system.
  • #1928
    Quote from taukarrie

    for the time being if i change my MCPatcher's java heap size to 3072 i am able to use the 256 resolution pack just fine. and at heap size 2048 i can only run 64

    apparerntly theres a memory issue with the MCpatcher right now


    Yes, there seems to be a memory issue.
    Please fix that bug, Kahar!
  • #1929
    Quote from shinji257

    No. 64-bit code will not run on a 32-bit operating system.


    k thnx
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes