[14w11b / 1.7.10 / 1.7.2 / 1.6.4 and earlier][update 6/27] MCPatcher HD fix 4.3.2_03

  • #7053
    Quote from Apocalypsing

    I'm still getting the same problem that existed in MCPatcher 2.4.4. The options for mipmapping and water animations are still not changing how the game is patched. I have mipmapping unchecked in the patcher options, and it still gets applied. I also have water animations set to 'Default', since I'm using Faithful 32x32, but they aren't set to default in-game.


    Can confirm with MCPatcher 2.4.4_01.
    Weird behaviour: When starting the minecraft.jar on one PC (Win 7-64, Java 7U9-64) mipmapping is switched off, but when starting the exactly same minecraft.jar on another PC (Win XP, Java 7U9-32) mipmapping is active.
    Switching MipMapping on and off in the options doesn't have any effect, also deleting mcpatcher.xml and starting from scratch doesn't help.
  • #7054
    Quote from Kumasasa

    Can confirm with MCPatcher 2.4.4_01.
    Weird behaviour: When starting the minecraft.jar on one PC (Win 7-64, Java 7U9-64) mipmapping is switched off, but when starting the exactly same minecraft.jar on another PC (Win XP, Java 7U9-32) mipmapping is active.
    Switching MipMapping on and off in the options doesn't have any effect, also deleting mcpatcher.xml and starting from scratch doesn't help.

    Do you have the game installed somewhere besides the default location? Does this happen with both the Test Minecraft button and the normal Minecraft launcher?

    If you use Test Minecraft, you should see this line in the log window:
    MCPatcherUtils v2.4.4_01 initialized. Directory <path>

    <path> is where it is going to look for mcpatcher.xml, so if that's different from where the game actually is, it would explain why it can't find it.

    Then run the the normal launcher from a cmd.exe window (java -jar Minecraft.jar) and look for the same line in that output. Post your results here and I'll see if I can get to the bottom of why this is happening.
  • #7055
    Quote from Kahr

    Do you have the game installed somewhere besides the default location? Does this happen with both the Test Minecraft button and the normal Minecraft launcher?

    If you use Test Minecraft, you should see this line in the log window:
    MCPatcherUtils v2.4.4_01 initialized. Directory <path>

    <path> is where it is going to look for mcpatcher.xml, so if that's different from where the game actually is, it would explain why it can't find it.

    Kahr,

    thanks, you gave the final tip.
    The problem was that there was no mcpatcher.xml on the PC of my wife.
    My default procedure is to patch Minecraft on my PC (thus working) and copy just the minecraft.jar on the PC of my wife.

    I thought up to now that the mcpatcher.xml only stores the settings for the patching process and isn't needed at runtime - lesson learned.

    Thanks a lot !

    Kumasasa
  • #7056
    I have been looking around for an answer to my issue but haven't found one. I recently downloaded a fresh minecraft (wasn't enjoying my modded game anymore), I deleted my minecraft folder and my first plan was to patch my game so I could use my favorite texture packs.

    I opened to fresh minecraft to make sure it worked then closed it. I next downloaded this patcher, following the instructions I patched my game, the log and whatnot said 'Done!' so I assumed it had properly worked. I opened minecraft once again and... nothing. A black screen for ever. Never giving a crash report or anything.

    I was wondering if anyone could give an explanation to this odd result.

    Should I post my Log information?
  • #7057
    Quote from Slytherite

    are you able to check or uncheck them?


    No, that's the problem.
  • #7058
    Quote from rbsanford

    No, that's the problem.

    I use Wolfcraft which is an HD texture pack, and i haven't had any problems. Do you have any mods besides what comes with MCPatcher?
    Wisemen say forgiveness is divine, but never pay full price for late pizza.
  • #7059
    Is the water meant to be non transparent when you go away from it?
    Quote from BlazingWolf731

    I have mcpatcher but when i press patch i let it do it's thing. then i open up minecraft and after i login in the screen is black any help. please i really need it.

    Also if you are still reading please look up on youtube BlazingWolf731 and subscribe

    Why would I subscribe to you? No offence, or anything, but seriously...
  • #7060
    Since 2.4.4 and 2.4.4_01 the screen is stuttering when I move and look around. FPS still the same but it isn't as smooth rendered as before.

    Using MISA.
    Last edited by FreshChris5000: 12/18/2012 6:39:18 AM
  • #7061
    i posted that i have problem with the water but i found that you updated mcpatcher and that fixed it! thanks
    Last edited by David184: 12/18/2012 6:37:09 AM
    Sorry for my bad english
    if you want to tell me something use quote!
  • #7062
    is there anyway to get only Better Skies mod to minecraft cuz I have optifine?
    Hi there
  • #7063
    Quote from Guddi112

    is there anyway to get only Better Skies mod to minecraft cuz I have optifine?

    Just check BetterSkies only :)
  • #7064
    Hi. Not sure if this has been mentioned yet (forgive me if it has), but I've heard quite a few people wondering if an option could be added to the Custom Colors mod to allow custom durability bar colors. Would such a thing be possible?
  • #7065
    Don't know if this has already been reported but the compass needle has a bug when a compass is in a frame.

    When you look at a compass in a frame, the needle is displayed as default one for the compass you handle and the needle always stay as default one for the compass in a frame...

    Follow me on twitter: @Sphax84
  • #7066
    I have a couple of really dumb problems that I can't solve because I'm also really dumb:
    - HD textures and Custom Colors is greyed out. I know it covers this in the troubleshooting but I can't seem to figure it out
    -When I patch a texture pack in, it becomes the default, and the old default goes away. Not that big of a deal, but it'd be nice to know if theres an easy fix.

    Help would be greatly appreciated, thanks!
  • #7067
    Oh, nevermind, it's called "MipMapping" and can be disabled under 'Options' in the Patcher.
    Last edited by Voimes: 12/19/2012 2:56:13 AM
  • #7068
    Quote from Sphax84

    Don't know if this has already been reported but the compass needle has a bug when a compass is in a frame.

    When you look at a compass in a frame, the needle is displayed as default one for the compass you handle and the needle always stay as default one for the compass in a frame...


    Can confirm this:

    Handheld compass before being inserted to Item Frame shows custom needle ...

    As soon as the compass is in the item frame, the needle jumps back to default on both the inserted and handheld compass textures.
    Last edited by _zombiehunter: 12/19/2012 9:47:28 AM

    "Better than Default" v1.7 is ready for download
  • #7069
    can you tell me more crealy how do i make it
  • #7070
    Quote from Sphax84

    When you look at a compass in a frame, the needle is displayed as default one for the compass you handle and the needle always stay as default one for the compass in a frame...

    Fixed!
  • #7071
    I love it! :steve_wink:
  • #7072
    Quote from Kahr

    Fixed!

    Cool! :)
    Also, another bug about optimization related to the custom compass needle. On my computer when I add the "compass_dial.png" (alone or with compass.properties), the game becomes VERY VERY laggy and it's visible directly on the main menu (with the panning on the blurry background)...

    Follow me on twitter: @Sphax84
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes