[Launcher] Magic Launcher 1.2.5 (mods, options, profiles, news)

Poll: Favorite features to be added

Favorite features to be added - Multiple Choice

  • Command-line options 9.8% of Users - 155 votes
  • Language support 8.6% of Users - 136 votes
  • Portable edition 10% of Users - 159 votes
  • Better conflict detection 17.7% of Users - 280 votes
  • Server browser + friends list 22.8% of Users - 361 votes
  • Backup manager 13.1% of Users - 208 votes
  • #7304
    I'm sorry to post this question because I'm sure it must be somewhere in the 363 previous pages, but I'm stumped. Everything works fine... 1.6.2 w/ Forge, Optifine and Zan's Minimap (a pretty slim install, I think), but only in offline mode. MagicLauncher will not connect to the internet. Any ideas? Thanks in advance.
  • #7305
    Quote from MattFinnish

    I'm sorry to post this question because I'm sure it must be somewhere in the 363 previous pages, but I'm stumped. Everything works fine... 1.6.2 w/ Forge, Optifine and Zan's Minimap (a pretty slim install, I think), but only in offline mode. MagicLauncher will not connect to the internet. Any ideas? Thanks in advance.


    I have that same problem.
  • #7306
    MagicLauncher doesn't launch up minecraft at all after clicking the Login button. Any idea why?
  • #7307
    I know i'm repeating my self but I still cant find the solution to the no sound bug, i'm only using optifine for the launcher.
  • #7308
    Quote from a123b

    Yes, I let the standard launcher download the files, but I moved the .minecraft folder to another location than my home dir (AppData on Windows), so the 1.6.2 disappeard logically, because the standard .minecraft directory is no longer present.

    The "Bug" is that ML doesn't look for the "version" and "assets" folders in the .minecraft folder specified as "Base Directory" in the advanced tab.
    Would be a nice feature if ML 1.1.7 would look for these folders in the specified custom base path ;)


    I noticed the same thing. Even if you use a specified custom base path, Magic Launcher will still look in the .minecraft folder in %AppData% home directory. It took me a little while to figure this out.

    On another note... It seems that the use of Magic Launcher is to not have to edit the minecraft jar file, just put your mods in a certain order and play. But now you have to alter the jar file with the Forge installer. Forge offers a universal and installer file on their site, but you need the installer to get it installed. Not sure why they offer a stand alone universal. One would think that that file would be put in you mods folder for Magic Launcher to use. I dunno. :mellow:
  • #7309
    I need help. Magic Launcher keeps failing to start up A my log is this.
    *** MagicMinecraftLauncher 1.1.6 ***
    LCP: ;/Users/zee/Library/Application Support/minecraft/versions/1.6.2 Mod/1.6.2 Mod.jar;/Users/zee/Library/Application Support/minecraft/libraries/net/sf/jopt-simple/jopt-simple/4.5/jopt-simple-4.5.jar;/Users/zee/Library/Application Support/minecraft/libraries/com/paulscode/codecjorbis/20101023/codecjorbis-20101023.jar;/Users/zee/Library/Application Support/minecraft/libraries/com/paulscode/codecwav/20101023/codecwav-20101023.jar;/Users/zee/Library/Application Support/minecraft/libraries/com/paulscode/libraryjavasound/20101123/libraryjavasound-20101123.jar;/Users/zee/Library/Application Support/minecraft/libraries/com/paulscode/librarylwjglopenal/20100824/librarylwjglopenal-20100824.jar;/Users/zee/Library/Application Support/minecraft/libraries/com/paulscode/soundsystem/20120107/soundsystem-20120107.jar;/Users/zee/Library/Application Support/minecraft/libraries/argo/argo/2.25_fixed/argo-2.25_fixed.jar;/Users/zee/Library/Application Support/minecraft/libraries/org/bouncycastle/bcprov-jdk15on/1.47/bcprov-jdk15on-1.47.jar;/Users/zee/Library/Application Support/minecraft/libraries/com/google/guava/guava/14.0/guava-14.0.jar;/Users/zee/Library/Application Support/minecraft/libraries/org/apache/commons/commons-lang3/3.1/commons-lang3-3.1.jar;/Users/zee/Library/Application Support/minecraft/libraries/commons-io/commons-io/2.4/commons-io-2.4.jar;/Users/zee/Library/Application Support/minecraft/libraries/net/java/jinput/jinput/2.0.5/jinput-2.0.5.jar;/Users/zee/Library/Application Support/minecraft/libraries/net/java/jutils/jutils/1.0.0/jutils-1.0.0.jar;/Users/zee/Library/Application Support/minecraft/libraries/com/google/code/gson/gson/2.2.2/gson-2.2.2.jar;/Users/zee/Library/Application Support/minecraft/libraries/org/lwjgl/lwjgl/lwjgl/2.9.0/lwjgl-2.9.0.jar;/Users/zee/Library/Application Support/minecraft/libraries/org/lwjgl/lwjgl/lwjgl_util/2.9.0/lwjgl_util-2.9.0.jar;/Users/zee/Library/Application Support/minecraft/libraries/org/lwjgl/lwjgl/lwjgl-platform/2.9.0/lwjgl-platform-2.9.0-natives-osx.jar;/Users/zee/Library/Application Support/minecraft/libraries/org/lwjgl/lwjgl/lwjgl/2.9.1-nightly-20130708-debug3/lwjgl-2.9.1-nightly-20130708-debug3.jar;/Users/zee/Library/Application Support/minecraft/libraries/org/lwjgl/lwjgl/lwjgl_util/2.9.1-nightly-20130708-debug3/lwjgl_util-2.9.1-nightly-20130708-debug3.jar;/Users/zee/Library/Application Support/minecraft/libraries/org/lwjgl/lwjgl/lwjgl-platform/2.9.1-nightly-20130708-debug3/lwjgl-platform-2.9.1-nightly-20130708-debug3-natives-osx.jar;/Users/zee/Library/Application Support/minecraft/libraries/net/java/jinput/jinput-platform/2.0.5/jinput-platform-2.0.5-natives-osx.jar
    MainClass: net.minecraft.client.main.Main
    Restoring disabled mods: mods
    Disable inactive mods: mods
    Restoring disabled mods: coremods
    Disable inactive mods: coremods
    java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at magic.launcher.Launcher.main(Unknown Source)
    Caused by: java.lang.NoClassDefFoundError: ue
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:295)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    at net.minecraft.client.main.Main.main(SourceFile:37)
    ... 5 more
    Caused by: java.lang.ClassNotFoundException: ue
    at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    ... 41 more
    I can't find the full report.
    Hopefully this is help full.
  • #7310
    Quote from Troncreeper101

    I know i'm repeating my self but I still cant find the solution to the no sound bug, i'm only using optifine for the launcher.


    same here, been watching the thread to see if there was a fix or any info regarding the no sound issue with the magic launcher. do wish someone in the know would give a shout as to whats going on soon.
  • #7311
    SOUND thing - I found that for me, if I switch between 2 texture packs - Ovo's Rustic Redemption and Sphax PureBD Craft, it somehow gets the sound working again. Don't know if it's an initialization thing or not.

    I found out by accident. I have Optifine loaded in Magic Launcher and have both texture packs in the Resourcepacks folder. I just go the standard Minecraft menus, change between the texture packs and bam, sound starts working.

    Maybe worth a try if you have exhausted all other avenues.
    Quote from Tornado_Lucas

    I uploaded this and it plays the game plain, really well. I can't figure out how to get mods. I downloaded two. I put them in the file called Mods under Application Support, Minecraft, Mods. When I open Magic Launcher and click to Add. It shows the mod files in there. When I click on them, nothing gets added to that bar at the bottom (like happens in YouTube how-to videos). I Click Open for each folder, but nothing gets added. I got Magic Launcher because I don't know how to do mods the other way. I'm trying to do this for my 7 year old son. Please adise.


    If you are using Magic Launcher, I would load Mod Loader (or Forge if that is what the Mods require) as the first item in your Magic Launcher mod list, and then load the mods after that.

    Hopefully that will work.

    What mods are you using by the way?
  • #7312
    can someone please help me with my sound problem I have no sounds. I only have the magic launcher and Optifine and nothing else can you please explain how to make my game have sound it does have sound if i use the standard minecraft launcher.
  • #7313
    Nate24k - See above
  • #7314
    I was one of the many people unable to install some mods, though I never posted about it. I am not saying this will work for everyone but it worked for me. I used the new forge installer (minecraftforge-installer-1.6.2-9.10.0.792.jar) like someone stated in a prior post. Now here is where it gets strange, instead of putting the mods in the jar, I put them in the mods folder or in the external mods section. Doesn't matter if it is Optifine or some other mod, they all went in. It fired right up the first time with no errors or anything. Again like I said this just worked for me, try it and if it helps great! And to the author of Magic Launcher great work, I love this program ^_^


    edit: Optifine is a bad example lol haven't got that to play nice yet...

    edit: I finally got Optifine to play nice by using " -Dfml.ignoreInvalidMinecraftCertificates=true -Dfml.ignorePatchDiscrepancies=true " in the advanced>> Parameters field but only if it is in the mods section of the launcher

    advanced tab

    Last edited by blackroseanjel: 7/15/2013 3:28:54 AM
  • #7315
    How do I install forge on this? Whenever I add it to the list of mods, it says at status "No mods found", and if I open it, forge isn't installed in MC. I tried it with the installer of forge, but still nothing worked. The button with "mods" or something like that wasn't there. The only other mod I have installed is Optifine.
  • #7316
    Quote from Tornado_Lucas

    I uploaded this and it plays the game plain, really well. I can't figure out how to get mods. I downloaded two. I put them in the file called Mods under Application Support, Minecraft, Mods. When I open Magic Launcher and click to Add. It shows the mod files in there. When I click on them, nothing gets added to that bar at the bottom (like happens in YouTube how-to videos). I Click Open for each folder, but nothing gets added. I got Magic Launcher because I don't know how to do mods the other way. I'm trying to do this for my 7 year old son. Please adise.

    Quote from danger2000

    How do I install forge on this? Whenever I add it to the list of mods, it says at status "No mods found", and if I open it, forge isn't installed in MC. I tried it with the installer of forge, but still nothing worked. The button with "mods" or something like that wasn't there. The only other mod I have installed is Optifine.


    Ok so here the instructions for all of you to get mods working (at least I got all of mines that were updated so far)

    You first start minecraft with the vanilal launcher once.
    You go and download forge installer, and you use it to install forge.
    You start that forge profil with the vanilla launcher once.
    You go into magic launcher and tell him to use the forged version

    You install your mods, using the 'add' button and not unziping any of the mod file you download!!!
    Install them one by one, so that if any of them bug you know which one it is! (because if it bug it won't be ML fault but the mod fault!)

    The only bad point of this is that magic launcher says there is no forge, but in fact when you play forge work perfectly fine.
    I think we just need to wait for an update so that the launcher can realize that when you use a forged version, there is forge inside... (duh)

    PS: just one more point, I discovered it upon installing optifine
    You need to go into the parameter tab (in the setup window) and type in
    -Dfml.ignorePatchDiscrepancies=true
    Into the parameter slot. (just copy and paste the above line, all symbols included even the minus at the start!)
    I don't know exactly what that line does, but Optifine work only with it and it doesn't create any crashes for me so I suppose it doesn't change much.

    That said another remark: When magic launcher crash, or refuse to start it might not be because of ML but because of the MOD you are trying to install, which isn't updated or if faulty.... just saying...


    Finally: It happen (it happened to me at least) that when you try start the game, magic launcher doesn't start it... Don't panic!
    Go to the vanilla launcher, to the forge profil and start it in vanilla.
    Then return to ML and use the 'test' button in the setup window.
    If that work, then you should be able to play fine.

    That's it! Fel' out!
  • #7317
    Thanks for the great application! :Diamond:
  • #7318
    why does it say "needs Modloader" when i try to put in rei's minimap? i have 3 mods installed Better sprinting
    OptiFine and what im trying to get to work, rei's minimap please help me
  • #7319
    Quote from Felina_Lain

    You go and download forge installer, and you use it to install forge.

    Why the installer and not the .jar ?
  • #7320
    This mod edits you minecraft, when using the vanila launcher, I see 6 buttons, when using this, I see 5 buttons
    Pm me if you need an good redstone circut or if you have an question about minecraft.
  • #7321
    Quote from quake3cat

    On another note... It seems that the use of Magic Launcher is to not have to edit the minecraft jar file, just put your mods in a certain order and play. But now you have to alter the jar file with the Forge installer. Forge offers a universal and installer file on their site, but you need the installer to get it installed. Not sure why they offer a stand alone universal. One would think that that file would be put in you mods folder for Magic Launcher to use. I dunno. :mellow:


    The Forge installer does not even touch the minecraft.jar. It creates a new launcher profile, copies the universal-jar into some directory and "tells" the launcher to download the required libraries, and then start Minecraft using Forge's main class, not Minecraft's vanilla one. The forge-universal.jar does no longer contain the modified classes itself, so it's useless to inject its contents into the minecraft.jar. It now contains binary patches to patch Minecraft's vanilla classes at runtime.

    So it would only be possible to just give ML a path to a Forge universal jar file if:
    1. The universal file itself contains the information about the new main class and the required 3rd-party-libs, maybe as a .json file
    2. ML would read this information, download the libs itself and start the main class given by the forge zip

    So, sp614x (or other custom launcher makers) and the Forge team have to define a standard way where in the "internal coremods" zip/jar to put the information about required libraries and maybe a base class, that every mod maker puts this information to the same json file in the zip, where every custom launcher tries to find it.
  • #7322
    Quote from CobbleBoy

    Why the installer and not the .jar ?


    The installer is a .jar that you start with java to run it as a mini-software
    It do all the work for you.
  • #7323
    The launcher is running the wrong version of the game, but when i go to change the launch directory the launcher freezes and i have to kill it with task manager. I have no mods installed.
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes