[Launcher] Magic Launcher 1.2.5 (mods, options, profiles, news)

Poll: Favorite features to be added

Favorite features to be added - Multiple Choice

  • Command-line options 9.8% of Users - 156 votes
  • Language support 8.6% of Users - 137 votes
  • Portable edition 10% of Users - 160 votes
  • Better conflict detection 17.6% of Users - 281 votes
  • Server browser + friends list 22.7% of Users - 362 votes
  • Backup manager 13.1% of Users - 209 votes
  • #4247
    I like the :DORE: Magic Launcher :DORE: but when i tried to put the Paintball mod on it, it says no mods found. What should I do?I like the :DORE: Magic Launcher :DORE: but when i tried to put the Paintball mod on it, it says no mods found. What should I do?
  • #4248
    Quote from marsdeks

    I like the :DORE: Magic Launcher :DORE: but when i tried to put the Paintball mod on it, it says no mods found. What should I do?

    I like the :DORE: Magic Launcher :DORE: but when i tried to put the Paintball mod on it, it says no mods found. What should I do?


    The code that says whether or not a mod's found's a little outdated.
    Let’s play good guys against bad guys… Yes. Let’s play that. Are you ready? You’re the bad guy. And when you’re bad, you just run. That’s fine right? Well… Shall we play?
  • #4249
    If it wasn't for this I never would have gotten mods like Twilight Forest to work properly. This is absolute godsend for anyone using any mods at all.
  • #4250
    I have a problem
    I used to play minecraft with a few mods but at 1 day it decided to stop working I haven't changed anything just the same setup than the day before (when it still worked) I hoped that this problem would be temporary but it is not I can't even start minecraft with the newest snapshot when I have no mods selected pls help me
    thx in advance

    this is what the log says



    *** Starting Minecraft ***
    Minecraft version: (modified!) 1.3.2
    Minecraft.jar: FORGE.jar
    Mods:
    OptiFine_1.3.2_HD_B3.zip
    [1.3.2]ReiMinimap_v3.2_05.zip
    Advanced Hud 4.7.4.zip
    Recipe Book.zip
    InstantLake 2.3.zip
    Inactive external mods:
    a_VazCore [1.0.2] mc.1.3.2.zip
    IronManModbyColossali.zip
    Layman Mod Maker [1.0] mc.1.3.2.zip
    Java path: C:\Program Files\Java\jre7\bin\java
    Memory: 1024 MB
    LauncherPath: /C:/Documents and Settings/Tino/Bureaublad/MagicLauncher_0.9.9.exe
    *** MagicMinecraftLauncher 0.9.9 ***
    java.lang.NoClassDefFoundError: org/lwjgl/LWJGLException
    at java.lang.Class.getDeclaredMethods0(Native Method)
    at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
    at java.lang.Class.getMethod0(Unknown Source)
    at java.lang.Class.getMethod(Unknown Source)
    at magic.launcher.Launcher.main(Unknown Source)
    Caused by: java.lang.ClassNotFoundException: org.lwjgl.LWJGLException
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 5 more
    No visible frames left, exit()
  • #4251
    Quote from YTboomerangfreak

    I have a problem
    I used to play minecraft with a few mods but at 1 day it decided to stop working I haven't changed anything just the same setup than the day before (when it still worked) I hoped that this problem would be temporary but it is not I can't even start minecraft with the newest snapshot when I have no mods selected pls help me
    thx in advance

    this is what the log says

    {snip}
    Weird... I was going to say try with a unmodified minecraft.jar - but you say it won't work even with the snapshot (I assume you're getting a similar error log)
    ....
    I see that in your log
    java.lang.NoClassDefFoundError: org/lwjgl/LWJGLException


    So could it be a JAVA problem ??...
    Has JAVA (auto) updated itself ?? - although I thought 'lwjgl' was actually part of Minecraft's setup anyway....

    I would suggest backing up your /.minecraft/ folder & doing a 'force update' from the official launcher... it could be the lwjgl file got corrupted somehow..
  • #4252
    Most useless mod.
    It has to be a Winrar.archive for it to be considered a mod.
  • #4253
    Quote from Crabby2122

    Most useless mod.
    It has to be a Winrar.archive for it to be considered a mod.
    And where does it say that 'Magic Launcher' is a MOD ???

    AFAIK - It states in first post
    Quote from The First Post »
    Magic Launcher is a new Minecraft launcher which can load mods dynamically without changing or patching the minecraft.jar.


    Another clue is that this post is in 'Minecraft TOOLS' thread and not in 'Minecraft MODS' ;P
    Last edited by CannonFoddr: 10/8/2012 9:26:58 AM
  • #4254
    Quote from CannonFoddr

    Weird... I was going to say try with a unmodified minecraft.jar - but you say it won't work even with the snapshot (I assume you're getting a similar error log)
    ....
    I see that in your log
    java.lang.NoClassDefFoundError: org/lwjgl/LWJGLException


    So could it be a JAVA problem ??...
    Has JAVA (auto) updated itself ?? - although I thought 'lwjgl' was actually part of Minecraft's setup anyway....

    I would suggest backing up your /.minecraft/ folder & doing a 'force update' from the official launcher... it could be the lwjgl file got corrupted somehow..



    thx I worked
    but do you also know why my minecraft sometimes shuts of (just closes without error log or something)
  • #4255
    Quote from YTboomerangfreak

    thx I worked
    but do you also know why my minecraft sometimes shuts of (just closes without error log or something)
    No Idea - usually when MC shuts down for me there's ALWAY a log somewhere... either a Forge, Modloader or Minecraft log

    You could have a look at this that might help creating a log file - never tried it so can't really help much about this
    Also, you could make sure that 'Show Log' is selected in [Setup]
  • #4256
    The launcher has worked great for a while, but now for some reason I can't log in. I looked through the 'details' file that is created when it 'can't connect to server', and it looks like it just can't connect to the internet for some reason. I know that its not Minecraft, the default launcher works fine.

    Here's the error/details





    MagicLauncher 0.9.9
    java.home: C:\Program Files\Java\jre7
    java.runtime.name: Java™ SE Runtime Environment
    java.runtime.version: 1.7.0_07-b11
    os.name: Windows 7
    os.version: 6.1
    os.arch: amd64
    sun.arch.data.model: 64
    Error checking for new version: Connection timed out: connect
    Error loading: http://twitter.com/s...Dinnerbone.rss: Connection timed out: connect
    Error loading: http://reddit.com/r/minecraft.rss: Connection timed out: connect
    Error loading: http://twitter.com/s...eline/jeb_.rss: Connection timed out: connect
    Error loading: http://notch.tumblr.com/rss: Connection timed out: connect
    Error loading: http://twitter.com/s...line/notch.rss: Connection timed out: connect
    Error loading: http://www.minecraft...s/writ/1-news/: Connection timed out: connect
    java.net.ConnectException: Connection timed out: connect
    at java.net.DualStackPlainSocketImpl.connect0(Native Method)
    at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
    at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
    at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
    at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
    at java.net.PlainSocketImpl.connect(Unknown Source)
    at java.net.SocksSocketImpl.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at sun.net.NetworkClient.doConnect(Unknown Source)
    at sun.net.www.http.HttpClient.openServer(Unknown Source)
    at sun.net.www.http.HttpClient.openServer(Unknown Source)
    at sun.net.www.http.HttpClient.<init>(Unknown Source)
    at sun.net.www.http.HttpClient.New(Unknown Source)
    at sun.net.www.http.HttpClient.New(Unknown Source)
    at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source)
    at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)
    at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source)
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
    at java.net.URL.openStream(Unknown Source)
    at magic.launcher.ao.run(Unknown Source)
    java.net.ConnectException: Connection timed out: connect
    at java.net.DualStackPlainSocketImpl.connect0(Native Method)
    at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
    at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
    at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
    at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
    at java.net.PlainSocketImpl.connect(Unknown Source)
    at java.net.SocksSocketImpl.connect(Unknown Source)
    at java.net.Socket.connect(Unknown Source)
    at sun.security.ssl.SSLSocketImpl.connect(Unknown Source)
    at sun.security.ssl.BaseSSLSocketImpl.connect(Unknown Source)
    at sun.net.NetworkClient.doConnect(Unknown Source)
    at sun.net.www.http.HttpClient.openServer(Unknown Source)
    at sun.net.www.http.HttpClient.openServer(Unknown Source)
    at sun.net.www.protocol.https.HttpsClient.<init>(Unknown Source)
    at sun.net.www.protocol.https.HttpsClient.New(Unknown Source)
    at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(Unknown Source)
    at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)
    at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(Unknown Source)
    at sun.net.www.protocol.https.HttpsURLConnectionImpl.connect(Unknown Source)
    at magic.launcher.ak.a(Unknown Source)
    at magic.launcher.z.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)

  • #4257
    hey, i have a fresh jar, and most of my mods will load up, but when i load the mods below, they show up as mods not found:

    Cave gen 3.0
    mob duisguises
    1.3.2 backpacks

    why am i getting these errors? i have eveything it says that is req...... what is the problem?please reply and quote this post so i get a notification when you answer... thank you.

    I Like ponies, Problem?
  • #4258
    Quote from GeneralEagleEye

    hey, i have a fresh jar, and most of my mods will load up, but when i load the mods below, they show up as mods not found:

    Cave gen 3.0
    mob duisguises
    1.3.2 backpacks
    world edit (not listed here)

    why am i getting these errors? i have eveything it says that is req...... what is the problem?please reply and quote this post so i get a notification when you answer... thank you.


    this is what is showing up, i have the folders simplified to the max (notice the magic launcher labels).... what am i doing wrong? PLEASE someone help me.... i wana use these mods so freaking bad :(

    Last edited by GeneralEagleEye: 10/8/2012 8:03:37 PM

    I Like ponies, Problem?
  • #4259
    O
    Quote from GeneralEagleEye

    this is what is showing up, i have the folders simplified to the max (notice the magic launcher labels).... what am i doing wrong? PLEASE someone help me.... i wana use these mods so freaking bad :(



    OK - couple of things I notice

    1) You seem to have Minecraft 'Forge' AND 'Modloader' installed (I can just about see it @ top of list)
    ... you only need one of them. Forge now has Modloader capabilities, not sure about ModloaderMP though
    2) 'Forge' should be @ top of list
    3) Optifine 'should' really be @ the bottom of the list
    4) According to a post above - 'No Mods Found' is a little 'outdated'... you might find that regardless of 'No mods Found' it they may still work - I have a couple in my setup (Finder Compass is one of them) that say that - but it still works
    5) Not used any of those MODS but....
    - A quick search shows that 'Backpack' is a 'Forge' Mod - so that has to be lower down the list than Forge - you have it above
    - Shapeshifter is apparently not compatible with a lot of mods (found info in this thread - just above the 'Download' section).. could be part of the problem
    - As for 'CaveGen'... can't see anything in the thread other than it needs ModloaderMP... not sure if 'Forge' has 'ModloaderMP' built in or not... can anyone else confirm this ???.
    If not I would assume you would need 'Forge' top of list & 'modloaderMP' lower down
    Last edited by CannonFoddr: 10/9/2012 12:59:02 AM
  • #4260
    Hello! I need some help. Basically I need instructions on how to properly set up the whole program new.

    Today I finally bought my own Minecraft account, downloaded the client, and test-played a bit. I used to play using my friend's account (on 1.2.5), but now that I.3 is out & all the mods I use are finally updated, I'm upgrading. I backed up & deleted the whole folder of all the old game before downloading the new one, and it works fine with no mods.
    Now I'm trying to install all the tools/utilities that I need for the game, and after that's done I'll work on re-installing my mods. But I've hit a major snag with installing the utilities.

    So far I've installed Magic Launcher (well, downloaded; there's no real installing to be done). Then, using Magiclauncher, I added the following 4 things, in this order: ModLoader, Forge, OptiFine, GuiAPI. I made sure it was the current version of each that I downloaded.
    Here's a screenshot of my Magiclauncher screen with the 4 of them loaded.

    When I tried to load the savegame I'd just been playing after fresh-installing the game it crashed (disconnected from server) 1 second after the game was loaded. Then I created a new world, with all these utilities installed (launched through MagicLauncher of course), But it got stuck on the world-generating screen for a looooong time; once the world was finally made, I played for about 1 second before getting disconnected from server. Tried making another world and it never got as far as the world being built; was just frozen forever on the screen where it says "Loading World - Building Terrain".

    I had a LOT of other internet stuff open, so I thought maybe it was just bandwidth-overload on my own computer; I closed all of the other stuff to check if that was the problem, but it didn't make the problem go away.
    I'd made a world when first loaded MagicLauncher w/no addons. I tried re-loading it with ONLY ModLoader & Forge active, and was able to play just fine. When I took a world which was made w/ all 4 utilities on, then tried to load w/ only ML & Forge on, I it was super-slow to load again but I played for about 10 minutes without any crash.
    Then went back to having all 4 addons on, and loaded several of the worlds I'd created while doing all this, And had problems every time. Sometimes it froze on the "Building Terrain" screen, sometimes it loaded but then got d/c'd from server, and sometimes I'd select a savedgame & click "Play selected world", and then it would jump right back to the main menu without even appearing to try to load the save.

    ...So, in conclusion, the real problem only seems to happen when I have all for addons loaded. Can someone please tell me if I installed them correctly? Are they in the right order? Do I need to install any of them with some other method than using the "ADD" button to the right of the mods list in the Setup screen?
    Also I notice a lot of the comments on this page are talking about problems with people getting disconnected from the server. Is my problem likely just the same as they're having? One way or another, there seems to be a conflict specifically with OptFine and/or GuiAPI.
  • #4261
    Quote from PixelPaladin2

    So far I've installed Magic Launcher (well, downloaded; there's no real installing to be done). Then, using Magiclauncher, I added the following 4 things, in this order: ModLoader, Forge, OptiFine, GuiAPI. I made sure it was the current version of each that I downloaded.
    Here's a screenshot of my Magiclauncher screen with the 4 of them loaded.

    I think the issue is actualy that you dont have the latest version of forge coupld with your minecraft.jar is modded.

    The latest version of forge doesnt need modloader nor modloaderMP, also forge needs to be at the very top of the list.

    You will also need to have a completely clean minecraft.jar (you dont need to delete the meta-inf dir either i havent yet and have had no issues at all...) as the whole point of Magic Launcher is that you dont need to edit minecraft,jar at all....

    so for now just try a clean minecraft.jar, updating forge to the latest and removing modloader from the list and see if that helps.
  • #4262
    Quote from PixelPaladin2

    Hello! I need some help. Basically I need instructions on how to properly set up the whole program new.

    {snip}
    OK - couple of things...
    Firstly you don't have the latest forge - forge is currently #250 (last time I looked) & you've only got #200 (get latest here)
    Secondly, when you get latest Forge... you don't need 'Modloader' installed, as Forge now has modloader capabilities
    Thirdly, it looks as though your minecraft.jar is 'pre-modded' (i.e. modified)...
    - Back up your minecraft.jar & do a 'force update', using the offical launcher, to make sure you have a clean file

    - Optifine is usually left @ the bottom of the list, with Forge (Or Modloader) @ the top, so there's no problems there...
    - I'd suggest you also have the 'Show log' selected (until you're up & running)... this may give a clue to what might be causing problems
  • #4263
    how can make this to work on windows 8?
  • #4264
    Quote from DarkStormDragon

    I think the issue is actualy that you dont have the latest version of forge coupld with your minecraft.jar is modded.

    The latest version of forge doesnt need modloader nor modloaderMP, also forge needs to be at the very top of the list.


    Quote from CannonFoddr

    OK - couple of things...
    Firstly you don't have the latest forge - forge is currently #250 (last time I looked) & you've only got #200 (get latest here)
    ...
    Thirdly, it looks as though your minecraft.jar is 'pre-modded' (i.e. modified)...
    - Back up your minecraft.jar & do a 'force update', using the offical launcher, to make sure you have a clean file


    Interesting.
    Re: Forge: I downloaded what I have from THIS LINK, which is to the same forum as you (CannonFoddr) posted, but the link is the one I had bookmarked back when I first got MC 1.2.5. I assumed it was up-to-date since the page says very clearly right up top that it's for Minecraft version 1.3.2. But I'll download the one from the link you gave me.
    Also I thought I was supposed to install both Forge AND Modloader because the instructions in the very first post of THIS thread, under the spoiler "Fixing Common Problems," specifically said to install BOTH, and in what order. And of all the threads I looked at for all the utilities involved, this is the only one where I could find instructions saying all the utilities I should install & in what order. I guess the instructions there are just leftover from MC 1.2.5 and THE CREATOR OF THIS THREAD (OR WHOEVER CURRENTLY RUNS IT) REALLY NEEDS TO UPDATE THE MAIN POST WITH VALID INSTRUCTIONS ON HOW TO INSTALL EVERYTHING NEEDED FOR THE CURRENT VERSION OF MAGIC-LAUNCHER TO WORK!!!
    *breathes* *breathes* Ok, *huff, pant* hopefully they heard me.

    Anyway I'll try again as soon as I have time, with ModLoader completely removed.

    Re: the Jar: It's interesting that you say I have a modified jar. The only program that would have modified my jar with any mods would be MagicLauncher (which I thought, by its very nature, never modifies the actual Jar). The ONLY time I touched the Jar at all was when I opened it to delete the infamous META_INF folder.
  • #4265
    Quote from PixelPaladin2

    Interesting.
    Re: Forge: I downloaded what I have from THIS LINK,

    Don't worry - when I first started changing over to Forge - I did the same thing until I went 'back a page' to the 'release' section of the forum & that's when I saw the newer 4.1.1 post (in fact I notice it's now up to #303 [recommended])


    Re: the Jar: It's interesting that you say I have a modified jar. The only program that would have modified my jar with any mods would be MagicLauncher (which I thought, by its very nature, never modifies the actual Jar). The ONLY time I touched the Jar at all was when I opened it to delete the infamous META_INF folder.
    Perhaps that's what Magic is referring to... since the minecraft.jar has been altered (as in you deleting the meta_inf folder) Magic know it's been 'modified'...

    'Meta_Inf' needn't of been deleted if you use Magic - it does it's clever trickery & 'deletes' that for you anyway

    And you're right - 'sp614x' really should update the first post.. but perhaps he's too busy with his other project(s) like Optifine
  • #4266
    Quote from CannonFoddr

    OOK - couple of things I notice

    1) You seem to have Minecraft 'Forge' AND 'Modloader' installed (I can just about see it @ top of list)
    ... you only need one of them. Forge now has Modloader capabilities, not sure about ModloaderMP though
    2) 'Forge' should be @ top of list
    3) Optifine 'should' really be @ the bottom of the list
    4) According to a post above - 'No Mods Found' is a little 'outdated'... you might find that regardless of 'No mods Found' it they may still work - I have a couple in my setup (Finder Compass is one of them) that say that - but it still works
    5) Not used any of those MODS but....
    - A quick search shows that 'Backpack' is a 'Forge' Mod - so that has to be lower down the list than Forge - you have it above
    - Shapeshifter is apparently not compatible with a lot of mods (found info in this thread - just above the 'Download' section).. could be part of the problem
    - As for 'CaveGen'... can't see anything in the thread other than it needs ModloaderMP... not sure if 'Forge' has 'ModloaderMP' built in or not... can anyone else confirm this ???.
    If not I would assume you would need 'Forge' top of list & 'modloaderMP' lower down


    reordered them, still didn't work... :(

    I Like ponies, Problem?
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes