This thread was automatically marked as Locked.

[TOOL] MCNostalgia 2.1.2 (With GUI) Now works with 1.4.6!

  • #1
    Since everybody seems to be missing the link to MCNostalgia 2.0, I've decided to start a separate thread about it.
    And now... Version 2.1.2 :D .

    New features include:
    - Waits for user to press enter once it finishes. (So people can see the output)
    - Checks to see that your minecraft is vanilla and at the current version
    - Oh, and I fixed that grammar error xD
    - Fixed some bugs, and now explains more stuff.
    - Added in a new indev fix by InsanityBringer
    - Made versions appear in order
    - Automatically downloads the patches
    - Automatically creates patches folder
    - Now with an alpha GUI by myself and searay330 (Requires wxpython if running from source)
    - Works with Minecraft 1.4.6

    Ok, I've seen that many of you are having issues with MCNostalgia. I've uploaded a new version of MCNostalgia, with some of the bugs fixed. You might notice that I don't include the patches folder anymore. This is on purpose, because MCNostalgia will now detect if there is no patches folder, and create it if it isn't there.
    I'm going to put the coinurl link in again. You can choose which one you want.
    MCNostalgia 2.1.2 via Adfly
    MCNostalgia 2.1.2 via CoinURL
    Heh, figured out the titled URL now :D

    Yes, this should work for macs, now stop asking. :P

    In the next version I'll probably include making backups so it can do "unpatching" (which as far as I can tell is how MCNostalgia 1.0.4 did it.)

    Here's some screenshots from Windows (Actually Windows running in VirtualBox)





    And here's some from Linux:







    Instructions: Download the zip file, extract it. If you have python installed, use MCNostalgia2.1.2.py. If you don't, but are running Windows, use MCNostalgia2.1.2.exe. The program will give you instructions from there. Yes, this does work with Minecraft 1.4.6. Remember, if you already have MCNostalgia, you can either delete everything in the patches folder (but not the patches folder itself) or just delete the whole MCNostalgia folder and redownload. It turns out some archive utilities, (file-roller and maybe some others) don't extract a folder if its empty. The MCNostalgia zip has such a folder, and it's the patches folder. So if you are having problems, make sure that the patches folder exists.

    EDIT: I have just been notified by CyborgDragon that I can take over the project for now, perhaps indefinitely. (See his thread for details.)

    Tutorial for Windows: (Thanks to RandomMac5)

    And finally, a tutorial for Mac OS X :D (Thanks to quinlan723)
    Last edited by sonicrules1234: 12/20/2012 12:14:55 PM
  • #2
    Cool. Thanks for your work on this. I'll be keeping this thread up until it's ready.
  • #3
    Sounds good, thanks for making version 2.0
  • #4
    Quote from Egon

    Cool. Thanks for your work on this. I'll be keeping this thread up until it's ready.



    Thanks for helping in my thread:

    My link
    ----------------------------------------------------------------------
    @sonicrules1234 of thread when exactly will it be out because I would like it ASAP because I want to get 1.8.1 back.

    Thanks,

    Acdc725
    Last edited by SSD99: 11/19/2011 8:58:25 PM
  • #5
    Quote from acdc725

    Thanks for helping in my thread:

    My link
    ----------------------------------------------------------------------
    @sonicrules1234 of thread when exactly will it be out because I would like it ASAP because I want to get 1.8.1 back.

    Thanks,

    Acdc725

    It's uploading as we speak.
  • #6
    Quote from acdc725

    Thanks for helping in my thread:

    My link
    ----------------------------------------------------------------------
    @sonicrules1234 of thread when exactly will it be out because I would like it ASAP because I want to get 1.8.1 back.

    Thanks,

    Acdc725

    Ok, all uploaded and the link is in the first post on this thread.
  • #7
    IT WORKS!! WOO-HOO!

    /thank
    /grovel
    /hug
  • #8
    Thank you very much!
  • #9
    1.9 Pre-release 5-6
    1.0 RC 1-2

    Okay, thanks.
  • #10
    pics? more info?
  • #11
    Thank you, but how do I remove the patch and play 1.0.0 again?
  • #12
    Quote from jfswedenJ

    Thank you, but how do I remove the patch and play 1.0.0 again?


    Force Update or delete the .Minecraft folder.

    Roxicodine, it downgrades your Minecraft with patches and it's command line, (It's MUCH simpler than it sounds) so you don't need pictures.
    Last edited by Error_52: 11/20/2011 4:58:05 AM
  • #13
    I tried patching back to 1.8.1, said it was done. But when I launched Minecraft, it keeps freezing at "Done loading" every time.

    Help?

    EDIT: Fixed by patching to 1.8.0
    Last edited by iGotPride: 11/20/2011 6:43:03 AM
  • #14
    Quote from Amykins

    IT WORKS!! WOO-HOO!

    /thank
    /grovel
    /hug

    Glad to hear you got it working :biggrin.gif:
  • #15
    Quote from sonicrules1234

    Glad to hear you got it working :biggrin.gif:


    All thanks to you, dude. <3 I figured out the order of installations to get MC to work properly on my moody-ass system:

    1. Reinstall MC
    2. Use your Nostalgia tool
    3. Use MCPatcher
    4. Use Mo'Creatures installer
    5. ?????
    6. Profit!
    Last edited by Amykins: 11/20/2011 12:57:27 PM
  • #16
    Thank you very much for this! It works wonderfully and it's surprisingly idiot-proof!
  • #17
    You guys might want to look at the first post again :tongue.gif:
    I just updated it with some important information.
  • #18
    i am getting this error: This application has failed to start because it's side by side configuration is incorrect. Pleas see the application event log for more detail.
    Is this common? and where is the event log? Please help me i wanna go back to 1.8.1!

    If Facebook, Myspace, and Twitter were all destroyed, 90% of teens would go insane. If you're one of the 10% that would be laughing at them, copy this into your signature and hope it happens.
  • #19
    Quote from Blackthunder365

    i am getting this error: This application has failed to start because it's side by side configuration is incorrect. Pleas see the application event log for more detail.
    Is this common? and where is the event log? Please help me i wanna go back to 1.8.1!

    I've never heard of that error before.
    By googling, I found this thread about your error. It talks about corrupt .dll files and how to fix it. I suggest you download the the redistributables in the order they suggest. Please tell me if this fixes your problem
  • #20
    Quote from sonicrules1234

    I've never heard of that error before.
    By googling, I found this thread about your error. It talks about corrupt .dll files and how to fix it. I suggest you download the the redistributables in the order they suggest. Please tell me if this fixes your problem

    Unfortunately, i have about 127 registry errors and can only fix 15 without paying for the program, so the ones i did fix weren't the right one. And was you saying you googled it telling me to google it?

    If Facebook, Myspace, and Twitter were all destroyed, 90% of teens would go insane. If you're one of the 10% that would be laughing at them, copy this into your signature and hope it happens.
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes