Updating & Installing Mods in 1.6.1

  • #41
    Quote from Mattthecoolcat

    How do I downgrade back to 1.5.2???
    Either: (1)Edit your profile on the new launcher so it's on 1.5.2 (2)Play on the old launcher
  • #42
    Quote from iPixeli

    Their website appears to be down from all the traffic.
    Yeah thats what i thought well i got in finally and found out about the installer. So i tried it and it seemed fine when i changed the profile, but it wouldnt load! Everytime i press play the console would say "Libraries & Versions: Finished with 2 errors!" Im gonna try the more manual version to see if that will work.
    Last edited by Mothman101: 7/2/2013 7:16:01 PM
  • #43
    the crashing problem is caused by the fact that the mods are incompatible. clear youre mods folder untill new updates come out for mods
  • #44
    Another easy way is to use Magic Launcher, which is demonstrated in this video.

    http://www.youtube.com/watch?v=DAUPz6CsuwU


    Maybe add it to the main post if you find it helpful, so others can make use of it as well? The modding community needs to be saved!
    CLICK ME. CLICK ME HARD.
  • #45
    I saw forge has an installer for playing the game, but how do I install forge to my mcp so that I can mod for 1.6.1???
  • #46
    Hey everyone, I HIGHLY recommend looking at the changed/new methods, if you're a modder.

    MAKE SURE that you change @PreInit, @Init, and @PostInit to @EventHandler

    *NOTE THAT YOU WILL NOT GET ANY ERRORS, HOWEVER YOUR IMPORT WILL BE DEPRECATED.

    Another note: Gui's have now changed. Your gui probably contains:
    mc.renderEngine.getTexture(textureName)


    Now, you must use it like this:
    ResourceLocation guiLocation = new ResourceLocation(texturelocation);
    			    this.mc.renderEngine.func_110577_a(guiLocation);
    Last edited by SoBiohazardous: 7/2/2013 8:02:20 PM
    I made some mods.
    Click the pictures to check them out!
  • #47
    HALP! Couldn't download https://s3.amazonaws.com/Minecraft.Download/versions/Modded/Modded.jar for job 'Version & Libraries'
    java.lang.RuntimeException: Server responded with 403
    at net.minecraft.launcher.updater.download.Downloadable.download(Downloadable.java:85)
    at net.minecraft.launcher.updater.download.DownloadJob.popAndDownload(DownloadJob.java:102)
    at net.minecraft.launcher.updater.download.DownloadJob.access$000(DownloadJob.java:10)
    at net.minecraft.launcher.updater.download.DownloadJob$1.run(DownloadJob.java:84)
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
    at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)

    Gave up trying to download https://s3.amazonaws.com/Minecraft.Download/versions/Modded/Modded.jar for job 'Version & Libraries'
    Job 'Version & Libraries' finished with 1 failure(s)!
    sunflower!
    Hatch your own dragon!new breeds added.I ADVERTISE TOO MUCH I KNOW I KNOW!!
  • #48
    How do I install 1.6.1 mods that DO NOT require forge or mod loader?!
  • #49
    Since many servers includnig my own have not updated to 1.6.1, I use 1.5.2 with the new launcher. No problems right?

    Wrong.

    My server has mods. (Yeah, i use client mods on a bukkit server)
    My server requires you have forge and a few certain mods- Problem is i can't figure out how to set up 1.5.2 in the new launcher.
    Help is appreciated

  • #50
    Quote from pokemonface12

    HALP! Couldn't download https://s3.amazonaws...dded/Modded.jar for job 'Version & Libraries'
    java.lang.RuntimeException: Server responded with 403
    at net.minecraft.launcher.updater.download.Downloadable.download(Downloadable.java:85)
    at net.minecraft.launcher.updater.download.DownloadJob.popAndDownload(DownloadJob.java:102)
    at net.minecraft.launcher.updater.download.DownloadJob.access$000(DownloadJob.java:10)
    at net.minecraft.launcher.updater.download.DownloadJob$1.run(DownloadJob.java:84)
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
    at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
    at java.util.concurrent.FutureTask.run(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.lang.Thread.run(Unknown Source)

    Gave up trying to download https://s3.amazonaws...dded/Modded.jar for job 'Version & Libraries'
    Job 'Version & Libraries' finished with 1 failure(s)!
    'TI CAN'T EVEN PLAY MINECRAFT!
    sunflower!
    Hatch your own dragon!new breeds added.I ADVERTISE TOO MUCH I KNOW I KNOW!!
  • #51
    Quote from Mattthecoolcat

    How do I downgrade back to 1.5.2???


    You can still play Minecraft 1.5.2 using the new launcher. You need to go to Profile Editor and create a new profile. Name it what ever you want, then check Game Directory Box. Change the User Version to 1.5.2 and click save. Now on the right of the launcher you will see a drop down menu called "Profile", click on it and change it to the profile you just created. Then log into your Minecraft account.

    You can also watch this video that shows you how to install optifine 1.5.2 mod with the new launcher.

    https://www.youtube.com/watch?v=XQ_MdKkgyxA
  • #52
    So I'm assuming you would put any mods you want in the mod folder you created in the cpw folder
    Quote from ezekielelin


    9. Open [minecraft]/libraries

    10. Make a folder called cpw and open it

    11. Make a folder called mods and open it

    12. Make a folder called fml and open it

    13. Make a folder called 5.2.29 and open it


    So I'm assuming you put any mods that require FML in that mod folder
  • #53
    Quote from ezekielelin

    The installer installs it almost instantly. I beg to differ.
    Could you please explain how you use the installer in that case? I have tried the way you wrote, but I don't get it to work.
    Last edited by Excavator2: 7/3/2013 1:02:18 AM
    I scored 82% on the Minecraft Trivia Quiz. How much do you know about Minecraft?
  • #54
    forge installs and seems to start minecraft up then it crashes
  • #55
    I need help with the texture code. In my 1.5.2 mod, in the main class I used '.setLocalisedName()' for my textures, but now they don't work :( anyone know what I have to do to fix this?
  • #56
    Question!

    13. Make a folder called 5.2.29 and open it

    14. Download the latest 1.6.1 Forge from files.minecraftforge.net and rename it to fml-5.2.29.jar


    1. Why is 5.2.29?
    2. The link is 1.5.2, is it work for 1.6.1 as well?

    Edit: NVM, I did it!

    Oh! iPixeli, one thing I wanna tell you, just open the spoiler and read the red text.


    {
    "id": "FML-1.6",
    "time": "2013-07-01T07:47:29-04:00",
    "releaseTime": "2013-06-28T10:48:41-04:00",
    "type": "release",
    "minecraftArguments": "${auth_player_name} ${auth_session} --gameDir ${game_directory} --assetsDir ${game_assets} --tweakClass cpw.mods.fml.common.launcher.FMLTweaker", "libraries":
    {
    "name": "com.paulscode:codecjorbis:20101023"
    },
    {
    "name": "com.paulscode:codecwav:20101023"
    },
    {
    "name": "com.paulscode:libraryjavasound:20101123"
    },
    {
    "name": "com.paulscode:librarylwjglopenal:20100824"
    },
    {
    "name": "com.paulscode:soundsystem:20120107"
    },
    {
    "name": "cpw.mods:fml:5.2.29"
    },
    {
    "name": "net.minecraft:launchwrapper:1.3"
    },
    {
    "name": "lzma:lzma:0.0.1"
    },
    {
    "name": "net.sf.jopt-simple:jopt-simple:4.5"
    },
    {
    "name": "argo:argo:2.25_fixed"
    },
    {
    "name": "org.apache.commons:commons-lang3:3.1"
    },
    {
    "name": "commons-io:commons-io:2.4"
    },
    {
    "name": "org.ow2.asm:asm-all:4.1"
    },
    {
    "name": "org.lwjgl.lwjgl:lwjgl:2.9.0"
    },
    {
    "name": "org.lwjgl.lwjgl:lwjgl_util:2.9.0"
    },
    {
    "name": "net.java.jinput:jinput:2.0.5"
    },
    {
    "name": "org.bouncycastle:bcprov-jdk15on:1.47"
    },
    {
    "name": "com.google.guava:guava:14.0"
    },
    {
    "name": "net.java.jutils:jutils:1.0.0"
    },
    {
    "name": "com.google.code.gson:gson:2.2.2"
    },
    {
    "name": "org.lwjgl.lwjgl:lwjgl-platform:2.9.0",
    "natives": {
    "linux": "natives-linux",
    "windows": "natives-windows",
    "osx": "natives-osx"
    },
    "extract": {
    "exclude":
    "META-INF/"
    ]
    }
    },
    {
    "name": "net.java.jinput:jinput-platform:2.0.5",
    "natives": {
    "linux": "natives-linux",
    "windows": "natives-windows",
    "osx": "natives-osx"
    },
    "extract": {
    "exclude":
    "META-INF/"
    ]
    }
    }
    ],
    "mainClass": "net.minecraft.launchwrapper.Launch",
    "minimumLauncherVersion": 2
    }

    That's what I wanna tell you :P
    Last edited by Niconiko: 7/3/2013 7:04:39 AM

  • #57
    Client> 2013-07-03 07:40:38 [INFO] [STDERR] This version of CodeChickenCore does not support minecraft version 1.6.1

    please help, i cant even uninstall it without an error i cant play at all
  • #58
    One thing I've been wondering since the new launcher...

    Does Forge respect custom game directories?

    For example, if I create a profile that points to F:\Minecraft\1.6.1-MyMod\.minecraft\ as the game directory, and have Forge installed into %appdata%\Roaming\.minecraft\versions\1.6.1-MyMod\, will Forge accurately put all its working files in F: instead of AppData?

    Setting up my 1.5.2 mods with the new launcher and a custom directory I want to set aside for purely 1.5.2 stuff, I found that OptiFine refuse to acknowledge custom directories and will only allow the game to load texture packs from %appdata%; while Forge also insists to create all its working files in %appdata%.

    I want to use custom directories to separate my different save games and texture packs for different versions.
    Last edited by zfz: 7/3/2013 9:05:45 AM
  • #59
    do I need to do that every time I want to install a mod? can I install multiple mods in one profile?
  • #60
    When I use the forge 1.6.1 installer, forge installs fine, and when I play the game, it works, but where would I put my 1.6.1 forge mods? What is the directory pathway starting with the [minecraft] folder?
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes