1.7.10

Shaders Mod v2.3.18 (updated by karyonix)

  • #4550
    Quote from karyonix

    Old Releases
    • ShadersMod (modified by karyonix) 1.46
    • ShadersMod-mc1.5.2-ofud3-1.46 for Minecraft 1.5.2 OptiFine HD Ultra D3
      Release note
      - Update for new texture implementation in Minecraft 1.5
      - texturename_n.png = normal map
      - texturename_s.png = specular map
      - texture and its normal map and specular map must have the same number of pixels.


    just wondering, is this the only version of Shadermod released/available for MC 1.5.2?
    thanks thnx!
  • #4552
    All of the shaders here are awesome! (I just wish that Sonic Ether's would work on my laptop :( )
    I ♥ bagels! ☺
  • #4553
    Quote from lvlup



    Was curious if the latest Beta17 of Shadermod fixed that algorithm?
    If yes, does that mean the mods Johnny mentioned above are compatible now?
    Minecraft 1.6 use a different texture system. Texture code from 1.5 are not used in 1.6.
    Their 1.6 version may be compatible.

    Quote from lvlup



    just wondering, is this the only version of Shadermod released/available for MC 1.5.2?
    thanks thnx!
    There are preview v1.45.2, release v1.46 from me and another release v2.0 from Sonic Ether.
    After the version for mc1.6 is stable if I have enough time I may backport it for mc1.5.2 .
  • #4554
    Aw.....
    1.6.2 worked for me.
    1.6.4 : Nah. It did not work.
    I installed these mods in order:
    1. Forge (1.6.4)
    2. Optifine (1.6.4)
    3. Shaders (1.6.2)
    I don't know why it did not work. It did not give an error log either.
  • #4555
    Quote from raz04

    Aw.....
    1.6.2 worked for me.
    1.6.4 : Nah. It did not work.
    I installed these mods in order:
    1. Forge (1.6.4)
    2. Optifine (1.6.4)
    3. Shaders (1.6.2)
    I don't know why it did not work. It did not give an error log either.
    I can't run Optifine Preview C4 with Forge or FML in 1.6.4, even without ShadersMod.
    Forge with ShadersMod can run without Optifine.
    So it's Forge or FML + Optifine incompatibility.
    Edit profile and set launcher visibility to keep launcher open to see console log.
    Last edited by karyonix: 9/22/2013 11:50:59 PM
  • #4556
    gettin same problem here!
  • #4557
    Quote from ieatkittins

    gettin same problem here!

    lolwat
    what problem? and please take a screenshot.
  • #4558
    Quote from chocapic13

    I'm working on a quite cool cool lens effect! The little problem is that lens pattern looks "stuck" to the camera :/

    awesome work :)!!
    Quote from SuporeMaster


    Why are you using such an outdated version?
    i'm playing very much with SEUS v09 Test5A. I love the old godrays...
  • #4559
    Hi since updating to minecraft 1.6.4 I have gotten the Shaders mod to work but not with optifine. (Is it compatible?)
    Also I have also noticed that I can see the chunk borders in the water that were not previously there in 1.6.2
    Any input would be appreciated.
    Thanks :D
    NOTE: This is copied off the SEUS/GLSL Shaders Thread
  • #4560
    Quote from Synthlight

    Hi since updating to minecraft 1.6.4 I have gotten the Shaders mod to work but not with optifine. (Is it compatible?)
    Also I have also noticed that I can see the chunk borders in the water that were not previously there in 1.6.2
    Any input would be appreciated.
    Thanks :D
    NOTE: This is copied off the SEUS/GLSL Shaders Thread


    I tried yesterday and it worked, but it wasn't working with Magic Launcher, you Need to use the Manual way with the classic launcher.

    WIP 128x 64x, SEUS support, Mod support in the pipeline TEKKIT, FTB, the more support the more mods!
  • #4561
    Quote from SuporeMaster

    Why are you using such an outdated version?
    Because i love this pack :D
    I cant find better than this for me
    i would be happy if someone could help
  • #4562
    Quote from chocapic13

    I'm working on a quite cool cool lens effect! The little problem is that lens pattern looks "stuck" to the camera :/



    ermeowherg dat's awesome :3
    I'm a helpful cat. :3
  • #4563
    Quote from Synthlight

    Hi since updating to minecraft 1.6.4 I have gotten the Shaders mod to work but not with optifine. (Is it compatible?)
    ShadersMod works in 1.6.4.
    But Optifine 1.6.4 C4 Preview does not work with FML/Forge. You will have to wait for Optifine update.
    Quote from Synthlight

    Also I have also noticed that I can see the chunk borders in the water that were not previously there in 1.6.2
    Some shaderpacks terrain animation depend on Optifine's way of sending coordinate. Without Optifine, they have this render glitch.
    Some shaderpacks do not have this dependency.



    shaderpack bump-shadow-waving-0.9.7 released
    Fixed AMD compatibility.
    Fixed POM border glitch when mipmap is enabled.
    Underwater shading is still incompleted.
    Last edited by karyonix: 9/23/2013 9:08:03 AM
  • #4564
    Karyonix:

    Quote from Wadu436

    I used the 1.6.4 optifine Ultra C4 preview + Minecraftforge 880

    If you want ill take a screenshot of the optifine menu with in the background shaders :P

    EDIT: I put the optifine files in the .jar


    Can you enlighten us as to what kind of problems one may see loading OF as a coremod, rather than a forge mod in 1.6.2/4?

    I know GLSL was designed to have OF as a forge mod, along side GLSL -- not having OF integrated directly into MC/Forge itself.

    I snagged this from the SEUS thread, some one thought he'd be a smarty-pants :P.

    I just warned him we can't support him, and don't know what side-effects he might incur because he did not follow the installation instructions properly.

    EDIT: When I say 'coremod' I don't mean the old 1.5.2 'coremod' deal, I mean manually embedded into the MC/Forge JAR directly.
    Last edited by JonnyBrando: 9/23/2013 1:14:13 PM
    My archive of Optifine and GLSL Shaders releases:
  • #4565
    Quote from DA3DSOUL

    to install the code, open the SEUS zip and extract it, go to the composite.vsh file and edit as instructed

    Doesn't seems to work. Did I do something wrong here?
    ihttp://pastebin.com/sD0jQMtq
  • #4566
    Quote from Liping

    Doesn't seems to work. Did I do something wrong here?
    ihttp://pastebin.com/sD0jQMtq


    From what I read, and understand, you need to do some more serious editing of the composite.vsh file.

    You need to declare a variable (sunangle), and then add the code he posted after the line 'texcoord = gl_MultiTexCoord0;'.

    Then you need to basically search through everything after the line 'void main() {' to replace 'worldTime' with 'scaledTime'.

    (INSERT)EDIT: Oh, actually, there's only 3 of them you need to change in there, don't edit the 'uniform int worldTime;' line, just everything after that.

    It's not just 'drag and drop' some code in and be done ... not as easy as all of the other changes posted on this thread so far.

    Don't get me wrong, not super hard either, just take your time and be careful what your editing. You can always re-download and restart as well ;).
    Last edited by JonnyBrando: 9/23/2013 2:04:19 PM
    My archive of Optifine and GLSL Shaders releases:
  • #4567
    Quote from JonnyBrando
    Karyonix: Can you enlighten us as to what kind of problems one may see loading OF as a coremod, rather than a forge mod in 1.6.2/4? I know GLSL was designed to have OF as a forge mod, along side GLSL -- not having OF integrated directly into MC/Forge itself. I snagged this from the SEUS thread, some one thought he'd be a smarty-pants :P. I just warned him we can't support him, and don't know what side-effects he might incur because he did not follow the installation instructions properly. EDIT: When I say 'coremod' I don't mean the old 1.5.2 'coremod' deal, I mean manually embedded into the MC/Forge JAR directly.
    Embedded in version jar or load from forge, I think it will not make any difference to ShadersMod.

    Read this twitter conversation about Forge+Optifine issue.
    https://twitter.com/sp614x/status/382177585624408064
    I think they are working on it.
    Last edited by karyonix: 9/23/2013 2:40:45 PM
  • #4568
    Quote from msz1261

    This was a shader mod issue. Fixed with Beta17.



    The clouds aren't default, and not from Optifine. My favorite resource backs or Misa and Photo Realism, but the clouds like look that good.


    It looks like default resource back with one of SEUS's dev versions that add volumetric clouds
  • #4569
    Quote from karyonix

    Embedded in version jar or load from forge, I think it will not make any difference to ShadersMod.

    Read this twitter conversation about Forge+Optifine issue.
    https://twitter.com/...177585624408064
    I think they are working on it.


    Thx for the update, Karyonix :)!
    My archive of Optifine and GLSL Shaders releases:
  • #4570
    Quote from DarkDVicious


    Quote from DarkDVicious

    i'm having an issue with v14. if i use optifine with it, my fps start to drop till 0 after a few seconds on map. without optifine i'm having stable 20-30 fps. if i use a older version (like v9) i can play with 40-60 fps.

    i tried a few diferent shaders packs and ressource packs, from ultra to lite and it happens with all.


    forge - 859
    optifine - ultra c4
    nvidia drivers 314.22


    UPDATE:
    still happening with new version 15


    the problem still persists, using optifine + shaders mod uses all the allocated memory from minecraft. like a said before after a few seconds/minutes all allocated memory is in use and minecraft runs at 0-1 fps, crashing after awhile ( not enough memory error), even when i allocted 6gb to minecraft.

    edit:
    already tried in a Minecraft 1.6.2 clean install.
    same thing
    Last edited by DarkDVicious: 9/23/2013 3:26:43 PM
    Portuguese Team
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes