[1.7.10][API] Render Player API

  • #142
    Yea, I read that.

    I only posted because (as far as I can remember) that message existed before the version of Forge which uses this class, so I wasn't sure if it was still valid.

    Sorry for wasting your time.
  • #143
    Tropicraft now uses this mod.
    Developer of
  • #144
    Quote from fishtaco567

    Tropicraft now uses this mod.

    Listed - thanks for relying on Render Player API :)

    Not Minecraft-related, I know - but the author wants more readers - and to be honest, he deserves them!
  • #145
    Hey Divisor will you update RenderPlayerAPI on 1.4.2 soon ?
    Last edited by castielq: 10/28/2012 8:24:04 AM
    I am not rude, i'm just telling the truth, with lies you will never win ! ~ by Castielq

  • #146
    Released Render Player API for Minecraft 1.4.2.

    Not Minecraft-related, I know - but the author wants more readers - and to be honest, he deserves them!
  • #147
    Released version 1.1 - Fixed method naming.

    Not Minecraft-related, I know - but the author wants more readers - and to be honest, he deserves them!
  • #148
    What is the Forge version that this new 1.4.2 version updates?

    Since both Forge and this API edit the same base class (baq), I want to be sure that installing this does not overwright the changes made by Forge that might be needed by any other mods...

    Thanks
  • #149
    Quote from Myschief

    What is the Forge version that this new 1.4.2 version updates?

    Since both Forge and this API edit the same base class (baq), I want to be sure that installing this does not overwright the changes made by Forge that might be needed by any other mods...

    Thanks

    -> Opening Post
    -> Chapter 'Installation'
    -> Section 'Incompatibilities'

    Not Minecraft-related, I know - but the author wants more readers - and to be honest, he deserves them!
  • #150
    Quote from Divisor

    -> Opening Post
    -> Chapter 'Installation'
    -> Section 'Incompatibilities'


    I read that you indicate it is compatible, but how does this work when there are Forge versions that were released after yours that includes the same modified base file? Do you update your version to be sure and incorporate the changes made by Forge? If so, then which Forge version does your file update?

    If not, then this could be an issue if Forge (or a Forge-compatible mod) expects to see code that is no longer there because your base class over-writes it.

    Please know that I am not trying to be difficult, I'm just trying to better understand. I am not a modder, but I use quite a few different mods (about 50). Forge offers me the ability to drastically reduce imcompatibilties and thus run more mods than I ever could before. That being said, nothing is perfect and I still run into some issues from time to time, thus I keep a close eye on what base files are being modded and by what mods. Just because Minecraft doesn't outright crash and mods may appear to work together at the onset, doesn't necessarily mean that all functionality actually works and the mods are compatible.
  • #151
    Quote from Myschief

    I read that you indicate it is compatible, but how does this work when there are Forge versions that were released after yours that includes the same modified base file?

    As long as the code inside the Minecraft Forge file in question does not change.

    Quote from Myschief

    Do you update your version to be sure and incorporate the changes made by Forge?

    Only if necessary (also see above)

    Quote from Myschief

    If so, then which Forge version does your file update?

    All recommended versions for Minecraft 1.4.2 so far (that would be version 6.0.1.349 or lower).
    Last edited by Divisor: 10/29/2012 3:17:51 PM

    Not Minecraft-related, I know - but the author wants more readers - and to be honest, he deserves them!
  • #152
    Hmm, using Forge 332 I noticed FML was complaining about RenderPlayer.armorFilenamePrefix being private, though we are using rpapi 1.0 still, if this has been fixed in 1.1, disregard.

    Also, why do you not provide the source code? If part of the instructions is to decompile with mcp AND THEN use those source files on a forge install, why not just save us the time and give us those mcp decompiled java files? Short of the usual easy to deal with mcp naming updates I see no downside of it. The first thing I always do with RPAPI after a decompile is upload the source files for my teammates to use to save time of a tedious decompile.
  • #153
    Thank you so much for explaining! I really appreciate this so now, when my "UberModofAmazingFunctionality" updates next week, or next month, or whenever, and it needs say Forge version 438, I know to be sure and keep an eye out for an update on this one :)
    Last edited by Myschief: 10/29/2012 3:54:05 PM
  • #154
    I installed forge just how i was suppost to, installed SMM and its required mods, and i got it to start up. for some reason, I cant use any of smart movement's features!
    EDIT:
    To be specific, it says i have smart movement installed. I go into a world, but i cant super jump, crawl, grab, ect... (i just realised i posted this in render api, not smartmovment. Sorry!)
    Last edited by Mr_person1234321: 10/29/2012 6:06:03 PM
    Member of the sky army.
  • #155
    I'd love it if you submitted a pull request with forge to have something similar to this added in.
  • #157
    Released version 1.3 - Improved Minecraft Forge compatibility and render player base registration robustness.

    Thanks to Corosus for telling me about an incompatibility with Minecraft Forge.

    Not Minecraft-related, I know - but the author wants more readers - and to be honest, he deserves them!
  • #158
    Hi, I just encountered an error while using this in conjunction with Minecraft forge for 1.4.2, while the API file being 1.2.
    It said the 'baq' isn't compatible with forge, what should I do to have these two running together while using mcpatcher?
  • #159
    can you add more enchantments to the mod list for the api and also fix it so we can play lan again PLEASE
  • #160
    Do you know when it will update?
  • #161
    Released Render Player API for Minecraft 1.4.4.

    Not Minecraft-related, I know - but the author wants more readers - and to be honest, he deserves them!
  • #162
    Obrigado Por me ajudar a baixar o Api
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes