[1.5] FML : a new mod loader

  • #81
    Quote from mitchmac

    I have been looking for a FML build for Minecraft 1.2.5 and having trouble because the FML download site says nothing about what version of Minecraft the builds are for. There are a few new mods out there for MC1.2.5 that require FML. I have some old FML downloads but they are all for server side and a search for the client side file turns up nothing.

    Get forge.
    Quote from ohjays

    Is anyone using this in combination with the "EasyMineLauncher" to launch minecraft, modloader based works find but fml obviously does something strange under the hood . Which is a pain in the whatsit as the launcher is great - lets me specify what jar and what dirs to run from plus it works great for the kids with our LAN ( meaning no internet for the challenged ) bukkit server

    Loading Minecraft from: D:\games8\minecraft\client-1.3.2\data\.minecraft\bin\min
    ecraft_bluedawn.jar
    2012-09-12 18:32:08 [INFO] [ForgeModLoader] Forge Mod Loader version 3.1.1.368 f
    or Minecraft client:1.3.2, server:1.3.2 loading
    2012-09-12 18:32:09 [INFO] [STDERR] Exception in thread "main" java.lang.Runtime
    Exception: cpw.mods.fml.relauncher.ReflectionHelper$UnableToFindClassException:
    java.lang.ClassNotFoundException: net.minecraft.Launcher
    2012-09-12 18:32:09 [INFO] [STDERR] at cpw.mods.fml.relauncher.FMLRelauncher
    .relaunchApplet(FMLRelauncher.java:257)
    2012-09-12 18:32:09 [INFO] [STDERR] at cpw.mods.fml.relauncher.FMLRelauncher
    .appletEntry(FMLRelauncher.java:200)
    2012-09-12 18:32:09 [INFO] [STDERR] at net.minecraft.client.MinecraftApplet.
    init(MinecraftApplet.java:23)
    2012-09-12 18:32:09 [INFO] [STDERR] at org.bonsaimind.easyminelauncher.Conta
    inerApplet.init(ContainerApplet.java:203)
    2012-09-12 18:32:09 [INFO] [STDERR] at org.bonsaimind.easyminelauncher.Main.
    main(Main.java:186)
    2012-09-12 18:32:09 [INFO] [STDERR] Caused by: cpw.mods.fml.relauncher.Reflectio
    nHelper$UnableToFindClassException: java.lang.ClassNotFoundException: net.minecr
    aft.Launcher
    2012-09-12 18:32:09 [INFO] [STDERR] at cpw.mods.fml.relauncher.ReflectionHel
    per.getClass(ReflectionHelper.java:159)
    2012-09-12 18:32:09 [INFO] [STDERR] at cpw.mods.fml.relauncher.FMLRelauncher
    .relaunchApplet(FMLRelauncher.java:242)
    2012-09-12 18:32:09 [INFO] [STDERR] ... 4 more
    2012-09-12 18:32:09 [INFO] [STDERR] Caused by: java.lang.ClassNotFoundException:
    net.minecraft.Launcher
    2012-09-12 18:32:09 [INFO] [STDERR] at java.net.URLClassLoader$1.run(Unknown
    Source)
    2012-09-12 18:32:09 [INFO] [STDERR] at java.net.URLClassLoader$1.run(Unknown
    Source)
    2012-09-12 18:32:09 [INFO] [STDERR] at java.security.AccessController.doPriv
    ileged(Native Method)
    2012-09-12 18:32:09 [INFO] [STDERR] at java.net.URLClassLoader.findClass(Unk
    nown Source)
    2012-09-12 18:32:09 [INFO] [STDERR] at java.lang.ClassLoader.loadClass(Unkno
    wn Source)
    2012-09-12 18:32:09 [INFO] [STDERR] at java.lang.ClassLoader.loadClass(Unkno
    wn Source)
    2012-09-12 18:32:09 [INFO] [STDERR] at java.lang.Class.forName0(Native Metho
    d)
    2012-09-12 18:32:09 [INFO] [STDERR] at java.lang.Class.forName(Unknown Sourc
    e)
    2012-09-12 18:32:09 [INFO] [STDERR] at cpw.mods.fml.relauncher.ReflectionHel
    per.getClass(ReflectionHelper.java:151)
    2012-09-12 18:32:09 [INFO] [STDERR] ... 5 more

    Link to this launcher?
  • #82
    How do u make mod loader?
    ~banjo226
  • #83
    Quote from banjo226

    How do u make mod loader?

    What drivel are you spouting?
  • #84
    I'm having an issue with FML and Optifine. When having Optifine installed I cannot permanently change the controls for some keys. I don't know exactly what keys, what I think it is, is that it's the keys for modloader mods. Example mods where I cannot change the key for is Console, Summon and InvTweaks. I can start MC, change them, restart MC and the keys have been reset.
  • #85
    Quote from luacs1998

    Get forge.

    Link to this launcher?


    Sure https://github.com/R...asyMineLauncher

    just handy as the kids only have to click the batch file and it goes straight into the game for them to either single play or connect to LAN bukkit to wreak havock <sigh> :)

    anyway i can continue using the anjocaido launcher , unfortunately it still has an update option.
    easyminelauncher was great, no options for the kids to get tangled in.
    Does anyone know if there's a plain batch command line to launch the real minecraft.jar ( not the launcher with the same name how silly to give it the same name) with specified user name on a command line
    something like java <secret commands> <minecraft the real.jar> -user=kiddie1 - server=lan1
    for instance
    Last edited by ohjays: 9/14/2012 10:22:27 PM
  • #86
    Quote from mitchmac
    I have been looking for a FML build for Minecraft 1.2.5 and having trouble because the FML download site says nothing about what version of Minecraft the builds are for. There are a few new mods out there for MC1.2.5 that require FML. I have some old FML downloads but they are all for server side and a search for the client side file turns up nothing.


    FML 2.2.106.176 was the final version of FML for Minecraft 1.2.5 I believe. All three versions of it are on the Github Downloads page, but here are the links directly:


    FML 176 for mc1.2.5

    Client
    Server
    Source
  • #87
    so if I have a Forge Mod Loader, I don't need to install Risugami's Mod Loader? Does Forge Mod Loader support all the mods?
  • #88
    Quote from ohjays

    Sure https://github.com/R...asyMineLauncher

    just handy as the kids only have to click the batch file and it goes straight into the game for them to either single play or connect to LAN bukkit to wreak havock <sigh> :)

    anyway i can continue using the anjocaido launcher , unfortunately it still has an update option.
    easyminelauncher was great, no options for the kids to get tangled in.
    Does anyone know if there's a plain batch command line to launch the real minecraft.jar ( not the launcher with the same name how silly to give it the same name) with specified user name on a command line
    something like java <secret commands> <minecraft the real.jar> -user=kiddie1 - server=lan1
    for instance

    As far as I know, you can only do that with Mojang's launcher jar.
    Quote from okok99haha

    so if I have a Forge Mod Loader, I don't need to install Risugami's Mod Loader? Does Forge Mod Loader support all the mods?

    Nope. FML is supposed to be fully compatible.
  • #89
    can you make an fix for the wireless redstone mod, please?
  • #90
    apparently forge modloader is f'ing my life
  • #91
    Alright I have a question since I am basically an idiot and I dont understand half of what is being said here.

    Currently I have a Better than Wolves Build for 1.3.2 and I also have some mods that are Modloader only but not Lan. Will this allow those mods to work in Lan?

    Thanks!!
  • #92
    Quote from dizney23

    Alright I have a question since I am basically an idiot and I dont understand half of what is being said here.

    Currently I have a Better than Wolves Build for 1.3.2 and I also have some mods that are Modloader only but not Lan. Will this allow those mods to work in Lan?

    Thanks!!
    No. There is no magic fix to make an SSP mod work in SMP or lan. The mod dev has to code the mod to work that way.
    You agreed to follow them when you made your account here.
  • #93
    Quote from dizney23

    Alright I have a question since I am basically an idiot and I dont understand half of what is being said here.

    Currently I have a Better than Wolves Build for 1.3.2 and I also have some mods that are Modloader only but not Lan. Will this allow those mods to work in Lan?

    Thanks!!

    As BTW is designed for LAN/SMP, it should work.
  • #94
    Um guys use Minecraft Forge, here is the link:

    http://www.minecraftforge.net/forum/index.php

    You can use this because FML 1.3.2 is included in the mod. Also Minecraft Forge will not work with Better Than Wolves because FlowerChild is acting like a child and programmed his mod to not work with Forge.
  • #95
    Quote from cambobambo

    Um guys use Minecraft Forge, here is the link:

    http://www.minecraft...forum/index.php

    You can use this because FML 1.3.2 is included in the mod. Also Minecraft Forge will not work with Better Than Wolves because FlowerChild is acting like a child and programmed his mod to not work with Forge.

    You don't say? :)
    Hence the name Forge Mod Loader.
  • #96
    I suppose FlowerChild may have had a point when it came to OP-ness and reasonable progression of the mod...
    Ecu seems to be coming around to the same line of thought too, although he's responding by nerfing his own mod.

    Does BTW actually work with FML, though? I would think not, but if it was just an install of FML and not Forge itself, could it?
    Can end-users actually install just FML easily?
    70% of people have signatures that try and boost their superiority complexes. Post this if you're a hypocrite.
  • #97
    ARG why wont it just go AWAY!
  • #98
    Yes, it is official, FML is updated to 1.4. Grab the MCP 7.17 pre release to build your mod for 1.4. Changes haven't been massive.. most of your stuff should 'just work'
    A cool banner was here, but it has been removed
  • #99
    Quote from cpw

    Yes, it is official, FML is updated to 1.4. Grab the MCP 7.17 pre release to build your mod for 1.4. Changes haven't been massive.. most of your stuff should 'just work'


    Thank you for actually using the pre-release for what it is intended for: updating the API libraries before the release is official!

    Version 2.1 now updated for MC 1.6.2
  • #100
    When i install it, it says done loading and doesnt finish :(
    Windows 8 is the best
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes