1.7.5

Sonic Ether's Unbelievable Shaders v10.1

  • #781
    i get no textures when i do this just colours D: any help pls
  • #782
    IDK what im doing wrong. Ive dl'ed a fresh Minecraft, installed Optifine (the verison said in the instructions) and opened up the installer and pressing "Install mods". No change at ALL except the stuff following optifine...
  • #783
    My problems,
    1.To much bloomn shiny, my eyes bleeding, how to fix it
    2. I dont have depth of field and motion blur
  • #784
    Yeah, I can't seem to get it to work. I've tried all kinds of variations between the different modifications, but nothing is working. Could I get like a video tutorial or something? Thanks.

    -Majent
  • #785
    Amazing mod.

    I have a pair of tricks to raise the performance:

    First tip its to download the latest lwjgl from the official web then replace jars and natives (jars .minecraft/bin) (Natives .minecraft/bin/natives).
    This can improve the performance a bit for both Ati and Nvidia cards.

    If you have an ati card u must try deactivating Advanced Opengl cause only works to increase performance but Ati cards seems to have more performance with this feature disabled.

    In my case Smooth Fps on cause -11 fps 34-38 vs 45-48 fps.

    And thats all... i have 45-48 fps now with a 6870 i'm pretty sure i can raise the performance more cause the gpu usage its in 78% if i figured out something i get back to you.

    P.D. Sorry for my bad english xD

    And screens:


    Last edited by Sdar: 1/18/2012 10:00:56 AM
  • #786
    Is there any way to disable the DOF? It kind of bothers me.
    Honestly, I don't have much to say here.
    ... Bye.
  • #787
    goto page 52 for an updated version of this for minecraft 1.1.


    This old version might still be more accurate for the minecraft 1.0 version of dynamic shadows.

    putting this backup in spoiler tags should save your scrolling wheel some time.

    This list edits quickly, leaving many typos:

    Do not try glsl shadow shaders with an intel graphic card, it almost certainly will not work. You could still try to use a shader-model-2.0 emulator. If you know one that works with minecraft tell here.

    start the glsl shader installer. All glsl shaders will always use an installer, deal with it. In win7 You need admin priviledges (or UAC disabled) to run the glsl installer.
    If you see 2 lines in the installer and one of them is "version 1.0.0 just right klick it and remove it. (this appears on some hardware and doesnt on other hardware.
    After your glsl shader installation, check the installation log for installation errors.

    I you see an installation error the installer failed to install. But you very likely are still be able to have dynamic shadows in minecraft. (All you need is to copy the jar file from another pc where the installation worked. This might not even need the same graphic card on both pcs.). You might also find other shader installers that work in the general glsl thread.

    Your minecraft.jar file should now have a "shaders" folder. The first post here has another zip with the shaders only, this one is more up to date, replace them for better performance and less missunderstandings!

    All the shader files in the minecraft.jar shader folder are plain text files and can be configured. this forum tells you how. We now configure the shadow shader to make sure it works at all if it can.

    To be on the save side use low detail settings at first by changing the composite.fsh in the minecraft.jar shader folder part:
    /* shadowres:4096 */

    to
    /* shadowres:2048 */
    for graphic cards older than 2010 (shadows as blocky as 16x16 textures)

    to
    /* shadowres:1024 */
    for graphic cards older than 2008

    to
    /* shadowres:512 */
    for graphic cards older than 2006

    or to to
    /* shadowres:128 */
    for graphic cards from 2002 to 2004 (shadows as blocky as minecraft blocks) dynamic shadows use shader model 1.0
    , while most other glsl shaders use shader model 2.0, so thats what your graphic card must support at least.most modern gfx drivers add this support to pretty much all gfx cards that are not just intel integrated chips.

    This just makes sure that your graphic card has enough memory to store the shadow-data in a low enough resolution that at least will show up.
    You can later increase that resolution up to something that is still playable in your acceptable framerate and display resolution.

    set your field of view to "normal", all to the left. You can turn off the sky and shadows will no longer be drawn on the sky.

    The most common errors often have the same cause:

    If you see shader effects but no shadows, get a black screen, messed up textures, white shiny areas, lines of shadows, a world loading loop or a blue screen with a hud,you just have to update your graphic driver before wasting any space with more repetitive comments in this tread. If it still does not work please tell your graphic card and driver data here. Decreasing your shadowres even further might help in some cases.

    Some people say they got the shadows working only without optifine, some people claim, they only gt it working after installing optifine. Try it with optifine first and if that fails try again without optifine. If you have texture errors or endless loading time, try it with the default textre pack.

    If you get only 5% to 50% as many frames per seconds everything is working correctly:

    You can increase your frames per second by lowering your screen resolution, lowering your FSAA setting, disabling other shaders in the final.fsh file, tweak around in optifine (disabling distance fog and lowering draw distance helps, sine shadows are not rendered at high distance anyways) or buying a new graphic card. This shader works nicely with ony 2gb of mainboard ram on relatively old dual core. All it demands is a high end graphic card. Without one you can still make great screenshots while finding a good place playing in a small window.

    Once you found a smoothly running /* shadowres:1024 */ value you can increase the shadow detail on cost of the maximum visibility range of shadows, or increase the range on cost of shadow detail, by changing the other parameter, \* SHADOWHPL:60 *\ to anything between 10.0 (sharpest shadows) and 180.0 (highest range) (anything outside this range barely ever makes any sense within minecraft). Increasing SHADOWHPL also needs you to changeother constants to the same value, or shadows will invert in the distance when you fly very high and look down.

    I did all these videos with a 3 year old pc on a gf9600 and I just halved my SHADOWDETAIL for the video because of fraps (german multiplayer server on my laptop, that has more ram for this task):

    This video only uses the tweaks mentioned above and it does NOT make use of the tweaks mentioned BELOW while it looks great during day, its just too bright most of the time and could use more contrast (and ravands 64x64 texture pack with misas mob textures).
    http://www.youtube.com/watch?v=f7AsWkLm8qc&feature=player_detailpage&list=PLA069B01BD6766DBE#t=28s
    Most people enjoy dynamic shadows like this, but I demanded more realistic brightness and contrast, some fixes and performance tweaks, so I played around with HDR and brightness settings...

    In comparison this video uses HDR and a much more realistic brightness setting at night and in the nether with maximum contrast. The hand is no longer transparent and other less usefull shaders are disabled to ensure a similar performance:
    http://www.youtube.com/watch?v=MPhoPBymduI
    nether and nighttime

    http://www.youtube.com/watch?v=Htsh_9uDdqc
    daytime in comparison with the same settings

    --more optimization per shader: ---

    You can always increase /* SHADOWRES:4096 */ to a higher value, but this will lower your fps and increase your world loading time and your graphic card will only support shadowres up to an unknown limit (resulting in an infinitely long loading time).

    To make your hand no longer transparent and even add self-shadowing to your hand and the item in it, change the gbuffers_hand.fsh to
    #version 120

    varying vec4 color;
    varying vec4 texcoord;
    varying vec4 lmcoord;
    varying vec3 normal;

    void main() {
    gl_Position = ftransform();
    color = gl_Color;
    texcoord = gl_TextureMatrix[0] * gl_MultiTexCoord0;
    lmcoord = gl_TextureMatrix[1] * gl_MultiTexCoord1;
    normal = gl_Normal;
    }
    as described 1 post below this.

    Just use Optifine for much better performance:
    Disable distance fog and depth fog.
    Set preload-chunks to a low value but not to 0, Increase it only when you travel a lot.
    You can set draw distance shorter, since shadows by default will not render to the horizon anyways.
    Setting everything to fast instead of fancy adds a few fps.
    Check out all the buttons that show up when you klick the lowest few buttons of the optifine settings.
    Make sure smoothfps is turned OFF with this shader (while it should be turned ON without shadows).
    Set mip-mapping to 4 (max), this is faster and looks better.
    Disabling advancedOpenGL (this just tries some visibility calculations but it is sometimes faster without) has shown much better performance on ATI, while enabling advancedopengl (or setting it to fast) has shown much better performance on NVIDIA (especially in caves).
    Disable as many features as you want to, like bettergrass or bettersnow.

    ---

    To make this shader look better you edit the final.fsh to ad add "//" infront of all "#dedfine..." lines EXCEPT for

    #define HDR (this enables high dynamic range as known from HL-lostCoast, essential to fix some errors in the nether and it helps the mood of this mod, sadly it causes some flickering on bright surfaces during the day.)
    #define CROSSPROCESS (this is essential if you use HDR with this shader)
    #define BRIGHTMULT 0.3 (this must be enabled and changed from 1.0 to 0.3 or 0.4, or HDR will make everything too bright)
    #define MOTIONBLUR (this is optional, but it really helps to cover up flickering shadows and flickering HDR sky during movement, especially on older graphic cards)
    #define HIGHDESATURATE (also essential to adjust the brightness)

    --- the following shaders are better disabled if you use shadows and HDR, because they do not add too much to this shadow shader, or are not working too well with it:


    //*DOF (dept of field autofocus doesnt really go well with this mod, shadows are already blurry by default and motionblur adds more than enough blur when its needed most by the shadow shader. some DOF shaders do not work at all with motionblur AND shadows)
    //*GODRAYS* are Crepuscular Rays, similar to lens flare effects. They do not work too well with shadows because they have a similar effect. They do work nicely with hadows but adjusting the brightness to see them it is very tricky, even without HDR. You can barely see godrays when shadows are enabled, therefore this shader is better off. But you should definitely turn it on for screenshots like this:
    http://www.youtube.com/watch?v=6ndHks2wJQ4

    //*BLOOM* (bloom, bloom never changes. bloom was invented by lowres console graphics to make everything look smoother and shinier. minecraft really doesnt need that ****. HDR already adds more "shinyness" and ambience than bloom could ever deliver.)
    //CEL_SHADING* (celshading creates cartoony outlines, this jjust doesnt make sense with smoothened shadoes)
    //SSAO* (is http://en.wikipedia.org/wiki/Screen_Space_Ambient_Occlusion, but who needs ambient occlusion if you have HDR and dynamic shadows, this just eats too much performance and adds too litle to shadows and minecraft in general. only enable SSAO when you also use a HD texture. SSAO goes very well together with bumpmapping, but the shadow shader does not yet work with bumpmaping)

    ---
    other performance enhanchers:

    just read the post 2 posts above this by Sdar, this is tricky and i wont repeat him.
    Last edited by username_not_taken: 1/20/2012 5:22:08 PM
  • #788
    I fixed the shadows going on top of the player's hand by using a different gbuffers_hand.fsh and gbuffers_hand.vsh.

    gbuffers_hand.fsh:
    #version 120
    
    uniform sampler2D texture;
    uniform sampler2D lightmap;
    
    varying vec4 color;
    varying vec4 texcoord;
    varying vec4 lmcoord;
    varying vec3 normal;
    
    void main() {
    
    	gl_FragData[0] = texture2D(texture, texcoord.st) * texture2D(lightmap, lmcoord.st) * color * vec4(1.0, 1.0, 1.0, 1.0);
    	//gl_FragData[1] = vec4(0.0);
    	gl_FragData[1] = vec4(vec3(gl_FragCoord.z), 1.0);
    	gl_FragData[2] = vec4(normal * 0.5 + 0.5, 1.0);
    	gl_FragData[4] = vec4(0.0, 0.0, 0.0, 1.0);
    		
    }


    gbuffers_hand.vsh:
    #version 120
    
    varying vec4 color;
    varying vec4 texcoord;
    varying vec4 lmcoord;
    varying vec3 normal;
    
    void main() {
    	gl_Position = ftransform();
    	
    	color = gl_Color;
    	
    	texcoord = gl_TextureMatrix[0] * gl_MultiTexCoord0;
    
    	lmcoord = gl_TextureMatrix[1] * gl_MultiTexCoord1;
    	
    	normal = gl_Normal;
    }


    EDIT:

    Also does anyone know if it's possible to get godrays and leave the sky turned on? Not having a sky is ugly.
    Last edited by Kentoss: 1/18/2012 10:07:38 AM
  • #789
    Help!
    I'm having a weird bug.
    Pic:
  • #790
    People need to read some of the posts before posting their questions.....everyone is repeating the same thing when the solution is already answered on the same page.
  • #791
    Mojang should add this as an option in the game.

    Good job :iapprove:
    I hate you
  • #792
    Quote from Kentoss

    I fixed the shadows going on top of the player's hand by using a different gbuffers_hand.fsh and gbuffers_hand.vsh.


    Now, when you get wood and see the shadows from the leaves on the log that you just cut, you will get wood.

    The first person character model is even casting a shadow on itself. Too bad I can not see my own feet.
    Last edited by username_not_taken: 1/18/2012 10:42:37 AM
  • #793
    Everytime i try to install it i get the kz class is frozen
  • #794
    im getting this http://imgur.com/PswP9 when im going underwater and there are still somethings to improve like performance (getting only 30 fps) but there is nothing else is to complain about ^^.
  • #795
    2 small errors: (almost all other shaders disabled)

    current version has fire, torches and glowstone not show any brighter area around them but ONLY in the nether. enabling the HDR shader fixes this up to a point that is essential for the nether to look incredible. (solvable by nabling HDR, scroll down)

    Shadows are often hanging in the air when the lightsource is low on the horizon and you look up to something that casts a shadow.
    Last edited by username_not_taken: 1/18/2012 1:13:33 PM
  • #796
    Quote from LuckystrikeFTW

    im getting this http://imgur.com/PswP9 when im going underwater and there are still somethings to improve like performance (getting only 30 fps) but there is nothing else is to complain about ^^.


    this is likely because of a transparentWater or deptFog setting in optifine.

    dnamic shadows are not placed underwater. all you see underwater is the SSAO shader overlay. you can disable all SSAO shaders in the finals.fsh , they do not look as good in combination with dynamic shadows.
    Last edited by username_not_taken: 1/18/2012 1:13:53 PM
  • #797
    alright i made sure i updated my grafic card and that it was with sky off blablabla..

    but now i have a weird bug, okay now when i stand with my back against the sun i see on the ground infront of me only white with transparent blocks inside them and when i turn around it just looks fine (so my front is now looking at the sun(well the direction)).

    Pic's:

    http://imgur.com/a/LEr2c

    sooo thats my problem btw this is the shader folder:(think it was) bumps-shadows-optifine-required.

    when i plunk in shadwos-optifine-required then it all fine but i still want to know what this bug is
    Mods i use:
    cjb's modpack
    modloader
    optfine
    and this one

    i have average fps atm ~30 a intelcore i5 and 4gb ram (a gt520 1024mb 48 cores(or smthing))

    i will go check what the other shaders show

    k i think its something with the bumpmaping
    Last edited by tweeter2: 1/18/2012 11:02:00 AM
  • #798
    Quote from tweeter2

    alright i made sure i updated my grafic card and that it was with sky off blablabla..

    but now i have a weird bug, okay now when i stand with my back against the sun i see on the ground infront of me only white with transparent blocks inside them and when i turn around it just looks fine (so my front is now looking at the sun(well the direction)).

    Pic's:

    http://imgur.com/a/LEr2c

    sooo thats my problem btw this is the shader folder:(think it was) bumps-shadows-optifine-required.

    when i plunk in shadwos-optifine-required then it all fine but i still want to know what this bug is
    Mods i use:
    cjb's modpack
    modloader
    optfine
    and this one

    i have average fps atm ~30 a intelcore i5 and 4gb ram (a gt520 1024mb 48 cores(or smthing))

    i will go check what the other shaders show

    k i think its something with the bumpmaping


    I get that very glitch when trying to use bumpmapping. IMHO bumpmapping is really not something that minecraft would benefit from.
  • #799
    Quote from sonicether

    I get that very glitch when trying to use bumpmapping. IMHO bumpmapping is really not something that minecraft would benefit from.

    soooo what do i need to do?(whats IMHO?)
    and eh how do u get ur shadows like in ur banner? mine are really eh foggy? i think i can say that(there is almost no shadow of tall grass or sugar canes)
    owh and eh when i use shadows-optifine-required.
    then when i pont at an random entity(doesnt matter which one a pig or a player)my hands get transparent.
    Last edited by tweeter2: 1/18/2012 11:24:31 AM
  • #800
    Great mod. I'm wanting to continue my LP with this, but all I want is the Dynamic Shadows part of it. Is there anyway to just have that part of the mod? (is it as simple as just adding the shadow shader file into the jar?)
    My YouTube Gaming Channel with Minecraft, South Park, Fallout 3 and much, much more.
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes