1.7.10 Optimisation

OptiFine HD A4 (FPS Boost, HD Textures, AA, AF and much more)

Poll: FPS increase with OptiFine

FPS increase with OptiFine - Single Choice

  • 0% 6.5%
  • 10% 7.1%
  • 25% 9.3%
  • 50% 18.1%
  • 100% 18%
  • 200%+ 41.1%
  • #20092
    Yay for a crash..
    3 mods loaded
    Optifine OptiFine_1.2.5_HD_MT_C6
    Minecraft Forge 3.3.8.152
    FML v2.2.78.153
    Forge Mod Loader version 2.2.78.153 for Minecraft 1.2.5
    mod_Aether : Available (Aether Jar Files 1.2.5.zip)
    mod_Trivia : Available (Aether Jar Files 1.2.5.zip)
    mod_MinecraftForge : Available (MinecraftForge-3.3.8.152-Client.zip)


    Minecraft has crashed!
    ----------------------

    Minecraft has stopped running because it encountered a problem.




    --- BEGIN ERROR REPORT 6ac10960 --------
    Generated 22/07/12 9:30 PM

    Minecraft: Minecraft 1.2.5
    OS: Windows 7 (amd64) version 6.1
    Java: 1.7.0_04-ea, Oracle Corporation
    VM: Java HotSpotâ„¢ 64-Bit Server VM (mixed mode), Oracle Corporation
    LWJGL: 2.4.2
    OpenGL: ATI Radeon HD 4350 version 3.3.10765 Compatibility Profile Context, ATI Technologies Inc.

    java.lang.NullPointerException
    at mod_Aether.keyboardEvent(mod_Aether.java:238)
    at BaseMod.keyBindingEvent(BaseMod.java:35)
    at cpw.mods.fml.common.modloader.ModLoaderModContainer.keyBindEvent(ModLoaderModContainer.java:711)
    at cpw.mods.fml.client.KeyBindingHandler.onEndTick(KeyBindingHandler.java:70)
    at cpw.mods.fml.client.FMLClientHandler.onPostWorldTick(FMLClientHandler.java:258)
    at net.minecraft.client.Minecraft.k(Minecraft.java:1892)
    at net.minecraft.client.Minecraft.x(Minecraft.java:822)
    at net.minecraft.client.Minecraft.run(Minecraft.java:750)
    at java.lang.Thread.run(Unknown Source)
    --- END ERROR REPORT 49f0eff ----------
    I'm running Minecraft with the magic launcher. And installed the following mods with magic launcher is this order:
    Minecraft forge 152
    Player api 1.5
    Aether 1.9 pre release for 1.2.5
    fps++ (official update by fishtaco)
    Better animations with most of the extras
    Lava fix (makes lava disappear like water)
    Optifine MT C6
    It seems like it crashes when i was entering a seed and pressed the b key. It happened twice at that exact moment. Please help.
    Edit: This is directly after a clean installation (completely new .minecraft folder)
    Last edited by MattThePadawan: 7/22/2012 4:44:34 AM
    With the Better Than Wolves mod!
  • #20093
    Quote from Bobrocket

    Using Ubuntu 12.04, I discovered some graphical glitches on optifine (that never happened on normal minecraft):

    -The sign body (where the text is) turns invisible, and occasionally the sign stand turns into random blocks from the tileset. (http://i.imgur.com/MJJki.png)
    -Double chests always appear to have their tops off, but not normal chests. (http://i.imgur.com/BJFZd.png)
    -The game halves my FPS when there is more than 2 mobs within a close proximity

    Edit:
    -When in the inventory screen, sometimes I can be seen with missing body parts. (http://i.imgur.com/ZzL3K.png)
    -Sometimes, mobs appear with random blocks from the tileset as their skin. (http://i.imgur.com/bgCl3.png)

    I'll edit this post with any more bugs I find.
    Thanks!


    Had that too :-(
    All I know for sure is that it has something to do with the multithreading feature. Since I have not yet discovered how to disable the "threaded optimization" feature on linux, I had to switch to the smooth version of optifine. Ever since I haven't had any more problems regarding that issue.


    Hope I could help.
  • #20094
    Im getting a really weird problem. All of the versions of optifine are making grass grow underwater. Its really annoying because the bottoms of pools and rivers are getting covered in grass. Any idea whats the matter? Heres a log if that helps.


    *** MagicMinecraftLauncher 0.9.8 ***
    Disable inactive mods
    27 achievements
    182 recipes
    LWJGL Version: 2.4.2
    OptiFine_1.2.5_HD_C6
    Sun Jul 22 10:14:20 EDT 2012
    OS: Windows 7 (x86) version 6.1
    Java: 1.6.0_14, Sun Microsystems Inc.
    VM: Java HotSpot(TM) Client VM (mixed mode), Sun Microsystems Inc.
    LWJGL: 2.4.2
    OpenGL: Mobile Intel(R) 4 Series Express Chipset Family version 2.1.0 - Build 8.15.10.1883, Intel
    OpenGL Version: 2.1
    OpenGL Fancy fog: Not available (GL_NV_fog_distance)
    Checking for new version
    setupTexture: "/title/mojang.png", id: 1
    Jul 22, 2012 10:14:20 AM cpw.mods.fml.common.FMLCommonHandler beginLoading
    INFO: Attempting early MinecraftForge initialization
    Jul 22, 2012 10:14:20 AM cpw.mods.fml.common.FMLCommonHandler beginLoading
    INFO: Completed early MinecraftForge initialization
    2012-07-22 10:14:20 [INFO] Forge Mod Loader version 2.2.78.153 for Minecraft 1.2.5 loading
    2012-07-22 10:14:20 [INFO] Forge Mod Loader has detected optifine OptiFine_1.2.5_HD_C6, enabling compatibility features
    2012-07-22 10:14:21 [INFO] Loading mods from C:\Users\jacob\AppData\Roaming\.minecraft\mods
    2012-07-22 10:14:21 [INFO] Directory sppcommands contained no mods
    2012-07-22 10:14:21 [INFO] Forge Mod Loader has loaded 4 mods
    WARNING: Found unknown Windows version: Windows 7
    Attempting to use default windows plug-in.
    Loading: net.java.games.input.DirectAndRawInputEnvironmentPlugin
    Version found: C6
    MinecraftForge v3.3.8.152 Initialized
    2012-07-22 10:14:21 [INFO] MinecraftForge v3.3.8.152 Initialized
    ModLoaderMP 1.0.0 Initialized
    2012-07-22 10:14:21 [INFO] Forge Mod Loader load complete, 4 mods loaded
    Starting up SoundSystem...
    Initializing LWJGL OpenAL
    (The LWJGL binding of OpenAL. For more information, see http://www.lwjgl.org)
    OpenAL initialized.
    setupTexture: "/terrain.png", id: 7
    TextureFX registered: bv@39060b, texId: 7, index: 237
    TextureFX registered: qa@67fe80, texId: 7, index: 205
    TextureFX registered: zp@ffeef1, texId: 7, index: 14
    setupTexture: "/gui/items.png", id: 8
    TextureFX registered: tu@3bc1a1, texId: 8, index: 54
    TextureFX registered: ht@1dcc4cd, texId: 8, index: 70
    TextureFX registered: ael@fccada, texId: 7, index: 206
    TextureFX registered: gf@69ed4a, texId: 7, index: 238
    TextureFX registered: nh@59cbda, texId: 7, index: 31
    TextureFX registered: nh@1567e6c, texId: 7, index: 47
    TextureFX removed: bv@39060b, texId: 7, index: 237
    TextureFX registered: TextureHDLavaFX@1248f2b, texId: 7, index: 237
    TextureFX removed: qa@67fe80, texId: 7, index: 205
    TextureFX registered: TextureHDWaterFX@4e21db, texId: 7, index: 205
    TextureFX removed: zp@ffeef1, texId: 7, index: 14
    TextureFX registered: TextureHDPortalFX@1b2b131, texId: 7, index: 14
    TextureFX removed: ael@fccada, texId: 7, index: 206
    TextureFX registered: TextureHDWaterFlowFX@8f3d27, texId: 7, index: 206
    TextureFX removed: gf@69ed4a, texId: 7, index: 238
    TextureFX registered: TextureHDLavaFlowFX@1f7cdc7, texId: 7, index: 238
    TextureFX removed: nh@59cbda, texId: 7, index: 31
    TextureFX registered: TextureHDFlamesFX@d402dd, texId: 7, index: 31
    TextureFX removed: nh@1567e6c, texId: 7, index: 47
    TextureFX registered: TextureHDFlamesFX@1e4905a, texId: 7, index: 47
    TextureFX removed: tu@3bc1a1, texId: 8, index: 54
    TextureFX registered: TextureHDCompassFX@d510e8, texId: 8, index: 54
    TextureFX removed: ht@1dcc4cd, texId: 8, index: 70
    TextureFX registered: TextureHDWatchFX@1458dcb, texId: 8, index: 70
    Loading custom colors: /misc/grasscolor.png
    Loading custom colors: /misc/foliagecolor.png
    setupTexture: "/ctm.png", id: 9
    MatchingCtmPng: true
    Registering default ConnectedTextures
    setupTexture: "/title/bg/panorama0.png", id: 11
    setupTexture: "/title/bg/panorama1.png", id: 12
    setupTexture: "/title/bg/panorama2.png", id: 13
    setupTexture: "/title/bg/panorama3.png", id: 14
    setupTexture: "/title/bg/panorama4.png", id: 15
    setupTexture: "/title/bg/panorama5.png", id: 16
    setupTexture: "/title/mclogo.png", id: 17
    setupTexture: "/gui/gui.png", id: 18
    setupTexture: "/gui/particles.png", id: 19
    setupTexture: "/gui/background.png", id: 20
    Commands: 145
    Attempting to load: spc_paint
    Attempting to load: spc_path
    Attempting to load: spc_WorldEdit
    java.lang.Exception: Check WorldEdit.jar is in the correct location
    at spc_WorldEdit.<init>(spc_WorldEdit.java:64)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
    at java.lang.reflect.Constructor.newInstance(Unknown Source)
    at java.lang.Class.newInstance0(Unknown Source)
    at java.lang.Class.newInstance(Unknown Source)
    at SPCPluginManager.loadPlugin(SPCPluginManager.java:211)
    at SPCPluginManager.loadPlugins(SPCPluginManager.java:120)
    at PlayerHelper.<init>(PlayerHelper.java:443)
    at vq.initPlayerHelper(EntityPlayerSP.java:901)
    at vq.<init>(EntityPlayerSP.java:68)
    at ki.b(PlayerController.java:118)
    at aes.b(PlayerControllerSP.java:190)
    at net.minecraft.client.Minecraft.a(Minecraft.java:2090)
    at net.minecraft.client.Minecraft.a(Minecraft.java:2032)
    at net.minecraft.client.Minecraft.a(Minecraft.java:1949)
    at mw.c(SourceFile:171)
    at mw.a(SourceFile:128)
    at vp.a(SourceFile:74)
    at vp.f(SourceFile:122)
    at vp.i(SourceFile:110)
    at net.minecraft.client.Minecraft.k(Minecraft.java:1567)
    at net.minecraft.client.Minecraft.x(Minecraft.java:822)
    at net.minecraft.client.Minecraft.run(Minecraft.java:750)
    at java.lang.Thread.run(Unknown Source)
    setupTexture: "/terrain/sun.png", id: 22
    setupTexture: "/terrain/moon_phases.png", id: 23
    Class not present: LightCache
    setupTexture: "/environment/clouds.png", id: 24
    setupTexture: "/mob/char.png", id: 25
    setupTexture: "/gui/icons.png", id: 26
    setupTexture: "%blur%/misc/glint.png", id: 27
    setupTexture: "/particles.png", id: 28
    setupTexture: "/achievement/bg.png", id: 29
    setupTexture: "/mob/spider.png", id: 30
    setupTexture: "/mob/spider_eyes.png", id: 31
    setupTexture: "/mob/creeper.png", id: 32
    setupTexture: "/mob/skeleton.png", id: 33
    setupTexture: "/mob/zombie.png", id: 34
    setupTexture: "/item/chest.png", id: 35
    setupTexture: "/gui/inventory.png", id: 36
    setupTexture: "/codechicken/nei/nei_sprites.png", id: 37
    setupTexture: "/mob/squid.png", id: 38
    setupTexture: "/mob/cow.png", id: 39
    Allocated subtessellator, count: 1
  • #20095
    Quote from MattThePadawan

    Yay for a crash..
    3 mods loaded
    Optifine OptiFine_1.2.5_HD_MT_C6
    Minecraft Forge 3.3.8.152
    FML v2.2.78.153
    Forge Mod Loader version 2.2.78.153 for Minecraft 1.2.5
    mod_Aether : Available (Aether Jar Files 1.2.5.zip)
    mod_Trivia : Available (Aether Jar Files 1.2.5.zip)
    mod_MinecraftForge : Available (MinecraftForge-3.3.8.152-Client.zip)


    Minecraft has crashed!
    ----------------------

    Minecraft has stopped running because it encountered a problem.




    --- BEGIN ERROR REPORT 6ac10960 --------
    Generated 22/07/12 9:30 PM

    Minecraft: Minecraft 1.2.5
    OS: Windows 7 (amd64) version 6.1
    Java: 1.7.0_04-ea, Oracle Corporation
    VM: Java HotSpotâ„¢ 64-Bit Server VM (mixed mode), Oracle Corporation
    LWJGL: 2.4.2
    OpenGL: ATI Radeon HD 4350 version 3.3.10765 Compatibility Profile Context, ATI Technologies Inc.

    java.lang.NullPointerException
    at mod_Aether.keyboardEvent(mod_Aether.java:238)
    at BaseMod.keyBindingEvent(BaseMod.java:35)
    at cpw.mods.fml.common.modloader.ModLoaderModContainer.keyBindEvent(ModLoaderModContainer.java:711)
    at cpw.mods.fml.client.KeyBindingHandler.onEndTick(KeyBindingHandler.java:70)
    at cpw.mods.fml.client.FMLClientHandler.onPostWorldTick(FMLClientHandler.java:258)
    at net.minecraft.client.Minecraft.k(Minecraft.java:1892)
    at net.minecraft.client.Minecraft.x(Minecraft.java:822)
    at net.minecraft.client.Minecraft.run(Minecraft.java:750)
    at java.lang.Thread.run(Unknown Source)
    --- END ERROR REPORT 49f0eff ----------
    I'm running Minecraft with the magic launcher. And installed the following mods with magic launcher is this order:
    Minecraft forge 152
    Player api 1.5
    Aether 1.9 pre release for 1.2.5
    fps++ (official update by fishtaco)
    Better animations with most of the extras
    Lava fix (makes lava disappear like water)
    Optifine MT C6
    It seems like it crashes when i was entering a seed and pressed the b key. It happened twice at that exact moment. Please help.
    Edit: This is directly after a clean installation (completely new .minecraft folder)



    By the looks of it, this crash is between forge and aether, not optifine.


    Quote from breezedevil

    I have got the same problem. Here's my crash log.

    OptiFine_1.2.5_HD_MT_C6
    Sun Jul 22 08:19:11 EST 2012
    OS: Windows Vista (x86) version 6.0
    Java: 1.7.0_05, Oracle Corporation
    VM: Java HotSpot(TM) Client VM (mixed mode), Oracle Corporation
    LWJGL: 2.8.4
    OpenGL: GeForce 8400 GS/PCIe/SSE2 version 3.3.0, NVIDIA Corporation
    OpenGL Version: 3.3
    Method not found: forge.ForgeHooksClient.onTextureLoadPre
    Class not present: FMLRenderAccessLibrary
    TextureFX registered: bv@c1f5f, texId: 9, index: 237
    TextureFX registered: qa@1f6ff8d, texId: 9, index: 205
    TextureFX registered: zp@103ac05, texId: 9, index: 14
    TextureFX registered: tu@1d623bb, texId: 10, index: 54
    TextureFX registered: ht@19b9c35, texId: 10, index: 70
    TextureFX registered: ael@12c5c66, texId: 9, index: 206
    TextureFX registered: gf@1663452, texId: 9, index: 238
    TextureFX registered: nh@f508b9, texId: 9, index: 31
    TextureFX registered: nh@10fe5ac, texId: 9, index: 47
    TextureFX removed: bv@c1f5f, texId: 9, index: 237
    TextureFX registered: TextureHDLavaFX@15fff9c, texId: 9, index: 237
    TextureFX removed: qa@1f6ff8d, texId: 9, index: 205
    TextureFX registered: TextureHDWaterFX@1867b45, texId: 9, index: 205
    TextureFX removed: zp@103ac05, texId: 9, index: 14
    TextureFX registered: TextureHDPortalFX@70b7d, texId: 9, index: 14
    TextureFX removed: ael@12c5c66, texId: 9, index: 206
    TextureFX registered: TextureHDWaterFlowFX@836bc5, texId: 9, index: 206
    TextureFX removed: gf@1663452, texId: 9, index: 238
    TextureFX registered: TextureHDLavaFlowFX@186330, texId: 9, index: 238
    TextureFX removed: nh@f508b9, texId: 9, index: 31
    TextureFX registered: TextureHDFlamesFX@117ee9e, texId: 9, index: 31
    TextureFX removed: nh@10fe5ac, texId: 9, index: 47
    TextureFX registered: TextureHDFlamesFX@32ee9c, texId: 9, index: 47
    TextureFX removed: tu@1d623bb, texId: 10, index: 54
    TextureFX registered: TextureHDCompassFX@7a5487, texId: 10, index: 54
    TextureFX removed: ht@19b9c35, texId: 10, index: 70
    TextureFX registered: TextureHDWatchFX@187868c, texId: 10, index: 70
    Loading custom colors: /misc/grasscolor.png
    Loading custom colors: /misc/foliagecolor.png
    Class not present: LightCache
    Method not found: forge.ForgeHooks.onEntityLivingUpdate
    Method not found: forge.ForgeHooks.onEntityLivingJump
    Method not found: forge.ForgeHooks.onEntityLivingFall
    Method not found: forge.ForgeHooks.onEntityLivingAttacked
    Method not found: forge.ForgeHooks.onEntityLivingHurt



    Your crash however, is mentioning that forge files are missing. So either something over-wrote them or they were not installed correctly.


    Quote from iiiHuman


    Do you have OptiFine installed LAST like you are supposed to? Or, "listed" last if using Magic Launcher?

    In the OptiFine settings, do you have the "Time" set to Day Only? What about the "Brightness Level" setting?

    :)


    I actually noticed the same in my game, (yes optifine is last, yes time is set to default, and not night/day only) but i also noticed something else.

    When i went to toggle the Time setting, it went --Default -> Day Only -> Default (again) -> Night Only-- which makes me think there may be a bug in that, at least in the graphical options menu, since normally it should go Def - Day - Night (without the extra default).
    Last edited by Oswarlan: 7/22/2012 9:44:01 AM
  • #20096
    Quote from paleryder22

    Im getting a really weird problem. All of the versions of optifine are making grass grow underwater. Its really annoying because the bottoms of pools and rivers are getting covered in grass. Any idea whats the matter? Heres a log if that helps.


    You probably have Clear Water on. That does that for some reason.

    <div class="g-ytsubscribe" data-channel="TengenToppaLaskeri" data-layout="full" data-theme="dark" data-count="default"></div>
  • #20097
    Is there any way to remove Optifine's ItemRenerderHD.class? I am using Mine Little Pony mod and it is supposed to change the location items are held at but I believe Optifine overrides it even when it is below Mine Little Pony mod in load order.
  • #20098
    THIS MOD IS SO AWESOME IM ADDING IT TO MY MOD PACK!!! :D
    But, I donated and didnt recieve my cape...
  • #20099
    Hey, just downloaded Optifine and it's working pretty great for some server lag issues I was having. However, when I tried to get into my Hardcore single player game, it crashed instantly. It went to black screen too fast for me to see what the error was. I also have the mods Millienaire, Mo' Creatures, and Redstone Power. Not sure if one of those is messing up with Opti.
  • #20100
    Quote from Penni

    Hey, just downloaded Optifine and it's working pretty great for some server lag issues I was having. However, when I tried to get into my Hardcore single player game, it crashed instantly. It went to black screen too fast for me to see what the error was. I also have the mods Millienaire, Mo' Creatures, and Redstone Power. Not sure if one of those is messing up with Opti.


    Try using magic launcher, with the show-log option enabled, to get a crash report.
    Last edited by Oswarlan: 7/22/2012 1:59:25 PM
  • #20101
    I keep getting a game crash when I enter a world. My mods are FML (forge modloader), More creeps and weirdos, Timber, Matmos, Minecraft comes alive, minimap and single player commands. Here is an error report:

    --- BEGIN ERROR REPORT f7c97ccb --------
    Generated 7/22/12 2:08 PM

    Minecraft: Minecraft 1.2.5
    OS: Mac OS X (x86_64) version 10.6.8
    Java: 1.6.0_33, Apple Inc.
    VM: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Apple Inc.
    LWJGL: 2.4.2
    OpenGL: ATI Radeon HD 4670 OpenGL Engine version 2.1 ATI-1.6.36, ATI Technologies Inc.

    cpw.mods.fml.common.LoaderException: cpw.mods.fml.common.LoaderException: java.lang.NoClassDefFoundError: bin/minecraft/mod_MinecraftForge (wrong name: mod_MinecraftForge)
    at cpw.mods.fml.common.Loader.load(Loader.java:436)
    at cpw.mods.fml.common.Loader.loadMods(Loader.java:592)
    at cpw.mods.fml.client.FMLClientHandler.onPreLoad(FMLClientHandler.java:193)
    at net.minecraft.client.Minecraft.a(Minecraft.java:383)
    at net.minecraft.client.Minecraft.run(Minecraft.java:735)
    at java.lang.Thread.run(Thread.java:680)
    Caused by: cpw.mods.fml.common.LoaderException: java.lang.NoClassDefFoundError: bin/minecraft/mod_MinecraftForge (wrong name: mod_MinecraftForge)
    at cpw.mods.fml.common.Loader.loadModClass(Loader.java:527)
    at cpw.mods.fml.common.Loader.attemptDirLoad(Loader.java:474)
    at cpw.mods.fml.common.Loader.attemptDirLoad(Loader.java:463)
    at cpw.mods.fml.common.Loader.attemptDirLoad(Loader.java:463)
    at cpw.mods.fml.common.Loader.load(Loader.java:385)
    ... 5 more
    Caused by: java.lang.NoClassDefFoundError: bin/minecraft/mod_MinecraftForge (wrong name: mod_MinecraftForge)
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:295)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:247)
    at cpw.mods.fml.common.Loader.loadModClass(Loader.java:494)
    ... 9 more
    --- END ERROR REPORT f9f72cfb ----------
  • #20102
    Quote from Crafty06

    I keep getting a game crash when I enter a world. My mods are FML (forge modloader), More creeps and weirdos, Timber, Matmos, Minecraft comes alive, minimap and single player commands. Here is an error report:



    1. Please use spoilers so that the error report doesn't take up a whole page.
    2. It looks to be a broken forge install, missing classes and mal-named forge mods.
  • #20103
    Quote from EPICDUDE73

    THIS MOD IS SO AWESOME IM ADDING IT TO MY MOD PACK!!! :D

    Have you got sp614x's permission?
  • #20104
    Neither the Smooth nor the Standard versions are working for me. I did the installation manually exactly how the instructions suggested. Both give me the same result; a black screen after I log in.

    Was I supposed to extract the zip file before I copied the .class files or open the archive & copy those? I did it through the archive.
  • #20105
    Quote from FrolicField

    Neither the Smooth nor the Standard versions are working for me. I did the installation manually exactly how the instructions suggested. Both give me the same result; a black screen after I log in.

    Was I supposed to extract the zip file before I copied the .class files or open the archive & copy those? I did it through the archive.


    To put it simply, you take all of the files contained in the optifine download zip and place them inside the minecraft.jar.
    If you still blackscreen, you would have to get a crash report to be able to find the cause.
  • #20106
    HD_c6 broke my minecraft with some sort of zombie.entity error or something, i'm not exactly sure what it is, but a clean minecraft doesn't help. I cant copy the log because it crashes, then shows for about 3 seconds and then freezes, so... i'll see what i can do, but for now i'll just revert to HD_C3
  • #20107
    This mod was EPIC!!! I use it all the time and it tripled my FPS!!! :D
    Last edited by Nz360ELITE: 7/22/2012 4:02:04 PM
    When life gives you lemons, throw them at people
  • #20108
    Quote from FrolicField

    Neither the Smooth nor the Standard versions are working for me. I did the installation manually exactly how the instructions suggested. Both give me the same result; a black screen after I log in.

    Was I supposed to extract the zip file before I copied the .class files or open the archive & copy those? I did it through the archive.

    It's easier to use the MagicLauncher
    Quote from Chaolin112

    HD_c6 broke my minecraft with some sort of zombie.entity error or something, i'm not exactly sure what it is, but a clean minecraft doesn't help. I cant copy the log because it crashes, then shows for about 3 seconds and then freezes, so... i'll see what i can do, but for now i'll just revert to HD_C3

    I think the MagicLauncher provides a Log. Could you show us?
  • #20109
    I hate this mod. Whenever you play a multiplayer server, you will crash! FIX IT NOW OR IM GETTING RID OF IT
  • #20110
    Quote from Oswarlan

    Try using magic launcher, with the show-log option enabled, to get a crash report.

    Wait, what is Magic Launcher? Sorry, I've never heard of that.

    Sorry, found the link.
    Last edited by Penni: 7/22/2012 5:16:00 PM
  • #20111
    Here is the error report I am getting.


    Mods loaded: 8
    ModLoader 1.2.5
    mod_MinecraftForge 3.1.2.94
    mod_MinecraftForge 3.1.2.94
    DrZhark's Mo'Creatures v3.5.0 (MC 1.2.5)
    mod_RedPowerCore 2.0pr5b1
    mod_RedPowerLighting 2.0pr5b1
    mod_RedPowerLogic 2.0pr5b1
    mod_RedPowerWiring 2.0pr5b1
    	  Minecraft has crashed!	 
    	  ----------------------	 
    Minecraft has stopped running because it encountered a problem.
    
    
    --- BEGIN ERROR REPORT 99533f6c --------
    Generated 7/22/12 3:18 PM
    Minecraft: Minecraft 1.2.5
    OS: Windows 7 (amd64) version 6.1
    Java: 1.7.0_03, Oracle Corporation
    VM: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    LWJGL: 2.4.2
    OpenGL: AMD M880G with ATI Mobility Radeon HD 4200	  version 2.1.8794, ATI Technologies Inc.
    java.lang.ClassCastException: java.lang.Boolean cannot be cast to java.lang.Integer
    at Reflector.callInt(Reflector.java:199)
    at acq.c(EntityLiving.java:972)
    at acq.a(EntityLiving.java:835)
    at yy.a(SourceFile:42)
    at MoCEntityWerewolf.a(MoCEntityWerewolf.java:81)
    at aer.a(SourceFile:86)
    at nn.b(Entity.java:842)
    at acq.a_(EntityLiving.java:1271)
    at MoCEntityWerewolf.a_(MoCEntityWerewolf.java:251)
    at acq.e(EntityLiving.java:1489)
    at yy.e(SourceFile:26)
    at MoCEntityWerewolf.e(MoCEntityWerewolf.java:285)
    at acq.J_(EntityLiving.java:687)
    at yy.J_(SourceFile:30)
    at xd.a(World.java:2182)
    at xd.f(World.java:2153)
    at xd.n(World.java:2039)
    at net.minecraft.client.Minecraft.k(Minecraft.java:1861)
    at net.minecraft.client.Minecraft.x(Minecraft.java:819)
    at net.minecraft.client.Minecraft.run(Minecraft.java:747)
    at java.lang.Thread.run(Unknown Source)
    --- END ERROR REPORT 46e46ce1 ----------
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes