1.7.10 Optimisation

OptiFine HD A4 (FPS Boost, HD Textures, AA, AF and much more)

Poll: FPS increase with OptiFine

FPS increase with OptiFine - Single Choice

  • 0% 6.5%
  • 10% 7.1%
  • 25% 9.3%
  • 50% 18.1%
  • 100% 18%
  • 200%+ 41.1%
  • #37071
    The instructions for using magic launcher to install it say to "select the optifine zip file". When I downloaded it I got an un-zipped file with all the .class files and such inside it. Should I just compress the file myself or what should I do? Just compress the file myself or is something wrong with he way my computer downloads things?
    If you agree with my post, found it helpful or it made you laugh (in a non mean way) please press that little green + as it reminds me people appreciate me and life!
  • #37072
    It should download as a zip.

    Does you computer show file extensions for files, like .exe or .rar?
    If not, maybe it is a zip, but it doesn't show on-screen as such.

    If you do have file extensions showing on your computer, then maybe download it again with another browser.

    If you do zip it up, make sure you go inside your optifine folder, select everything, and zip all that up, rather than zip the folder up.
    I doubt it would work with the contents contained in a zip and then a folder.
  • #37073
    nvm
    Last edited by deathgleaner: 8/28/2013 12:58:51 PM
    dg
  • #37074
    I haven't seen someone post this problem yet but when i ZOOM, it does it correctly but its all smooth like when i press F8.
    But when i un-zoom it stops making my mouse smooth. Its like it toogles f8 automaticly when i press the zoom button and when i let go it un-toggles it. I have no idea why this is happening and i checked everything in the options menu and theres nothing there that could help.

    maybe my mods are interfering so these are my mods:

    Optifine (obviously)
    rei's minimap
    modloader
    better sprinting
    Armor status HUD and StatusEffect HUD
    BSPKRSCore
    RadarBro.

    All these mods work perfectly together. the only problem in the zoom/smooth bug. please help!
  • #37075
    Optifine actually decreases my FPS, SIGNIFICANTLY. Like, I have an ultra weak and stupid slow computer, and I usually get around 15-20 FPS, maybe 25 if I'm lucky, and I always have to use tiny-normal render distance with fast graphics and Max FPS settings. But when I install Optifine it lags me down to 0-5 FPS, even with your recommended speedy settings. I hate it because I used to use this mod and it made Minecraft SO MUCH FASTER, but now its just a nuisance. Do you have any tips about how to actually make it faster? I love this Mod, but now its not worth it.
  • #37076
    Thank you very much optifine for fixing the capes the being sued rumor was a bit bazar but im very happy its not true

  • #37077
    Quote from Ismitebuildings

    I haven't seen someone post this problem yet but when i ZOOM, it does it correctly but its all smooth like when i press F8.
    But when i un-zoom it stops making my mouse smooth. Its like it toogles f8 automaticly when i press the zoom button and when i let go it un-toggles it. I have no idea why this is happening and i checked everything in the options menu and theres nothing there that could help.

    maybe my mods are interfering so these are my mods:

    Optifine (obviously)
    rei's minimap
    modloader
    better sprinting
    Armor status HUD and StatusEffect HUD
    BSPKRSCore
    RadarBro.

    All these mods work perfectly together. the only problem in the zoom/smooth bug. please help!


    I posted this but it wasn't seen by anybody. Optifine is my only mod so it isn't from a conflict. Are your signs rendering text from more than a few blocks away as mine aren't doing that. 2 bad things about an amazing mod.
  • #37078
    Quote from IXIWarPigX

    Optifine actually decreases my FPS, SIGNIFICANTLY. Like, I have an ultra weak and stupid slow computer, and I usually get around 15-20 FPS, maybe 25 if I'm lucky, and I always have to use tiny-normal render distance with fast graphics and Max FPS settings. But when I install Optifine it lags me down to 0-5 FPS, even with your recommended speedy settings. I hate it because I used to use this mod and it made Minecraft SO MUCH FASTER, but now its just a nuisance. Do you have any tips about how to actually make it faster? I love this Mod, but now its not worth it.

    Check the FAQ.
  • #37079
    What is your rules on modpacks?
  • #37080
    Quote from schpeelah

    You have Forge and Optifine. Do not use MCPatcher.


    ChickenBones' mods such as Ender Storage and MultiBlocks are incompatible with Optifine because they remove the aforementioned lastBrightnessY field from objects, which isn't used by the default Minecraft renderer but is used by Optifine. Those mods are not compatible and are unlikely to be anytime soon.


    ChickenBones' mods such as EnderStorage, ForgeMultipart and anything else using ChickenBones' render library are incompatible with Optifine because Optifine removes the lastBrightness(X/Y) fields from the OpenGLHelper class. These fields are added by forge for mods to correctly light their objects in certain situations. Vanilla does not use this, but if optifine wishes to be Forge compatible, it should not be removing them.
  • #37081
    still haven troble
  • #37082
    will we see a fix for the Chickenbones/Forge issue anytime soon? i can't live without OptiFine haha
  • #37083
    Quote from Kris1432

    will we see a fix for the Chickenbones/Forge issue anytime soon? i can't live without OptiFine haha

    What do you mean? I use 11 Mods together quite well. I use: OptiFine, the 3 Forge Mod things, Code ChickenCore, NEI, Rei's Minimap, In-Game NBT Edit, Inventory Tweaks, MAtmos, Presence Footsteps, and TerrainControl all together without crashes.
  • #37084
    Quote from KR1dude

    What do you mean? I use 11 Mods together quite well. I use: OptiFine, the 3 Forge Mod things, Code ChickenCore, NEI, Rei's Minimap, In-Game NBT Edit, Inventory Tweaks, MAtmos, Presence Footsteps, and TerrainControl all together without crashes.


    Quite a bit of people (including myself) are having trouble using Enderstorage and NEI along with Optifine. The reason why they are incompatible is due to Optifine "not playing nice" with Forge.
  • #37085
    So I read that the older version of Optifine 1.5.2 pre D3 had a bug that allowed you to see under the lava. Is there a way to add this back in manually by chance ?
  • #37086
    I love this mod. It speed my Minecraft up a lot
  • #37087
    Quote from Capt0z

    I seem to crash every few minutes while using Optifine in 1.6.2. Any help would be appreciated.

    ---- Minecraft Crash Report ----
    // Ooh. Shiny.
    
    Time: 22/08/13 3:31 PM
    Description: Unexpected error
    
    java.lang.ArrayIndexOutOfBoundsException: -1
        at amy.a(SourceFile:119)
        at aqw.b_(SourceFile:557)
        at ConnectedTextures.isNeighbour(ConnectedTextures.java:705)
        at ConnectedTextures.getConnectedTextureVertical(ConnectedTextures.java:792)
        at ConnectedTextures.getConnectedTexture(ConnectedTextures.java:307)
        at ConnectedTextures.getConnectedTexture(ConnectedTextures.java:194)
        at ConnectedTextures.getConnectedTextureSingle(ConnectedTextures.java:97)
        at ConnectedTextures.getConnectedTexture(ConnectedTextures.java:55)
        at bfo.j(RenderBlocks.java:3023)
        at bfo.b(RenderBlocks.java:423)
        at bex.a(WorldRenderer.java:279)
        at bfi.a(RenderGlobal.java:1709)
        at bfb.a(EntityRenderer.java:1468)
        at bfb.b(EntityRenderer.java:1119)
        at ats.S(SourceFile:686)
        at ats.d(SourceFile:619)
        at net.minecraft.client.main.Main.main(SourceFile:101)
    
    
    A detailed walkthrough of the error, its code path and all known details is as follows:
    ---------------------------------------------------------------------------------------
    
    -- Head --
    Stacktrace:
        at amy.a(SourceFile:119)
        at aqw.b_(SourceFile:557)
        at ConnectedTextures.isNeighbour(ConnectedTextures.java:705)
        at ConnectedTextures.getConnectedTextureVertical(ConnectedTextures.java:792)
        at ConnectedTextures.getConnectedTexture(ConnectedTextures.java:307)
        at ConnectedTextures.getConnectedTexture(ConnectedTextures.java:194)
        at ConnectedTextures.getConnectedTextureSingle(ConnectedTextures.java:97)
        at ConnectedTextures.getConnectedTexture(ConnectedTextures.java:55)
        at bfo.j(RenderBlocks.java:3023)
        at bfo.b(RenderBlocks.java:423)
        at bex.a(WorldRenderer.java:279)
        at bfi.a(RenderGlobal.java:1709)
        at bfb.a(EntityRenderer.java:1468)
    
    -- Affected level --
    Details:
        Level name: MpServer
        All players: 1 total; [bdf['capt0z'/16741499, l='MpServer', x=-994.57, y=90.62, z=-89.32]]
        Chunk stats: MultiplayerChunkCache: 729
        Level seed: 0
        Level generator: ID 00 - default, ver 1. Features enabled: false
        Level generator options: 
        Level spawn location: World: (-69,75,-570), Chunk: (at 11,4,6 in -5,-36; contains blocks -80,0,-576 to -65,255,-561), Region: (-1,-2; contains chunks -32,-64 to -1,-33, blocks -512,0,-1024 to -1,255,-513)
        Level time: 555437102 game time, 481524534 day time
        Level dimension: 0
        Level storage version: 0x00000 - Unknown?
        Level weather: Rain time: 0 (now: true), thunder time: 0 (now: false)
        Level game mode: Game mode: survival (ID 0). Hardcore: false. Cheats: false
        Forced entities: 5 total; [bdf['capt0z'/16741499, l='MpServer', x=-994.57, y=90.62, z=-89.32], ok['Painting'/105, l='MpServer', x=-1024.00, y=65.00, z=-110.94], bev['Saluka16'/16114732, l='MpServer', x=-1025.00, y=74.28, z=-39.45], oc['entity.ItemFrame.name'/106, l='MpServer', x=-1020.50, y=75.50, z=-65.06], ok['Painting'/105, l='MpServer', x=-1024.00, y=65.00, z=-110.94]]
        Retry entities: 0 total; []
        Server brand: craftbukkit
        Server type: Non-integrated multiplayer server
    Stacktrace:
        at bda.a(SourceFile:284)
        at ats.b(SourceFile:1761)
        at ats.d(SourceFile:633)
        at net.minecraft.client.main.Main.main(SourceFile:101)
    
    -- System Details --
    Details:
        Minecraft Version: 1.6.2
        Operating System: Windows 7 (amd64) version 6.1
        Java Version: 1.7.0_17, Oracle Corporation
        Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
        Memory: 324196720 bytes (309 MB) / 474152960 bytes (452 MB) up to 954466304 bytes (910 MB)
        JVM Flags: 2 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1G
        AABB Pool Size: 6024 (337344 bytes; 0 MB) allocated, 1126 (63056 bytes; 0 MB) used
        Suspicious classes: IWrUpdater, Config, WrUpdates, ...[acs.tabbychat.core.GuiNewChatTC, GuiChatTC, TabbyChat, ...], [acs.tabbychat.gui.ITCSettingsGUI, TCSettingsGUI, TCSettingsGeneral, ...], [acs.tabbychat.lang.TCTranslate, TCLanguage, TCLanguageEnglish, ...], [acs.tabbychat.settings.ITCSetting, TCSetting, TCSettingBool, ...], [acs.tabbychat.threads.BackgroundUpdateCheck], [acs.tabbychat.util.TabbyChatUtils, TCChatLineFake], [reifnsk.minimap.ReiMinimap, GuiScreenInterface, GuiOptionScreen, ...]
        IntCache: cache: 0, tcache: 0, allocated: 3, tallocated: 63
        ModLoader: Mods loaded: 3
    ModLoader 1.6.2
    mod_ReiMinimap v3.4_01 [1.6.2]
    mod_TabbyChat 1.9.02
    
        Launched Version: Modded 1.6.2
        LWJGL: 2.9.0
        OpenGL: ATI Radeon HD 5700 Series GL version 4.1.11005 Compatibility Profile Context, ATI Technologies Inc.
        Is Modded: Very likely; Jar signature invalidated
        Type: Client (map_client.txt)
        Resource Pack: Conquest_V1.0.zip
        Current Language: English (US)
        Profiler Position: N/A (disabled)
        Vec3 Pool Size: 529 (29624 bytes; 0 MB) allocated, 40 (2240 bytes; 0 MB) used

    Edit: after further investigation, I only crash like this in multiplayer, not singleplayer.

    Edit 2: And only while using connected textures (either fast or fancy) while playing multiplayer.
  • #37088
    Quote from Capt0z

    There used to be a quote here...

    I've briefly read the log, and I think it might be Modloader. I only use Forge, and I've heard people having a lot of problems. I would really recommend Forge, it's like a bigger and more stable version of Modloader.

    Most people think the cake is a lie. Without cake my life has no meaning. My life has a meaning. Therefore the cake is true.
    If you need any help with shaders, I made a Word document having a few fixes: https://www.dropbox....10.0 fixes.docx If your problem is not listed, feel free to send me a PM!
  • #37089
    Quote from sp614x

    If the cape is still not visible you can check the FAQ or send an email to support and it will be fixed.
    I have checked the FAQ, followed all steps and checked everything. Still nothing. So i sent an email in hopes this can be sorted out.

    thank you for being patient with me. :3
  • #37090
    This mod isn't working for my forge, idk if its a mod I have or if I am installing wrong someone help...

    :Leaves:
    :Leaves::Leaves::Leaves:
    :log:
    :log:
    :log:
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes