1.7.10 Optimisation

OptiFine HD A4 (FPS Boost, HD Textures, AA, AF and much more)

Poll: FPS increase with OptiFine

FPS increase with OptiFine - Single Choice

  • 0% 6.5%
  • 10% 7.1%
  • 25% 9.3%
  • 50% 18.1%
  • 100% 18%
  • 200%+ 41.1%
  • #27052
    Thank you a lot :steve_wink: :steve_csi:
  • #27053
    I use HD textures for railcraft, no problems so far but with the update to HD D5 it's loading wrong track textures for the High Speed rails.
    It only happens when traveling by cart. When I am at the rails when starting the game they are the right textures but riding again the next new chunk loading I get wrong textures again. Is there some Option I can change.... ?

    For now I went back to HD D3.

    Dree
  • #27054
    Quote from Thorwan

    Hey folks. I've used Optifine for a few months now and love it so far. But I've got a problem:
    One of the guys on our SMP server built a "Museum" close to my home where he wants to display all Items available in MC. It is really great, but it seems like the hundreds of Item Frames in there have a huge influx on my fps. Even when I'm in my own Castle, with no direct line of sight, whenever I turn in that direction my fps drop from 120+ to under 30. Same happens outside: Whenever I turn to the Museum, fps go downhill.
    I'm wondering if one of Optifines options could help. Any suggestions?
    I use Optifine HD Ultra D5 and experimented with different settings, but to no avail. From its description, I thought Advanced OpenGL should help, but it doesn't. :(

    Advanced OpenGL helps when rendering terrain.
    The ItemFrames are entities and can not use the Advanced OpenGL checks.
    I have an idea which may be working, added to TODO list.
  • #27055
    Would it be efficient to lower the resolution of the texture pack the further away a surface is? Every chunk that is more than 4 chunks away would be only 16x16 using a 32x32 pack for example. Of course, there would have to be a second texture pack, I'm just wondering how much this could theoretically improve the framerate :)
    Fantasy-realistic role play: Adornis, contact skypeyord on skype for more information.
    www.adornis.de coming soon :)
  • #27056
    Quote from sp614x


    Advanced OpenGL helps when rendering terrain.
    The ItemFrames are entities and can not use the Advanced OpenGL checks.
    I have an idea which may be working, added to TODO list.

    Great and again, thanks a lot!
  • #27057
    Ok so I notice some thing while I was playing, the background is missing in the texture pack I am using (Athery's Ascended).


    As you can see in the two screen shots I have provided.

    Now I am wondering if it is a compatibility issue or one of my settings is messing with the background.
    Last edited by Azurewhitewolf: 12/13/2012 1:34:36 PM
  • #27058
    Quote from Azurewhitewolf

    Ok so I notice some thing while I was playing, the background is missing in the texture pack I am using (Athery's Ascended).


    As you can see in the two screen shots I have provided.

    Now I am wondering if it is a compatibility issue or one of my settings is messing with the background.

    This is the Better Skies mod.
  • #27059
    Quote from Crafter16

    This is the Better Skies mod.

    Ok cool thanks. now Im just missing that mod in Optifine. any way to implement it into the mod?
  • #27060
    thanks for your awesome mod sp614x
    including 1.7.4-1.8 updates - mirror: https://drive.google...bjA&usp=sharing
    Official VDC server: vdc.zomb69server.co.vu
  • #27061
    Quote from zomb69

    thanks for your awesome mod sp614x

    :-)
  • #27062
    I'm a bit weary about installing the D5 update since someone said tracks were messed up..
  • #27063
    high i'm trying to load the mod in with magic launcher and am getting 13 errors. when I load minecraft it crashes when I try to start the world.

    magic launcher log


    MagicLauncher 1.0.0
    java.home: C:\Program Files\Java\jre7
    java.runtime.name: Java™ SE Runtime Environment
    java.runtime.version: 1.7.0_09-b05
    os.name: Windows 8
    os.version: 6.2
    os.arch: amd64
    sun.arch.data.model: 64
    Missing class member: public Lcom/pclewis/mcpatcher/mod/MobRandomizer$ExtraInfo; randomMobsInfo, class: md, mod: OptiFine_1.4.5_HD_U_D5.zip
    Class member is not public: F e, class: bac, mod: OptiFine_1.4.5_HD_U_D5.zip
    Missing class member: public (F)F getNightVisionStrength, class: bac, mod: OptiFine_1.4.5_HD_U_D5.zip
    Class member is not public: private Z l, class: atj, mod: OptiFine_1.4.5_HD_U_D5.zip
    Missing class member: public
    Missing class member: public (Lasl;Ljava/lang/String;Lbap;)V initialize, class: atj, mod: OptiFine_1.4.5_HD_U_D5.zip
    Missing class member: public (Lnet/minecraft/client/Minecraft;)V reloadTextures, class: bap, mod: OptiFine_1.4.5_HD_U_D5.zip
    Class member is not public: private I i, class: bao, mod: OptiFine_1.4.5_HD_U_D5.zip
    Class member is not public: private I r, class: bao, mod: OptiFine_1.4.5_HD_U_D5.zip
    Class member is not public: private I s, class: bao, mod: OptiFine_1.4.5_HD_U_D5.zip
    Class member is not public: private I E, class: bao, mod: OptiFine_1.4.5_HD_U_D5.zip
    Missing class member: public I texture, class: bao, mod: OptiFine_1.4.5_HD_U_D5.zip
    Class member is not public: private ()V d, class: bao, mod: OptiFine_1.4.5_HD_U_D5.zip

    edit:
    system specs
    i7-2600k
    asus p8p67 evo
    mis twin frozr II gtx 570
    8gb DDR3
    windows 8 pro x64
    Last edited by shermantanker: 12/13/2012 7:38:35 PM
  • #27064
    Hey there! My minecraft is running alot worse than it use to. I'm talking from my normal settings of Fancy Normal with over 40 fps most of the time to under 20, near 10 at some times. I have intel hd 3000 i5 processor 2.40 GHz. Would it help to say I recently updated my graphics driver?
  • #27065
    Quote from Thoma353

    when i tried to put it in my .jar, the game crashed on me. Is there any reason why?
    It Crashed When I Put It In
  • #27066
    12w50a Optifine version yet?



  • #27067
    Thanks for the D6 update. I couldnt play long without some mods or entities missing parts or having corrupt looking textures (I use a x16 texture pack which doesnt need the custom water etc)
  • #27068
    Quote from Greevir

    Ugh! I'm so freakin aggravated right now! I just can not get any of the Optifine version to work right. They all have the same issue! I load into the game at my base, I travel out a ways, come back, and half of my stuff is invisible! I have to restart the game to fix it. I've disabled every option one by one, tried smooth, Multi-core, default chunkloading. Tried advanced opengl off and on, tried everything I can possible thing of. Updated forge, downgraded forge, no difference. Signs have no text, sections of Buildcraft pipes go invis, barrels from factorization go invis..... I've given up. Have used Optifine for god knows how long without any major hassles till now. I simply just simply had to remove it for now. Any suggestions would be great!


    Try either D3 ultra or D5 standard.
    Use a forge no later than 435 -- 436 and up currently have a nasty bug.

    Try using Vsync for the "performance" button on the first page (not the performance tab that brings up another page).
    Quote from BenBomb33

    How to i get the optifine folder to be not a folder anymore? because i cannot add a folder to magic launcher.


    Quote from BenBomb33

    Ugh, sorry about all these posts. I just tried one last time, and Optifine said "OK" but i went into minecraft and there was no optifine. And usually when i install optifine manually, there is flickering chunks. So should i delete my minecraft folder, then run the game? Im not sure what to do.


    Sounds like your optifine download got messed up. Redownload.
    My channel with Mystcraft, and general Minecraft Let's Plays: http://www.youtube.com/user/Keybounce
    ** NEW: FtB "Magic Farm", performance testing and java flags.
    My main world: http://www.minecraft...ts-play-series/
    "Wait, an update?! Geez, I didn't know we skipped Easter and went straight to Christmas."
  • #27069
    Quote from Keybounce

    Try either D3 ultra or D5 standard.
    Use a forge no later than 435 -- 436 and up currently have a nasty bug.


    Whoops! D5 is still compiled against 408, and Optifine and forge share a class file (or did last time I checked). Keep close to 408.
    My channel with Mystcraft, and general Minecraft Let's Plays: http://www.youtube.com/user/Keybounce
    ** NEW: FtB "Magic Farm", performance testing and java flags.
    My main world: http://www.minecraft...ts-play-series/
    "Wait, an update?! Geez, I didn't know we skipped Easter and went straight to Christmas."
  • #27070
    Quote from shermantanker

    high i'm trying to load the mod in with magic launcher and am getting 13 errors. when I load minecraft it crashes when I try to start the world.

    magic launcher log


    Missing class member: public Lcom/pclewis/mcpatcher/mod/MobRandomizer$ExtraInfo; randomMobsInfo, class: md, mod: OptiFine_1.4.5_HD_U_D5.zip

    edit:
    system specs
    i7-2600k
    asus p8p67 evo
    mis twin frozr II gtx 570
    8gb DDR3
    windows 8 pro x64


    You've patched your .jar with MCPatcher at some point. Download a clean minecraft.jar and then use that.
  • #27071
    Quote from coolnilk

    12w50a Optifine version yet?

    Optifine doesn't update to snapshots.

    Click on the achievement to find out how.
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes