This thread was automatically marked as Locked.

[1.3.1] GLSL Shaders (DoF, Bump Mapping, Waving Wheat, Dynamic Shadows, and More!)

  • #3931
    Quote from ihatetn931

    It dosen't work with the current update. We have to wait till the creator or someone updates this for 1.6

    the guy has been gone since april
  • #3932
    Quote from guiltyspark

    the guy has been gone since april



    You mean
    Last Active: May 22 2011 12:37

    Just cause he's gone dosen't mean someone esle will update it. He updated it for 1.5 so he may update it for 1.6 as well. Just give him time. Maybe he's working on the todo list for it.

    Just cause Notch released an update dosen't mean all mods have to updated right away.

    This mod is worth wating for. If you wanna use it then downgrade to 1.5 other then that there isn't much you can do. Unless you know java and wanna update it yourself.
  • #3933
    plz 1.6.5 updade, I just decided to download it and saw it works with 1.5
  • #3934
    Be patient. If its not in another week probably some one else will do it by then.
  • #3935
    I want it now, but you know what? take all the time you want, you deserve it after all.

    After making a mod that changes the entire rendering system I'd be a little insane.
    Last edited by SebMcMeb: 5/30/2011 5:02:50 PM
    I scare even creepers. I want to ☑ Do the Astro ☑ Meet Bucket Head ☑ Sodomize myself. I like to ☑ Roleplay ☑ Build crap ☑ Do a cool hat trick
  • #3936
    I am sure this will work with 1.6.5, will it?

    Anyways, i have 1.6.5, but when i tried to install this mod/shader the logs report an error...
    Here is the log:

    Starting installation
    Creating backup
    Unpacking JAR

    ==== Installing Shaders ====
    Error installing Shaders!
    javassist.NotFoundException: b(..) is not found in oy
    at javassist.CtClassType.getDeclaredMethod(CtClassType.java:1215)
    at Hooks.install(Hooks.java:34)
    at daxnitro.nitrous.InstallThread.installMods(InstallThread.java:125)
    at daxnitro.nitrous.InstallThread.run(InstallThread.java:44)
    ==== Shaders Failed Installation ====

    Repacking JAR
    Installation complete


    end log.
    lol, silly installer.

    Can someone tell me what the problem is?

    THANK YOU
  • #3937
    Quote from Psychoul
    Can someone tell me what the problem is?


    The problem is that your eyes are unable to process the title saying [V1.5].
    http://sundergaming.com/minecraft/seedgen2.htm
    Random Minecraft Seed Generator

    http://sundergaming.com/3kbcraft/map/map.html
    3KillaBytes Minecraft Server Map (Tectonicus)

    IP: minecraft.sundergaming.com:25565
    Phantom's Survival Server [3KBCraft]
  • #3938
    Quote from PhantomGamers

    The problem is that your eyes are unable to process the title saying [V1.5].

    Hohoho, genius.
    I scare even creepers. I want to ☑ Do the Astro ☑ Meet Bucket Head ☑ Sodomize myself. I like to ☑ Roleplay ☑ Build crap ☑ Do a cool hat trick
  • #3939
    Quote from PhantomGamers

    The problem is that your eyes are unable to process the title saying [V1.5].


    According to the OP's post, it is not downward compatible, but he says nothing about it being upward compatible.
    I know what you are trying to imply, so i'll just wait until he updates the installer.

    EDIT: BUT what does the error log imply? What is it saying with java errors
    :
    javassist.NotFoundException: b(..) is not found in oy
    at javassist.CtClassType.getDeclaredMethod(CtClassType.java:1215)
    at Hooks.install(Hooks.java:34)
    at daxnitro.nitrous.InstallThread.installMods(InstallThread.java:125)
    at daxnitro.nitrous.InstallThread.run(InstallThread.java:44)
    Perhaps the mod will work if we place it in the right places, aka manually install it? Or what is so different between 1.6.5 and 1.5 that we couldn't install things manually.
    Last edited by Psychoul: 5/30/2011 6:37:11 PM
  • #3940
    Quote from Psychoul

    According to the OP's post, it is not downward compatible, but he says nothing about it being upward compatible.
    I know what you are trying to imply, so i'll just wait until he updates the installer.

    EDIT: BUT what does the error log imply? What is it saying with java errors
    :
    javassist.NotFoundException: b(..) is not found in oy
    at javassist.CtClassType.getDeclaredMethod(CtClassType.java:1215)
    at Hooks.install(Hooks.java:34)
    at daxnitro.nitrous.InstallThread.installMods(InstallThread.java:125)
    at daxnitro.nitrous.InstallThread.run(InstallThread.java:44)
    Perhaps the mod will work if we place it in the right places, aka manually install it? Or what is so different between 1.6.5 and 1.5 that we couldn't install things manually.


    Nope.

    Afraid not. We know what the problem is:
    When Notch recompiled Minecraft into version 1.6.5, it jumbled up a bunch of vital resource files. No matter what order you zip them into the .jar archive in, those .class files you're putting in there are still going to be referring to the wrong variables in the wrong sections of the wrong files. Unless you figure out a way to find out where each of those resources is supposed to go now, and then rewrite every line of the .class files that makes a broken reference like that, and replace it with an updated reference, it will never, ever, ever work.

    I'm sure someone could pick the mod apart and figure out where the original creator of it left off, and pick it up there, but you have to know what the hell you're even looking at XD

    The mod hasn't remained without update long enough for someone else to get fed up enough with waiting and start developing it themselves. If you want that to happen right now, you could, I suppose, look into programming Java, learn it, and do it yourself, but once you see how challenging it is, you'll figure out why nobody else has tried yet since the update.
  • #3941
    EDIT: The guy above me not only beat me to it, but explained it much better. Read his.
    Quote from Psychoul

    According to the OP's post, it is not downward compatible, but he says nothing about it being upward compatible.
    I know what you are trying to imply, so i'll just wait until he updates the installer.

    EDIT: BUT what does the error log imply? What is it saying with java errors
    :
    javassist.NotFoundException: b(..) is not found in oy
    at javassist.CtClassType.getDeclaredMethod(CtClassType.java:1215)
    at Hooks.install(Hooks.java:34)
    at daxnitro.nitrous.InstallThread.installMods(InstallThread.java:125)
    at daxnitro.nitrous.InstallThread.run(InstallThread.java:44)
    Perhaps the mod will work if we place it in the right places, aka manually install it? Or what is so different between 1.6.5 and 1.5 that we couldn't install things manually.


    It's rare you see things that are forward-compatible, so assume it's not.
    I don't know much Java, but it looks like MC can't find the items needed to install the mod. For all I know, the ending numbers are script line numbers, so you could find it and fix it if you knew enough, but... I don't know enough to do that.
    Notch did disable then re-enable the Advanced OpenGL system for Minecraft in the latest versions (1.6-1.6.4 it was disabled, re-enabled in 1.6.5), so there may have been changes made that messed up things this mod was dependent upon?
    Now I'm just guessing. For a mod this awesome, just wait till he updates it. Last time he got the update out 8 days after the latest version appears, it's only been two since 1.6.5.
    Delayed gratification is a wonderful thing.
    Last edited by playbass06: 5/30/2011 9:04:48 PM
  • #3942
    Ya it could be, since oy is a class within minecraft.jar (i wonder how Notch names the .class files.)

    If only we knew WHY the GLSL installer does not work. I was looking through the code (source and decompiled the .class) I traced my around things, but i cannot seem to find what b(..) . I think that the NotFoundException is thrown within a method that this guy's mod made... the only place that i can see it would call a NotFound, because of oy, is when "oy" is used as a key in called method Hashtable(191)... as in get clazz = getCached(classname);
    if(clazz != null)
    return clazz;

    clazz should return not null because of the nature of get() from Hashtable...
    THEREFORE an exception is not thrown there....
    WHAT is b()?

    And more importantly, what values are changing when Notch patches the game?
    are the class names completely changing (i highly doubt it)?

    btw, can anyone tell me what the oy class does?

    EDIT:
    I just realized that this guy's mod source contains class Hook

    "
    // Obfuscated names. Hopefully this is all that will need to be changed for future releases.

    static final String EntityRenderer = "oy";
    (...many more Strings...)
    "

    hopefully that is all that should be changed... perhaps the class names are moved around?
    Last edited by Psychoul: 5/31/2011 6:09:15 AM
  • #3943
    I look forward to this mod getting updated.
  • #3944
    I think the modder will update it soon. I recall that he had a spread sheet of what he wanted to do, to fix, and to change. So there's quite enough reason to believe that he will. You got to give him credit guys, his mod is actually something worthwhile. Its also highly modular or compatible with other mods. Lets just be thankful and patient.
  • #3945
    I should of started learning to make shaders sooner so i would of had more time to make them.

    Can't wait till the update is release :-)

    Shaders on 1.6 and minecraft peformance increase. No fps drops :-)
  • #3946
    Good thing notch added that performance thing and open GL again. Notch needs to add support for mods, cuz now I get a solid 500 fps, but if I tele it lags for a sec. But still.
  • #3947
    Just found this mod, never used it before. Looking forward to the update, and perhaps to make a bumpmap for my own texture pack! (16x16...haha!)
  • #3948
    Quote from Zomxilla

    Just found this mod, never used it before. Looking forward to the update, and perhaps to make a bumpmap for my own texture pack! (16x16...haha!)



    It will work but it dosen't come out looking that great. You may get it lookin good wish ya luck tho
  • #3949
    Quote from Zomxilla

    Just found this mod, never used it before. Looking forward to the update, and perhaps to make a bumpmap for my own texture pack! (16x16...haha!)

    If you need help creating a bumpmap, I'll gladly help you out on that.

    On a sidenote, I hope this pack gets updated soon, whenever I play Minecraft now I get remembered on how awesome it was with GLSL shaders... DoF, Bloom and all those nifty things. Good job daxnitro, I'll be looking forward, I've been using your mod since it came out.
  • #3950
    Guys, halp.
    if i open INSTALLER.EXE from the archive (without unpacking)
    he response FATAL ERROR
    Catalogging local mods
    Scanning C:\Documents and Settings\Clover\Application Data\.Nitrous\mods
    Scanning C:\Documents and Settings\Clover\Local Settings\Temp\Rar$EX00.734\mods
    Found mod Shaders

    Starting installation
    Creating backup
    Unpacking JAR
    Fatal error!
    java.util.zip.ZipException: error in opening zip file
    at java.util.zip.ZipFile.open(Native Method)
    at java.util.zip.ZipFile.<init>(Unknown Source)
    at java.util.zip.ZipFile.<init>(Unknown Source)
    at daxnitro.nitrous.FileUtility.unzipFile(FileUtility.java:41)
    at daxnitro.nitrous.InstallThread.unpackJAR(InstallThread.java:88)
    at daxnitro.nitrous.InstallThread.run(InstallThread.java:39)


    if i unpacking all files to application data/.minecraft/ - folder mods switch to ACCES DENIED mode.
    i create filder mods manually, and unpacked there @shaders@ and .DS_Store file. then, unpacked in .minecraft root - installer.exe and nitrous jar....
    installer.exe didnt open! because PERHAPS I DONT HEVE PERMISSION to open this file!
    (win XP here)
    what shud ai do?

    How to install this shaders manually? if this possibly?
    Last edited by CloverVerona: 6/2/2011 3:37:37 AM
  • To post a comment, please or register a new account.
Posts Quoted:
Reply
Clear All Quotes